chromium-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. # norootforbuild
  5. %if %{?_dist_release} == "vl6"
  6. %define with_system_icu 1
  7. %endif
  8. %define svn_rev 56023
  9. Name: chromium
  10. Summary: Google's opens source browser project
  11. Summary(ja): Googleのオープンソースウェブブラウザ
  12. #'
  13. Version: 6.0.493.0
  14. Release: 1%{?_dist_release}
  15. License: BSD
  16. Group: Applications/Internet
  17. Source0: %{name}.%{version}.svn%{svn_rev}.tar.lzma
  18. ## The following are included for source reasons only
  19. # Custom build tools for chromium, hammer is a fancy front-end for scons
  20. Source1: http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
  21. %{?nosrc:NoSource: 0}
  22. %{?nosrc:NoSource: 1}
  23. # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
  24. Source2: repack_chromium_archive.sh
  25. # Script used to create the tar.lzma archive from a checked out source
  26. #Source3: pack_chromium_source.sh
  27. Source3: pack_chromium_source-vine.sh
  28. #Source10: chromium.desktop
  29. Source10: chromium-vine.desktop
  30. # Patch template which adds vendor to user agent
  31. ##!!Source20: chromium-vendor.patch.in
  32. Source20: chromium-vendor-vine.patch.in
  33. ##!!Source30: master_preferences
  34. Source30: master_preferences.vine
  35. #Source31: default_bookmarks.html
  36. #Source31: default_bookmarks.html.vine
  37. # icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
  38. Source100: icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
  39. Provides: chromium-browser = %{version}
  40. #Obsoletes: chromium-browser < %{version}
  41. ## Start Patches
  42. # Many changes to the gyp system so we can use system libraries
  43. # My first ever patch set. I hope I did well.
  44. Patch3: chromium-gyp-system-icu.patch
  45. Patch4: chromium-no-sqlite-debug.patch
  46. Patch5: chromium-gyp-system-04-nss-nspr.patch
  47. Patch7: chromium-codechanges-nss-nspr.patch
  48. Patch8: chromium-codechanges-zlib.patch
  49. #Patch9: chromium-drop-sse.patch
  50. Patch10: chromium-fix-wrapper.patch
  51. Patch12: chromium-no-test-sources.patch
  52. Patch13: chromium-no-courgette.patch
  53. Patch14: chromium-master-prefs-path.patch
  54. #Patch15: chromium-media-probe.patch
  55. Patch16: chromium-icu-code-changes.patch
  56. Patch17: chromium-system-glew.patch
  57. Patch18: chromium-system-expat.patch
  58. Patch19: chromium-system-zlib.patch
  59. Patch20: chromium-noffmpeg.patch
  60. Patch21: chromium-system-old-ffmpeg-way.patch
  61. Patch23: chromium-disable-mmx.patch
  62. #Patch24: chromium-fix-yuv_row_posix-shared.patch
  63. Patch25: tcmalloc-factory.patch
  64. # Vine
  65. BuildRequires: gcc gcc-c++
  66. %if %{?_dist_release} == "vl5"
  67. BuildRequires: libstdc++34 libstdc++34-devel
  68. %elseif %{?_dist_release} == "vl6"
  69. BuildRequires: libstdc++ libstdc++-devel
  70. %endif
  71. BuildRequires: libevent
  72. ##!!BuildRequires: pkg-config
  73. BuildRequires: python
  74. ##!!BuildRequires: python-xml
  75. BuildRequires: python-pyxml
  76. BuildRequires: perl bison flex gperf
  77. ##!!BuildRequires: wdiff
  78. ##!!BuildRequires: update-desktop-files
  79. BuildRequires: desktop-file-utils
  80. BuildRequires: lzma
  81. ##!!BuildRequires: mozilla-nss-devel
  82. BuildRequires: nss-devel
  83. ##!!BuildRequires: alsa-devel
  84. BuildRequires: alsa-lib-devel
  85. BuildRequires: gtk2-devel
  86. BuildRequires: glib2-devel
  87. BuildRequires: cairo-devel >= 1.6
  88. ##!!BuildRequires: mozilla-nspr-devel
  89. BuildRequires: nspr-devel
  90. ##!!BuildRequires: gconf2-devel
  91. BuildRequires: GConf2-devel
  92. BuildRequires: freetype2-devel
  93. ##!!BuildRequires: dbus-1-devel
  94. BuildRequires: dbus-devel
  95. BuildRequires: libxslt-devel
  96. BuildRequires: libxml2-devel
  97. BuildRequires: libjpeg-devel
  98. BuildRequires: zlib-devel
  99. ##!!BuildRequires: libbz2-devel
  100. BuildRequires: bzip2-devel
  101. BuildRequires: cups-devel
  102. %if %{?_dist_release} == "vl6"
  103. BuildRequires: fdupes
  104. %endif
  105. ##!!BuildRequires: libexpat-devel
  106. BuildRequires: expat-devel
  107. BuildRequires: libpng-devel
  108. BuildRequires: sqlite3-devel
  109. BuildRequires: gnutls-devel
  110. %if %{?_dist_release} == "vl5"
  111. BuildRequires: gnome-keyring-devel
  112. %elseif %{?_dist_release} == "vl6"
  113. BuildRequires: libgnome-keyring-devel
  114. %endif
  115. BuildRequires: glew-devel
  116. ##!!BuildRequires: Mesa-devel
  117. BuildRequires: mesa-libGLU-devel
  118. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  119. BuildRequires: libevent-devel
  120. ##Vine Linux
  121. BuildRequires: libXScrnSaver-devel
  122. #BuildRequires: gle-devel
  123. #BuildRequires: webkit-gtk-devel
  124. #BuildRequires: scons
  125. %ifarch x86_64
  126. Requires: nspluginwrapper
  127. %endif
  128. ##!!Requires: alsa
  129. Requires: alsa-lib
  130. # shouldn't be required to name all dependencies
  131. # Requires: mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
  132. ## Recommends the ffmpeg libraries (available from packman)
  133. #Recommends: libavcodec52 libavformat52 libavutil50
  134. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  135. %description
  136. Chromium is the open-source project behind Google Chrome.
  137. We invite you to join us in our effort to help build a safer, faster,
  138. and more stable way for all Internet users to experience the web,
  139. and to create a powerful platform for developing a new generation of
  140. web applications.
  141. %description -l ja
  142. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  143. 私たちは、ウェブを体験しているすべてのインターネットユーザに対して
  144. より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
  145. ウェブアプリケーションの新しい世代を発展させるように
  146. 強力なプラットホームを作成するために、
  147. 私たちの取り組みで私たちに加わるようにあなたを誘います。
  148. %prep
  149. [ -d %{name} ] && %__rm -rf %{name}
  150. lzma -cd %{SOURCE0} | tar xf -
  151. %setup -D -T -n %{name}
  152. # use static libicu
  153. %if %{?_dist_release} == "vl5"
  154. cd src/third_party || exit 1
  155. %__rm -rf icu || exit 1
  156. tar jxvf %{SOURCE100} || exit 1
  157. %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
  158. cd - || exit 1
  159. %endif
  160. # use system libicu only if >= 4.0
  161. %{?with_system_icu:%patch3 -p1}
  162. %patch4 -p1
  163. %patch5 -p1
  164. %patch7 -p1
  165. %patch8 -p1
  166. #%patch9 -p1
  167. %patch10 -p1
  168. %patch12 -p1
  169. %patch13 -p1
  170. %patch14 -p1
  171. #%patch15 -p0
  172. %{?with_system_icu:%patch16 -p1}
  173. %patch17 -p1
  174. %patch18 -p1
  175. %patch19 -p1
  176. %patch20 -p1
  177. %patch21 -p1
  178. %patch25 -p1
  179. %ifarch %ix86
  180. %patch23 -p1
  181. %endif
  182. #%patch24 -p1
  183. # apply vendor patch after substitution
  184. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  185. %build
  186. ## create make files
  187. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  188. for i in src/build/common.gypi; do
  189. %__sed -i "s|'-march=pentium4',||g" $i
  190. %__sed -i "s|'-msse2',||g" $i
  191. %__sed -i "s|'-mfpmath=sse',||g" $i
  192. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  193. %__sed -i "s|'-m32',||g" $i
  194. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  195. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  196. done
  197. # '
  198. pushd src
  199. ./build/gyp_chromium -f make build/all.gyp \
  200. -Duse_system_ffmpeg=1 \
  201. -Duse_system_zlib=1 \
  202. -Duse_system_libpng=1 \
  203. -Duse_system_bzip2=1 \
  204. -Duse_system_libbz2=1 \
  205. -Duse_system_libjpeg=1 \
  206. -Duse_system_libxml=1 \
  207. -Duse_system_libxslt=1 \
  208. -Duse_system_libevent=1 \
  209. -Dproprietary_codecs=1 \
  210. -Dlinux_fpic=1 \
  211. %{?with_system_icu:-Duse_system_icu=1} \
  212. %{!?with_system_icu:-Duse_system_icu=0} \
  213. %ifarch %{ix86}
  214. -Dtarget_arch=ia32 \
  215. -Ddisable_sse2=1 \
  216. %endif
  217. %ifarch x86_64
  218. -Dtarget_arch=x64 \
  219. %endif
  220. %if %{?_dist_release} == "vl6"
  221. -Dno_strict_aliasing=1 -Dgcc_version=44 \
  222. %endif
  223. -Drelease_extra_cflags=-fPIC \
  224. ;
  225. #make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
  226. #%__make -r -j5 chrome BUILDTYPE=Release
  227. %__make %{?_smp_mflags} chrome BUILDTYPE=Release
  228. popd
  229. %install
  230. %{__rm} -rf %{buildroot}
  231. ## Create install directories
  232. %{__mkdir_p} %{buildroot}%{_libdir}/%{name}
  233. %{__mkdir_p} %{buildroot}%{_bindir}
  234. %{__mkdir_p} %{buildroot}%{_datadir}/applications
  235. %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
  236. %{__mkdir_p} %{buildroot}%{_mandir}/man1
  237. %{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
  238. # chromium 'make' deposits us back at the top level build directory
  239. pushd src/out/Release
  240. ls -l
  241. # clean somechromium-codechanges-zlib.patch
  242. # clean debug junk
  243. %{__rm} -rf obj/ mksnapshot obj.target obj.host
  244. find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
  245. # clean NaCl stuff... maybe NaCl will be in its own package in the future.
  246. %{__rm} -f ncdecode_table ncdecode_tablegen
  247. # clean other temporary binaries used in the compilation of chromium
  248. %{__rm} -f protoc xdg-settings
  249. %{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
  250. # Man page
  251. [ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
  252. %__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
  253. # Add startup file with plugins enabled
  254. %{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
  255. #!/bin/bash
  256. %{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl "\$@"
  257. EOF
  258. # # link to browser plugin path. Plugin patch doesn't work. Why?
  259. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  260. # pushd %{buildroot}%{_libdir}/%{name}
  261. # %{__ln_s} %{_libdir}/browser-plugins plugins
  262. # popd
  263. pushd %{buildroot}%{_libdir}/%{name}
  264. %ifarch x86_64
  265. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  266. %else
  267. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  268. %endif
  269. #touch %{buildroot}%{_libdir}/libavcodec.so.52
  270. #%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  271. #touch %{buildroot}%{_libdir}/libavformat.so.52
  272. #%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  273. #touch %{buildroot}%{_libdir}/libavutil.so.50
  274. #%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  275. popd
  276. # Install desktop-related files
  277. %__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
  278. %__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
  279. desktop-file-install --vendor Vine \
  280. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  281. --delete-original \
  282. --mode 644 \
  283. $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  284. # Install the master_preferences file
  285. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
  286. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
  287. ## install o3d plugin
  288. #pushd src/o3d/build/out/Release
  289. #%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
  290. %clean
  291. %{__rm} -rf %{buildroot}
  292. %files
  293. %defattr(-,root,root)
  294. %doc src/AUTHORS src/LICENSE
  295. %dir %{_libdir}/%{name}
  296. %attr(0755,root,root) %{_bindir}/%{name}
  297. %{_mandir}/man1/*
  298. %{_datadir}/applications/*%{name}.desktop
  299. %{_datadir}/pixmaps/%{name}.png
  300. %{_libdir}/%{name}/*
  301. %config %{_sysconfdir}/%{name}
  302. #%{_libdir}/browser-plugins/*
  303. #%exclude %{_libdir}/libavcodec.so.52
  304. #%exclude %{_libdir}/libavutil.so.50
  305. #%exclude %{_libdir}/libavformat.so.52
  306. %changelog
  307. * Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
  308. - updated to snapshot 6.0.493
  309. - used with_system_icu (for vl6)
  310. - added BuildRequires: libicu-devel
  311. * Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
  312. - build for Vine Linux 5.x
  313. - add BuildRequires: gnome-keyring-devel
  314. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
  315. - updated to snapshot 6.0.454
  316. - added BuildRequires:
  317. - sqlite3-devel
  318. - gnutls-devel
  319. - libgnome-keyring-devel
  320. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
  321. - updated to snapshot 6.0.431.0 r49253
  322. - added BuildRequires: cups-devel
  323. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
  324. - updated to snapshot 6.0.405.0 r47263
  325. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  326. - unused with_system_icu (for vl6)
  327. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  328. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  329. - updated to snapshot 5.0.378.0 r44472
  330. - used with_system_icu (for vl6)
  331. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  332. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  333. - updated to snapshot 5.0.372.0 r43947
  334. - added BuildRequires: glew-devel
  335. - changed Group tag to Applications/Internet
  336. - added Summary(ja) and %%description -l ja
  337. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  338. - updated to snapshot 5.0.365.0 r42966
  339. - merged 5.0.353.0-4vl5
  340. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  341. - build on Vine Linux 5.1
  342. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  343. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  344. - updated to snapshot 5.0.364.0 r42779
  345. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  346. - updated to snapshot 5.0.359.0 r42116
  347. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  348. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  349. - fixed master_preferences.vine, little
  350. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  351. - fixed to install master_preferences
  352. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  353. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  354. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  355. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  356. - updated to snapshot 5.0.353.0 r41449
  357. * Wed Mar 10 2010 bgmerrell@novell.com
  358. - Add master_preferences source file and install it to /etc/chromium.
  359. - Create a new patch (chromium-master-prefs-path.patch) which tells
  360. chromium to look in /etc/chromium for the master_preferences file
  361. (instead of looking in the default directory, which is the same
  362. directory as the 'chrome' binary).
  363. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  364. - updated to snapshot 5.0.335.0 r39556
  365. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  366. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  367. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  368. - updated to snapshot 5.0.330.0 r39074
  369. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  370. - use_system_ffmpeg
  371. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  372. - added Requires: nspluginwrapper
  373. - fixed a symbolic link of plugins directory with nspluginwrapper
  374. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  375. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  376. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  377. - added BuildRequires: mesa-libGLU-devel
  378. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  379. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  380. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  381. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  382. - Update to 4.0.260
  383. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  384. - Update to 4.0.259
  385. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  386. - Update to 4.0.258
  387. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  388. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  389. changed to having an built-in v8
  390. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  391. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  392. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  393. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  394. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  395. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  396. - update to newer svn snapshot
  397. + Obsoletes fwrite patch (included upstream)
  398. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  399. - update to newer svn snapshot
  400. + Requires newer version of v8
  401. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  402. - do not force SSE on x86 (drop-sse.patch)
  403. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  404. - Update to newer svn snapshot
  405. - Fixed spec file in order to build
  406. - Included patch to build with system zlib
  407. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  408. - package renamed to chromium
  409. - cleaned up spec file
  410. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  411. - v8 is now built as a separate package, and is required
  412. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  413. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  414. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  415. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  416. - initial build
  417. #% changelog
  418. * Sun Jan 24 2010 prusnak@suse.cz
  419. - added vendor to user agent (chromium-vendor.patch.in)
  420. * Sun Nov 29 2009 prusnak@suse.cz
  421. - added --enable-sync to wrapper to enable bookmark sync
  422. * Fri Nov 13 2009 tittiatcoke@gmail.com
  423. - update to 247.0 svn 31928
  424. * Fri Oct 30 2009 tittiatcoke@gmail.com
  425. - update to 229.0 svn 30454
  426. + Fix regression where popups and app frames lost their titlebars.
  427. + Makes it so that when a folder is open on the bookmark bar
  428. and the mouse moves over another folder, the menu for that
  429. folder is shown.
  430. + Lazily create the find bar.
  431. + Polish to the gmail checker sample.
  432. * New, crisper icons that are exactly 19x19
  433. * Add a loading animation at the beginning before Gmail
  434. responds.
  435. * Fix a bug where we sometimes don't update the UI after a
  436. logout/login cycle.
  437. + Refactor widget methods to support desktop notifications,
  438. including GTK stubs.
  439. + Find-in-page should not ding while deleting characters.
  440. + Add SSL wrapper for linux and mac. This allows notifier to
  441. use chrome's SSL layer instead of OpenSSL.
  442. + Add three of the six extensions to PAC that Internet Explorer supports.
  443. + WebSocket support in chromium. (Run with --enable-web-sockets
  444. enables WebSocket features.)
  445. + Do not allow GTK File Chooser dialogs to return directories.
  446. + Fix the notifier SSL layer to make notifications work for
  447. Linux Bookmark sync.
  448. + linux: don't override mouse selection behavior in omnibox
  449. * Sun Oct 25 2009 tittiatcoke@gmail.com
  450. - Update to 224.4 svn 30027
  451. + First cut at new page and browser action docs based
  452. on new API. Deleted old stuff.
  453. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  454. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  455. + Minimize dependency of user scripts
  456. + Fixup the flip_framer eof-handling semantics now that we have
  457. the FIN bit in place
  458. + app depends on x11 because of active_window_watcher_x
  459. + Adding two images for the new Extension managment UI
  460. + Removing hard-coded Chrome Frame output path
  461. + Rearrange clipboard code
  462. + Fix crash bug when attempting to download a url with unsupported scheme,
  463. e.g. 'data:', by 'Alt + Click'
  464. + GTK: Change text for extension download UI
  465. + Ignore invalid urls on command line
  466. + Make dropped tabs animate from where they were dropped.
  467. + Make room for the full width of the tab placeholder.
  468. + Make tab dragging as smooth as glass.
  469. + Remove an annoying NOTIMPLEMNETED
  470. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  471. + If we're in the middle of a drag, don't allow the user to middle
  472. click to close or right click for the context menu
  473. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  474. + Remove +x bit from files that shouldn't have it
  475. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  476. + Adding new image needed for the managment UI
  477. + Fix a race bug where content scripts would not apply to the first page load
  478. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  479. + Fix bubbles deactivating the opaque frame
  480. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  481. + ake all pepper plugins default to windowless and transparent
  482. + Add styles for printing
  483. + Implement the new extension management UI
  484. + Add support for to automation interface load install and load extensions
  485. + GTK: theme the info bar border
  486. + Update V8 to version 1.3.16.1
  487. + Introduce WebSecurityPolicy for security related methods
  488. + New button scheme...borders are separate from the inner contents so
  489. that they can be highlighted / depressed independently
  490. + When opening Chrome maximized with an application window already
  491. running, the Chrome window was not activated
  492. + Fix compatibility problems with FileZilla FTP Server
  493. + Remove the extension shelf on Linux
  494. + Fix the proxy host and port string to start with http:// if it does not already
  495. + Enable HTML5 databases for all extension renderer processes