cluster-glue-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319
  1. %global gname haclient
  2. %global uname hacluster
  3. %global nogroup nobody
  4. # When downloading directly from Mercurial, it will automatically add this prefix
  5. # Invoking 'hg archive' wont but you can add one with: hg archive -t tgz -p "Reusable-Cluster-Components-" -r $upstreamversion $upstreamversion.tar.gz
  6. %global specversion 1
  7. %global upstreamprefix Reusable-Cluster-Components-
  8. %global upstreamversion aa1f9dee2793
  9. # Keep around for when/if required
  10. #global alphatag %{upstreamversion}.hg
  11. Name: cluster-glue
  12. Summary: Reusable cluster components
  13. Summary(ja): 再利用可能なクラスタコンポーネント
  14. Version: 1.0.2
  15. Release: 2%{?_dist_release}
  16. License: GPLv2+ and LGPLv2+
  17. Url: http://linux-ha.org/wiki/Cluster_Glue
  18. Group: System Environment/Base
  19. Source0: http://hg.linux-ha.org/glue/archive/%{upstreamversion}.tar.bz2
  20. Provides: stonith = 3.0.0-1
  21. Provides: pils = 3.0.0-1
  22. Obsoletes: stonith < 3.0.0-1
  23. Obsoletes: pils < 3.0.0-1
  24. ## Setup/build bits
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  26. # Build dependencies
  27. Requires: perl-TimeDate
  28. BuildRequires: automake autoconf libtool pkgconfig chrpath libtool-ltdl-devel
  29. BuildRequires: bzip2-devel glib2-devel python-devel libxml2-devel
  30. # For documentation
  31. BuildRequires: libxslt docbook-style-xsl
  32. # For additional Stonith plugins
  33. BuildRequires: net-snmp-devel OpenIPMI-devel openhpi-devel curl-devel
  34. %if 0%{?fedora} > 11 || 0%{?rhel} > 5
  35. BuildRequires: libuuid-devel
  36. %else
  37. BuildRequires: e2fsprogs-devel
  38. %endif
  39. %prep
  40. %setup -q -n %{upstreamprefix}%{upstreamversion}
  41. ./autogen.sh
  42. %{configure} CFLAGS="${CFLAGS} $(echo '%{optflags}')" \
  43. --enable-fatal-warnings=no \
  44. --localstatedir=%{_var} \
  45. --with-daemon-group=%{gname} \
  46. --with-daemon-user=%{uname}
  47. %build
  48. make %{_smp_mflags}
  49. %install
  50. rm -rf %{buildroot}
  51. make install DESTDIR=%{buildroot}
  52. ## tree fix up
  53. # Dont package static libs
  54. find %{buildroot} -name '*.a' -exec rm {} \;
  55. find %{buildroot} -name '*.la' -exec rm {} \;
  56. # Don't package things we wont support
  57. rm -f %{buildroot}/%{_libdir}/stonith/plugins/stonith2/rhcs.*
  58. %clean
  59. rm -rf %{buildroot}
  60. # cluster-glue
  61. %description
  62. A collection of common tools that are useful for writing cluster managers
  63. such as Pacemaker.
  64. Provides a local resource manager that understands the OCF and LSB
  65. standards, and an interface to common STONITH devices.
  66. %files
  67. %defattr(-,root,root)
  68. %{_sbindir}/ha_logger
  69. %{_sbindir}/hb_report
  70. %{_sbindir}/lrmadmin
  71. %{_sbindir}/meatclient
  72. %{_sbindir}/sbd
  73. %{_sbindir}/stonith
  74. %{_sysconfdir}/init.d/logd
  75. %dir %{_libdir}/heartbeat
  76. %dir %{_libdir}/heartbeat/plugins
  77. %dir %{_libdir}/heartbeat/plugins/RAExec
  78. %dir %{_libdir}/heartbeat/plugins/InterfaceMgr
  79. %{_libdir}/heartbeat/lrmd
  80. %{_libdir}/heartbeat/ha_logd
  81. %{_libdir}/heartbeat/plugins/RAExec/*.so
  82. %{_libdir}/heartbeat/plugins/InterfaceMgr/*.so
  83. %dir %{_libdir}/stonith
  84. %dir %{_libdir}/stonith/plugins
  85. %dir %{_libdir}/stonith/plugins/stonith2
  86. %{_datadir}/cluster-glue/ha_log.sh
  87. %{_libdir}/stonith/plugins/external
  88. %{_libdir}/stonith/plugins/stonith2/*.so
  89. %{_libdir}/stonith/plugins/stonith2/*.py*
  90. %{_libdir}/stonith/plugins/xen0-ha-dom0-stonith-helper
  91. %dir %{_datadir}/cluster-glue
  92. %{_datadir}/cluster-glue/ha_cf_support.sh
  93. %{_datadir}/cluster-glue/openais_conf_support.sh
  94. %{_datadir}/cluster-glue/utillib.sh
  95. %{_datadir}/cluster-glue/combine-logs.pl
  96. %dir %{_var}/lib/heartbeat
  97. %dir %{_var}/lib/heartbeat/cores
  98. %dir %attr (0700, root, root) %{_var}/lib/heartbeat/cores/root
  99. %dir %attr (0700, nobody, %{nogroup}) %{_var}/lib/heartbeat/cores/nobody
  100. %dir %attr (0700, %{uname}, %{gname}) %{_var}/lib/heartbeat/cores/%{uname}
  101. %doc %{_datadir}/doc/cluster-glue/stonith
  102. %doc %{_mandir}/man1/*
  103. %doc %{_mandir}/man8/*
  104. %doc AUTHORS
  105. %doc COPYING
  106. # cluster-glue-libs
  107. %package -n cluster-glue-libs
  108. Summary: Reusable cluster libraries
  109. Summary(ja): Reusable cluster libraries
  110. Group: Development/Libraries
  111. Requires: %{name} = %{version}-%{release}
  112. %description -n cluster-glue-libs
  113. A collection of libraries that are useful for writing cluster managers
  114. such as Pacemaker.
  115. %pre
  116. getent group %{gname} >/dev/null || groupadd -r %{gname}
  117. getent passwd %{uname} >/dev/null || \
  118. useradd -r -g %{gname} -d %{_var}/lib/heartbeat/cores/hacluster -s /sbin/nologin \
  119. -c "heartbeat user" %{uname}
  120. exit 0
  121. %post -n cluster-glue-libs -p /sbin/ldconfig
  122. %postun -n cluster-glue-libs -p /sbin/ldconfig
  123. %files -n cluster-glue-libs
  124. %defattr(-,root,root)
  125. %{_libdir}/lib*.so.*
  126. %doc AUTHORS
  127. %doc COPYING.LIB
  128. # cluster-glue-libs-devel
  129. %package -n cluster-glue-libs-devel
  130. Summary: Headers and libraries for writing cluster managers
  131. Summary(ja): Headers and libraries for writing cluster managers
  132. Group: Development/Libraries
  133. Requires: cluster-glue-libs = %{version}-%{release}
  134. %description -n cluster-glue-libs-devel
  135. Headers and shared libraries for a useful for writing cluster managers
  136. such as Pacemaker.
  137. %files -n cluster-glue-libs-devel
  138. %defattr(-,root,root)
  139. %dir %{_libdir}/heartbeat
  140. %dir %{_libdir}/heartbeat/plugins
  141. %dir %{_libdir}/heartbeat/plugins/test
  142. %dir %{_datadir}/cluster-glue
  143. %{_libdir}/lib*.so
  144. %{_libdir}/heartbeat/ipctest
  145. %{_libdir}/heartbeat/ipctransientclient
  146. %{_libdir}/heartbeat/ipctransientserver
  147. %{_libdir}/heartbeat/transient-test.sh
  148. %{_libdir}/heartbeat/base64_md5_test
  149. %{_libdir}/heartbeat/logtest
  150. %{_includedir}/clplumbing
  151. %{_includedir}/heartbeat
  152. %{_includedir}/stonith
  153. %{_includedir}/pils
  154. %{_datadir}/cluster-glue/lrmtest
  155. %{_libdir}/heartbeat/plugins/test/test.so
  156. %doc AUTHORS
  157. %doc COPYING
  158. %doc COPYING.LIB
  159. %changelog
  160. * Mon Jul 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  161. - Obsoletes/Provides: stonith, pils
  162. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  163. - initial build for Vine Linux
  164. * Mon Jan 11 2010 Andrew Beekhof <andrew@beekhof.net> - 1.0.2-1
  165. - Suppress unsupported stonith plugins
  166. - Update to latest upstream release: aa1f9dee2793
  167. + High: stonith: add ha_log.sh for external plugins (LF 1971)
  168. + High: stonith: external plugins log using ha_log.sh (LF 2294)
  169. + High: stonith: external/dracmc-telnet: new stonith plugin for Dell Drac/MC Blade Enclosure and Cyclades terminal server
  170. + High: stonith: external/riloe: workaround for the iLO double close of RIBCL element (bnc#553340)
  171. + High: stonith: external: log messages immediately on manage and status calls
  172. + High: stonith: external: log output of plugins (bnc#548699,553340)
  173. + Medium: LRM: lrmd: log outcome of monitor once an hour
  174. + Medium: LRM: lrmd: remove operation history on client unregister and flushing all operations (LF 2161)
  175. + Medium: LRM: lrmd: restore reset scheduler for children (bnc#551971, lf#2296)
  176. + Medium: LRM: raexec: close the logd fd too when executing agents (LF 2267)
  177. + Medium: Tools: hb_report: add -V (version) option and add support for corosync
  178. + Medium: external STONITH plugins: remove dependency on .ocf-shellfuncs (LF2249)
  179. + Medium: stonith: cyclades: fix for support for newer PM10 firmware (LF 1938)
  180. + Medium: stonith: external/ipmi: add explanation on reset and power off (LF 2071)
  181. + Medium: stonith: external/riloe: make sure that host is turned on after power off/on reset (LF 2282)
  182. + Medium: stonith: meatclient: add -w option to wait until it can connect
  183. + Medium: stonith: print complete metadata for -m (LF 2279)
  184. + Medium: stonith: stonith: add -m option to display metadata
  185. * Mon Nov 23 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.12.b79635605337.hg
  186. - Correctly select libuuid for building on rhel >=6
  187. * Mon Oct 12 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.11.b79635605337.hg
  188. - Add install dependancy on perl-TimeDate for hb_report
  189. - Update to upstream version b79635605337
  190. + Build: fix defines for pacemaker-pygui compatibility.
  191. + High: Tools: hb_report: log/events combining
  192. + High: doc: new README for wti_mpc
  193. + High: hb_report: add man page hb_report.8
  194. + High: hb_report: extract important events from the logs
  195. + High: stonith: external/ibmrsa-telnet: add support for later RSA cards
  196. + High: stonith: wti_mpc: support for MIB versions 1 and 3
  197. + Logd: Start/stop priorities are not created by configure
  198. + Med: sbd: Fix definition of size_t.
  199. + Med: sbd: Nodename comparison should be case insensitive (bnc#534445)
  200. + Med: wti_nps: add support for internet power switch model (bnc#539912)
  201. + Medium (LF 2194): LRM: fix return code on RA exec failure
  202. + Medium: Tools: hb_report: add -v option (debugging)
  203. + Medium: Tools: hb_report: options -C and -D are obsoleted
  204. + ha_logd: Fix a compile error/warning.
  205. + hb_report: report corosync packages too.
  206. + sbd: Accept -h (bnc#529574)
  207. + sbd: really fix the sector_size type.
  208. * Fri Oct 9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0-0.10.d97b9dea436e.hg.1
  209. - rebuild with new net-snmp
  210. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-0.9.d97b9dea436e.hg.1
  211. - rebuilt with new openssl
  212. * Mon Aug 17 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.9.d97b9dea436e.hg
  213. - Include relevant provides: and obsoletes: directives for heartbeat
  214. - Update the tarball from upstream to version d97b9dea436e
  215. + Include license files
  216. + Fix error messages in autogen.sh
  217. + High (bnc#501723): Tools: hb_report: collect archived logs too
  218. + Medium: clplumbing: check input when creating IPC channels
  219. + Medium (bnc#510299): stonith: set G_SLICE to always-malloc to avoid bad interaction with the threaded openhpi
  220. + Med: hb_report: report on more packages and with more state.
  221. + The -E option to lrmadmin does not take an argument
  222. + Provide a default value for docdir and ensure it is expanded
  223. + Low: clplumbing: fix a potential resource leak in cl_random (bnc#525393).
  224. + Med: hb_report: Include dlm_tool debugging information if available.
  225. + hb_report: Include more possible error output.
  226. + Medium: logd: add init script and example configuration file.
  227. + High: logd: Fix init script. Remove apphbd references.
  228. + logd: configuration file is optional.
  229. + logd: print status on finished operations.
  230. + High: sbd: actually install the binary.
  231. + Medium: stonith: remove references to heartbeat artifacts.
  232. + High: hb_report: define HA_NOARCHBIN
  233. + hb_report: correct syntax error.
  234. + hb_report: Include details about more packages even.
  235. + hb_report: report corosync packages too.
  236. * Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 1.0-0.8.75cab275433e.hg
  237. - Use bzipped upstream tarball.
  238. * Tue Jul 28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.7.75cab275433e.hg
  239. - Add a leading zero to the revision when alphatag is used
  240. * Tue Jul 28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.6.75cab275433e.hg
  241. - Incorporate results of Fedora review
  242. - Use global instead of define
  243. - Remove unused rpm variable
  244. - Remove redundant configure options
  245. - Change version to 1.0.0 pre-release and include Mercurial tag in version
  246. * Mon Jul 27 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-5
  247. - Use linux-ha.org for Source0
  248. - Remove Requires: $name from -devel as its implied
  249. - Instead of 'daemon', use the user and group from Heartbeat and create it
  250. if necessary
  251. * Fri Jul 24 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-4
  252. - Update the tarball from upstream to version 75cab275433e
  253. - Include an AUTHORS and license file in each package
  254. - Change the library package name to cluster-glue-libs to be more
  255. Fedora compliant
  256. * Mon Jul 20 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-3
  257. - Package the project AUTHORS file
  258. - Have Source0 reference the upstream Mercurial repo
  259. * Tue Jul 14 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-2
  260. - More cleanups
  261. * Fri Jul 3 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.9-1
  262. - Fedora-ize the spec file
  263. * Fri Jun 5 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-0
  264. - Initial checkin