compiler-rt-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: LLVM "compiler-rt" runtime libraries
  6. Summary(ja): LLVM "compiler-rt" ランタイムライブラリ
  7. Name: compiler-rt
  8. Version: 14.0.5
  9. Release: 1%{?_dist_release}
  10. Group: programming
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: NCSA
  14. URL: https://llvm.org/
  15. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
  16. # patches
  17. Patch0: add-llvm-cmake-package.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: cmake
  20. BuildRequires: ninja
  21. BuildRequires: python3
  22. BuildRequires: python3-devel
  23. BuildRequires: llvm-devel = %{version}
  24. BuildRequires: llvm-static = %{version}
  25. Requires: clang = %{version}-%{release}
  26. # LLVM is not supported on PPC64
  27. # http://llvm.org/bugs/show_bug.cgi?id=3729
  28. ExcludeArch: ppc64
  29. %description
  30. The compiler-rt project is a part of the LLVM project. It provides
  31. implementation of the low-level target-specific hooks required by
  32. code generation, sanitizer runtimes and profiling library for code
  33. instrumentation, and Blocks C language extension.
  34. %debug_package
  35. %prep
  36. %autosetup -n compiler-rt-%{version}.src -p2
  37. pathfix%{python3_version}.py -i %{__python3} -pn lib/hwasan/scripts/hwasan_symbolize
  38. %build
  39. %cmake \
  40. -GNinja \
  41. -DCMAKE_BUILD_TYPE=Release \
  42. -DLLVM_CONFIG_PATH:FILEPATH=%{_bindir}/llvm-config-%{__isa_bits} \
  43. -DCMAKE_INSTALL_RPATH=";" \
  44. -DCMAKE_SKIP_RPATH:BOOL=ON \
  45. %if 0%{?__isa_bits} == 64
  46. -DLLVM_LIBDIR_SUFFIX=64 \
  47. %else
  48. -DLLVM_LIBDIR_SUFFIX= \
  49. %endif
  50. -DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF # could be on?
  51. %cmake_build
  52. %install
  53. rm -rf %{buildroot}
  54. %cmake_install
  55. # compiler-rt
  56. # move sanitizer lists to better place
  57. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/share
  58. mv -v %{buildroot}%{_datadir}/*list.txt %{buildroot}%{_libdir}/clang/%{version}/share/
  59. # move sanitizer libs to better place
  60. %global libclang_rt_installdir lib/linux
  61. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib
  62. mv -v %{buildroot}%{_prefix}/%{libclang_rt_installdir}/*clang_rt* %{buildroot}%{_libdir}/clang/%{version}/lib
  63. mkdir -p %{buildroot}%{_libdir}/clang/%{version}/lib/linux/
  64. pushd %{buildroot}%{_libdir}/clang/%{version}/lib
  65. for i in *.a *.so
  66. do
  67. ln -s ../$i linux/$i
  68. done
  69. %if %{with test}
  70. %check
  71. #cmake_build --target check-compiler-rt
  72. %endif
  73. %clean
  74. rm -rf %{buildroot}
  75. %files
  76. %license LICENSE.TXT
  77. %{_includedir}/*
  78. %{_libdir}/clang/%{version}/lib/*
  79. %{_libdir}/clang/%{version}/share/*
  80. %ifarch x86_64 aarch64
  81. %{_bindir}/hwasan_symbolize
  82. %endif
  83. %changelog
  84. * Thu Jun 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  85. - new upstream release.
  86. - dropped Patch0.
  87. - imported Patch0 from rawhide.
  88. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  89. - new upstream release.
  90. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  91. - new upstream release.
  92. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  93. - new upstream release.
  94. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  95. - devided compiler-rt from llvm.
  96. - new upstream release.
  97. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  98. - enabled to build utils.
  99. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  100. - new upstream release.
  101. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  102. - new upstream release.
  103. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  104. - rebuilt with libffi-3.3.
  105. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  106. - new upstream release.
  107. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  108. - new upstream release.
  109. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  110. - dropped all patches.
  111. - switched build-system to ninja.
  112. - switched python to python3.
  113. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  114. - new upstream release.
  115. - added OpenMP.
  116. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  117. - fixed %%files.
  118. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  119. - new upstream release.
  120. - dropped Patch0, 4, 5, 100 and 200.
  121. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  122. - renamed a subpackage "llvm-libs".
  123. - added a subpackage "lld".
  124. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  125. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  126. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  127. - new upstream release.
  128. - dropped Patch1 and 2: fixed in upstream.
  129. - imported Patch0, 3-5, 100 and 200 from rawhide.
  130. - disabled Patch1002: no longer needed?
  131. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  132. - new upstream release.
  133. - switched to cmake.
  134. - disable ocaml binding as default.
  135. - updated Patch1000 and 1002.
  136. - disabled Patch1000 as default.
  137. - cleanup patches.
  138. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  139. - rebuild with gcc-5.4.0
  140. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  141. - new upstream release
  142. - added BR: ocaml-ctypes
  143. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  144. - new upstream release
  145. - dropt Patch 1, 201 and 1001
  146. - updated Patch 1000
  147. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  148. - updated to 3.5.1
  149. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  150. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  151. - obsoleted clang-doc
  152. - built with ocaml 4.02.1
  153. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  154. - fix <BTS:2832>
  155. - fix configure option "--with-c-include-dirs"
  156. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  157. - update Patch1001: clang-3.5.0-driver-lib64.patch
  158. - update Patch1002: clang-3.5.0-driver-vine.patch
  159. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  160. - update to 3.5.0
  161. - remove Patch11 (clang-hardfloat-hack.patch)
  162. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  163. - rebuild with libffi-3.0.13
  164. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  165. - update to 3.3
  166. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  167. - ld.gold (patch1000,1001)
  168. - add /%{_lib} to ld search path
  169. - add support *-vine-linux gcc (patch1002)
  170. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  171. - update to 3.1
  172. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  173. - updated to 3.0 release
  174. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  175. - added patch 2-4 to support -O4 link-time optimization
  176. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  177. - disable -fno-var-tracking-assignments on ppc
  178. (seems like gcc-4.4.5 still doesn't support this)
  179. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  180. - new upstream release
  181. - add BR: libffi-devel
  182. - add R: libffi-devel to -devel
  183. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  184. - initial build for Vine Linux
  185. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  186. - Update to final 2.7 release
  187. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  188. - Update to first 2.7 pre-release
  189. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  190. - Update to 2.6 pre-release2
  191. - -devel subpackage now virtually provides -static
  192. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  193. - Disable var tracking assignments on PPC
  194. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  195. - Don't adjust clang include dir; files there are noarch (bz#521893)
  196. - Enable clang unit tests
  197. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  198. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  199. - Package Clang's static analyzer tools
  200. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  201. - PIC is now enabled by default; explicitly disable on %%{ix86}
  202. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  203. - First 2.6 prerelease
  204. - Enable Clang front-end
  205. - Enable debuginfo generation
  206. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  207. - Disable assertions (needed by OpenGTL, bz#521261)
  208. - Align spec file with upstream build instructions
  209. - Enable unit tests
  210. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  211. - Only disable PIC on %%ix86; ppc actually needs it
  212. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  213. - Disable use of position-independent code on 32-bit platforms
  214. (buggy in LLVM <= 2.5)
  215. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  216. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  217. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  218. - Remove build scripts; they require the build directory to work
  219. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  220. - Update to 2.5
  221. - Package build scripts (bug #457881)
  222. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  223. - Patched build process for the OCaml binding
  224. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  225. - Update to 2.4
  226. - Package Ocaml binding
  227. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  228. - Add dependency on groff
  229. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  230. - LLVM 2.3
  231. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  232. - fix license tags
  233. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  234. - Fix compilation problems with gcc 4.3
  235. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  236. - Autorebuild for GCC 4.3
  237. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  238. - Fix review comments
  239. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  240. - Initial version