libomp-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. Summary: OpenMP runtime for clang
  6. Summary(ja): clang用OpenMPランタイム
  7. Name: libomp
  8. Version: 14.0.5
  9. Release: 1%{?_dist_release}
  10. Group: system
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: NCSA
  14. URL: https://llvm.org/
  15. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/openmp-%{version}.src.tar.xz
  16. # patches
  17. Patch0: 0001-PATCH-openmp-CMake-Make-LIBOMP_HEADERS_INSTALL_PATH-.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: cmake
  20. BuildRequires: ninja
  21. BuildRequires: libffi-devel >= 3.3
  22. BuildRequires: elfutils-libelf-devel
  23. # The AMDGCN device RTL requires clang and llvm-link to build
  24. BuildRequires: clang
  25. BuildRequires: llvm
  26. # libomptarget needs the llvm cmake files
  27. BuildRequires: llvm-devel
  28. BuildRequires: llvm-static
  29. %description
  30. The package contains the OpenMP runtime for clang.
  31. %package devel
  32. Summary: OpenMP header files
  33. Summary(ja): OpenMPヘッダファイル
  34. Group: programming
  35. Requires: clang-devel%{?isa} = %{version}
  36. %description devel
  37. The package contains the OpenMP header files.
  38. %debug_package
  39. %prep
  40. %autosetup -p2 -n openmp-%{version}.src
  41. %build
  42. # LTO causes build failures in this package. Disable LTO for now
  43. %define _lto_cflags %{nil}
  44. %cmake \
  45. -GNinja \
  46. -DLIBOMP_INSTALL_ALIASES=OFF \
  47. -DLLVM_DIR=%{_libdir}/cmake/llvm \
  48. -DLIBOMP_HEADERS_INSTALL_PATH:PATH=%{_libdir}/clang/%{version}/include \
  49. %if 0%{?__isa_bits} == 64
  50. -DOPENMP_LIBDIR_SUFFIX=64 \
  51. %else
  52. -DOPENMP_LIBDIR_SUFFIX= \
  53. %endif
  54. -DCMAKE_SKIP_RPATH:BOOL=ON
  55. %cmake_build
  56. %install
  57. rm -rf %{buildroot}
  58. %cmake_install
  59. # Remove static libraries with equivalent shared libraries
  60. rm -f %{buildroot}%{_libdir}/libarcher_static.a
  61. %if %{with test}
  62. %check
  63. %cmake_build --target check-openmp
  64. %endif
  65. %clean
  66. rm -rf %{buildroot}
  67. %files
  68. %license LICENSE.TXT
  69. %{_libdir}/libarcher.so
  70. %{_libdir}/libomp.so
  71. %{_libdir}/libompd.so
  72. %{_libdir}/libomptarget.so
  73. %ifnarch %{ix86} %{arm}
  74. %{_libdir}/libomptarget-new-*.bc
  75. %{_libdir}/libomptarget.rtl.amdgpu.so
  76. %{_libdir}/libomptarget.rtl.cuda.so
  77. %{_libdir}/libomptarget.rtl.%{_arch}.so
  78. %endif
  79. %files devel
  80. %{_libdir}/clang/%{version}/include/omp.h
  81. %{_libdir}/clang/%{version}/include/omp-tools.h
  82. %{_libdir}/clang/%{version}/include/ompt.h
  83. %{_includedir}/ompt-multiplex.h
  84. %{_libdir}/cmake/openmp/FindOpenMPTarget.cmake
  85. %changelog
  86. * Thu Jun 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  87. - new upstream release.
  88. - updated Patch0.
  89. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  90. - new upstream release.
  91. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  92. - new upstream release.
  93. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  94. - new upstream release.
  95. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  96. - devided libomp from llvm.
  97. - new upstream release.
  98. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  99. - enabled to build utils.
  100. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  101. - new upstream release.
  102. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  103. - new upstream release.
  104. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  105. - rebuilt with libffi-3.3.
  106. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  107. - new upstream release.
  108. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  109. - new upstream release.
  110. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  111. - dropped all patches.
  112. - switched build-system to ninja.
  113. - switched python to python3.
  114. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  115. - new upstream release.
  116. - added OpenMP.
  117. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  118. - fixed %%files.
  119. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  120. - new upstream release.
  121. - dropped Patch0, 4, 5, 100 and 200.
  122. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  123. - renamed a subpackage "llvm-libs".
  124. - added a subpackage "lld".
  125. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  126. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  127. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  128. - new upstream release.
  129. - dropped Patch1 and 2: fixed in upstream.
  130. - imported Patch0, 3-5, 100 and 200 from rawhide.
  131. - disabled Patch1002: no longer needed?
  132. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  133. - new upstream release.
  134. - switched to cmake.
  135. - disable ocaml binding as default.
  136. - updated Patch1000 and 1002.
  137. - disabled Patch1000 as default.
  138. - cleanup patches.
  139. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  140. - rebuild with gcc-5.4.0
  141. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  142. - new upstream release
  143. - added BR: ocaml-ctypes
  144. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  145. - new upstream release
  146. - dropt Patch 1, 201 and 1001
  147. - updated Patch 1000
  148. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  149. - updated to 3.5.1
  150. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  151. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  152. - obsoleted clang-doc
  153. - built with ocaml 4.02.1
  154. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  155. - fix <BTS:2832>
  156. - fix configure option "--with-c-include-dirs"
  157. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  158. - update Patch1001: clang-3.5.0-driver-lib64.patch
  159. - update Patch1002: clang-3.5.0-driver-vine.patch
  160. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  161. - update to 3.5.0
  162. - remove Patch11 (clang-hardfloat-hack.patch)
  163. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  164. - rebuild with libffi-3.0.13
  165. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  166. - update to 3.3
  167. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  168. - ld.gold (patch1000,1001)
  169. - add /%{_lib} to ld search path
  170. - add support *-vine-linux gcc (patch1002)
  171. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  172. - update to 3.1
  173. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  174. - updated to 3.0 release
  175. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  176. - added patch 2-4 to support -O4 link-time optimization
  177. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  178. - disable -fno-var-tracking-assignments on ppc
  179. (seems like gcc-4.4.5 still doesn't support this)
  180. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  181. - new upstream release
  182. - add BR: libffi-devel
  183. - add R: libffi-devel to -devel
  184. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  185. - initial build for Vine Linux
  186. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  187. - Update to final 2.7 release
  188. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  189. - Update to first 2.7 pre-release
  190. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  191. - Update to 2.6 pre-release2
  192. - -devel subpackage now virtually provides -static
  193. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  194. - Disable var tracking assignments on PPC
  195. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  196. - Don't adjust clang include dir; files there are noarch (bz#521893)
  197. - Enable clang unit tests
  198. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  199. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  200. - Package Clang's static analyzer tools
  201. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  202. - PIC is now enabled by default; explicitly disable on %%{ix86}
  203. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  204. - First 2.6 prerelease
  205. - Enable Clang front-end
  206. - Enable debuginfo generation
  207. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  208. - Disable assertions (needed by OpenGTL, bz#521261)
  209. - Align spec file with upstream build instructions
  210. - Enable unit tests
  211. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  212. - Only disable PIC on %%ix86; ppc actually needs it
  213. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  214. - Disable use of position-independent code on 32-bit platforms
  215. (buggy in LLVM <= 2.5)
  216. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  217. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  218. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  219. - Remove build scripts; they require the build directory to work
  220. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  221. - Update to 2.5
  222. - Package build scripts (bug #457881)
  223. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  224. - Patched build process for the OCaml binding
  225. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  226. - Update to 2.4
  227. - Package Ocaml binding
  228. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  229. - Add dependency on groff
  230. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  231. - LLVM 2.3
  232. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  233. - fix license tags
  234. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  235. - Fix compilation problems with gcc 4.3
  236. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  237. - Autorebuild for GCC 4.3
  238. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  239. - Fix review comments
  240. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  241. - Initial version