perl-DBI-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202
  1. %define version 1.618
  2. %define release 1
  3. Summary: A database access API for perl
  4. Summary(ja): perl 用データベース接続 API
  5. Name: perl-DBI
  6. Version: %{version}
  7. Release: %{release}%{?_dist_release}
  8. License: Artistic
  9. Group: Development/Libraries
  10. URL: http://dbi.perl.org/
  11. Source0: http://www.cpan.org/authors/id/T/TI/TIMB/DBI-%{version}.tar.gz
  12. BuildRequires: perl(ExtUtils::MakeMaker)
  13. # Run-time
  14. BuildRequires: perl(base)
  15. BuildRequires: perl(constant)
  16. BuildRequires: perl(Carp)
  17. # Clone is optional
  18. BuildRequires: perl(Clone)
  19. BuildRequires: perl(Coro)
  20. BuildRequires: perl(Coro::Handle)
  21. BuildRequires: perl(Coro::Select)
  22. BuildRequires: perl(Cwd)
  23. BuildRequires: perl(Data::Dumper)
  24. # DB_File is optional
  25. BuildRequires: perl(DB_File)
  26. BuildRequires: perl(DynaLoader)
  27. BuildRequires: perl(Errno)
  28. BuildRequires: perl(Exporter)
  29. BuildRequires: perl(Fcntl)
  30. BuildRequires: perl(File::Basename)
  31. BuildRequires: perl(File::Spec)
  32. BuildRequires: perl(Getopt::Long)
  33. BuildRequires: perl(IO::File)
  34. BuildRequires: perl(IO::Select)
  35. BuildRequires: perl(IPC::Open3)
  36. BuildRequires: perl(Math::BigInt)
  37. # MLDBM is optional
  38. ##BuildRequires: perl(MLDBM)
  39. # RPC::PlClient is optional
  40. ##BuildRequires: perl(RPC::PlClient) >= 0.2000
  41. # RPC::PlServer is optional
  42. ##BuildRequires: perl(RPC::PlServer)
  43. BuildRequires: perl(Scalar::Util)
  44. # SQL::Statement is optional
  45. BuildRequires: perl(SQL::Statement) >= 1.28
  46. BuildRequires: perl(Storable)
  47. BuildRequires: perl(Symbol)
  48. BuildRequires: perl(threads)
  49. BuildRequires: perl(Tie::Hash)
  50. BuildRequires: perl(UNIVERSAL)
  51. # Tests
  52. BuildRequires: perl(Encode)
  53. BuildRequires: perl(File::Path)
  54. BuildRequires: perl(lib)
  55. BuildRequires: perl(Net::Daemon::Test)
  56. BuildRequires: perl(Test::More)
  57. BuildRequires: perl(Test::Simple) >= 0.90
  58. # Optional tests
  59. BuildRequires: perl(Test::Pod) >= 1.00
  60. BuildRequires: perl(Test::Pod::Coverage) >= 1.04
  61. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  62. Requires: perl(Math::BigInt)
  63. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  64. %description
  65. DBI is a database access Application Programming Interface (API) for
  66. the Perl Language. The DBI API Specification defines a set of
  67. functions, variables and conventions that provide a consistent
  68. database interface independent of the actual database being used.
  69. %description -l ja
  70. DBI は Perl でデータベースにアクセスするための API です.
  71. DBI API では,実際に使われるデータベースに依存しない様に,
  72. 関数,変数などの取り決めが定義されています.
  73. %prep
  74. %setup -q -n DBI-%{version}
  75. iconv -f iso8859-1 -t utf-8 lib/DBD/Gofer.pm >lib/DBD/Gofer.pm.new &&
  76. mv lib/DBD/Gofer.pm{.new,}
  77. chmod 644 ex/*
  78. chmod 744 dbixs_rev.pl
  79. sed -i 's?#!perl?#!%{__perl}?' ex/corogofer.pl
  80. %build
  81. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  82. make %{?_smp_mflags}
  83. %install
  84. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  85. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  86. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  87. find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
  88. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  89. chmod -R u+w %{buildroot}/*
  90. # Remove Win32 specific files and man pages to avoid unwanted dependencies
  91. rm -rf %{buildroot}%{perl_vendorarch}/{Win32,DBI/W32ODBC.pm} \
  92. %{buildroot}%{_mandir}/man3/{DBI::W32,Win32::DBI}ODBC.3pm
  93. perl -pi -e 's"#!perl -w"#!/usr/bin/perl -w"' \
  94. %{buildroot}%{perl_vendorarch}/{goferperf,dbixs_rev}.pl
  95. %clean
  96. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  97. %check
  98. make test
  99. %files
  100. %defattr(-,root,root)
  101. %doc Changes README ex/
  102. %{perl_vendorarch}/*.p*
  103. %{perl_vendorarch}/Bundle/
  104. %{perl_vendorarch}/DBD/
  105. %{perl_vendorarch}/DBI/
  106. %{perl_vendorarch}/auto/DBI/
  107. %{_bindir}/*
  108. %{_mandir}/*/*
  109. %changelog
  110. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.618-1
  111. - updated to 1.618; spec revamped
  112. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.604-4vl6
  113. - rebuild with perl 5.12.3
  114. - using __perl_requires macro for VineSeed (vl6)
  115. * Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.604-3
  116. - spec in utf-8
  117. * Thu May 1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.604-2
  118. - rebuilt with perl-5.10.0.
  119. * Wed Apr 23 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.604-1
  120. - new upstream release
  121. * Mon Aug 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.58-0vl1
  122. - new upstream release
  123. * Sun Jan 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.53-0vl1
  124. - new upstream release
  125. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.51-0vl1
  126. - new upstream release
  127. - changed Group to Development/Libraries
  128. - installed module files to vendor_perl
  129. * Sat Jul 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.46-0vl2
  130. - use filter-requires-dbi.sh instead of find-requires.perl
  131. * Sat Dec 04 2004 IWAI, Masaharu <iwai@alib.jp> 1.46-0vl1
  132. - new upstream version
  133. - build on perl-5.8.6-0vl1
  134. * Sat May 22 2004 Satoshi MACHINO <machino@vinelinux.org> 1.40-0vl1
  135. - new upstream version
  136. * Sat May 24 2003 IWAI Masaharu <iwai@alib.jp> 1.37-0vl1
  137. - update 1.37
  138. - build with perl-5.8.0
  139. - add make test
  140. * Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 1.21-0vl1
  141. - updated 1.21
  142. * Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 1.20-0vl1
  143. - updated 1.20
  144. * Sat Sep 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.19-0vl2
  145. - the spec was in Shift-JIS. Fixed.
  146. * Fri Aug 03 2001 Satoshi MACHINO <machino@vinelinux.org> 1.19-0vl1
  147. - updated 1.19
  148. * Sat Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl2
  149. - rebuild on perl-5.6.0
  150. - changed mandir to /usr/share/man
  151. - removed version in Requires perl
  152. * Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl1
  153. - updated perl-DBL-1.15
  154. * Tue May 08 2001 Satoshi MACHINO <machino@vinelinux.org> 1.14-10vl1
  155. - fixed Vine Linux
  156. * Tue Feb 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  157. - Cleanups
  158. * Thu Nov 30 2000 Trond Eivind Glomsr <teg@redhat.com>
  159. - build for main distribution
  160. - use %%{_tmppath}
  161. - change name of specfile
  162. - don't use a find script to generate file lists
  163. - general cleanup
  164. - add descriptive summary and description
  165. * Mon Aug 14 2000 Tim Powers <timp@redhat.com>
  166. - Spec file was autogenerated.