python-qt5-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736
  1. # prevent anything matching from being scanned for provides
  2. %define filter_provides_in(P) %{expand: \
  3. %global __filter_prov_cmd %{?__filter_prov_cmd} %{__grep} -v %{-P} '%*' | \
  4. }
  5. # prevent anything matching from being scanned for requires
  6. %define filter_requires_in(P) %{expand: \
  7. %global __filter_req_cmd %{?__filter_req_cmd} %{__grep} -v %{-P} '%*' | \
  8. }
  9. # filter anything matching out of the provides stream
  10. %define filter_from_provides() %{expand: \
  11. %global __filter_from_prov %{?__filter_from_prov} | %{__sed} -e '%*' \
  12. }
  13. # filter anything matching out of the requires stream
  14. %define filter_from_requires() %{expand: \
  15. %global __filter_from_req %{?__filter_from_req} | %{__sed} -e '%*' \
  16. }
  17. # actually set up the filtering bits
  18. %define filter_setup %{expand: \
  19. %global _use_internal_dependency_generator 0 \
  20. %global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u \
  21. %global __find_provides /bin/sh -c "%{?__filter_prov_cmd} %{__deploop P} %{?__filter_from_prov}" \
  22. %global __find_requires /bin/sh -c "%{?__filter_req_cmd} %{__deploop R} %{?__filter_from_req}" \
  23. }
  24. %global with_python3 1
  25. %global python3_dbus_dir %(%{__python3} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])")
  26. %global with_python2 1
  27. %global python_dbus_dir %(%{__python} -c "import dbus.mainloop; print(dbus.mainloop.__path__[0])")
  28. # enable/disable individual modules
  29. # drop power64, it's not supported yet (than)
  30. %ifarch %{ix86} x86_64 %{arm} aarch64 mips mipsel mips64el
  31. %global webengine 0
  32. %endif
  33. %global webkit 0
  34. #global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
  35. %global rpm_macros_dir %{_sysconfdir}/rpm
  36. %global py3_sipdir %{_datadir}/sip/PyQt5
  37. Summary: PyQt5 is Python bindings for Qt5
  38. Name: python-qt5
  39. Version: 5.12.3
  40. Release: 3%{?_dist_release}
  41. Vendor: Project Vine
  42. Distribution: Vine Linux
  43. # all BSD, except for GPLv2+ dbus bindings and examples
  44. License: BSD and GPLv2+
  45. Url: https://www.riverbankcomputing.com/software/pyqt/
  46. Source0: https://www.riverbankcomputing.com/static/Downloads/PyQt5/%{version}/PyQt5_gpl-%{version}.tar.gz
  47. Source1: macros.pyqt5
  48. # wrapper, see https://bugzilla.redhat.com/show_bug.cgi?id=1193107#c9
  49. Source2: pylupdate5.sh
  50. Source3: pyrcc5.sh
  51. Source4: pyuic5.sh
  52. ## upstream patches
  53. ## upstreamable patches
  54. Patch0: python-qt5_sipdir.patch
  55. Patch1000: python-qt5-sip-option.patch
  56. Patch1001: pyqt5-5.12.3-python2.patch
  57. BuildRequires: chrpath
  58. BuildRequires: findutils
  59. BuildRequires: qt5-rpm-macros
  60. BuildRequires: pkgconfig(dbus-1)
  61. BuildRequires: pkgconfig(dbus-python)
  62. BuildRequires: pkgconfig(phonon4qt5)
  63. BuildRequires: pkgconfig(Qt5Core)
  64. #BuildRequires: pkgconfig(Enginio)
  65. BuildRequires: pkgconfig(Qt5Bluetooth)
  66. BuildRequires: pkgconfig(Qt5DBus)
  67. #BuildRequires: pkgconfig(Qt5Declarative)
  68. BuildRequires: qt5-qtdeclarative-devel
  69. BuildRequires: pkgconfig(Qt5Designer)
  70. BuildRequires: pkgconfig(Qt5Gui) pkgconfig(Qt5Multimedia)
  71. BuildRequires: pkgconfig(Qt5Location)
  72. BuildRequires: pkgconfig(Qt5Nfc)
  73. BuildRequires: pkgconfig(Qt5Network) pkgconfig(Qt5OpenGL)
  74. BuildRequires: pkgconfig(Qt5Positioning)
  75. BuildRequires: pkgconfig(Qt5Quick) pkgconfig(Qt5QuickWidgets)
  76. #BuildRequires: pkgconfig(Qt5Script)
  77. BuildRequires: pkgconfig(Qt5Sensors)
  78. BuildRequires: pkgconfig(Qt5SerialPort)
  79. BuildRequires: pkgconfig(Qt5Sql) pkgconfig(Qt5Svg) pkgconfig(Qt5Test)
  80. BuildRequires: pkgconfig(Qt5X11Extras)
  81. BuildRequires: pkgconfig(Qt5Xml) pkgconfig(Qt5XmlPatterns)
  82. BuildRequires: pkgconfig(Qt5WebChannel)
  83. BuildRequires: pkgconfig(Qt5WebSockets)
  84. BuildRequires: sip-devel >= 4.18
  85. %if 0%{?with_python2}
  86. BuildRequires: python-devel python
  87. BuildRequires: python-rpm-macros
  88. BuildRequires: python-enum34
  89. %endif # with_python2
  90. %if 0%{?with_python3}
  91. BuildRequires: python3-devel python3
  92. BuildRequires: python3-rpm-macros
  93. BuildRequires: python3-sip-devel >= 4.18
  94. BuildRequires: dbus-python3
  95. %endif # with_python3
  96. # when split out
  97. %if 0%{?webengine} || 0%{?webkit}
  98. Obsoletes: python-qt5 < 5.5.1-10
  99. %endif
  100. Requires: %{name}-rpm-macros = %{version}-%{release}
  101. Requires: python-qt5-base = %{version}-%{release}
  102. Requires: dbus-python
  103. BuildRequires: qt5-qtbase-private-devel
  104. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  105. %{?_sip_api:Requires: sip-api(%{_sip_api_major}) >= %{_sip_api}}
  106. %filter_provides_in %{python_sitearch} %{?_qt5_plugindir}
  107. %if 0%{?with_python3}
  108. %filter_provides_in %{python3_sitearch} %{?_qt5_plugindir}
  109. %endif
  110. %filter_setup
  111. Provides: PyQt5 = %{version}-%{release}
  112. Provides: PyQt5%{?_isa} = %{version}-%{release}
  113. Provides: python-PyQt5 = %{version}-%{release}
  114. Provides: python-PyQt5%{?_isa} = %{version}-%{release}
  115. Provides: python2-PyQt5 = %{version}-%{release}
  116. Provides: python2-PyQt5%{?_isa} = %{version}-%{release}
  117. Provides: python2-qt5 = %{version}-%{release}
  118. Provides: python2-qt5%{?_isa} = %{version}-%{release}
  119. %description
  120. PyQt5 is Python bindings for Qt5.
  121. %if 0%{?with_python2}
  122. %package base
  123. Summary: Python bindings for Qt5 base
  124. Requires: %{name}-rpm-macros = %{version}-%{release}
  125. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  126. %{?_sip_api:Requires: python-pyqt5-sip-api(%{_sip_api_major}) >= %{_sip_api}}
  127. Requires: dbus-python
  128. Obsoletes: python-qt5 < 5.5.1-10
  129. Provides: python-PyQt5-base = %{version}-%{release}
  130. Provides: python-PyQt5-base%{?_isa} = %{version}-%{release}
  131. %{?python_provide:%python_provide python-qt5-base}
  132. %description base
  133. %{summary}.
  134. %package devel
  135. Summary: Development files for %{name}
  136. Requires: %{name}%{?_isa} = %{version}-%{release}
  137. Requires: qt5-qtbase-devel
  138. Requires: sip-devel
  139. Provides: PyQt5-devel = %{version}-%{release}
  140. Provides: python-PyQt5-devel = %{version}-%{release}
  141. %description devel
  142. Files needed to build other bindings for C++ classes that inherit from any
  143. of the Qt5 classes (e.g. KDE or your own).
  144. %endif
  145. %package rpm-macros
  146. Summary: RPM macros %{name}
  147. # when split out
  148. Conflicts: python-qt5 < 5.6
  149. Conflicts: python3-qt5 < 5.6
  150. BuildArch: noarch
  151. %description rpm-macros
  152. %{summary}.
  153. %package -n python3-qt5
  154. Summary: Python 3 bindings for Qt5
  155. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  156. %{?_sip_api:Requires: python3-sip-api(%{_sip_api_major}) >= %{_sip_api}}
  157. # when split out
  158. %if 0%{?webengine} || 0%{?webkit}
  159. Obsoletes: python3-qt5 < 5.5.1-10
  160. %endif
  161. Provides: python3-PyQt5 = %{version}-%{release}
  162. Provides: python3-PyQt5%{?_isa} = %{version}-%{release}
  163. Requires: %{name}-rpm-macros = %{version}-%{release}
  164. Requires: python3-qt5-base = %{version}-%{release}
  165. Requires: dbus-python3
  166. %description -n python3-qt5
  167. %{summary}.
  168. %package -n python3-qt5-base
  169. Summary: Python 3 bindings for Qt5 base
  170. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  171. %{?_sip_api:Requires: python3-pyqt5-sip-api(%{_sip_api_major}) >= %{_sip_api}}
  172. Provides: python3-PyQt5-base = %{version}-%{release}
  173. Provides: python3-PyQt5-base%{?_isa} = %{version}-%{release}
  174. Requires: %{name}-rpm-macros = %{version}-%{release}
  175. Requires: dbus-python3
  176. %{?python_provide:%python_provide python3-qt5-base}
  177. %description -n python3-qt5-base
  178. %{summary}.
  179. %package -n python3-qt5-devel
  180. Summary: Python 3 bindings for Qt5
  181. Requires: python3-qt5%{?_isa} = %{version}-%{release}
  182. Requires: qt5-qtbase-devel
  183. Requires: python3-sip-devel
  184. Provides: python3-PyQt5-devel = %{version}-%{release}
  185. %description -n python3-qt5-devel
  186. Files needed to build other bindings for C++ classes that inherit from any
  187. of the Qt5 classes
  188. %package doc
  189. Summary: Developer documentation for %{name}
  190. Provides: PyQt5-doc = %{version}-%{release}
  191. BuildArch: noarch
  192. %description doc
  193. %{summary}.
  194. %if 0%{?webengine}
  195. %package webengine
  196. Summary: Python bindings for Qt5 WebEngine
  197. BuildRequires: pkgconfig(Qt5WebEngine)
  198. BuildRequires: qt5-qtwebengine-devel
  199. Obsoletes: python-qt5 < 5.5.1-10
  200. Requires: %{name}%{?_isa} = %{version}-%{release}
  201. %description webengine
  202. %package -n python3-qt5-webengine
  203. Summary: Python bindings for Qt5 WebEngine
  204. Obsoletes: python3-webengine < 5.5.1-13
  205. Obsoletes: python3-qt5 < 5.5.1-10
  206. Requires: python3-qt5%{?_isa} = %{version}-%{release}
  207. %description -n python3-qt5-webengine
  208. %endif
  209. %if 0%{?webkit}
  210. %package webkit
  211. Summary: Python bindings for Qt5 Webkit
  212. BuildRequires: pkgconfig(Qt5WebKit) pkgconfig(Qt5WebKitWidgets)
  213. Obsoletes: python3-webkit < 5.5.1-12
  214. Obsoletes: python-qt5 < 5.5.1-10
  215. Requires: %{name}%{?_isa} = %{version}-%{release}
  216. %description webkit
  217. %package -n python3-qt5-webkit
  218. Summary: Python bindings for Qt5 Webkit
  219. Obsoletes: python3-qt5 < 5.5.1-10
  220. Requires: python3-qt5%{?_isa} = %{version}-%{release}
  221. %description -n python3-qt5-webkit
  222. %endif
  223. %prep
  224. %setup -q -n PyQt5_gpl-%{version}%{?snap:-snapshot-%{snap}}
  225. %patch0 -p1
  226. %patch1000 -p1
  227. %patch1001 -p1
  228. %build
  229. PATH=%{_qt5_bindir}:$PATH ; export PATH
  230. # Python 2 build:
  231. %if 0%{?with_python2}
  232. mkdir %{_target_platform}
  233. pushd %{_target_platform}
  234. %{__python} ../configure.py \
  235. --assume-shared \
  236. --confirm-license \
  237. --no-designer-plugin \
  238. --no-qml-plugin \
  239. --qmake=%{_qt5_qmake} \
  240. %{!?with_python3:--no-qsci-api}%{?with_python3:--qsci-api --qsci-api-destdir=%{_qt5_datadir}/qsci} \
  241. --verbose \
  242. --dbus=/usr/include/dbus-1.0/ \
  243. QMAKE_CFLAGS_RELEASE="%{optflags}" \
  244. QMAKE_CXXFLAGS_RELEASE="%{optflags} -I/usr/%{_lib}/dbus-1.0/include/" \
  245. QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
  246. make %{?_smp_mflags}
  247. popd
  248. %endif # with_python2
  249. # Python 3 build:
  250. %if 0%{?with_python3}
  251. mkdir %{_target_platform}-python3
  252. pushd %{_target_platform}-python3
  253. %{__python3} ../configure.py \
  254. --assume-shared \
  255. --confirm-license \
  256. --qmake=%{_qt5_qmake} \
  257. %{?with_python2:--no-qsci-api}%{!?with_python2:--qsci-api --qsci-api-destdir=%{_qt5_datadir}/qsci} \
  258. %{?py3_sip:--sip=%{_bindir}/python3-sip} \
  259. %{?py3_sipdir:--sipdir=%{py3_sipdir}} \
  260. --verbose \
  261. %{?python3_sip_incdir} \
  262. --dbus=/usr/include/dbus-1.0/ \
  263. QMAKE_CFLAGS_RELEASE="%{optflags}" \
  264. QMAKE_CXXFLAGS_RELEASE="%{optflags} -I/usr/%{_lib}/dbus-1.0/include/" \
  265. QMAKE_LFLAGS_RELEASE="%{?__global_ldflags}"
  266. make %{?_smp_mflags}
  267. popd
  268. %endif # with_python3
  269. %install
  270. # Python 3 build:
  271. %if 0%{?with_python3}
  272. %make_install INSTALL_ROOT=%{buildroot} -C %{_target_platform}-python3
  273. if [ "%{_prefix}" != "/usr" ]; then
  274. cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/
  275. rm -rf %{buildroot}/usr/*
  276. fi
  277. %if "%py3_sipdir" == "%{_datadir}/sip/PyQt5"
  278. # copy files to old location for compat purposes temporarily
  279. mkdir -p %{buildroot}%{_datadir}/python3-sip
  280. cp -alf %{buildroot}%{py3_sipdir} \
  281. %{buildroot}%{_datadir}/python3-sip/PyQt5
  282. %endif
  283. if [ "%{_prefix}" != "/usr" ]; then
  284. cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/ || echo "Nothing to copy"
  285. rm -rf %{buildroot}/usr/*
  286. fi
  287. # ensure .so modules are executable for proper -debuginfo extraction
  288. find %{buildroot} -type f -name '*.so' | xargs chmod a+rx
  289. #for i in %%{buildroot}%%{python3_sitearch}/PyQt5/*.so %%{buildroot}%%{python3_dbus_dir}/pyqt5.so ; do
  290. #test -x $i || chmod a+rx $i
  291. #done
  292. %endif # with_python3
  293. # Python 2 build:
  294. %if 0%{?with_python2}
  295. %make_install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  296. if [ "%{_prefix}" != "/usr" ]; then
  297. cp -ru %{buildroot}/usr/* %{buildroot}%{_prefix}/
  298. rm -rf %{buildroot}/usr/*
  299. fi
  300. # ensure .so modules are executable for proper -debuginfo extraction
  301. find %{buildroot} -type f -name '*.so' | xargs chmod a+rx
  302. #for i in %%{buildroot}%%{python2_sitearch}/PyQt5/*.so %%{buildroot}%%{python2_dbus_dir}/pyqt5.so ; do
  303. #test -x $i || chmod a+rx $i
  304. #done
  305. %endif # with_python2
  306. # remove Python3 code from Python2 directory, fixes FTBFS like PyQt4 (#564633)
  307. rm -rfv %{buildroot}%{python2_sitearch}/PyQt5/uic/port_v3/
  308. # remove Python2 code from Python3 directory (for when/if we support python3 here)
  309. rm -rfv %{buildroot}%{python3_sitearch}/PyQt5/uic/port_v2/
  310. # rpm macros
  311. install -p -m644 -D %{SOURCE1} \
  312. %{buildroot}%{rpm_macros_dir}/macros.pyqt5
  313. sed -i \
  314. -e "s|@@NAME@@|%{name}|g" \
  315. -e "s|@@EPOCH@@|%{?epoch}%{!?epoch:0}|g" \
  316. -e "s|@@VERSION@@|%{version}|g" \
  317. -e "s|@@EVR@@|%{?epoch:%{epoch:}}%{version}-%{release}|g" \
  318. %{buildroot}%{rpm_macros_dir}/macros.pyqt5
  319. %if 0%{?with_python3}
  320. # install wrappers to handle both/either python2/python3
  321. # TODO: consider alternatives? -- rex
  322. rm -fv %{buildroot}%{_bindir}/{pyrcc5,pylupdate5,pyuic5}
  323. install -p -m755 -D %{SOURCE2} %{buildroot}%{_bindir}/pylupdate5
  324. install -p -m755 -D %{SOURCE3} %{buildroot}%{_bindir}/pyrcc5
  325. install -p -m755 -D %{SOURCE4} %{buildroot}%{_bindir}/pyuic5
  326. sed -i \
  327. -e "s|@PYTHON3@|%{__python3}|g" \
  328. -e "s|@PYTHON2@|%{__python2}|g" \
  329. %{buildroot}%{_bindir}/{pyrcc5,pylupdate5,pyuic5}
  330. %endif
  331. %if 0%{?with_python2}
  332. %files
  333. #{python_sitearch}/PyQt5/Enginio.so
  334. %{python_sitearch}/PyQt5/QtBluetooth.so
  335. %{python_sitearch}/PyQt5/QtDesigner.so
  336. %{python_sitearch}/PyQt5/QtHelp.so
  337. %{python_sitearch}/PyQt5/QtLocation.so
  338. %{python_sitearch}/PyQt5/QtMultimedia.so
  339. %{python_sitearch}/PyQt5/QtMultimediaWidgets.so
  340. %{python_sitearch}/PyQt5/QtNfc.so
  341. %{python_sitearch}/PyQt5/QtPositioning.so
  342. %{python_sitearch}/PyQt5/QtQml.so
  343. %{python_sitearch}/PyQt5/QtQuick.so
  344. %{python_sitearch}/PyQt5/QtQuickWidgets.so
  345. %{python_sitearch}/PyQt5/QtSensors.so
  346. %{python_sitearch}/PyQt5/QtSerialPort.so
  347. %{python_sitearch}/PyQt5/QtSvg.so
  348. %{python_sitearch}/PyQt5/QtWebChannel.so
  349. %{python_sitearch}/PyQt5/QtWebSockets.so
  350. %{python_sitearch}/PyQt5/QtX11Extras.so
  351. %{python_sitearch}/PyQt5/QtXmlPatterns.so
  352. %files base
  353. %doc NEWS README
  354. %license LICENSE
  355. %{python_dbus_dir}/pyqt5.so
  356. %dir %{python_sitearch}/PyQt5/
  357. %{python_sitearch}/PyQt5-%{version}%{?snap:.%{snap}}.dist-info
  358. %{python_sitearch}/PyQt5/__init__.py*
  359. %{python_sitearch}/PyQt5/Qt.so
  360. %{python_sitearch}/PyQt5/QtCore.so
  361. %{python_sitearch}/PyQt5/QtDBus.so
  362. %{python_sitearch}/PyQt5/QtGui.so
  363. %{python_sitearch}/PyQt5/QtNetwork.so
  364. %{python_sitearch}/PyQt5/QtOpenGL.so
  365. %{python_sitearch}/PyQt5/QtPrintSupport.so
  366. %{python_sitearch}/PyQt5/QtSql.so
  367. %{python_sitearch}/PyQt5/QtTest.so
  368. %{python_sitearch}/PyQt5/QtWidgets.so
  369. %{python_sitearch}/PyQt5/QtXml.so
  370. %{python_sitearch}/PyQt5/_QOpenGLFunctions_2_0.so
  371. %{python_sitearch}/PyQt5/_QOpenGLFunctions_2_1.so
  372. %{python_sitearch}/PyQt5/_QOpenGLFunctions_4_1_Core.so
  373. # *was* in -devel
  374. %{_bindir}/pylupdate5
  375. %{_bindir}/pyrcc5
  376. %{_bindir}/pyuic5
  377. %{python_sitearch}/PyQt5/uic/
  378. %{python_sitearch}/PyQt5/pylupdate.so
  379. %{python_sitearch}/PyQt5/pylupdate_main.py*
  380. %{python_sitearch}/PyQt5/pyrcc.so
  381. %{python_sitearch}/PyQt5/pyrcc_main.py*
  382. %if 0%{?webengine}
  383. %files webengine
  384. %{python_sitearch}/PyQt5/QtWebEngine.*
  385. %{python_sitearch}/PyQt5/QtWebEngineCore.*
  386. %{python_sitearch}/PyQt5/QtWebEngineWidgets.*
  387. %endif
  388. %if 0%{?webkit}
  389. %files webkit
  390. %{python_sitearch}/PyQt5/QtWebKit.*
  391. %{python_sitearch}/PyQt5/QtWebKitWidgets.*
  392. %endif
  393. %files devel
  394. %{_datadir}/sip/PyQt5/
  395. %endif
  396. %files rpm-macros
  397. %{rpm_macros_dir}/macros.pyqt5
  398. %if 0%{?with_python3}
  399. %files -n python3-qt5
  400. #{python3_sitearch}/PyQt5/Enginio.*
  401. %{python3_sitearch}/PyQt5/QtBluetooth.*
  402. %{python3_sitearch}/PyQt5/QtDesigner.*
  403. %{python3_sitearch}/PyQt5/QtHelp.*
  404. %{python3_sitearch}/PyQt5/QtLocation.*
  405. %{python3_sitearch}/PyQt5/QtMultimedia.*
  406. %{python3_sitearch}/PyQt5/QtMultimediaWidgets.*
  407. %{python3_sitearch}/PyQt5/QtNfc.*
  408. %{python3_sitearch}/PyQt5/QtPositioning.*
  409. %{python3_sitearch}/PyQt5/QtQml.*
  410. %{python3_sitearch}/PyQt5/QtQuick.*
  411. %{python3_sitearch}/PyQt5/QtQuickWidgets.*
  412. %{python3_sitearch}/PyQt5/QtSensors.*
  413. %{python3_sitearch}/PyQt5/QtSerialPort.*
  414. %{python3_sitearch}/PyQt5/QtSvg.*
  415. %{python3_sitearch}/PyQt5/QtWebChannel.*
  416. %{python3_sitearch}/PyQt5/QtWebSockets.*
  417. %{python3_sitearch}/PyQt5/QtX11Extras.*
  418. %{python3_sitearch}/PyQt5/QtXmlPatterns.*
  419. %files -n python3-qt5-base
  420. %doc NEWS README
  421. %license LICENSE
  422. %{python3_dbus_dir}/pyqt5.so
  423. %dir %{python3_sitearch}/PyQt5/
  424. %{python3_sitearch}/PyQt5-%{version}%{?snap:.%{snap}}.dist-info
  425. #{python3_sitearch}/PyQt5/__pycache__/__init__.*
  426. %{python3_sitearch}/PyQt5/__init__.py*
  427. %{python3_sitearch}/PyQt5/Qt.*
  428. %{python3_sitearch}/PyQt5/QtCore.*
  429. %{python3_sitearch}/PyQt5/QtDBus.*
  430. %{python3_sitearch}/PyQt5/QtGui.*
  431. %{python3_sitearch}/PyQt5/QtNetwork.*
  432. %{python3_sitearch}/PyQt5/QtOpenGL.*
  433. %{python3_sitearch}/PyQt5/QtPrintSupport.*
  434. %{python3_sitearch}/PyQt5/QtSql.*
  435. %{python3_sitearch}/PyQt5/QtTest.*
  436. %{python3_sitearch}/PyQt5/QtWidgets.*
  437. %{python3_sitearch}/PyQt5/QtXml.*
  438. %{python3_sitearch}/PyQt5/_QOpenGLFunctions_2_0.*
  439. %{python3_sitearch}/PyQt5/_QOpenGLFunctions_2_1.*
  440. %{python3_sitearch}/PyQt5/_QOpenGLFunctions_4_1_Core.*
  441. # plugins
  442. %{_qt5_plugindir}/PyQt5/
  443. %{_qt5_plugindir}/designer/libpyqt5.so
  444. %{python3_sitearch}/PyQt5/uic/
  445. # *was* in python3-qt5-devel
  446. %{_bindir}/pylupdate5
  447. %{_bindir}/pyrcc5
  448. %{_bindir}/pyuic5
  449. %{python3_sitearch}/PyQt5/pylupdate.so
  450. %{python3_sitearch}/PyQt5/pylupdate_main.py*
  451. #{python3_sitearch}/PyQt5/__pycache__/pylupdate_main*
  452. %{python3_sitearch}/PyQt5/pyrcc.so
  453. %{python3_sitearch}/PyQt5/pyrcc_main.py*
  454. #{python3_sitearch}/PyQt5/__pycache__/pyrcc_main*
  455. %if 0%{?webengine}
  456. %files -n python3-qt5-webengine
  457. %{python3_sitearch}/PyQt5/QtWebEngine.*
  458. %{python3_sitearch}/PyQt5/QtWebEngineCore.*
  459. %{python3_sitearch}/PyQt5/QtWebEngineWidgets.*
  460. %endif
  461. %if 0%{?webkit}
  462. %files -n python3-qt5-webkit
  463. %{python3_sitearch}/PyQt5/QtWebKit.*
  464. %{python3_sitearch}/PyQt5/QtWebKitWidgets.*
  465. %endif
  466. %files -n python3-qt5-devel
  467. %{py3_sipdir}/
  468. # compat location
  469. %dir %{_datadir}/python3-sip/
  470. %{_datadir}/python3-sip/PyQt5/
  471. %endif # with_python3
  472. %files doc
  473. #doc doc/*
  474. %doc examples/
  475. # avoid dep on qscintilla-python, own %%_qt5_datadir/qsci/... here for now
  476. %dir %{_qt5_datadir}/qsci/
  477. %dir %{_qt5_datadir}/qsci/api/
  478. %dir %{_qt5_datadir}/qsci/api/python/
  479. %doc %{_qt5_datadir}/qsci/api/python/PyQt5.api
  480. %changelog
  481. * Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.3-3
  482. - rebuilt with qt5-5.12.8.
  483. * Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.3-2
  484. - rebuilt with qt5-5.12.7.
  485. * Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.3-1
  486. - new upstream release.
  487. * Sat Jan 27 2018 Toshiaki Ara <ara_t@384.jp> - 5.6-7
  488. - rebuild under current VineSeed
  489. * Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6-6
  490. - initial build for Vine Linux.
  491. * Wed Jul 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-5
  492. - BR: qt5-qtbase-private-devel
  493. - python3-qt5: add versioned qt5 dep (like base python-qt5 pkg has)
  494. * Wed Jun 29 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-4
  495. - rebuild (qt5)
  496. * Wed Jun 15 2016 Than Ngo <than@redhat.com> - 5.6-3
  497. - drop ppc ppc64 ppc64le, it's not supported yet
  498. * Mon May 02 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-2
  499. - -rpm-macros: Conflicts: python(3)-qt5 < 5.6
  500. * Mon Apr 25 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6-1
  501. - PyQt5-5.6
  502. * Wed Apr 13 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.5.1-20
  503. - rebuild (sip), re-enable -webengine for secondary archs
  504. * Thu Mar 24 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-19
  505. - limit -webengine support to just primary archs (for now)
  506. * Thu Mar 24 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-18
  507. - -rpm-macros subpkg
  508. * Tue Mar 15 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-17
  509. - rebuild (qt5-qtenginio)
  510. * Mon Mar 14 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-16
  511. - -webengine: add ExclusiveArch (matching qt5-qtwebengine's)
  512. * Mon Mar 07 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-15
  513. - add Obsoletes for misnamed -webengine/-webkit pkgs (#1315025)
  514. * Sat Mar 05 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-14
  515. - python-qt5 is not built with $RPM_OPT_FLAGS (#1314998)
  516. * Thu Mar 03 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-13
  517. - fix python3-qt5-webengine name
  518. * Thu Mar 03 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-12
  519. - fix python3-qt5-webkit name
  520. * Wed Mar 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-11
  521. - use safer subdir builds
  522. * Wed Mar 02 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-10
  523. - -webengine,-webkit subpkgs
  524. * Sat Feb 27 2016 Christian Dersch <lupinix@mailbox.org> - 5.5.1-9
  525. - Enabled QtWebEngine for Fedora >= 24
  526. * Sat Feb 27 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-8
  527. - rebuild
  528. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.1-7
  529. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  530. * Mon Feb 01 2016 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-6
  531. - explicitly set CFLAGS,CXXFLAGS,LFLAGS
  532. * Wed Jan 13 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.5.1-5
  533. - %%description: mention PyQt5
  534. * Mon Dec 07 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-4
  535. - rebuild (qt5), Provides: python2-qt5
  536. * Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.5.1-3
  537. - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
  538. * Mon Nov 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-2
  539. - rebuild (qt5)
  540. * Mon Oct 26 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.1-1
  541. - 5.5.1
  542. - enable qtenginio, fix pyuic5 wrapper, use %%license
  543. * Mon Oct 12 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5-2
  544. - rebuild (qt5)
  545. * Thu Jul 30 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5-1
  546. - 5.5
  547. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4.2-2
  548. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  549. * Fri Jun 12 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.2-1
  550. - 5.4.2
  551. * Fri Jun 05 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-5
  552. - wrong python release used in pyuic5 launch script (#1193107)
  553. - -doc: add qsci doc QyQt5.api content
  554. - enable Qt5WebChannel/Qt5WebSockets support
  555. * Fri Jun 05 2015 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
  556. - Add patch to fix python3 sip installation dir (#1228432)
  557. * Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
  558. - Rebuilt for GCC 5 C++11 ABI change
  559. * Wed Mar 25 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-2
  560. - rebuild (sip)
  561. * Thu Feb 26 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-1
  562. - 5.4.1
  563. * Wed Feb 25 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-6
  564. - rebuild (sip)
  565. * Tue Jan 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-5
  566. - +macros.pyqt5
  567. * Fri Jan 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4-4
  568. - -devel: restore dep on base pkg
  569. * Sun Dec 28 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.4-3
  570. - python3-qt5-devel subpkg
  571. * Sat Dec 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4-2
  572. - ensure .so modules are executable (for proper -debuginfo extraction)
  573. * Fri Dec 26 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4-1
  574. - 5.4
  575. * Thu Nov 13 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-6
  576. - restore python3 support
  577. * Tue Nov 11 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-5
  578. - pkgconfig(QtOpenGL) being satisfied by qt4 devel (#1162415)
  579. * Thu Nov 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-4
  580. - try to determine dbus-python install paths dynamically (#1161121)
  581. * Thu Nov 06 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.3.2-3
  582. - Build failure in sipQtWebKitWidgestQWebInspector: qprinter.h not found (#1160932)
  583. - python2_sitelib should be python2_sitearch (#1161121)
  584. * Mon Sep 15 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
  585. - PyQt-gpl-5.3.2
  586. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
  587. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  588. * Sun Jul 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.1-1
  589. - PyQt-gpl-5.3.1
  590. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3-3
  591. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  592. * Mon Jun 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3-2
  593. - python3: (Build)Requires: python3-dbus
  594. * Mon Jun 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3-1
  595. - PyQt-gpl-5.3
  596. - +Qt5Bluetooth,Qt5Quick,Qt5SerialPorts support
  597. * Mon May 12 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
  598. - rebuild (f21-python)
  599. - +Qt5Positioning,Qt5Sensors support
  600. * Sun Mar 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
  601. - PyQt-5.2.1
  602. * Sat Mar 08 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.2-5
  603. - Rebuild against fixed qt5-qtbase to fix -debuginfo (#1065636)
  604. * Sat Feb 15 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-4
  605. - python3-qt5 support
  606. * Thu Feb 13 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-3
  607. - Provides: PyQt5
  608. * Thu Feb 06 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-2
  609. - BR: python2-devel, use %%__python2 macro
  610. * Wed Jan 08 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2-1
  611. - PyQt-5.2