pango-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622
  1. %define glib2_version 2.55.0
  2. %define pkgconfig_version 0.12
  3. %define freetype2_version 2.8.1
  4. %define fontconfig_version 2.12.6
  5. %define cairo_version 1.14.12
  6. # biarch support
  7. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  8. %define _querymodules_suffix %{nil}
  9. %if %{build_compat32}
  10. %define _querymodules_suffix -32
  11. %endif
  12. Summary: System for layout and rendering of internationalized text.
  13. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  14. Name: pango
  15. Version: 1.48.3
  16. Release: 1%{?_dist_release}
  17. Group: system
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. License: LGPL
  21. URL: https://pango.gnome.org/
  22. %global shortver %(echo %{version} | cut -d . -f 1,2)
  23. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. # We need to prereq this so we can run pango-querymodules
  26. Requires: glib2 >= %{glib2_version}
  27. Requires: freetype2 >= %{freetype2_version}
  28. BuildRequires: meson
  29. BuildRequires: glib2-devel >= %{glib2_version}
  30. BuildRequires: pkgconfig >= %{pkgconfig_version}
  31. BuildRequires: freetype2-devel >= %{freetype2_version}
  32. BuildRequires: fontconfig-devel >= %{fontconfig_version}
  33. BuildRequires: libX11-devel, libXft-devel, libXrender-devel
  34. BuildRequires: cairo-devel >= %{cairo_version}
  35. BuildRequires: libSM-devel
  36. BuildRequires: gobject-introspection-devel
  37. BuildRequires: libthai-devel
  38. BuildRequires: harfbuzz-devel
  39. BuildRequires: fribidi-devel
  40. BuildRequires: gtk-doc
  41. BuildRequires: help2man
  42. Obsoletes: pango-gtkbeta, fribidi-gtkbeta
  43. %description
  44. Pango is a system for layout and rendering of internationalized text.
  45. %description -l ja
  46. Pango は国際化テキストのレイアウト・レンダリングシステムです。
  47. %package devel
  48. Summary: System for layout and rendering of internationalized text.
  49. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  50. Group: programming
  51. Requires: %{name} = %{version}
  52. Requires: glib2-devel >= %{glib2_version}
  53. Requires: freetype2-devel >= %{freetype2_version}
  54. Requires: cairo-devel >= %{cairo_version}
  55. Requires: libX11-devel, libXft-devel, libXrender-devel
  56. Requires: harfbuzz-devel
  57. Obsoletes: fribidi-gtkbeta-devel, pango-gtkbeta-devel
  58. %description devel
  59. The pango-devel package includes the static libraries, header files,
  60. and developer docs for the pango package.
  61. Install pango-devel if you want to develop programs which will use
  62. pango.
  63. #####################################################################
  64. # compat32
  65. %package -n compat32-%{name}
  66. Summary: System for layout and rendering of internationalized text.
  67. Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
  68. Group: system
  69. %description -n compat32-%{name}
  70. Pango is a system for layout and rendering of internationalized text.
  71. %description -n compat32-%{name} -l ja
  72. Pango は国際化テキストのレイアウト・レンダリングシステムです。
  73. %package -n compat32-%{name}-devel
  74. Summary: Development files for pango
  75. Summary(ja): pango 用の開発ファイル
  76. Group: programming
  77. Requires: compat32-%{name} = %{version}
  78. Requires: %{name}-devel = %{version}
  79. %description -n compat32-%{name}-devel
  80. The pango-devel package includes the static libraries, header files,
  81. and developer docs for the pango package.
  82. %debug_package
  83. %prep
  84. %setup -q -n pango-%{version}
  85. %build
  86. %meson \
  87. -Dgtk_doc=false \
  88. -Dintrospection=enabled \
  89. -Duse_fontconfig=true \
  90. -Dinstall-tests=false
  91. %meson_build
  92. %install
  93. rm -rf $RPM_BUILD_ROOT
  94. %meson_install
  95. %files
  96. %defattr(-, root, root)
  97. %license COPYING
  98. %doc README AUTHORS NEWS
  99. %doc pango-view/HELLO.txt
  100. #doc README AUTHORS COPYING ChangeLog
  101. #doc examples/HELLO.utf8
  102. %{_bindir}/pango-view
  103. %{_bindir}/pango-list
  104. %{_libdir}/libpango*-*.so.*
  105. %dir %{_libdir}/girepository-1.0
  106. %{_libdir}/girepository-1.0/*
  107. %{_mandir}/man*/*
  108. %files devel
  109. %defattr(-, root, root)
  110. %{_libdir}/libpango*.so
  111. %{_includedir}/*
  112. %{_libdir}/pkgconfig/*
  113. %{_datadir}/gir-1.0
  114. %if %{build_compat32}
  115. %files -n compat32-%{name}
  116. %defattr(-, root, root)
  117. %{_libdir}/libpango*-*.so.*
  118. %files -n compat32-%{name}-devel
  119. %defattr(-, root, root)
  120. %{_libdir}/libpango*.so
  121. %endif
  122. %changelog
  123. * Thu Mar 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.48.3-1
  124. - new upstream release.
  125. - dropped scriptlets.
  126. * Tue May 05 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.44.7-1
  127. - new upstream release.
  128. * Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.40.14-1
  129. - new upstream release.
  130. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.40.1-1
  131. - new upstream release
  132. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.38.1-1
  133. - new upstream release
  134. - remove old patches
  135. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.8-1
  136. - new upstream release
  137. * Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.5-1
  138. - new upstream release
  139. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.3-1
  140. - new upstream release
  141. * Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.2-1
  142. - new upstream release
  143. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.1-1
  144. - new upstream release
  145. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.0-1
  146. - new upstream release
  147. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.1-1
  148. - new upstream release
  149. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.0-1
  150. - new upstream release
  151. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.5-1
  152. - new upstream release
  153. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.2-1
  154. - new upstream release
  155. * Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.1-1
  156. - new upstream release
  157. - update Patch0 (pango-1.31.2-lib64.patch)
  158. - add BuildRequires: harfbuzz-devel
  159. * Tue Jun 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
  160. - new upstream release
  161. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
  162. - new upstream release
  163. * Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-2
  164. - add BuildRequires: libthai-devel
  165. * Thu Oct 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-1
  166. - new upstream release
  167. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.3-1
  168. - new upstream release
  169. * Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.28.4-1
  170. - new upstream release with security fixes (CVE-2011-0020, 0064)
  171. - add Vendor/Distri tags
  172. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.3-1
  173. - add BuildRequires: libSM-devel, gobject-introspection-devel
  174. - add Patch1 (pango-1.28.1-gobject-introspection.patch)
  175. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.28.1-2
  176. - build with rpm-4.8.1-1 for pkg-config file
  177. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.1-1
  178. - new upstream release
  179. * Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.0-1
  180. - new upstream release
  181. * Sun Jan 10 2010 Shu KONNO <owa@bg.wakwak.com> 1.26.2-2
  182. - changed %%makeinstall to make install with DESTDIR option
  183. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.2-1
  184. - new upstream release
  185. * Sun Nov 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.1-1
  186. - new upstream release
  187. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
  188. - new upstream release
  189. * Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.5-1
  190. - new upstream release
  191. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.4-1
  192. - new upstream release
  193. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.2-1
  194. - new upstream release
  195. * Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.24.1-2
  196. - removed %%if !%%{build_compat32} case condition
  197. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.1-1
  198. - new upstream release
  199. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
  200. - new upstream release
  201. * Tue Dec 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.4-1
  202. - new upstream release
  203. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.3-1
  204. - new upstream release
  205. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.1-1
  206. - new upstream release
  207. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.0-1
  208. - new upstream release
  209. * Thu Jul 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-1
  210. - new upstream release
  211. * Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.20.3-2
  212. - spec in UTF-8 actually
  213. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.3-1
  214. - new upstream release
  215. - rebuilt with xorg-x11 7.3
  216. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-1vl5
  217. - new upstream release
  218. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-1vl5
  219. - used %{?_dist_release}
  220. * Wed Mar 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
  221. - new upstream release
  222. * Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.4-0vl1
  223. - new upstream release
  224. * Fri Nov 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.3-0vl1
  225. - new upstream release
  226. - added Patch0 instead of Patch5
  227. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
  228. - replace build with new environment
  229. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
  230. - rebuild with new environment
  231. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl1
  232. - new upstream release
  233. * Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.2-0vl1
  234. - new upstream release
  235. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.9-0vl1
  236. - new upstream release
  237. * Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.7-0vl1
  238. - new upstream release
  239. * Sat Sep 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.4-0vl1
  240. - new upstream release
  241. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.0-0vl1
  242. - new upstream release
  243. * Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl3
  244. - rebuild with cairo-1.2.0
  245. * Tue Aug 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl2
  246. - add Patch10 to create fake style(italic/bold) for all fonts.
  247. http://bugzilla.gnome.org/show_bug.cgi?id=319808
  248. - This patch is not applied in upstream, but it seems usefull
  249. for us.
  250. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl1
  251. - new upstream release
  252. * Sun Apr 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-0vl1
  253. - new upstream release
  254. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.1-0vl1
  255. - new upstream release
  256. * Fri Mar 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl2
  257. - fix broken dependancy
  258. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl1
  259. - new upstream release
  260. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.99-0vl1
  261. - new upstream release
  262. - add compat32 package for x86_64 arch support
  263. - add Patch5 for biarch support
  264. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-0vl1
  265. - new upstream release
  266. * Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-0vl1
  267. - new upstream release
  268. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-0vl1
  269. - new upstream release
  270. * Mon Aug 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl2
  271. - rebuild with cairo-0.9
  272. - add patch10 to disable building example programs
  273. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl1
  274. - new upstream release
  275. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
  276. - new upstream release
  277. - drop obsolete patches
  278. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  279. - new upstream release
  280. - import upstream patches from fedora package.
  281. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
  282. - new upstream release
  283. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
  284. - new upstream release
  285. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
  286. - remove unneeded dependancy to freetype2-devel
  287. * Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl2
  288. - add patch10 to build against freetype-2.1.7
  289. - rebuild with freetype-2.1.7
  290. * Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl1
  291. - new upstream release
  292. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
  293. - new upstream release
  294. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
  295. - new upstream release
  296. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl2
  297. - merge patch1,2 from rawhide package.
  298. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  299. - new upstream release
  300. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.5-0vl1
  301. - new upstream release
  302. - Build for Vine Linux, specfile are based on rawhide release
  303. * Thu Nov 21 2002 Havoc Pennington <hp@redhat.com>
  304. - change PKG_CONFIG_PATH hack to also search /usr/X11R6/lib64/pkgconfig
  305. * Wed Nov 20 2002 Havoc Pennington <hp@redhat.com>
  306. - explicitly require pangoxft to be built, so we catch situations such
  307. as xft.pc moving to /usr/X11R6
  308. - also add /usr/X11R6/lib/pkgconfig to PKG_CONFIG_PATH as a temporary
  309. hack
  310. * Thu Nov 7 2002 Havoc Pennington <hp@redhat.com>
  311. - 1.1.3
  312. * Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-5
  313. - Require the necessary freetype version, don't just
  314. BuildRequires it (#74744)
  315. * Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-4
  316. - Own /etc/pango (#73962, Enrico Scholz)
  317. - Remove .la files from the build root
  318. * Mon Oct 7 2002 Havoc Pennington <hp@redhat.com>
  319. - require glib 2.0.6-3, try rebuild on more arches
  320. * Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
  321. - Version 1.1.1 (main change, fixes font selection for FT2 backend,
  322. as in gdmgreeter)
  323. * Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
  324. - Fix linked list manipulation problem that was causing hang for anaconda
  325. - Fix warning from loading mini-fonts with context == NULL
  326. * Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
  327. - Fix major memory leak in the last patch
  328. * Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
  329. - Actually use language tags at the rendering layer (should fix #68211)
  330. * Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
  331. - Remove fixed-ltmain.sh, relibtoolize; to fix relink problems without
  332. - Fix bug causing hex boxes to be misrendered
  333. leaving RPATH (#66005)
  334. - For FT2 backend, supply FT_LOAD_NO_BITMAP to avoid problems with
  335. fonts with embedded bitmaps (#67851)
  336. * Mon Jul 8 2002 Owen Taylor <otaylor@redhat.com>
  337. - Make basic-x shaper work with our big-5 fonts
  338. * Wed Jul 3 2002 Owen Taylor <otaylor@redhat.com>
  339. - New upstream tarball with hooks for change-on-the fly font rendering
  340. * Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
  341. - Up FreeType version to deal with FreeType-2.0.x / 2.1.x \
  342. ABI changes for pango's OpenType code.
  343. * Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
  344. - Add some Korean aliases that the installer wants
  345. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  346. - automated rebuild
  347. * Sat Jun 8 2002 Havoc Pennington <hp@redhat.com>
  348. - devel package requires fontconfig/Xft devel packages
  349. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  350. - rebuild in different environment
  351. * Thu Jun 6 2002 Owen Taylor <otaylor@redhat.com>
  352. - Snapshot with Xft2/fontconfig support
  353. * Wed May 29 2002 Owen Taylor <otaylor@redhat.com>
  354. - Version 1.0.2
  355. - Patch for charmaps problem
  356. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  357. - automated rebuild
  358. * Wed May 22 2002 Havoc Pennington <hp@redhat.com>
  359. - rebuild in different environment
  360. * Wed May 22 2002 Havoc Pennington <hp@redhat.com>
  361. - add patch to adjust to newer version of freetype
  362. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  363. - Update to version 1.0.1, remove patch
  364. * Tue Mar 19 2002 Owen Taylor <otaylor@redhat.com>
  365. - Patch from CVS for big speedup with FreeType-2.0.9
  366. * Mon Mar 11 2002 Owen Taylor <otaylor@redhat.com>
  367. - Rebuild
  368. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  369. - Version 1.0.0
  370. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  371. - Update to 0.26
  372. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  373. - Bump for rebuild
  374. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  375. - Update to 0.25
  376. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  377. - add horrible buildrequires hack
  378. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  379. - 0.24.90 cvs snap
  380. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  381. - Version 0.24
  382. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  383. - automated rebuild
  384. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  385. - new snap 0.23.90
  386. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  387. - rebuild with 64-bit-fixed glib
  388. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  389. - Version 0.22
  390. - add explicit check for required glib2 version before we do the build,
  391. so we don't end up with bad RPMs on --nodeps builds
  392. - PreReq the glib2_version version, instead of 1.3.8 hardcoded that
  393. no one had updated recently
  394. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  395. - Version 0.21
  396. * Thu Oct 4 2001 Havoc Pennington <hp@redhat.com>
  397. - cvs snap
  398. - new cvs snap with a bugfix
  399. * Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
  400. - sync with Owen's changes, fix up dependency versions
  401. * Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
  402. - 0.19
  403. * Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
  404. - build CVS snap
  405. * Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
  406. - no relinking junk
  407. * Tue Sep 4 2001 root <root@dhcpd37.meridian.redhat.com>
  408. - Version 0.18
  409. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  410. - Configure --disable-gtk-doc
  411. - BuildRequires freetype-devel, XFree86-devel
  412. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  413. - 0.17
  414. - libtool hackarounds
  415. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  416. - 0.16, rename back to pango from pango-gtkbeta
  417. * Fri Feb 16 2001 Owen Taylor <otaylor@redhat.com>
  418. - Obsolete fribidi-gtkbeta
  419. * Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
  420. - Remove that patch I just put in
  421. * Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
  422. - Patch pangox.pc.in to include -Iincludedir
  423. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  424. - final 0.13
  425. * Tue Nov 14 2000 Owen Taylor <otaylor@redhat.com>
  426. - New 0.13 tarball
  427. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  428. - 0.13pre1
  429. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  430. - Rename to 0.12b to avoid versioning problems
  431. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  432. - Move to a CVS snapshot
  433. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  434. - Move back to /usr
  435. - Version 0.12
  436. * Mon Jun 19 2000 Owen Taylor <otaylor@redhat.com>
  437. - Add missing %%defattr
  438. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  439. - Rebuild with a prefix of /opt/gtk-beta
  440. * Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
  441. - version 0.11
  442. - add --without-qt
  443. * Wed Apr 26 2000 Owen Taylor <otaylor@redhat.com>
  444. - Make the devel package require *-gtkbeta-* not the normal packages.
  445. * Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  446. - GTK+ snapshot version installing in /opt/gtk-beta
  447. * Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
  448. - Created spec file