suricata-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563
  1. %bcond_with systemd
  2. %bcond_with libprelude
  3. Summary: Intrusion Detection System
  4. Name: suricata
  5. Version: 6.0.2
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: network,security
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2
  11. URL: https://suricata-ids.org/
  12. Source0: https://www.openinfosecfoundation.org/download/%{name}-%{version}.tar.gz
  13. Source1: suricata.sysconfig
  14. Source2: fedora.notes
  15. Source3: suricata-tmpfiles.conf
  16. Source1000: suricata.init
  17. Source1001: suricata.logrotate
  18. Source1002: pre_start
  19. Source1003: post_stop
  20. # Irrelevant docs are getting installed, drop them
  21. Patch1: suricata-2.0.9-docs.patch
  22. # Suricata service file needs some options supplied
  23. Patch2: suricata-4.1.1-service.patch
  24. # Linux 5.2 headers moved SIOCGSTAMP to linux/sockios.h. Glibc will
  25. # include it via sys/socket.h in a future release. This is temporary
  26. # and should not be needed on other kernel/glibc combos.
  27. Patch3: suricata-4.1.4-socket.patch
  28. BuildRequires: gcc gcc-c++
  29. BuildRequires: rust cargo
  30. BuildRequires: libyaml-devel python3-pyyaml
  31. BuildRequires: libnfnetlink-devel libnetfilter_queue-devel libnet-devel
  32. BuildRequires: zlib-devel pcre-devel libcap-ng-devel
  33. BuildRequires: lz4-devel libpcap-devel
  34. BuildRequires: nspr-devel nss-devel file-devel
  35. BuildRequires: jansson-devel libmaxminddb-devel python3-devel lua-devel
  36. # Next line is for eBPF support
  37. %ifarch x86_64
  38. BuildRequires: clang llvm libbpf-devel
  39. %endif
  40. BuildRequires: autoconf automake libtool
  41. %if %{with systemd}
  42. BuildRequires: systemd
  43. %endif
  44. BuildRequires: hiredis-devel
  45. BuildRequires: libevent-devel
  46. %if %{with libprelude}
  47. BuildRequires: libprelude-devel
  48. %endif
  49. BuildRequires: gnutls-devel
  50. %ifarch x86_64
  51. BuildRequires: hyperscan-devel
  52. %endif
  53. Requires: python3-pyyaml
  54. Requires(pre): /usr/sbin/useradd
  55. %if %{with systemd}
  56. Requires(post): systemd
  57. Requires(preun): systemd
  58. Requires(postun): systemd
  59. %endif
  60. %description
  61. The Suricata Engine is an Open Source Next Generation Intrusion
  62. Detection and Prevention Engine. This engine is not intended to
  63. just replace or emulate the existing tools in the industry, but
  64. will bring new ideas and technologies to the field. This new Engine
  65. supports Multi-threading, Automatic Protocol Detection (IP, TCP,
  66. UDP, ICMP, HTTP, TLS, FTP and SMB! ), Gzip Decompression, Fast IP
  67. Matching, and GeoIP identification.
  68. %debug_package
  69. %prep
  70. %setup -q
  71. install -m 644 %{SOURCE2} doc/
  72. %patch1 -p1
  73. %patch2 -p1
  74. %patch3 -p1
  75. sed -i 's/(datadir)/(sysconfdir)/' etc/Makefile.am
  76. %ifarch x86_64
  77. sed -i 's/-D__KERNEL__/-D__KERNEL__ -D__x86_64__/' ebpf/Makefile.am
  78. %endif
  79. autoreconf -fv --install
  80. %build
  81. %configure --enable-gccprotect --enable-pie --disable-gccmarch-native \
  82. --disable-coccinelle --enable-nfqueue --enable-af-packet \
  83. --with-libnspr-includes=/usr/include/nspr4 \
  84. --with-libnss-includes=/usr/include/nss3 \
  85. --enable-jansson --enable-geoip --enable-lua --enable-hiredis \
  86. %if %{with libprelude}
  87. --enable-prelude \
  88. %endif
  89. --enable-rust \
  90. %ifarch x86_64
  91. --enable-ebpf-build --enable-ebpf \
  92. %endif
  93. --enable-python
  94. %make_build
  95. %install
  96. make DESTDIR="%{buildroot}" "bindir=%{_sbindir}" install
  97. # Setup etc directory
  98. mkdir -p %{buildroot}%{_sysconfdir}/%{name}/rules
  99. #install -m 640 rules/*.rules %{buildroot}%{_sysconfdir}/%{name}/rules
  100. for f in rules/*.rules; do
  101. touch %{buildroot}%{_sysconfdir}/%{name}/$f
  102. done
  103. install -m 600 *.config %{buildroot}%{_sysconfdir}/%{name}
  104. install -m 600 suricata.yaml %{buildroot}%{_sysconfdir}/%{name}/
  105. install -m 755 %{SOURCE1002} %{buildroot}%{_sysconfdir}/%{name}/
  106. install -m 755 %{SOURCE1003} %{buildroot}%{_sysconfdir}/%{name}/
  107. %if %{with systemd}
  108. mkdir -p %{buildroot}%{_unitdir}
  109. install -m 0644 etc/%{name}.service %{buildroot}%{_unitdir}/
  110. sed -i \
  111. -e 's|/var/run/|/run/|' \
  112. -e '/ExecStart=/i ExecStartPre=%{_sysconfdir}/%{name}/pre_start' \
  113. -e '/ExecStart=/i ExecStopPost=%{_sysconfdir}/%{name}/post_stop' \
  114. %{buildroot}%{_unitdir}/%{name}.service
  115. %else
  116. mkdir -p %{buildroot}%{_initdir}
  117. install -m 0644 %{SOURCE1000} %{buildroot}%{_initdir}/%{name}
  118. %endif
  119. mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
  120. install -m 0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  121. # Set up logging
  122. mkdir -p %{buildroot}/%{_var}/log/%{name}
  123. mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
  124. #install -m 644 etc/%{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  125. #sed -i -e 's|/var/run/%{name}\.pid|/var/run/%{name}/%{name}.pid|' %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  126. install -m 644 %{SOURCE1001} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  127. # Remove a couple things so they don't get picked up
  128. rm -rf %{buildroot}%{_includedir}
  129. rm -f %{buildroot}%{_libdir}/libhtp.la
  130. rm -f %{buildroot}%{_libdir}/libhtp.a
  131. rm -f %{buildroot}%{_libdir}/libhtp.so
  132. rm -rf %{buildroot}%{_libdir}/pkgconfig
  133. # Setup suricata-update data directory
  134. mkdir -p %{buildroot}/%{_var}/lib/%{name}
  135. # Setup tmpdirs
  136. %if %{with systemd}
  137. mkdir -p %{buildroot}%{_tmpfilesdir}
  138. install -m 0644 %{SOURCE3} %{buildroot}%{_tmpfilesdir}/%{name}.conf
  139. %endif
  140. mkdir -p %{buildroot}/run
  141. install -d -m 0755 %{buildroot}/run/%{name}/
  142. cp suricata-update/README.rst doc/suricata-update-README.rst
  143. %check
  144. make check
  145. %pre
  146. getent passwd suricata >/dev/null || useradd -r -M -s /sbin/nologin suricata
  147. %post
  148. %if %{with systemd}
  149. %systemd_post suricata.service
  150. %else
  151. if [ $1 -gt 0 ]; then
  152. /sbin/chkconfig --add suricata
  153. fi
  154. %endif
  155. %preun
  156. %if %{with systemd}
  157. %systemd_preun suricata.service
  158. %else
  159. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  160. /sbin/service suricata stop
  161. /sbin/chkconfig suricata off ||:
  162. /sbin/chkconfig --del suricata
  163. fi
  164. %endif
  165. %postun
  166. %if %{with systemd}
  167. %systemd_postun_with_restart suricata.service
  168. %else
  169. if [ $1 -gt 0 -a -f /var/run/suricata/suricata.pid -a ! -x /bin/systemctl ]; then
  170. /sbin/service suricata restart
  171. fi
  172. %endif
  173. %files
  174. %doc doc/Basic_Setup.txt doc/suricata-update-README.rst
  175. %doc doc/Setting_up_IPSinline_for_Linux.txt doc/fedora.notes
  176. %{!?_licensedir:%global license %%doc}
  177. %license COPYING
  178. %attr(644,root,root) %{_mandir}/man1/*
  179. %{_sbindir}/suricata
  180. %{_bindir}/suricatasc
  181. %{_bindir}/suricatactl
  182. %{_bindir}/suricata-update
  183. %{_libdir}/libhtp*
  184. %{python3_sitelib}/suricatasc/*
  185. %{python3_sitelib}/suricata/*
  186. %{python3_sitelib}/*egg-info
  187. %config(noreplace) %attr(0755,root,root) %{_sysconfdir}/%{name}/pre_start
  188. %config(noreplace) %attr(0755,root,root) %{_sysconfdir}/%{name}/post_stop
  189. %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/suricata.yaml
  190. %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/*.config
  191. %ghost %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/rules/*.rules
  192. %config(noreplace) %attr(0600,suricata,root) %{_sysconfdir}/sysconfig/%{name}
  193. %config(noreplace) %attr(644,root,root) %{_sysconfdir}/logrotate.d/%{name}
  194. %attr(750,suricata,suricata) %dir %{_var}/log/%{name}
  195. %attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}
  196. %attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}/rules
  197. %attr(2770,suricata,suricata) %dir %{_var}/lib/%{name}
  198. %attr(2770,suricata,suricata) %dir /run/%{name}/
  199. %if %{with systemd}
  200. %attr(644,root,root) %{_unitdir}/suricata.service
  201. %{_tmpfilesdir}/%{name}.conf
  202. %else
  203. %attr(0755,root,root) %{_initdir}/%{name}
  204. %endif
  205. %{_datadir}/%{name}/rules
  206. %changelog
  207. * Thu Mar 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.2-1
  208. - new upstream release.
  209. * Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.1-1
  210. - new upstream release.
  211. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-2
  212. - rebuilt with python-3.8.
  213. * Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-1
  214. - new upstream release.
  215. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-2
  216. - rebuilt with libevent-2.1.11.
  217. * Sat Mar 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
  218. - new upstream release.
  219. * Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.0-3
  220. - initial build for Vine Linux.
  221. * Fri Oct 18 2019 Steve Grubb <sgrubb@redhat.com> 5.0.0-2
  222. - New feature release (which also fixes a security issue)
  223. - Enable ebpf on x86_64 only
  224. - Disable building on ppc64le due to rust problems
  225. * Thu Aug 01 2019 Steve Grubb <sgrubb@redhat.com> 4.1.4-4
  226. - Fix FTBFS bz 1736727
  227. * Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.4-3
  228. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  229. * Mon Jul 22 2019 Steve Grubb <sgrubb@redhat.com> 4.1.4-2
  230. - Rebuild for libprelude so bump
  231. * Tue Apr 30 2019 Jason Taylor <jtfas90@gmail.com> 4.1.4-1
  232. - Upstream bugfix release
  233. * Thu Mar 07 2019 Steve Grubb <sgrubb@redhat.com> 4.1.3-1
  234. - Upstream bugfix release
  235. * Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.2-2
  236. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  237. * Fri Dec 21 2018 Jason Taylor <jtfas90@gmail.com> 4.1.2-1
  238. - Upstream bugfix release
  239. - Updated source to use official download site
  240. * Thu Dec 20 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-4
  241. - Adjust permissions on /run/suricata and /var/lib/suricata to group writable
  242. * Mon Dec 17 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-2
  243. - Remove ragel requirement
  244. * Mon Dec 17 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-1
  245. - Make log directory group readable
  246. - Allow users of the suricata group to run suricata-update
  247. - Add lz4-devel BuildRequires to support pcap compression
  248. - Update service file for systemd security protections
  249. - Upstream bugfix update
  250. * Tue Nov 20 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-3
  251. - Use the upstream service and logrote files (#1330331)
  252. - Make the log directory readable by members of the suricata group (#1651394)
  253. * Wed Nov 07 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-2
  254. - Add cargo BuildRequires
  255. * Tue Nov 06 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-1
  256. - Latest upstream major release
  257. - Fixes CVE-2018-18956 Segmentation fault in the ProcessMimeEntity function
  258. * Mon Aug 13 2018 Steve Grubb <sgrubb@redhat.com> - 4.0.5-3
  259. - Consolidate branches so that everything is in sync (#1614935)
  260. * Fri Aug 10 2018 Jason Taylor <jtfas90@gmail.com> 4.0.5-2
  261. - fixes bz#1614935
  262. * Wed Jul 18 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.5-1
  263. - upstream security fix release
  264. - addresses CVE-2018-10242, CVE-2018-10243, CVE-2018-10244
  265. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.4-3
  266. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  267. * Mon Jul 09 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-2
  268. - bumped release for build against hyperscan 5.0.0
  269. * Mon Jul 09 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-1
  270. - added gcc-c++ buildrequires
  271. * Thu Feb 15 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-1
  272. - fixes bz#1543250 and bz#1543251
  273. - multiple upstream bugfixes
  274. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-3
  275. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  276. * Mon Dec 11 2017 Jason Taylor <jtfas90@gmail.com> 4.0.3-2
  277. - Added prelude support
  278. * Fri Dec 08 2017 Jason Taylor <jtfas90@gmail.com> 4.0.3-1
  279. - Upstream bugfix release
  280. * Wed Oct 18 2017 Steve Grubb <sgrubb@redhat.com> 4.0.1-1
  281. - Upstream bugfix update
  282. * Tue Sep 26 2017 Steve Grubb <sgrubb@redhat.com> 4.0.0-2
  283. - Make suricata user own /run/suricata (#1396150)
  284. * Mon Jul 31 2017 Jason Taylor <jtfas90@gmail.com> 4.0.0-1
  285. - Latest upstream major release
  286. - Build now has hyperscan and redis support
  287. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.3-2
  288. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  289. * Thu Jul 13 2017 Jason Taylor <jtfas90@gmail.com> 3.2.3-1
  290. - Upstream bugfix update
  291. * Wed Jun 07 2017 Steve Grubb <sgrubb@redhat.com> 3.2.2-1
  292. - Upstream bugfix update
  293. * Wed Feb 15 2017 Steve Grubb <sgrubb@redhat.com> 3.2.1-1
  294. - Upstream security update
  295. * Mon Feb 13 2017 Steve Grubb <sgrubb@redhat.com> 3.2-1
  296. - New upstream feature release
  297. - Rotate /var/log/suricata/eve.json (#1396151)
  298. - Fix ownership of /run/suricata (#1396150)
  299. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.3-2
  300. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  301. * Tue Nov 01 2016 Steve Grubb <sgrubb@redhat.com> 3.1.3-1
  302. - New upstream bug fix release
  303. * Wed Sep 07 2016 Steve Grubb <sgrubb@redhat.com> 3.1.2-1
  304. - New upstream bug fix release
  305. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.1-2
  306. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  307. * Wed Jul 13 2016 Steve Grubb <sgrubb@redhat.com> 3.1.1-1
  308. - New upstream bug fix release
  309. * Wed Jun 22 2016 Steve Grubb <sgrubb@redhat.com> 3.1-1
  310. - New upstream bug fix release
  311. * Mon Apr 04 2016 Steve Grubb <sgrubb@redhat.com> 3.0.1-1
  312. - New upstream bug fix release
  313. * Wed Mar 16 2016 Steve Grubb <sgrubb@redhat.com> 3.0-2
  314. - Fixed Bug 1227085 - Have Suricata start after the network is online
  315. * Mon Mar 07 2016 Steve Grubb <sgrubb@redhat.com> 3.0-1
  316. - New upstream bug fix release
  317. * Wed Feb 10 2016 Peter Schiffer <pschiffe@redhat.com> 2.0.11-3
  318. - Run suricata under suricata user
  319. * Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.11-2
  320. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  321. * Mon Dec 28 2015 Steve Grubb <sgrubb@redhat.com> 2.0.11-1
  322. - New upstream bug fix release
  323. * Wed Nov 25 2015 Steve Grubb <sgrubb@redhat.com> 2.0.10-1
  324. - New upstream bug fix release
  325. * Sat Oct 03 2015 Steve Grubb <sgrubb@redhat.com> 2.0.9-1
  326. - New upstream bug fix release
  327. * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.8-2
  328. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  329. * Wed May 06 2015 Steve Grubb <sgrubb@redhat.com> 2.0.8-1
  330. - New upstream security bug fix release
  331. * Thu Feb 26 2015 Steve Grubb <sgrubb@redhat.com> 2.0.7-1
  332. - New upstream security bug fix release for CVE-2015-0928
  333. * Thu Jan 15 2015 Steve Grubb <sgrubb@redhat.com> 2.0.6-1
  334. - New upstream bug fix release
  335. - Don't use the system libhtp library
  336. * Fri Dec 12 2014 Steve Grubb <sgrubb@redhat.com> 2.0.5-1
  337. - New upstream bug fix release
  338. - Use the system libhtp library
  339. * Wed Sep 24 2014 Steve Grubb <sgrubb@redhat.com> 2.0.4-1
  340. - New upstream bug fix release
  341. - Fixes CVE-2014-6603 out-of-bounds access in SSH parser
  342. * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-2
  343. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  344. * Fri Aug 08 2014 Steve Grubb <sgrubb@redhat.com> 2.0.3-1
  345. - New upstream bug fix release
  346. * Sat Jun 28 2014 Steve Grubb <sgrubb@redhat.com> 2.0.2-2
  347. - Specfile cleanups (#1113413)
  348. * Wed Jun 25 2014 Steve Grubb <sgrubb@redhat.com> 2.0.2-1
  349. - New upstream bug fix release
  350. - Enable liblua support
  351. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-2
  352. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  353. * Wed May 21 2014 Steve Grubb <sgrubb@redhat.com> 2.0.1-1
  354. - New upstream bug fix release
  355. * Wed Mar 26 2014 Steve Grubb <sgrubb@redhat.com> 2.0-1
  356. - Major new upstream release with new features
  357. * Tue Jan 21 2014 Dan Horák <dan[at]danny.cz> 1.4.7-3
  358. - luajit available only on selected arches
  359. * Sat Jan 11 2014 Steve Grubb <sgrubb@redhat.com> 1.4.7-2
  360. - Enable luajit support
  361. * Wed Dec 18 2013 Steve Grubb <sgrubb@redhat.com> 1.4.7-1
  362. - New upstream bug fix release
  363. * Fri Oct 04 2013 Steve Grubb <sgrubb@redhat.com> 1.4.6-1
  364. - New upstream bug fix release
  365. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3-3
  366. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  367. * Fri Jun 21 2013 Steve Grubb <sgrubb@redhat.com> 1.4.3-2
  368. - Drop prelude support
  369. * Fri Jun 21 2013 Steve Grubb <sgrubb@redhat.com> 1.4.3-1
  370. - New upstream bug fix release
  371. * Mon Jun 03 2013 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
  372. - New upstream bug fix release
  373. * Sun Mar 10 2013 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
  374. - New upstream bugfix release
  375. - Enable libgeoip support
  376. - Switch to stack-protector-all
  377. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-2
  378. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  379. * Thu Dec 20 2012 Steve Grubb <sgrubb@redhat.com> 1.4-1
  380. - New upstream feature enhancement release
  381. * Thu Dec 06 2012 Steve Grubb <sgrubb@redhat.com> 1.3.5-1
  382. - New upstream bugfix release
  383. * Tue Nov 27 2012 Steve Grubb <sgrubb@redhat.com> 1.3.4-1
  384. - New upstream release
  385. * Mon Nov 05 2012 Steve Grubb <sgrubb@redhat.com> 1.3.3-1
  386. - New upstream release
  387. * Tue Oct 09 2012 Steve Grubb <sgrubb@redhat.com> 1.3.2-2
  388. - Add nss-devel build require and systemd macros
  389. * Mon Oct 08 2012 Steve Grubb <sgrubb@redhat.com> 1.3.2-1
  390. - New upstream release
  391. * Sat Aug 25 2012 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
  392. - New upstream release
  393. - Switch startup to use systemd
  394. * Fri Jul 06 2012 Steve Grubb <sgrubb@redhat.com> 1.3-1
  395. - New upstream release
  396. * Fri Mar 30 2012 Jon Ciesla <limburgher@gmail.com> - 1.2.1-3
  397. - Rebuild for updated libnet.
  398. * Fri Feb 10 2012 Petr Pisar <ppisar@redhat.com> - 1.2.1-2
  399. - Rebuild against PCRE 8.30
  400. * Thu Feb 02 2012 Steve Grubb <sgrubb@redhat.com> 1.2.1-1
  401. - New upstream release
  402. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-3
  403. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  404. * Thu Dec 22 2011 Steve Grubb <sgrubb@redhat.com> 1.1.1-2
  405. - Enable AF_PACKET support
  406. * Wed Dec 07 2011 Steve Grubb <sgrubb@redhat.com> 1.1.1-1
  407. - New upstream release
  408. * Mon Jul 25 2011 Steve Grubb <sgrubb@redhat.com> 1.0.5-1
  409. - New upstream release
  410. * Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 1.0.4-1
  411. - New upstream release
  412. * Thu Apr 28 2011 Dan Horák <dan[at]danny.cz> 1.0.3-2
  413. - don't override -march set by the buildsystem (fixes build on non-x86)
  414. * Sat Apr 23 2011 Steve Grubb <sgrubb@redhat.com> 1.0.3-1
  415. - New upstream release
  416. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
  417. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  418. * Wed Nov 10 2010 Steve Grubb <sgrubb@redhat.com> 1.0.2-1
  419. - New upstream release (#651978)
  420. * Thu Jul 01 2010 Steve Grubb <sgrubb@redhat.com> 1.0.0-1
  421. - New upstream release
  422. * Fri May 07 2010 Steve Grubb <sgrubb@redhat.com> 0.9.0-1
  423. - New upstream release
  424. * Tue Apr 20 2010 Steve Grubb <sgrubb@redhat.com> 0.8.2-1
  425. - New upstream release
  426. * Sat Feb 27 2010 Steve Grubb <sgrubb@redhat.com> 0.8.1-1
  427. - Initial packaging