ElectricFence-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. Summary: A debugger which detects memory allocation violations.
  2. Name: ElectricFence
  3. Version: 2.2.2
  4. Release: 12%{?_dist_release}
  5. License: GPL
  6. Group: Development/Tools
  7. Source: ftp://ftp.perens.com/pub/ElectricFence/beta/%{name}-%{version}.tar.gz
  8. Patch1: ElectricFence-2.0.5-longjmp.patch
  9. Patch2: ElectricFence-2.1-vaarg.patch
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. %description
  12. ElectricFence is a utility for C programming and
  13. debugging. ElectricFence uses the virtual memory hardware of your
  14. system to detect when software overruns malloc() buffer boundaries,
  15. and/or to detect any accesses of memory released by
  16. free(). ElectricFence will then stop the program on the first
  17. instruction that caused a bounds violation and you can use your
  18. favorite debugger to display the offending statement.
  19. Install ElectricFence if you need a debugger to find malloc()
  20. violations.
  21. %prep
  22. %setup -q
  23. %patch1 -p1 -b .longjmp
  24. %patch2 -p1 -b .vaarg
  25. %build
  26. make CFLAGS='${RPM_OPT_FLAGS} -DUSE_SEMAPHORE -fPIC'
  27. %install
  28. rm -rf %{buildroot}
  29. mkdir -p %{buildroot}{%{_bindir},%{_libdir},%{_mandir}/man3}
  30. make BIN_INSTALL_DIR=%{buildroot}%{_bindir} \
  31. LIB_INSTALL_DIR=%{buildroot}%{_libdir} \
  32. MAN_INSTALL_DIR=%{buildroot}%{_mandir}/man3 \
  33. install
  34. echo ".so man3/efence.3" > %{buildroot}%{_mandir}/man3/libefence.3
  35. %clean
  36. rm -rf %{buildroot}
  37. %post -p /sbin/ldconfig
  38. %postun -p /sbin/ldconfig
  39. %files
  40. %defattr(-,root,root)
  41. %doc README CHANGES COPYING
  42. %{_bindir}/*
  43. %{_libdir}/*
  44. %{_mandir}/*/*
  45. %changelog
  46. * Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-12
  47. - applied new versioning policy
  48. * Fri Aug 24 2007 Shu KONNO <owa@bg.wakwak.com> 2.2.2-11vl3
  49. - s/Copyright/License/
  50. * Mon Apr 7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.2.2-11vl2
  51. - rebuild
  52. * Fri Dec 06 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-11vl1
  53. - based on 2.2.2-11 from Rawhide and built for Vine Linux
  54. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  55. - automated rebuild
  56. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  57. - automated rebuild
  58. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  59. - automated rebuild
  60. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  61. - Bump release + rebuild.
  62. * Thu Nov 16 2000 Tim Powers <timp@redhat.com>
  63. - use -fPIC, not -fpic, also -DUSE_SEMAPHORE to make it thread safe,
  64. as per bug #20935
  65. * Tue Sep 19 2000 Bill Nottingham <notting@redhat.com>
  66. - use -fpic
  67. * Fri Aug 18 2000 Tim Waugh <twaugh@redhat.com>
  68. - fix efence.3/libefence.3 confusion (#16412).
  69. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  70. - added ldconfig stuff to ;post and postun
  71. - added Requires /sbin/ldconfig
  72. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  73. - automatic rebuild
  74. * Wed Jul 05 2000 Preston Brown <pbrown@redhat.com>
  75. - back in main distro
  76. - 2.2.2 version - claimed beta, but no releases in over a year.
  77. - FHS macros
  78. * Fri May 26 2000 Tim Powers <timp@redhat.com>
  79. - moved to Powertools
  80. - fix map page location to be in /usr/share/man
  81. * Tue May 16 2000 Jakub Jelinek <jakub@redhat.com>
  82. - fix build on ia64
  83. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  84. - fix description
  85. - man pages are compressed
  86. * Tue Jan 4 2000 Jeff Johnson <jbj@redhat.com>
  87. - remove ExcludeArch: alpha (#6683).
  88. * Sat Apr 10 1999 Matt Wilson <msw@redhat.com>
  89. - version 2.1
  90. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  91. - auto rebuild in the new build environment (release 13)
  92. * Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
  93. - build for glibc 2.1
  94. * Fri Aug 21 1998 Jeff Johnson <jbj@redhat.com>
  95. - create efence.3 (problem #830)
  96. * Tue Aug 4 1998 Jeff Johnson <jbj@redhat.com>
  97. - build root
  98. * Mon Jun 01 1998 Prospector System <bugs@redhat.com>
  99. - translations modified for de
  100. * Mon Jun 01 1998 Prospector System <bugs@redhat.com>
  101. - need to use sigsetjmp() and siglongjmp() for proper testing
  102. * Fri May 01 1998 Prospector System <bugs@redhat.com>
  103. - translations modified for de, fr, tr
  104. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  105. - use ExcludeArch instead of Exclude
  106. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  107. - built against glibc