anthy-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396
  1. %define __libtoolize :
  2. %define emacsen_pkg 1
  3. %{?without_emacsen: %define emacsen_pkg 0}
  4. %if %{emacsen_pkg}
  5. %undefine without_emacsen
  6. %define anthy_el anthy-el
  7. %define anthy anthy
  8. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  9. %else
  10. %define without_emacsen 1
  11. %endif
  12. %define ut_patch_date 20100517
  13. Summary: A Japanese character input system library (with dictionary).
  14. Summary(ja): Anthy - 日本語入力システムおよび辞書
  15. Name: anthy
  16. Version: 9100h
  17. Release: 11%{?_dist_release}
  18. URL: http://www.sourceforge.jp/projects/anthy/
  19. Source: %{name}-%{version}.tar.gz
  20. Source1: anthy-el-install.sh
  21. Source2: anthy-el-remove.sh
  22. Source3: anthy-init.el
  23. Source4: vine-default-anthy.el
  24. # large dictionary and improvement patch made by UTSUMI at
  25. # http://www.geocities.jp/ep3797/anthy_dict_01.html
  26. Source100: anthy-ut-patches-%{ut_patch_date}.tar.bz2
  27. # anthy patches made by G-HAL
  28. # http://www.fenix.ne.jp/~G-HAL/soft/nosettle/#anthy
  29. Patch100: anthy-9100h.patch13B-23-iconv-ucdict.2010507.alt-depgraph-100120-patch100126.alt-cannadic-091230.patch
  30. Patch110: anthy-9100h.patch13B-23-iconv-jisx0213.patch
  31. Patch120: anthy-ut-patches-20100517-ANTHY_ENCODING_EUCJP.patch
  32. License: GPL, LGPL, BSD
  33. Group: Applications/System
  34. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  35. BuildRequires: automake, autoconf
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: daisuke, kazutaka
  39. %description
  40. Anthy is free and secure Japanese input system.
  41. %description -l ja
  42. Anthy はフリーでセキュアな日本語入力システムです。
  43. %if %{emacsen_pkg}
  44. %package -n %{anthy_el}
  45. Summary: Emacs-lisp frontend for Anthy
  46. Summary(ja): Anthy 用 Emacs-lisp フロントエンド
  47. Group: Applications/Editors/Emacs
  48. BuildRequires: emacsen
  49. Requires(post,preun): emacsen, emacsen-common >= 0.1
  50. Requires: %{name} = %{version}-%{release}
  51. %description -n %{anthy_el}
  52. Emacs-lisp frontend for Anthy
  53. %description -n %{anthy_el} -l ja
  54. Anthy のための Emacs-lisp フロントエンド
  55. %endif
  56. %package devel
  57. Summary: Development files for libanthy
  58. Summary(ja): libanthy を使ったアプリケーションを開発するためのファイル
  59. Group: Development/Libraries
  60. Requires: %{name} = %{version}-%{release}
  61. Requires: pkgconfig
  62. %description devel
  63. Devepment files for anthy libraries.
  64. %description devel -l ja
  65. libanthy を利用したアプリケーションを開発するために必要なヘッダやライブラリ
  66. が含まれています。
  67. %prep
  68. %setup -q -a 100
  69. %patch100 -p1
  70. %patch110 -p1
  71. %patch120 -p1
  72. pushd anthy-ut-patches-%{ut_patch_date}
  73. ./apply-patches.sh
  74. popd
  75. # fix file permission...
  76. chmod a+x ./depgraph/mkdepword \
  77. ./calctrans/divide.sh \
  78. ./mkworddic/mkucdic.pl
  79. %build
  80. #libtoolize --copy --force
  81. autoreconf -f -i
  82. %configure --localstatedir=%{_var}
  83. #%__make %{?_smp_mflags}
  84. # don't use smp option
  85. %__make
  86. %install
  87. %__rm -rf ${RPM_BUILD_ROOT}
  88. %makeinstall
  89. %if %{emacsen_pkg}
  90. %__mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
  91. #%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
  92. #%__mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
  93. %__cp -af %{SOURCE3} %{SOURCE4} \
  94. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
  95. %__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  96. %__mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  97. %endif
  98. %if %{emacsen_pkg}
  99. %{?emacsen_pkg: %_installemacsenscript %{anthy} %{SOURCE1}}
  100. %{?emacsen_pkg: %_removeemacsenscript %{anthy} %{SOURCE2}}
  101. %else
  102. %__rm -rf ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{anthy}
  103. %endif
  104. ## remove unuse files
  105. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  106. %if %{emacsen_pkg}
  107. %post -n %{anthy_el}
  108. if [ "$1" = 2 ]; then
  109. %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
  110. fi
  111. %{?emacsen_pkg: %_addemacsenlist %{anthy}}
  112. %{?emacsen_pkg: %_emacsenPackageInstall %{anthy}}
  113. %preun -n %{anthy_el}
  114. if [ "$1" = 0 ]; then
  115. %{?emacsen_pkg: %_emacsenPackageRemove %{anthy}}
  116. %{?emacsen_pkg: %_removeemacsenlist %{anthy}}
  117. fi
  118. %endif
  119. %clean
  120. %__rm -rf ${RPM_BUILD_ROOT}
  121. %post -p /sbin/ldconfig
  122. %postun -p /sbin/ldconfig
  123. %files
  124. %defattr(-,root,root)
  125. %{_bindir}/*
  126. %{_sysconfdir}/*
  127. %{_datadir}/anthy
  128. %{_libdir}/libanthy*.so
  129. %{_libdir}/libanthy*.so.*
  130. %doc AUTHORS COPYING ChangeLog DIARY NEWS README doc Doxyfile README.en
  131. %if %{emacsen_pkg}
  132. %files -n %{anthy_el}
  133. %defattr(-, root, root)
  134. %{_datadir}/emacs/site-lisp/%{anthy}
  135. #%{_prefix}/lib/emacsen-common/packages/install/%{anthy}
  136. #%{_prefix}/lib/emacsen-common/packages/remove/%{anthy}
  137. %{emacsen_pkgdir}/install/%{anthy}
  138. %{emacsen_pkgdir}/remove/%{anthy}
  139. %endif
  140. %files devel
  141. %defattr(-,root,root)
  142. %{_includedir}/*
  143. %{_libdir}/libanthy*.a
  144. #%{_libdir}/libanthy*.la
  145. %{_libdir}/pkgconfig/*.pc
  146. %changelog
  147. * Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 9100h-11
  148. - rebuilt with rpm-4.8.1 for pkg-config
  149. * Sun Jun 06 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9100h-10
  150. - add patch110 to change EUCJP AS EUCJP/JISX0213
  151. - add patch120 to change default encoding to EUCJP for compatibility
  152. * Fri Jun 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9100h-9
  153. - move ut patch to Source100
  154. - add Patch100 to add G-HAL's patches
  155. - diffed from G-HAL's modified anthy archive.
  156. - new ut patch does not include G-HAL's patches
  157. * Wed May 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 9100h-8
  158. - update Patch100 (anthy-ut-patches-20100517.tar.bz2)
  159. - run autoreconf at %%build section
  160. * Tue Jul 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-7
  161. - updated vine-default-anthy.el
  162. - set 1 for anthy-accept-timeout (because default timeout is too long)
  163. * Sat Jun 27 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-6
  164. - update Patch100 (anthy-ut-patches-20090604.tar.bz2)
  165. * Mon May 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-5
  166. - update Patch100 (anthy-ut-patches-20090507.tar.bz2)
  167. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-4
  168. - updated anthy-el-install.sh
  169. - *-init.el: changed from hard copy to symbolic link
  170. on /etc/emacs-XX.YY/site-start.d
  171. - corrected byte-compiling messages of emacs flaver
  172. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 9100h-3
  173. - added vine-default-anthy.el
  174. - updated anthy-el-install.sh, anthy-el-remove.sh for vine-default-anthy.el
  175. * Tue Apr 07 2009 Shu KONNO <owa@bg.wakwak.com> 9100h-2
  176. - removed %%{?_smp_mflags} at make
  177. * Sun Mar 15 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100h-1
  178. - new upstream release
  179. - update Patch100
  180. * Wed Jan 21 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 9100e-3
  181. - add patch100 to improve conversion logic and add large dirctionary
  182. - add License LGPL and BSD for added patches
  183. -
  184. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 9100e-2vl5
  185. - added %%emacsen_pkgdir
  186. - removed *.la
  187. - spec in utf-8
  188. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100e-1vl5
  189. - new upstream release
  190. 1* Fri Dec 28 2007 IWAI, Masaharu <iwai@alib.jp> 9100d-0vl1
  191. - new upstream release
  192. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9100-0vl1
  193. - new upstream release
  194. * Fri Jun 15 2007 IWAI, Masaharu <iwai@alib.jp> 9011-0vl1
  195. - new upstream release
  196. * Tue Oct 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl3
  197. - use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
  198. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7900-0vl2
  199. - changed anthy-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  200. * Fri Aug 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7900-0vl1
  201. - new upstream release
  202. * Fri Apr 28 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500b-0vl1
  203. - new upstream release
  204. * Sat Mar 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7500-0vl1
  205. - new upstream release
  206. * Fri Dec 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl3
  207. - add BuildRequires: emacsen instead of emacs
  208. - add Requires: %%{name} to anthy-el package
  209. - add libanthy*.la to devel package
  210. - update anthy-el-install.sh
  211. - add anthy-azik.el, anthy-kyuri.el
  212. * Sun Dec 18 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl2
  213. - add BuildRequires: emacs
  214. * Tue Dec 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 7100b-0vl1
  215. - new upstream release
  216. * Mon Oct 17 2005 IWAI, Masaharu <iwai@alib.jp> 7015-0vl1
  217. - new upstream release
  218. * Mon Oct 10 2005 IWAI, Masaharu <iwai@alib.jp> 6829-0vl1
  219. - new upstream release
  220. * Sun Jul 31 2005 IWAI, Masaharu <iwai@alib.jp> 6724-0vl1
  221. - new upstream release
  222. - add documents: Doxyfile and README.en
  223. * Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6700b-0vl1
  224. - new upstream release
  225. * Tue May 10 2005 IWAI, Masaharu <iwai@alib.jp> 6508-0vl1
  226. - new upstream release
  227. * Sat Apr 9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6300d-0vl1
  228. - new upstream release
  229. - added %{_libdir}/pkgconfig/anthy.pc to devel package
  230. * Fri Oct 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5812-0vl1
  231. - new upstream release
  232. * Sat Oct 09 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5714-0vl1
  233. - new upstream release
  234. * Sun Jul 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5500-0vl1
  235. - new upstream release
  236. * Thu Jun 3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl3
  237. - move libanthy*.so to anthy main package. it is needed by some
  238. anthy application.
  239. * Thu Jun 3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl2
  240. - split development files to anthy-devel
  241. * Thu Jun 3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5323-0vl1
  242. - new upstream release
  243. * Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5220-0vl1
  244. - new upstream release
  245. * Wed Mar 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5122-0vl1
  246. - new upstream release
  247. * Sun Feb 29 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5100-0vl1
  248. - new upstream release
  249. * Mon Feb 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 5021-0vl1
  250. - new upstream release
  251. * Wed Feb 11 2004 IWAI, Masaharu <iwai@alib.jp> 5008-0vl1
  252. - new upstream release
  253. * Tue Jan 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4925-0vl1
  254. - new upstream release
  255. * Sun Jan 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4901-0vl1
  256. - new upstream release
  257. * Thu Nov 27 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4723-0vl1
  258. - new upstream release
  259. * Mon Nov 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4708-0vl1
  260. - new upstream release
  261. * Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 4524-0vl1
  262. - new upstream release
  263. * Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 4520-0vl1
  264. - new upstream release
  265. * Tue Sep 9 2003 IWAI, Masaharu <iwai@alib.jp> 4507-0vl3
  266. - update anthy-el-install.sh (Source1): [VineSeed-Plus:01834]
  267. - The files to byte-compile is made the same as the upstream.
  268. * Tue Sep 9 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4507-0vl2
  269. - not bytecompile leim-list.el for XEmacs
  270. * Sun Sep 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4507-0vl1
  271. - new upstream release
  272. * Sun Aug 31 2003 IWAI, Masaharu <iwai@alib.jp> 4431-0vl1
  273. - new upstream snapshot release
  274. - create anthy-el package for emacsen
  275. * Fri Aug 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4421-0vl1
  276. - new upstream snapshot release
  277. * Fri Jul 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4300-0vl1
  278. - initial build for Vine Linux
  279. * Thu Jul 10 2003 Yuhei Matsunaga <yuhei@users.sourceforge.jp>
  280. - up to 4200.
  281. - added description.
  282. * Fri Nov 25 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
  283. - 3500c-1
  284. - up to 3500c.
  285. - added some documents.
  286. * Fri Nov 22 2002 OGUMA "dellin" Hironori <dellin@team-ct.org>
  287. - up to 3500b.
  288. * Thu Jan 3 2002 Yusuke Tabata <yusuke@kmc.gr.jp>
  289. - changed my mail address and URL of web page
  290. * Thu Nov 11 2001 Takayoshi Nobuoka <taka@trans-nt.com>
  291. - add %{_sysconfdir}/* at %files
  292. * Wed Sep 9 2001 Takayoshi Nobuoka <taka@trans-nt.com>
  293. - use _bindir and so on.
  294. * Sun Aug 19 2001 Tabatee <yusuke@kmc.kyoto-u.ac.jp>
  295. - Initial build.