bogofilter-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186
  1. Name: bogofilter
  2. Summary: fast anti-spam filtering by Bayesian statistical analysis
  3. Summary(ja): ベイジアン解析による高速アンチスパムフィルタリング
  4. Version: 1.2.3
  5. Release: 1%{?_dist_release}
  6. URL: http://bogofilter.sourceforge.net/
  7. Source0: http://prdownloads.sourceforge.net/bogofilter/bogofilter-%{version}.tar.bz2
  8. Source999: filter-requires-bogofilter.sh
  9. Patch10: http://www.c-wind.com/bogofilter/bogofilter-%{version}+mecab-0.1.patch.gz
  10. License: GPLv2
  11. Group: Applications/Internet
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: db4-devel >= 4.3.29, mecab-devel, gsl-devel, flex
  14. %define __find_requires %{SOURCE999}
  15. %description
  16. Bogofilter is a Bayesian spam filter. In its normal mode of
  17. operation, it takes an email message or other text on standard input,
  18. does a statistical check against lists of "good" and "bad" words, and
  19. returns a status code indicating whether or not the message is spam.
  20. Bogofilter is designed with fast algorithms (including Berkeley DB system),
  21. coded directly in C, and tuned for speed, so it can be used for production
  22. by sites that process a lot of mail.
  23. %prep
  24. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  25. %setup -q
  26. %patch10 -p1 -b .mecab
  27. %build
  28. export CFLAGS="$RPM_OPT_FLAGS -DWAKATI"
  29. export LIBS="`mecab-config --libs`"
  30. %configure --program-prefix=
  31. %__make
  32. %install
  33. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  34. make install DESTDIR=$RPM_BUILD_ROOT
  35. %__cp -p %{buildroot}%{_sysconfdir}/bogofilter.cf.example \
  36. %{buildroot}%{_sysconfdir}/bogofilter.cf
  37. for n in xml html ; do
  38. %__install -d -m755 .inst/$n
  39. %__install -p -m644 doc/*.$n .inst/$n
  40. done
  41. #for d in contrib ; do
  42. # %__install -d -m755 %{buildroot}%{_datadir}/%{name}/$d
  43. # for f in $(%{_bindir}/find $d -maxdepth 1 -type f) ; do
  44. # case $f in
  45. # *.c|*.o|*.obj|*/Makefile*)
  46. # continue
  47. # ;;
  48. # *.1)
  49. # %__cp -p $f %{buildroot}%{_mandir}/man1
  50. # ;;
  51. # *)
  52. # %__cp -p $f %{buildroot}%{_datadir}/%{name}/$d
  53. # ;;
  54. # esac
  55. # done
  56. #done
  57. %{__chmod} -x contrib/*
  58. for README in contrib randomtrain ; do
  59. %__ln_s ../../%{name}/contrib/README.$README doc/README.$README
  60. done
  61. # drop executable bit from contrib/* to avoid unneeded dependencies
  62. #%{_bindir}/find %{buildroot}%{_datadir}/%{name}/contrib -type f \
  63. # -exec %__chmod -x '{}' \;
  64. %clean
  65. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && rm -rf %{buildroot}
  66. %files
  67. %defattr(-,root,root)
  68. %doc AUTHORS COPYING INSTALL NEWS
  69. %doc README* RELEASE.NOTES* TODO GETTING.STARTED
  70. %doc doc/README* doc/bogofilter-SA* doc/integrating* doc/rpm.notes.BerkeleyDB
  71. %doc doc/programmer
  72. %doc .inst/html .inst/xml
  73. %doc contrib
  74. %{_sysconfdir}/bogofilter.cf.example
  75. %config(noreplace) %{_sysconfdir}/bogofilter.cf
  76. %{_bindir}/bogofilter
  77. %{_bindir}/bogolexer
  78. %{_bindir}/bogotune
  79. %{_bindir}/bogoutil
  80. %{_bindir}/bogoupgrade
  81. %{_bindir}/bf_compact
  82. %{_bindir}/bf_copy
  83. %{_bindir}/bf_tar
  84. %{_mandir}/man1/bogofilter.1*
  85. %{_mandir}/man1/bogolexer.1*
  86. %{_mandir}/man1/bogotune.1*
  87. %{_mandir}/man1/bogoutil.1*
  88. %{_mandir}/man1/bogoupgrade.1*
  89. %{_mandir}/man1/bf_compact.1*
  90. %{_mandir}/man1/bf_copy.1*
  91. %{_mandir}/man1/bf_tar.1*
  92. %changelog
  93. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
  94. - update to 1.2.3
  95. - use mecab instead of kakasi
  96. - BR: mecab-devel
  97. * Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-2
  98. - rebuild with current VineSeed environment
  99. - fix perl requirements
  100. * Thu Dec 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.2.2-1
  101. - new upstream release
  102. - update Patch10
  103. - add Requires: kakasi (<BTS:VineLinux:852>)
  104. - updates Source999: add filtering string
  105. * Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
  106. - applied new versioning policy, spec in utf-8
  107. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl5
  108. - rebuild with gsl-1.9
  109. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl4
  110. - rebuild with db4-4.3
  111. * Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl3
  112. - add filter-requires-bogofilter.sh (source999)
  113. * Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  114. - rebuild
  115. * Wed Mar 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  116. - new upstream release
  117. - modified kakasi patch
  118. * Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl2
  119. - rebuild
  120. * Mon Feb 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
  121. - new upstream release
  122. - update kakasi patch
  123. - remove unneeded macro %%mydocdir
  124. - fix symlink
  125. - add Japanese summary
  126. - drop executable bit from contrib/*
  127. * Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl2
  128. - rebuild
  129. * Tue Oct 11 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.96.2-0vl1
  130. - new upstream release
  131. - update and modify kakasi patch
  132. - fix dependencies
  133. - add BuildRequires: kakasi-devel, gsl-devel, flex
  134. - add Requires: gsl
  135. - update %%files
  136. - update %%doc
  137. - add %%{_bindir}/bf_{compact,copy,tar} and corresponding man pages
  138. * Sun Nov 7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.92.6-0vl2
  139. - rebuilt with db4-4.2.52
  140. * Tue Sep 21 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.6-0vl1
  141. - new upstream release.
  142. - update kakasi patch.
  143. * Sun May 2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.5-0vl1
  144. - new upstream release
  145. - add kakasi patch (http://www.ono.org/software/bogofilter/)
  146. * Sun Jun 15 2003 IWAI Masaharu <iwai@alib.jp> 0.13.6.2-0vl1
  147. - upstream release
  148. - using --program-prefix option with configure script
  149. - update %%files section
  150. * Fri May 16 2003 IWAI Masaharu <iwai@alib.jp> 0.12.3-0vl1
  151. - first release for Vine Linux