clucene-core-vl.spec 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. Name: clucene-core
  2. Summary: A C++ port of Lucene
  3. Version: 2.3.3.4
  4. Release: 1%{?_dist_release}
  5. License: LGPLv2+ or ASL 2.0
  6. Group: System Environment/Libraries
  7. URL: http://sourceforge.net/projects/clucene
  8. Source: %{name}-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: cmake
  11. BuildRequires: gawk
  12. BuildRequires: libboost-devel
  13. BuildRequires: zlib-devel
  14. %description
  15. CLucene is a C++ port of the popular Apache Lucene search engine
  16. (http://lucene.apache.org/java).
  17. CLucene aims to be a high-speed alternative to Java Lucene, its API is very
  18. similar to that of the Java version. CLucene has recently been brought up to
  19. date with Lucene 2.3.2. It contains most of the same functionality as the Java version.
  20. %package devel
  21. Summary: Headers for developing programs that will use %{name}
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. %description devel
  25. This package contains the static libraries and header files needed for
  26. developing with clucene
  27. %prep
  28. %setup -q
  29. %build
  30. mkdir -p %{_target_platform}
  31. pushd %{_target_platform}
  32. export CFLAGS="%{optflags}"
  33. export CXXFLAGS="%{optflags}"
  34. export FFLAGS="%{optflags}"
  35. %ifarch x86_64 ppc64
  36. %define lib_suffix 64
  37. %else
  38. %define lib_suffix %{nil}
  39. %endif
  40. %cmake \
  41. -DCMAKE_INSTALL_PREFIX=%{_prefix} \
  42. -DLIB_DESTINATION=%{_libdir} -DLIB_SUFFIX=%{lib_suffix} \
  43. -DLUCENE_SYS_INCLUDES=%{_libdir} \
  44. ..
  45. popd
  46. make VERBOSE=1 %{?_smp_mflags} -C %{_target_platform}
  47. %install
  48. rm -rf $RPM_BUILD_ROOT
  49. make DESTDIR=$RPM_BUILD_ROOT install -C %{_target_platform}
  50. rm -rf $RPM_BUILD_ROOT%{_libdir}/CLuceneConfig.cmake
  51. #rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  52. #check
  53. #cd %{_target_platform}
  54. #make cl_test
  55. #make test
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %post -p /sbin/ldconfig
  59. %postun -p /sbin/ldconfig
  60. %files
  61. %defattr(-,root,root)
  62. %doc APACHE.license AUTHORS ChangeLog COPYING LGPL.license README
  63. %{_libdir}/libclucene*.so.*
  64. %files devel
  65. %defattr(-,root,root)
  66. %dir %{_includedir}/CLucene
  67. %dir %{_libdir}/CLucene
  68. %{_includedir}/CLucene/*
  69. %{_includedir}/CLucene.h
  70. %{_libdir}/libclucene*.so
  71. %{_libdir}/CLucene/clucene-config.h
  72. %{_libdir}/CLucene/CLuceneConfig.cmake
  73. %{_libdir}/pkgconfig/libclucene-core.pc
  74. %changelog
  75. * Sat Sep 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.3.4-1
  76. - new upstream release
  77. * Mon Oct 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.21b-2
  78. - run make check at %%check
  79. * Tue Dec 9 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.9.21b-1
  80. - new upstream release
  81. * Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.9.20-1
  82. - fix release
  83. * Mon Nov 19 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.9.20-0vl2
  84. - stop moving clucene-config.h from %%{_libdir}/CLucene
  85. * Thu Oct 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.9.20-0vl1
  86. - new upstream release
  87. * Sat Jul 28 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.9.19-0vl1
  88. - new upstream release
  89. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.9.16a-0vl1
  90. - initial release