file-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. %define __libtoolize :
  4. Summary: A utility for determining file types.
  5. Summary(ja): ファイルの種類を判別するユーティリティー
  6. Name: file
  7. Version: 5.11
  8. Release: 1%{?_dist_release}
  9. License: BSD
  10. Group: Applications/System
  11. Source0: ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
  12. # Addtional magic file for Vine
  13. Source10: magic.printer-j
  14. # Upstream says it's up to distributions to add a way to support local-magic.
  15. Patch0: file-localmagic.patch
  16. # sent upstream - should be included in next upstream release
  17. Patch1: file-tnef.patch
  18. Patch2: file-5.10-strength.patch
  19. Patch3: file-5.10-sticky-bit.patch
  20. Patch4: file-python-func.patch
  21. Patch5: file-qed-vdi-image.patch
  22. Patch6: file-5.11-ia64-swap.patch
  23. Patch7: file-4.17-rpm-name.patch
  24. Patch8: file-5.11-magicmgc-home.patch
  25. Patch9: file-5.11-compress.patch
  26. Buildroot: %{_tmppath}/%{name}-%{version}-root
  27. #BuildRequires: automake
  28. #BuildRequires: autoconf
  29. BuildRequires: zlib-devel
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: daisuke
  33. %description
  34. The file command is used to identify a particular file according to the
  35. type of data contained by the file. File can identify many different
  36. file types, including ELF binaries, system libraries, RPM packages, and
  37. different graphics formats.
  38. You should install the file package, since the file command is such a
  39. useful utility.
  40. %description -l ja
  41. file コマンドは、ファイルに含まれるデータの種類によって各ファイルが
  42. どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
  43. ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
  44. を含む、多くの異なるファイルの種類を見分けることができます。
  45. %package devel
  46. Summary: Libraries and header files for file development
  47. Summary(ja): libmagic の開発用ファイル
  48. Group: Development/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. %description devel
  51. The file-devel package contains the header files and libmagic library
  52. necessary for developing programs using libmagic.
  53. %package static
  54. Summary: Static library for file development
  55. Summary(ja): libmagic のスタティックライブラリ
  56. Group: Development/Libraries
  57. Requires: %{name} = %{version}-%{release}
  58. %description static
  59. The file-static package contains the static version of
  60. the libmagic library.
  61. %package -n python-magic
  62. Summary: Python bindings for the libmagic API
  63. Group: Development/Libraries
  64. BuildRequires: python-devel
  65. Requires: %{name} = %{version}-%{release}
  66. %description -n python-magic
  67. This package contains the Python bindings to allow access to the
  68. libmagic API. The libmagic library is also used by the familiar
  69. file(1) command.
  70. %prep
  71. %setup -q
  72. %patch0 -p1
  73. %patch1 -p1
  74. %patch2 -p1
  75. %patch3 -p1
  76. %patch4 -p1
  77. %patch5 -p1
  78. %patch6 -p1
  79. %patch7 -p1
  80. %patch8 -p1
  81. %patch9 -p1
  82. cat %{SOURCE10} >> ./magic/Localstuff
  83. iconv -f iso-8859-1 -t utf-8 < doc/libmagic.man > doc/libmagic.man_
  84. touch -r doc/libmagic.man doc/libmagic.man_
  85. mv doc/libmagic.man_ doc/libmagic.man
  86. %build
  87. #autoreconf
  88. CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
  89. %configure --enable-fsect-man5 --disable-rpath
  90. # remove hardcoded library paths from local libtool
  91. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  92. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  93. export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{name}-%{version}/src/.libs
  94. make
  95. cd python
  96. CFLAGS="%{optflags}" %{__python} setup.py build
  97. %install
  98. rm -rf $RPM_BUILD_ROOT
  99. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  100. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
  101. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
  102. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5
  103. mkdir -p $RPM_BUILD_ROOT%{_datadir}/misc
  104. mkdir -p $RPM_BUILD_ROOT%{_datadir}/file
  105. make install DESTDIR=$RPM_BUILD_ROOT
  106. cat magic/Magdir/* > ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  107. ln -s misc/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  108. ##ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  109. ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/file/magic
  110. cd python
  111. %{__python} setup.py install -O1 --skip-build --root ${RPM_BUILD_ROOT}
  112. %{__install} -d ${RPM_BUILD_ROOT}%{_datadir}/%{name}
  113. # LIBTOOL=/usr/bin/libtool
  114. #ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  115. #ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  116. #ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  117. #{ cd ${RPM_BUILD_ROOT}
  118. # strip .%{_bindir}/file
  119. # cp %SOURCE1 .%{_datadir}/magic.mime
  120. #}
  121. # remove unuse files
  122. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  123. %clean
  124. rm -rf $RPM_BUILD_ROOT
  125. %post -p /sbin/ldconfig
  126. %postun -p /sbin/ldconfig
  127. %files
  128. %defattr(-,root,root)
  129. %doc COPYING ChangeLog README
  130. %{_bindir}/*
  131. %{_libdir}/libmagic.so.*
  132. %{_datadir}/file/*
  133. %{_datadir}/magic*
  134. %{_datadir}/misc/*
  135. %{_mandir}/man[15]/*
  136. %files devel
  137. %defattr(-,root,root,-)
  138. %{_libdir}/*.so
  139. %{_includedir}/magic.h
  140. %{_mandir}/man3/*
  141. %files static
  142. %defattr(-,root,root,-)
  143. %{_libdir}/*.a
  144. %files -n python-magic
  145. %defattr(-, root, root, -)
  146. %doc python/README COPYING python/example.py
  147. %{python_sitelib}/magic.py
  148. %{python_sitelib}/magic.pyc
  149. %{python_sitelib}/magic.pyo
  150. %{python_sitelib}/*egg-info
  151. %changelog
  152. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.11-1
  153. - new upstream reelase
  154. - drop all local patches
  155. - import fedora patches
  156. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-3
  157. - rebuild with python-2.7.2
  158. * Sun Feb 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-2
  159. - rebuild package
  160. - fix Patch100
  161. * Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.05-1
  162. - new upstream release
  163. - updated Vine patches (but Patch100 has not been ported yet...)
  164. - split to devel and static subpackcages
  165. * Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.21-3
  166. - rebuilt with rpm-4.8.1
  167. - add environment variable LIBTOOL for make command
  168. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
  169. - spec in utf-8
  170. - removed *.la
  171. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
  172. - applied new versioning policy
  173. * Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
  174. - new upstream release
  175. - import debian/fedora patches
  176. - drop obsolete vine magic.
  177. * Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
  178. - rebuild for VineSeed with new tool chain
  179. * Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
  180. - add patch110 for fix CVE-2007-2799
  181. - add zlib-devel to BuildPreReq tag
  182. * Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
  183. - add patch100 for fix CVE-2007-1536
  184. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
  185. - changed Group to Applications/System
  186. * Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
  187. - new upstream release
  188. - update vine patches
  189. * Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
  190. - update Patch10, use 'size_t' in src/jcode.[ch]
  191. * Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
  192. - update to 4.03
  193. - update Patch0, 1, 10 for 4.03
  194. - s/Copyright/License/
  195. * Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
  196. - update to 4.02
  197. - update Vine patches for 4.02
  198. * Sun Mar 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
  199. - new upstream release
  200. - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
  201. - remove unneeded patches.
  202. - update Vine patches for 3.41
  203. * Mon Apr 1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
  204. - added NPDL2 data [Vine:02348]
  205. * Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
  206. - update to 3.37
  207. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  208. - 3.35-0vl3
  209. - disable some entries in elf for problems on big-endian archs
  210. * Wed Jun 6 2001 Jun Nishii <jun@vinelinux.org>
  211. - file-3.35-0vl1
  212. - ver.up
  213. - added %doc
  214. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  215. - file-3.33-1vl4
  216. - more fix and clean up jtext patch (file-3.33-vinejtext.patch)
  217. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  218. - file-3.33-1vl3
  219. - fix again jtext patch (file-3.33-vinejtext.patch)
  220. - added file-3.33-vinenames.patch to avoid miss-judgement
  221. * Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
  222. - file-3.33-1vl2
  223. - update jtext patch (file-3.33-vinejtext.patch)
  224. * Mon Jan 8 2001 Jun Nishii <jun@vinelinux.org>
  225. - file-3.33-1vl1
  226. - modify description-ja and spec
  227. * Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  228. - file-3.28-2vl2
  229. - fixed %files section to handle compressed man pages
  230. * Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
  231. - marged RH 3.28-2 and Vine 3.27-3vl3
  232. * Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
  233. - add ia64 patch from rth
  234. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  235. - handle compressed manpages
  236. - update to 3.28
  237. * Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
  238. - Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
  239. * Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
  240. - patch dues not apply bug.
  241. * Wed Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
  242. - not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
  243. - ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
  244. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  245. - identify ELF stripped files correctly (#4665).
  246. - use SPARC (not sparc) consistently throughout (#4665).
  247. - add entries for MS Office files (#4665).
  248. * Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
  249. - diddle magic so that *.tfm files are identified correctly.
  250. * Tue Jul 6 1999 Jeff Johnson <jbj@redhat.com>
  251. - update to 3.27.
  252. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  253. - experimental support for realmedia files added
  254. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  255. - auto rebuild in the new build environment (release 5)
  256. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  257. - strip binary.
  258. * Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
  259. - add SPARC V9 magic.
  260. * Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
  261. - update to 3.26.
  262. * Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
  263. - update to 3.25.
  264. - detect gimp XCF versions.
  265. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  266. - translations modified for de, fr, tr
  267. * Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
  268. - updated to 3.24
  269. - buildrooted
  270. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  271. - built against glibc
  272. * Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
  273. - Fixed problems caused by 64 bit time_t.
  274. * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
  275. - Improved recognition of Linux kernel images.