freerdp-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218
  1. Name: freerdp
  2. Version: 1.0.1
  3. Release: 1%{?_dist_release}
  4. Summary: Remote Desktop Protocol client
  5. Summary(ja): リモートデスクトッププロトコルクライアント
  6. Group: Applications/Intenet
  7. License: GPLv2+
  8. URL: http://www.freerdp.com/
  9. Source0: https://github.com/downloads/FreeRDP/FreeRDP/%{name}-%{version}.tar.gz
  10. # https://github.com/FreeRDP/FreeRDP/commit/165d39a290a109c0af16a1d223d1426cb524a844 backport
  11. Patch0: fastpath_send_input_pdu-sec_bytes.patch
  12. Patch1: c10866db66c0d462ea7c2c38bb01740bcfb4fcb4.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: cmake
  15. BuildRequires: xmlto
  16. BuildRequires: openssl-devel
  17. BuildRequires: libX11-devel
  18. BuildRequires: libXext-devel
  19. BuildRequires: libXinerama-devel
  20. BuildRequires: libXcursor-devel
  21. BuildRequires: libXdamage-devel
  22. BuildRequires: libXv-devel
  23. BuildRequires: libxkbfile-devel
  24. BuildRequires: pulseaudio-libs-devel
  25. BuildRequires: cups-devel
  26. BuildRequires: pcsc-lite-devel
  27. BuildRequires: desktop-file-utils
  28. Provides: xfreerdp = %{version}-%{release}
  29. Requires: %{name}-libs = %{version}-%{release}, %{name}-plugins = %{version}-%{release}
  30. Requires: %{name}-plugins = %{version}-%{release}
  31. %description
  32. The xfreerdp Remote Desktop Protocol (RDP) client from the FreeRDP
  33. project.
  34. xfreerdp can connect to RDP servers such as Microsoft Windows
  35. machines, xrdp and VirtualBox.
  36. %package libs
  37. Summary: Core libraries implementing the RDP protocol
  38. Summary(ja): RDPプロトコル実装のコアライブラリ
  39. Group: System Environment/Libraries
  40. %description libs
  41. libfreerdp implements the core of the RDP protocol.
  42. libfreerdpchanman can be used to load plugins that can handle channels
  43. in the RDP protocol.
  44. libfreerdpkbd implements functionality for handling keyboards in X.
  45. %package plugins
  46. Summary: Plugins for handling the standard RDP channels
  47. Summary(ja): 標準RDPチャンネルを扱うためのプラグイン
  48. Group: System Environment/Libraries
  49. Requires: %{name}-libs = %{version}-%{release}
  50. %description plugins
  51. A set of plugins to the channel manager implementing the standard virtual
  52. channels extending RDP core functionality. For example, sounds, clipboard
  53. sync, disk/printer redirection, etc.
  54. %package devel
  55. Summary: Development files for %{name}
  56. Summary(ja): %{name}の開発ファイル
  57. Group: Development/Libraries
  58. Requires: %{name}-libs = %{version}-%{release}
  59. Requires: pkgconfig
  60. %description devel
  61. The %{name}-devel package contains libraries and header files for
  62. developing applications that use %{name}-libs.
  63. %prep
  64. %setup -q
  65. %patch0 -p1
  66. %patch1 -p1
  67. cat << EOF > xfreerdp.desktop
  68. [Desktop Entry]
  69. Type=Application
  70. Name=X FreeRDP
  71. NoDisplay=true
  72. Comment=Connect to RDP server and display remote desktop
  73. Icon=%{name}
  74. Exec=/usr/bin/xfreerdp
  75. Terminal=false
  76. Categories=Network;RemoteAccess;
  77. EOF
  78. %build
  79. %cmake \
  80. -DWITH_CUPS=ON \
  81. -DWITH_PCSC=ON \
  82. -DWITH_PULSEAUDIO=ON \
  83. -DWITH_X11=ON \
  84. -DWITH_XCURSOR=ON \
  85. -DWITH_XEXT=ON \
  86. -DWITH_XINERAMA=ON \
  87. -DWITH_XKBFILE=ON \
  88. -DWITH_XV=ON \
  89. -DWITH_ALSA=OFF \
  90. -DWITH_CUNIT=OFF \
  91. -DWITH_DIRECTFB=OFF \
  92. -DWITH_FFMPEG=OFF \
  93. -DWITH_SSE2=OFF \
  94. -DCMAKE_INSTALL_LIBDIR:PATH=%{_lib} \
  95. .
  96. make %{?_smp_mflags}
  97. %install
  98. rm -rf $RPM_BUILD_ROOT
  99. make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
  100. # No need for keymap files when using xkbfile
  101. rm -rf $RPM_BUILD_ROOT/usr/share/freerdp
  102. desktop-file-install --dir=$RPM_BUILD_ROOT%{_datadir}/applications xfreerdp.desktop
  103. install -p -D resources/FreeRDP_Icon_256px.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/%{name}.png
  104. %clean
  105. rm -rf $RPM_BUILD_ROOT
  106. %post
  107. # This is no gtk application, but try to integrate nicely with GNOME if it is available
  108. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  109. %post libs -p /sbin/ldconfig
  110. %postun libs -p /sbin/ldconfig
  111. %files
  112. %defattr(-,root,root,-)
  113. %{_bindir}/xfreerdp
  114. %{_mandir}/man1/xfreerdp.*
  115. %{_datadir}/applications/xfreerdp.desktop
  116. %{_datadir}/icons/hicolor/256x256/apps/%{name}.png
  117. %files libs
  118. %defattr(-,root,root,-)
  119. %doc LICENSE README ChangeLog
  120. %{_libdir}/lib%{name}-*.so.*
  121. %dir %{_libdir}/%{name}/
  122. %files plugins
  123. %defattr(-,root,root,-)
  124. %{_libdir}/%{name}/*
  125. %files devel
  126. %defattr(-,root,root,-)
  127. %{_includedir}/%{name}/
  128. %{_libdir}/lib%{name}-*.so
  129. %{_libdir}/pkgconfig/%{name}.pc
  130. %changelog
  131. * Mon Sep 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.13.6-1
  132. - update to 1.0.1
  133. - import patches from fedora package.
  134. - add BRs.
  135. * Fri May 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
  136. - initial build for Vine Linux
  137. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.2-3
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  139. * Fri Jan 28 2011 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-2
  140. - rebuild on rawhide because of broken dependencies
  141. * Tue Nov 16 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.2-1
  142. - freerdp-0.8.2
  143. * Mon Nov 08 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-2
  144. - make -devel require pkgconfig
  145. - first official Fedora package
  146. * Sun Nov 07 2010 Mads Kiilerich <mads@kiilerich.com> - 0.8.1-1
  147. - freerdp-0.8.1
  148. * Sat Sep 25 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-2
  149. - hack the generated libtool to not set rpath on x86_64
  150. - configure with alsa explicitly
  151. * Tue Aug 24 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.4-1
  152. - freerdp-0.7.4
  153. - cleanup of packaging structure
  154. * Wed Jul 28 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.3-1
  155. - 0.7.3
  156. - fix some minor pylint warnings
  157. * Fri Jul 23 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.2-2
  158. - 0.7.2
  159. - Address many comments from cwickert:
  160. - - cleanup of old formatting, alignment with spectemplate-lib.spec and
  161. cwickert spec from #616193
  162. - - add alsa as build requirement
  163. - - remove superfluous configure options and disable static libs
  164. - - add missing rpm groups
  165. * Sun Jun 13 2010 Mads Kiilerich <mads@kiilerich.com> - 0.7.0-1
  166. - First official release, first review request