g-wrap-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193
  1. %define ver 1.9.14
  2. %define rel 1%{?_dist_release}
  3. Summary: A tool for creating Scheme interfaces to C libraries.
  4. Summary(ja): C ライブラリへの Scheme 言語インタフェースを作成するツール
  5. Name: g-wrap
  6. Version: %{ver}
  7. Release: %{rel}
  8. Group: Development/Libraries
  9. License: GPL
  10. URL: http://www.gnucash.org/
  11. Source: ftp://ftp.gnucash.org/pub/g-wrap/%{name}-%{version}.tar.gz
  12. Requires: guile
  13. BuildRequires: guile-devel, libffi-devel
  14. BuildRequires: glib2-devel, slib
  15. Requires(pre): /sbin/install-info /sbin/ldconfig
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. g-wrap is a tool for creating Scheme interfaces to C libraries. At
  21. the moment it is most heavily focused on providing access to C
  22. libraries from guile, but it also supports RScheme.
  23. The g-wrap package contains the libraries necessary to run
  24. applications built with g-wrap. If you wish to build applications
  25. that use g-wrap, you should install the g-wrap-devel package.
  26. %description -l ja
  27. g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
  28. guile から C言語のライブライリへのアクセスを提供することを目的
  29. としています。 RScheme もサポートしています
  30. g-wrap には g-wrap 使って作成したアプリケーションを動作させるために
  31. 必要なライブラリが含まれています. g-wrap を使ってアプリケーションを
  32. 作成したい場合 g-wrap-devel をinstallしてください.
  33. %package devel
  34. Summary: Include files and libraries needed for g-wrap development.
  35. Summary(ja): g-wrap を使用した開発に必要なヘッダファイルやライブラリ
  36. Group: Development/Libraries
  37. Requires(pre): /sbin/install-info
  38. Requires: g-wrap = %{version}, guile-devel
  39. %description devel
  40. g-wrap is a tool for creating Scheme interfaces to C libraries. At
  41. the moment it is most heavily focused on providing access to C
  42. libraries from guile, but it also supports RScheme.
  43. You can provide access to a given C API by creating a specification
  44. file describing the interface you want published at the Scheme level.
  45. g-wrap will handle generating all the lower level library interface
  46. code so that the C library shows up as a set of Scheme functions.
  47. You should install g-wrap-devel if you need to compile programs that
  48. need to use g-wrap C<->Scheme functionality
  49. %description devel -l ja
  50. g-wrap は C ライブラリへのScheme言語インタフェースを作成するツールです
  51. guile から C言語のライブライリへのアクセスを提供することを目的
  52. としています。 RScheme もサポートしています
  53. Schem レベルで表現したいインターフェースを記述を指定したファイルを作成
  54. することによりC PAI へのアクセスを提供します.
  55. g-wrap は 低レベルライブラリインターフェースすべての生成を扱うことが
  56. できます。したがって C ライブラリには Schem 関数の集合としてみえます.
  57. g-wrap のC と Scheme 間の変換機能を必要とするプログラムをコンパイルする
  58. 場合 g-wrap-devel をinstallしておかねかればなりません.
  59. %prep
  60. %setup -q
  61. %build
  62. %configure --disable-static
  63. #remove Rpath
  64. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  65. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  66. #Is not parallel-build-safe
  67. %{__make}
  68. %install
  69. %{__rm} -rf ${RPM_BUILD_ROOT}
  70. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  71. #Remove unneeded file
  72. find ${RPM_BUILD_ROOT} -name '*.la' -exec rm -f {} ';'
  73. rm -f ${RPM_BUILD_ROOT}%{_datadir}/info/dir
  74. mv ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm ./config.old
  75. cat config.old > config.scm
  76. install -p -m 644 config.scm ${RPM_BUILD_ROOT}%{_datadir}/guile/site/g-wrap/config.scm
  77. %clean
  78. %{__rm} -rf ${RPM_BUILD_ROOT}
  79. %post -p /sbin/ldconfig
  80. %post devel
  81. /sbin/install-info \
  82. --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
  83. %preun -p /sbin/ldconfig
  84. %preun devel
  85. if [ "$1" = "0" ]; then
  86. /sbin/install-info --delete \
  87. --info-dir=%{_infodir} %{_infodir}/g-wrap.info.gz
  88. fi
  89. %files
  90. %defattr(-,root,root)
  91. %doc AUTHORS COPYING.LIB ChangeLog INSTALL NEWS README THANKS
  92. %dir %{_libdir}/%{name}
  93. %dir %{_libdir}/%{name}/modules
  94. %{_libdir}/%{name}/modules/*.so.*
  95. %{_libdir}/*.so.*
  96. %{_datadir}/guile/site/*
  97. %files devel
  98. %defattr(-,root,root)
  99. %{_bindir}/*
  100. %{_libdir}/*.so
  101. %{_libdir}/%{name}/modules/libgw-guile-gw-glib.so
  102. %{_libdir}/%{name}/modules/libgw-guile-standard.so
  103. %{_includedir}/*
  104. %{_datadir}/aclocal/*
  105. %{_libdir}/pkgconfig/*
  106. %{_mandir}/man1/g-wrap-config.1.gz
  107. %doc %{_infodir}/g-wrap.*
  108. %changelog
  109. * Tue Jun 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.14-1
  110. - update to 1.9.14
  111. - remove old patches
  112. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.9.1-1
  113. - new upstream release
  114. - update BuildRequires: umb-scheme -> slib
  115. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.4-10vl5
  116. - applied new versioning policy, spec in utf-8
  117. - removed *.la
  118. * Tue Oct 25 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-9vl1
  119. - added Patches from Fedora
  120. * Thu Jul 7 2005 Bill Nottingham <notting@redhat.com> 1.3.4-9
  121. - add patch for M4 quoting (#162649, <rc040203@freenet.de>)
  122. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl3
  123. - rebuild with new toolchains
  124. - s/Copyright/License/
  125. * Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-3vl2
  126. - build against new guile 1.6.4
  127. * Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.4-2vl1
  128. - based on rawhide 1.3.4-2
  129. - update to 1.3.4
  130. - move .la files to main package (#79068)
  131. - rebuild with new guile 1.6.3
  132. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.10-1vl1
  133. - updated to 1.1.10
  134. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl4
  135. - add defattr
  136. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.1.9-1vl2
  137. - japanized spec file ( add %descripsion -l ja Summary(ja)
  138. * Wed Nov 08 2000 Derek Atkins <warlord@MIT.EDU>
  139. - Don't destroy the build directory -- RPM can do that on its own
  140. - Properly build both g-wrap and g-wrap-devel (info file into -devel)
  141. - currently only one info file
  142. * Wed Oct 25 2000 Dave Peticolas <dave@krondo.com>
  143. - use /usr/info/* for automatic gzipping
  144. * Sat May 27 2000 Mark Horning <rip6@rip6.net>
  145. - Created spec file