gamin-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define python_archlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
  3. Summary: Library providing the FAM File Alteration Monitor API
  4. Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
  5. Name: gamin
  6. Version: 0.1.10
  7. Release: 5%{?_dist_release}
  8. License: LGPLv2
  9. Group: System Environment/Daemons
  10. Source: gamin-%{version}.tar.bz2
  11. # patch from ubuntu
  12. # https://bugs.launchpad.net/ubuntu/+source/gamin/+bug/829504
  13. Patch10: 21_no_g_const_return.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. URL: http://www.gnome.org/~veillard/gamin/
  16. Obsoletes: fam
  17. Provides: fam
  18. BuildRequires: glib2-devel, python, python-devel
  19. %description
  20. The Gamin library provides an API and ABI compatible file alteration
  21. monitor mechanism compatible with FAM but not dependent on a system wide
  22. daemon.
  23. %description -l ja
  24. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  25. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  26. パープログラムをオンデマンドに起動します。
  27. %package devel
  28. Summary: Development files for the Gamin library
  29. Summary(ja): Gamin ライブラリの開発用ファイル
  30. Group: Development/Libraries
  31. Requires: gamin = %{version}-%{release}
  32. Obsoletes: fam-devel
  33. Provides: fam-devel
  34. %description devel
  35. The Gamin library provides an API and ABI compatible file alteration
  36. monitor mechanism compatible with FAM but not dependent on a system wide
  37. daemon.
  38. %description devel -l ja
  39. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  40. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  41. パープログラムをオンデマンドに起動します。
  42. %package python
  43. Summary: Python bindings for the Gamin library
  44. Summary(ja): Gamin ライブラリ用の Python バインディング
  45. Group: Development/Libraries
  46. Requires: gamin = %{version}-%{release}
  47. Requires: python
  48. #Requires: %{_libdir}/python%(echo `python -c "import sys; print sys.version[0:3]"`)
  49. %description python
  50. The gamin-python package contains a module that allow monitoring of
  51. files and directories from the Python language based on the support
  52. of the gamin package.
  53. %description python -l ja
  54. gamin-python は gamin ライブラリを利用して Python 言語からファイルや
  55. ディレクトリのモニタリングを行うためのモジュールです。
  56. ## to build compat32 for x86_64 architecture support
  57. %package -n compat32-%{name}
  58. Summary: Library providing the FAM File Alteration Monitor API
  59. Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
  60. Group: System Environment/Daemons
  61. Requires: gamin = %{version}-%{release}
  62. %description -n compat32-%{name}
  63. The Gamin library provides an API and ABI compatible file alteration
  64. monitor mechanism compatible with FAM but not dependent on a system wide
  65. daemon.
  66. %description -n compat32-%{name} -l ja
  67. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  68. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  69. パープログラムをオンデマンドに起動します。
  70. %package -n compat32-%{name}-devel
  71. Summary: Development files for the Gamin library
  72. Summary(ja): Gamin ライブラリの開発用ファイル
  73. Group: Development/Libraries
  74. Requires: compat32-gamin = %{version}-%{release}
  75. %description -n compat32-%{name}-devel
  76. The Gamin library provides an API and ABI compatible file alteration
  77. monitor mechanism compatible with FAM but not dependent on a system wide
  78. daemon.
  79. %description -n compat32-%{name}-devel -l ja
  80. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  81. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  82. %prep
  83. %setup -q
  84. %patch10 -p1
  85. find server/ -type f -exec sed -i 's/G_CONST_RETURN/const/' {} ';'
  86. %build
  87. %configure
  88. %__make %{?_smp_mflags}
  89. %install
  90. rm -fr %{buildroot}
  91. %makeinstall
  92. ## remove unuse files
  93. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  94. rm -f $RPM_BUILD_ROOT%{python_archlib}/*.la
  95. %clean
  96. rm -fr %{buildroot}
  97. %post -p /sbin/ldconfig
  98. %postun -p /sbin/ldconfig
  99. %post -n compat32-%{name} -p /sbin/ldconfig
  100. %postun -n compat32-%{name} -p /sbin/ldconfig
  101. %files
  102. %defattr(-, root, root)
  103. %doc AUTHORS ChangeLog NEWS README Copyright TODO
  104. %doc doc/*.html
  105. %doc doc/*.gif
  106. %doc doc/*.txt
  107. %{_libdir}/lib*.so.*
  108. %{_libexecdir}/gam_server
  109. %files devel
  110. %defattr(-, root, root)
  111. %{_libdir}/lib*.so
  112. %{_libdir}/*a
  113. %{_includedir}/fam.h
  114. %{_libdir}/pkgconfig/gamin.pc
  115. %files python
  116. %defattr(-, root, root)
  117. %doc AUTHORS ChangeLog NEWS README Copyright TODO
  118. %{_libdir}/python*/site-packages/gamin.py*
  119. %{_libdir}/python*/site-packages/_gamin*
  120. %doc python/tests/*.py
  121. %doc doc/python.html
  122. %if %{build_compat32}
  123. %files -n compat32-%{name}
  124. %defattr(-, root, root)
  125. %{_libdir}/lib*.so.*
  126. %files -n compat32-%{name}-devel
  127. %defattr(-, root, root)
  128. %{_libdir}/lib*.so
  129. %{_libdir}/*a
  130. %{_libdir}/pkgconfig/gamin.pc
  131. %endif
  132. %changelog
  133. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-5
  134. - rebuild with python-2.7.2
  135. - add Patch10 (21_no_g_const_return.patch)
  136. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 0.1.10-4
  137. - update Requires for python subpackage
  138. - drop directory dependency
  139. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.10-3
  140. - build with rpm-4.8.1-1 for pkg-config file
  141. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.10-2
  142. - rebuild with python-2.6
  143. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.10-1
  144. - new upstream release
  145. * Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.1.9-3
  146. - fix license tag to LGPLv2
  147. - import patches from Fedora development
  148. - Patch0: don't poll for non-existant watched files
  149. - Patch1: Fix a memory leak
  150. - Patch2: workaround for missing struct ucred in glibc headers
  151. (fixed x86_64/ppc compilation)
  152. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.1.9-2
  153. - spec in utf-8
  154. - removed *.la
  155. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.1.9-1
  156. - added compat32-* packages for x86_64 architecture support
  157. - applied new versioning policy
  158. * Wed Mar 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.9-0vl1
  159. - new upstream release
  160. - Patch10 was included in upstream, dropped
  161. * Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.1.8-0vl2
  162. - added Patch10 (<BTS:507>) which should be fixed in the new upstream release
  163. * Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.8-0vl1
  164. - new upstream release
  165. * Mon Sep 4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.1.7-0vl2
  166. - stop removing *.la
  167. * Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.7-0vl1
  168. - initial build for Vine Linux
  169. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2.1
  170. - bump again for double-long bug on ppc(64)
  171. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2
  172. - rebuilt for new gcc4.1 snapshot and glibc changes
  173. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  174. - rebuilt
  175. * Thu Oct 27 2005 Daniel Veillard <veillard@redhat.com> 0.1.7-1
  176. - hopefully fixes gam_server crashes
  177. - some portability fixes
  178. - removed a minor leak
  179. * Thu Sep 8 2005 Daniel Veillard <veillard@redhat.com> 0.1.6-1
  180. - revamp of the inotify back-end
  181. - memory leak fix
  182. - various fixes and cleanups
  183. * Tue Aug 9 2005 Daniel Veillard <veillard@redhat.com> 0.1.5-1
  184. - Improvement of configuration, system wide configuration files and
  185. per filesystem type default
  186. - Rewrite of the inotify back-end, reduce resources usage, tuning in
  187. case of busy resources
  188. - Documentation updates
  189. - Changes to compile inotify back-end on various architectures
  190. - Debugging output improvements
  191. * Tue Aug 2 2005 Daniel Veillard <veillard@redhat.com> 0.1.3-1
  192. - Fix to compile on older gcc versions
  193. - Inotify back-end changes and optimizations
  194. - Debug ouput cleanup, pid and process name reports
  195. - Dropped kernel monitor bugfix
  196. - Removed the old glist copy used for debugging
  197. - Maintain mounted filesystems knowledge, and per fstype preferences
  198. * Wed Jul 13 2005 Daniel Veillard <veillard@redhat.com> 0.1.2-1
  199. - inotify back end patches, ready for the new inotify support in kernel
  200. - lot of server code cleanup patches
  201. - fixed an authentication problem
  202. * Fri Jun 10 2005 Daniel Veillard <veillard@redhat.com> 0.1.1-1
  203. - gamin_data_conn_event fix
  204. - crash from bug gnome #303932
  205. - Inotify and mounted media #171201
  206. - mounted media did not show up on Desktop #159748
  207. - write may not be atomic
  208. - Monitoring a directory when it is a file
  209. - Portability to Hurd/Mach and various code cleanups
  210. - Added support for ~ as user home alias in .gaminrc
  211. * Thu May 12 2005 Daniel Veillard <veillard@redhat.com> 0.1.0-1
  212. - Close inherited file descriptors on exec of gam_server
  213. - Cancelling a monitor send back a FAMAcknowledge
  214. - Fixed for big files > 2GB
  215. - Bug when monitoring a non existing directory
  216. - Make client side thread safe
  217. - Unreadable directory fixes
  218. - Better flow control handling
  219. - Updated to latest inotify version: 0.23-6
  220. * Tue Mar 15 2005 Daniel Veillard <veillard@redhat.com> 0.0.26-1
  221. - Fix an include problem showing up with gcc4</li>
  222. - Fix the crash on failed tree assert bug #150471 based on patch from Dean Brettle
  223. - removed an incompatibility with SGI FAM #149822
  224. * Tue Mar 1 2005 Daniel Veillard <veillard@redhat.com> 0.0.25-1
  225. - Fix a configure problem reported by Martin Schlemmer
  226. - Fix the /media/* and /mnt/* mount blocking problems from 0.0.24 e.g. #142637
  227. - Fix the monitoring of directory using poll and not kernel
  228. * Fri Feb 18 2005 Daniel Veillard <veillard@redhat.com> 0.0.24-1
  229. - more documentation
  230. - lot of serious bug fixes including Gnome Desktop refresh bug
  231. - extending the framework for more debug (configure --enable-debug-api)
  232. - extending the python bindings for watching the same resource multiple times
  233. and adding debug framework support
  234. - growing the regression tests a lot based on python bindings
  235. - inotify-0.19 patch from John McCutchan
  236. - renamed python private module to _gamin to follow Python PEP 8
  237. * Tue Feb 8 2005 Daniel Veillard <veillard@redhat.com> 0.0.23-1
  238. - memory corruption fix from Mark on the client side
  239. - extending the protocol and API to allow skipping Exists and EndExists
  240. events to avoid deadlock on reconnect or when they are not used.
  241. * Mon Jan 31 2005 Daniel Veillard <veillard@redhat.com> 0.0.22-1
  242. - bit of python bindings improvements, added test
  243. - fixed 3 bugs
  244. * Wed Jan 26 2005 Daniel Veillard <veillard@redhat.com> 0.0.21-1
  245. - Added Python support
  246. - Updated for inotify-0.18
  247. * Thu Jan 6 2005 Daniel Veillard <veillard@redhat.com> 0.0.20-1
  248. - Frederic Crozat seems to have found the GList corruption which may fix
  249. #132354 and related problems
  250. - Frederic Crozat also fixed poll only mode
  251. * Fri Dec 3 2004 Daniel Veillard <veillard@redhat.com> 0.0.19-1
  252. - still chasing the loop bug, made another pass at checking GList,
  253. added own copy with memory poisonning of GList implementation.
  254. - fixed a compile issue when compiling without debug
  255. * Fri Nov 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.18-1
  256. - still chasing the loop bug, checked and cleaned up all GList use
  257. - patch from markmc to minimize load on busy apps
  258. * Wed Oct 20 2004 Daniel Veillard <veillard@redhat.com> 0.0.16-1
  259. - chasing #132354, lot of debugging, checking and testing and a bit
  260. of refactoring
  261. * Sat Oct 16 2004 Daniel Veillard <veillard@redhat.com> 0.0.15-1
  262. - workaround to detect loops and avoid the nasty effects, see RedHat bug #132354
  263. * Sun Oct 3 2004 Daniel Veillard <veillard@redhat.com> 0.0.14-1
  264. - Found and fixed the annoying bug where update were not received
  265. should fix bugs ##132429, #133665 and #134413
  266. - new mechanism to debug on-the-fly by sending SIGUSR2 to client or server
  267. - Added documentation about internals
  268. * Fri Oct 1 2004 Daniel Veillard <veillard@redhat.com> 0.0.13-1
  269. - applied portability fixes
  270. - hardened the code while chasing a segfault
  271. * Thu Sep 30 2004 Daniel Veillard <veillard@redhat.com> 0.0.12-1
  272. - potential fix for a hard to reproduce looping problem.
  273. * Mon Sep 27 2004 Daniel Veillard <veillard@redhat.com> 0.0.11-1
  274. - update to the latest version of inotify
  275. - inotify support compiled in by default
  276. - fix ABI FAM compatibility problems #133162
  277. * Tue Sep 21 2004 Daniel Veillard <veillard@redhat.com> 0.0.10-1
  278. - more documentation
  279. - Added support for a configuration file $HOME/.gaminrc
  280. - fixes FAM compatibility issues with FAMErrno and FamErrlist #132944
  281. * Wed Sep 1 2004 Daniel Veillard <veillard@redhat.com> 0.0.9-1
  282. - fix crash with konqueror #130967
  283. - exclude kernel (dnotify) monitoring for /mnt//* /media//*
  284. * Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.8-1
  285. - Fixes crashes of the gam_server
  286. - try to correct the kernel/poll switching mode
  287. * Tue Aug 24 2004 Daniel Veillard <veillard@redhat.com> 0.0.7-1
  288. - add support for both polling and dnotify simultaneously
  289. - fixes monitoring of initially missing files
  290. - load control on very busy resources #124361, desactivating
  291. dnotify and falling back to polling for CPU drain
  292. * Thu Aug 19 2004 Daniel Veillard <veillard@redhat.com> 0.0.6-1
  293. - fixes simple file monitoring should close RH #129974
  294. - relocate gam_server in $(libexec)
  295. * Thu Aug 5 2004 Daniel Veillard <veillard@redhat.com> 0.0.5-1
  296. - Fix a crash when the client binary forks the gam_server and an
  297. atexit handler is run.
  298. * Wed Aug 4 2004 Daniel Veillard <veillard@redhat.com> 0.0.4-1
  299. - should fix KDE build problems