gnome-shell-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277
  1. %define pkg_version 3.8.4
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window management and application launching for GNOME
  4. Name: gnome-shell
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.8/%{name}-%{version}.tar.xz
  8. # settings for Vine
  9. Patch101: gnome-shell-vine-settings.patch
  10. License: GPLv2+
  11. Group: User Interface/Desktops
  12. URL: http://live.gnome.org/GnomeShell
  13. Requires: mutter
  14. Requires: caribou
  15. Requires: ca-certificates
  16. Requires: at-spi2-atk
  17. Requires: telepathy-logger
  18. Requires: network-manager-applet
  19. Requires: gnome-tweak-tool
  20. BuildRequires: gnome-common
  21. BuildRequires: libtool
  22. BuildRequires: automake
  23. BuildRequires: autoconf
  24. BuildRequires: pkgconfig
  25. BuildRequires: gtk2-devel
  26. BuildRequires: clutter-devel
  27. BuildRequires: mutter-devel
  28. BuildRequires: gjs-devel
  29. BuildRequires: gnome-desktop3-devel
  30. BuildRequires: gnome-menus-devel
  31. BuildRequires: libSM-devel
  32. BuildRequires: libffi-devel
  33. BuildRequires: startup-notification-devel
  34. BuildRequires: gnome-doc-utils
  35. BuildRequires: desktop-file-utils
  36. BuildRequires: libcroco-devel
  37. BuildRequires: librsvg2-devel
  38. BuildRequires: gobject-introspection-devel
  39. BuildRequires: control-center-devel
  40. BuildRequires: gcr-devel
  41. BuildRequires: gstreamer-devel
  42. BuildRequires: dbus-glib-devel
  43. BuildRequires: telepathy-logger-devel
  44. BuildRequires: polkit-devel
  45. BuildRequires: pulseaudio-libs-devel
  46. BuildRequires: evolution-data-server-devel
  47. BuildRequires: folks-devel
  48. BuildRequires: NetworkManager-glib-devel
  49. BuildRequires: libnm-gtk-devel
  50. BuildRequires: libgudev1-devel
  51. BuildRequires: libcanberra-gtk3-devel
  52. BuildRequires: caribou-devel
  53. BuildRequires: ca-certificates
  54. BuildRequires: intltool
  55. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  56. Vendor: Project Vine
  57. Distribution: Vine Linux
  58. Packager: Takemikaduchi
  59. %description
  60. GNOME Shell is the defining technology of the GNOME 3 desktop user experience.
  61. It provides core interface functions like switching to windows and launching
  62. applications. GNOME Shell takes advantage of the capabilities of modern graphics
  63. hardware and introduces innovative user interface concepts to provide a delightful
  64. and easy to use experience.
  65. %package docs
  66. Summary: Documentation for %{name}
  67. Summary(ja): %{name} 用のドキュメント
  68. Group: Documentation
  69. Requires: %{name} = %{version}-%{release}
  70. BuildArch: noarch
  71. %description docs
  72. This package contains documentation for %{name}.
  73. %prep
  74. %setup -q
  75. %patch101 -p1 -b .vine
  76. %build
  77. libtoolize --copy --force
  78. autoreconf
  79. %configure \
  80. --disable-static
  81. %{__make} %{?_smp_mflags}
  82. %install
  83. %{__rm} -rf ${RPM_BUILD_ROOT}
  84. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  85. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  86. %find_lang %{name}
  87. %clean
  88. %{__rm} -rf ${RPM_BUILD_ROOT}
  89. %post
  90. /sbin/ldconfig
  91. touch --no-create %{_datadir}/icons/hicolor
  92. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  93. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  94. fi
  95. %postun
  96. /sbin/ldconfig
  97. touch --no-create %{_datadir}/icons/hicolor
  98. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  99. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  100. fi
  101. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  102. %posttrans
  103. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  104. %files -f %{name}.lang
  105. %defattr(-,root,root,-)
  106. %doc COPYING NEWS README
  107. %{_bindir}/gnome-shell
  108. %{_bindir}/gnome-shell-extension-tool
  109. %{_bindir}/gnome-shell-extension-prefs
  110. %{_bindir}/gnome-shell-perf-tool
  111. %{_libdir}/%{name}/*
  112. %{_libdir}/mozilla/plugins/libgnome-shell-browser-plugin.so
  113. %{_libexecdir}/gnome-shell-calendar-server
  114. %{_libexecdir}/gnome-shell-hotplug-sniffer
  115. %{_libexecdir}/gnome-shell-perf-helper
  116. %{_datadir}/GConf/gsettings/gnome-shell-overrides.convert
  117. %{_datadir}/applications/gnome-shell.desktop
  118. %{_datadir}/applications/gnome-shell-extension-prefs.desktop
  119. %{_datadir}/applications/evolution-calendar.desktop
  120. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider.xml
  121. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screencast.xml
  122. %{_datadir}/dbus-1/interfaces/org.gnome.Shell.Screenshot.xml
  123. %{_datadir}/dbus-1/interfaces/org.gnome.ShellSearchProvider2.xml
  124. %{_datadir}/dbus-1/services/org.gnome.Shell.CalendarServer.service
  125. %{_datadir}/dbus-1/services/org.gnome.Shell.HotplugSniffer.service
  126. %{_datadir}/glib-2.0/schemas/org.gnome.shell.gschema.xml
  127. %{_datadir}/%{name}/*
  128. %{_datadir}/gnome-control-center/keybindings/50-gnome-shell-screenshot.xml
  129. %{_datadir}/gnome-control-center/keybindings/50-gnome-shell-system.xml
  130. %{_mandir}/man1/%{name}.1.gz
  131. %files docs
  132. %defattr(-,root,root,-)
  133. %{_datadir}/gtk-doc/html/shell
  134. %{_datadir}/gtk-doc/html/st
  135. %changelog
  136. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.4-1
  137. - new upstream release
  138. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
  139. - new upstream release
  140. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  141. - new upstream release
  142. * Mon Apr 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  143. - new upstream release
  144. - update Patch101 (gnome-shell-vine-settings.patch)
  145. - add BuildRequires: control-center-devel, libnm-gtk-devel, caribou-devel
  146. - add Requires: telepathy-logger, network-manager-applet, gnome-tweak-tool
  147. - create %%{name}-docs subpackage
  148. * Sun Mar 03 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3.1-1
  149. - new upstream release
  150. - remove Source102 (gnome-shell.gnome-3-6.ja.po)
  151. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
  152. - new upstream release
  153. - add Source102 (gnome-shell.gnome-3-6.ja.po)
  154. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  155. - new upstream release
  156. - remove Patch0 (gnome-shell-3.4.1-git20121031.patch)
  157. * Thu Nov 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-2
  158. - rebuild with telepathy-logger-0.6.0
  159. - add Patch0 (gnome-shell-3.4.1-git20121031.patch)
  160. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  161. - new upstream release
  162. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  163. - new upstream release
  164. - add Patch0 (gnome-shell-3.5.92-git20120921.patch)
  165. - update Patch101 (gnome-shell-vine-settings.patch)
  166. - change BuildRequires: ca-certificates instead of openssl
  167. - add BuildRequires: libcanberra-gtl3-devel
  168. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  169. - new upstream release
  170. - remove Patch103 (gnome-shell-ja.po-date.patch)
  171. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  172. - new upstream release
  173. - update Patch101,103
  174. - remove Patch0,102
  175. - add BuildRequires: gcr-devel
  176. - remove BuildRequires: GConf2-devel
  177. - add Requires: at-spi2-atk
  178. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2.1-1
  179. - new upstream release
  180. - remove Patch1
  181. * Sun Nov 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-2
  182. - add Patch0 (gnome-shell-3.2.1-shell_parse_argv.patch)
  183. - add Patch1 (gnome-shell-3.2.1-ja.po.patch)
  184. - rename Patch103 (gnome-shell-ja.po-date.patch)
  185. - drop Patch102
  186. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  187. - new upstream release
  188. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  189. - new upstream release
  190. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  191. - new upstream release
  192. - update Patch101
  193. - update Patch102
  194. - update Patch103 (gnome-shell-3.1.91.1-ja.po.patch)
  195. - add BuildRequires: libgudev1-devel, openssl
  196. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90.1-1
  197. - new upstream release
  198. - add BuildRequires: folks-devel, NetworkManager-glib-devel
  199. - add Requires: caribou
  200. - remove Patch0
  201. - update Patch101
  202. - update Patch102
  203. - update Patch103 (gnome-shell-3.1.90.1-ja.po.patch)
  204. * Mon Aug 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-2
  205. - rebuild with gnome-menus-3.1.5
  206. - add Patch0 (gnome-shell-git20110821.patch)
  207. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  208. - new upstream release
  209. - add BuildRequires: telepathy-logger-devel, polkit-devel, pulseaudio-libs-devel, evolution-data-server-devel
  210. - change BuildRequires: gnome-desktop3-devel instead of gnome-desktop-devel
  211. - remove BuildRequires: xulrunner-devel
  212. - add Patch101 (gnome-shell-vine-settings.patch)
  213. - add Patch102 (gnome-shell-vine-customize.patch)
  214. - add Patch103 (gnome-shell-3.1.4-ja.po.patch)
  215. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
  216. - add Requires: mutter
  217. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
  218. - new upstream release
  219. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  220. - initial build for Vine Linux