guile-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define mver 1.8
  3. Name: guile
  4. Summary: A GNU implementation of Scheme for application extensibility.
  5. Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
  6. Version: 1.8.7
  7. Release: 2%{?_dist_release}
  8. Group: Development/Languages
  9. License: GPLv2+ and LGPLv2+ and GFDL and OFSFDL
  10. URL: http://www.gnu.org/software/guile/
  11. Source: ftp://ftp.gnu.org/gnu/guile-%{version}.tar.gz
  12. # following patchs are imported from fedora-dev
  13. Patch1: guile-1.8.7-multilib.patch
  14. Patch2: guile-1.8.7-testsuite.patch
  15. Patch3: guile-1.8.7-ia64jmp.patch
  16. Patch4: guile-1.8.6-deplibs.patch
  17. Patch5: guile-1.8.7-linemarkers.patch
  18. Patch6: guile-1.8.7-testsuite2.patch
  19. Buildroot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: libtool libtool-ltdl-devel >= 2.2.6a
  21. BuildRequires: gmp-devel readline-devel emacs
  22. Requires(post): /sbin/install-info
  23. Requires(preun): /sbin/install-info
  24. Requires: coreutils
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: yasumichi
  28. %description
  29. GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
  30. implementation of the Scheme programming language, written in C. GUILE
  31. provides a machine-independent execution platform that can be linked in
  32. as a library during the building of extensible programs.
  33. Install the guile package if you'd like to add extensibility to programs
  34. that you are developing.
  35. %package devel
  36. Summary: Libraries and header files for the GUILE extensibility library.
  37. Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: gmp-devel
  41. %description devel
  42. The guile-devel package includes the libraries, header files, etc.,
  43. that you'll need to develop applications that are linked with the
  44. GUILE extensibility library.
  45. You need to install the guile-devel package if you want to develop
  46. applications that will be linked to GUILE. You'll also need to
  47. install the guile package.
  48. %package -n compat32-%{name}
  49. Summary: A GNU implementation of Scheme for application extensibility.
  50. Summary(ja): アプリケーション拡張用 Scheme の GNU な実装
  51. Group: Development/Languages
  52. Requires: %{name} = %{version}-%{release}
  53. %description -n compat32-%{name}
  54. GUILE (GNU's Ubiquitous Intelligent Language for Extension) is a library
  55. implementation of the Scheme programming language, written in C. GUILE
  56. provides a machine-independent execution platform that can be linked in
  57. as a library during the building of extensible programs.
  58. Install the guile package if you'd like to add extensibility to programs
  59. that you are developing.
  60. %package -n compat32-%{name}-devel
  61. Summary: Libraries and header files for the GUILE extensibility library.
  62. Summary(ja): GUILE 用の開発ライブラリおよびヘッダファイル
  63. Group: Development/Libraries
  64. Requires: %{name}-devel = %{version}-%{release}
  65. Requires: compat32-%{name} = %{version}-%{release}
  66. Requires: compat32-gmp-devel
  67. %description -n compat32-%{name}-devel
  68. The guile-devel package includes the libraries, header files, etc.,
  69. that you'll need to develop applications that are linked with the
  70. GUILE extensibility library.
  71. You need to install the guile-devel package if you want to develop
  72. applications that will be linked to GUILE. You'll also need to
  73. install the guile package.
  74. %prep
  75. %setup -q
  76. %patch1 -p1 -b .multilib
  77. %patch2 -p1 -b .testsuite
  78. %patch3 -p1 -b .ia64jmp
  79. %patch4 -p1 -b .deplibs
  80. %patch5 -p1 -b .linemarkers
  81. %patch6 -p1 -b .testsuite2
  82. %build
  83. %configure --disable-static --disable-error-on-warning
  84. # Remove RPATH
  85. sed -i 's|" $sys_lib_dlsearch_path "|" $sys_lib_dlsearch_path %{_libdir} "|' \
  86. {,guile-readline/}libtool
  87. make %{?_smp_mflags}
  88. %install
  89. rm -rf $RPM_BUILD_ROOT
  90. make DESTDIR=$RPM_BUILD_ROOT install
  91. mkdir -p $RPM_BUILD_ROOT%{_datadir}/guile/site
  92. rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.la
  93. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  94. # Compress large documentation
  95. bzip2 NEWS
  96. for i in ${RPM_BUILD_ROOT}%{_infodir}/goops.info; do
  97. iconv -f iso8859-1 -t utf-8 < $i > $i.utf8 && mv -f ${i}{.utf8,}
  98. done
  99. touch $RPM_BUILD_ROOT%{_datadir}/guile/%{mver}/slibcat
  100. ln -s ../../slib $RPM_BUILD_ROOT%{_datadir}/guile/%{mver}/slib
  101. %clean
  102. rm -rf $RPM_BUILD_ROOT
  103. %post
  104. /sbin/ldconfig
  105. /sbin/install-info %{_infodir}/guile.info.gz %{_infodir}/dir
  106. /sbin/install-info %{_infodir}/r5rs.info.gz %{_infodir}/dir
  107. /sbin/install-info %{_infodir}/goops.info.gz %{_infodir}/dir
  108. /sbin/install-info %{_infodir}/guile-tut.info.gz %{_infodir}/dir
  109. %postun -p /sbin/ldconfig
  110. %preun
  111. if [ "$1" = 0 ]; then
  112. /sbin/install-info --delete %{_infodir}/guile.info.gz %{_infodir}/dir
  113. /sbin/install-info --delete %{_infodir}/r5rs.info.gz %{_infodir}/dir
  114. /sbin/install-info --delete %{_infodir}/goops.info.gz %{_infodir}/dir
  115. /sbin/install-info --delete %{_infodir}/guile-tut.info.gz %{_infodir}/dir
  116. fi
  117. :
  118. %post -n compat32-%{name} -p /sbin/ldconfig
  119. %postun -n compat32-%{name} -p /sbin/ldconfig
  120. %files
  121. %defattr(-,root,root,-)
  122. %doc AUTHORS COPYING* ChangeLog HACKING NEWS.bz2 README THANKS
  123. %{_bindir}/guile
  124. %{_bindir}/guile-tools
  125. %{_libdir}/libguile*.so.*
  126. %{_libdir}/libguilereadline-*.so
  127. %{_libdir}/libguile-srfi-srfi-*.so
  128. %dir %{_datadir}/guile
  129. %dir %{_datadir}/guile/%{mver}
  130. %{_datadir}/guile/%{mver}/ice-9
  131. %{_datadir}/guile/%{mver}/lang
  132. %{_datadir}/guile/%{mver}/oop
  133. %{_datadir}/guile/%{mver}/scripts
  134. %{_datadir}/guile/%{mver}/srfi
  135. %{_datadir}/guile/%{mver}/guile-procedures.txt
  136. %ghost %{_datadir}/guile/%{mver}/slibcat
  137. %ghost %{_datadir}/guile/%{mver}/slib
  138. %dir %{_datadir}/guile/site
  139. %dir %{_datadir}/emacs/site-lisp
  140. %{_datadir}/emacs/site-lisp/*.el
  141. %{_infodir}/*
  142. %{_mandir}/man1/guile.1*
  143. %files devel
  144. %defattr(-,root,root,-)
  145. %{_bindir}/guile-config
  146. %{_bindir}/guile-snarf
  147. %{_datadir}/aclocal/*
  148. %{_libdir}/libguile.so
  149. %{_libdir}/pkgconfig/*.pc
  150. %{_includedir}/guile
  151. %{_includedir}/libguile
  152. %{_includedir}/libguile.h
  153. # compat32
  154. %if %{build_compat32}
  155. %files -n compat32-%{name}
  156. %defattr(-,root,root,-)
  157. %{_libdir}/libguile*.so.*
  158. %{_libdir}/libguilereadline-*.so
  159. %{_libdir}/libguile-srfi-srfi-*.so
  160. %files -n compat32-%{name}-devel
  161. %defattr(-,root,root,-)
  162. %{_libdir}/libguile.so
  163. %{_libdir}/pkgconfig/*.pc
  164. %endif
  165. %changelog
  166. * Sat Oct 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-2
  167. - rebuilt with rpm-4.8.1
  168. - added Patch1, 2, 3, 5 and 6 from Fedora
  169. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.7-1
  170. - new upstream release.
  171. - comment out Patch11,12.
  172. * Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-4
  173. - added Requires: gmp-devel to guile-devel
  174. * Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.8.6-3
  175. - added compat32 package for x86_64 arch support
  176. * Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-2
  177. - rebuild with libtool-2.2.6a
  178. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.6-1
  179. - new upstream release
  180. - import some patches from fedora development
  181. - drop some old patches
  182. - update spec based on fedora package
  183. - spec in utf-8
  184. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-6vl5
  185. - use macro for Release
  186. * Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.6.7-5vl5
  187. - apply new virsioning policy.
  188. - remove *.la
  189. * Sun Apr 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl2
  190. - rebuilt with readline 5.1
  191. * Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-4vl1
  192. - added Patches from Fedora
  193. * Fri Sep 02 2005 Phil Knirsch <pknirsch@redhat.com> 5:1.6.7-4
  194. - Fix dynamic linking on 64bit archs (#159971)
  195. * Tue Dec 21 2004 Phil Knirsch <pknirsch@redhat.com> 5:1.6.4-16
  196. - Moved info files to base package as they are not devel related (#139948)
  197. - Moved static guilereadline and guile-srfi-srfi libs to devel package (#140893)
  198. - Fixed guile-tools not finding guile lib dir (#142642)
  199. - Added some nice tools (#142642)
  200. - Removed smp build, seems to be broken atm
  201. * Fri Jan 7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.7-0vl1
  202. - new upstream release
  203. - dropped patch2, 4, 6
  204. - added BuildPrereq: perl
  205. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl2
  206. - rebuild with new toolchains
  207. - s/Copyright/License/
  208. - added srfi libs
  209. - patch for ppc64 from Fedora package
  210. * Thu May 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
  211. - update to 1.6.4
  212. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.6.3-0vl3
  213. - rebuild with readline-4.3
  214. * Thu Feb 13 2003 Ryoichi INAGAKI <ryo1i@bc.wakwak.com> 1.6.3-0vl2
  215. - based on Rawhide 1.6.0-4
  216. - Included s390 as working arch as well, switch to general unknown arch patch
  217. - rebuild to fix broken deps
  218. - fix continuations.h on ia64
  219. - new upstream 1.6.3
  220. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.3.4-9vl1
  221. - porting for Vine Linux
  222. - remove 1.3 patches( not required so that upstream upgrade )
  223. * Fri Jul 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  224. - Add version number to prereq for umb-scheme to get the post-install to
  225. work properly.
  226. * Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
  227. - Add an Epoch = 1 in case anyone happened to have 1.4 installed.
  228. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  229. - automatic rebuild
  230. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  231. - Back down to 1.3.4.
  232. - Fix to actually link against the version of libguile in the package.
  233. * Sun Jun 4 2000 Nalin Dahyabhai <nalin@redhat.com>
  234. - FHS fixups using the %%{makeinstall} macro.
  235. * Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  236. - fix preun-devel
  237. - call ldconfig directly in postun
  238. * Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  239. - rebuild with new readline
  240. - update to 1.3.4
  241. * Mon Feb 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  242. - using the same catalog as umb-scheme makes umb-scheme a prereq
  243. * Thu Feb 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  244. - readline is needed for %post
  245. * Tue Feb 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  246. - use the same catalog as umb-scheme
  247. * Thu Sep 2 1999 Jeff Johnson <jbj@redhat.com>
  248. - fix broken %postun
  249. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  250. - auto rebuild in the new build environment (release 6)
  251. * Wed Mar 17 1999 Michael Johnson <johnsonm@redhat.com>
  252. - added .ansi patch to fix #endif
  253. * Wed Feb 10 1999 Cristian Gafton <gafton@redhat.com>
  254. - add patch for the scm stuff
  255. * Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
  256. - integrate changes from rhcn version (#640)
  257. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  258. - call libtoolize first to get it to compile on the arm
  259. * Sat Jan 9 1999 Todd Larason <jtl@molehill.org>
  260. - Added "Requires: guile" at suggestion of Manu Rouat <emmanuel.rouat@wanadoo.fr>
  261. * Fri Jan 1 1999 Todd Larason <jtl@molehill.org>
  262. - guile-devel does depend on guile
  263. - remove devel dependancy on m4
  264. - move guile-snarf from guile to guile-devel
  265. - Converted to rhcn
  266. * Wed Oct 21 1998 Jeff Johnson <jbj@redhat.com>
  267. - update to 1.3.
  268. - don't strip libguile.so.*.0.0. (but set the execute bits).
  269. * Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
  270. - spec file fixups
  271. * Wed Sep 2 1998 Michael Fulbright <msf@redhat.com>
  272. - Updated for RH 5.2
  273. * Mon Jan 26 1998 Marc Ewing <marc@redhat.com>
  274. - Started with spec from Tomasz Koczko <kloczek@idk.com.pl>
  275. - added slib link
  276. * Thu Sep 18 1997 Tomasz Koczko <kloczek@idk.com.pl> (1.2-3)
  277. - added %attr(-, root, root) for %doc,
  278. - in %post, %postun ldconfig runed as parameter "-p",
  279. - removed /bin/sh from requires,
  280. - added %description,
  281. - changes in %files.
  282. * Fri Jul 11 1997 Tomasz Koczko <kloczek@rudy.mif.pg.gda.pl> (1.2-2)
  283. - all rewrited for using Buildroot,
  284. - added %postun,
  285. - removed making buid logs,
  286. - removed "--inclededir", added "--enable-dynamic-linking" to configure
  287. parameters,
  288. - added striping shared libs and /usr/bin/guile,
  289. - added "Requires: /bin/sh" (for guile-snarf) in guile package and
  290. "Requires: m4" for guile-devel,
  291. - added macro %{PACKAGE_VERSION} in "Source:" and %files,
  292. - added %attr macros in %files.