hostapd-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144
  1. %define base_name hostapd
  2. %define pkg_version 2.0
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
  5. Summary(ja): IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS 認証局
  6. Name: %{base_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. Source0: %{base_name}-%{version}.tar.gz
  10. Source1: %{base_name}-init.sh
  11. Source2: %{base_name}-%{version}.config
  12. Patch0: %{base_name}-%{version}.patch
  13. License: GPL2
  14. Group: System Environment/Daemons
  15. URL: http://hostap.epitest.fi/hostapd/
  16. Requires: openssl, libnl >= 1.1
  17. Requires(post): %{_syssbindir}/chkconfig
  18. Requires(preun): %{_syssbindir}/chkconfig
  19. BuildRequires: openssl-devel, libnl-devel
  20. BuildRoot: %{_tmppath}/%{base_name}-%{version}-root
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: miyabi
  24. %description
  25. hostapd is a user space daemon for access point and authentication servers. It implements IEEE 802.11 access point management,
  26. IEEE 802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and RADIUS authentication server.
  27. The current version supports Linux (Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211).
  28. %description -l ja
  29. hostapd はアクセスポイントと認証サーバのためのユーザスペースデーモンです。
  30. IEEE 802.11 アクセスポイント管理、IEEE 802.1X/WPA/WPA2/EAP 認証局、RADIUS クライアント、EAP サーバ、および RADIUS 認証サーバを実装します。
  31. 最新版は、Linux(Host AP、madwifi、mac80211ベースのドライバー)とFreeBSD(net80211)をサポートします。
  32. %prep
  33. %setup -q
  34. %patch0 -p1
  35. cp %{SOURCE1} .
  36. cp %{SOURCE2} ./%{base_name}/.config
  37. %build
  38. cd %{base_name}
  39. %{__make} %{?_smp_mflags}
  40. %install
  41. [ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
  42. pushd %{base_name}
  43. %{__make} install DESTDIR="${RPM_BUILD_ROOT}"
  44. popd
  45. mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
  46. install %{SOURCE1} ${RPM_BUILD_ROOT}%{_initdir}/%{base_name}
  47. %post
  48. if ! /sbin/chkconfig %{base_name}; then
  49. /sbin/chkconfig --add %{base_name}
  50. fi
  51. if [ "$1" -eq "2" ]; then
  52. %{_initdir}/%{base_name} condrestart
  53. fi
  54. %preun
  55. if [ "$1" -eq "0" ]; then
  56. %{_initdir}/%{base_name} stop
  57. /sbin/chkconfig --del %{base_name}
  58. fi
  59. %clean
  60. [ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
  61. %files
  62. %defattr(-, root, root)
  63. # Directory
  64. %dir %{_sysconfdir}/%{base_name}/
  65. # Program Files
  66. %attr(0755, root, root) %{_sbindir}/%{base_name}
  67. %attr(0755, root, root) %{_bindir}/hostapd_cli
  68. %attr(0755, root, root) %{_initdir}/%{base_name}
  69. # Config Files
  70. %attr(0644, root, root) %config(noreplace) %{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
  71. # Document Files
  72. %doc %{base_name}/ChangeLog COPYING README
  73. %{_mandir}/man8/%{base_name}.8.gz
  74. %{_mandir}/man1/hostapd_cli.1.gz
  75. %changelog
  76. * Sun Mar 17 2013 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.0-1
  77. - new upstream release
  78. - change filename hostapd.conf -> hostapd.conf.sample
  79. - change .config
  80. - add WPS support
  81. * Sun Dec 2 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.1-1
  82. - new upstream release
  83. * Fri Oct 19 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0.0-1
  84. - new upstream release
  85. - add Summary(ja)
  86. - add section - %description -l ja
  87. - add parameter noreplace to %config
  88. - change spec file
  89. * Tue Oct 9 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-3
  90. - add patch100 for fix CVE-2012-4445 (EPA-TLS message)
  91. * Thu Feb 10 2011 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-2
  92. - fix daemon script
  93. - change spec file
  94. - separation from patch file
  95. - daemon script
  96. - .config
  97. - add Source1 - hostapd-init.sh
  98. - add Source2 - hostapd-0.7.3.config
  99. - add Requires(post) - chkconfig
  100. - add Requires(preun) - chkconfig
  101. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-2
  102. - rebuild with openssl-1.0.0c
  103. * Tue Sep 21 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-1
  104. - new upstream release
  105. * Sat May 08 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.10-1
  106. - new upstream release
  107. * Sun Nov 15 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.9-1
  108. - new upstream release
  109. * Mon Jan 05 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.11-1
  110. - new upstream release
  111. * Wed Apr 16 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.10-1
  112. - initial build for Vine Linux