icedtea-web-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244
  1. # We require at the least the first release java-1.6.0-openjdk
  2. # with IcedTea6 1.10
  3. %define min_openjdk_version 1.6.0.0-60
  4. %define multilib_arches ppc64 sparc64 x86_64
  5. # Version of java
  6. %define javaver 1.7.0
  7. # Alternatives priority
  8. %define priority 17000
  9. %ifarch %{ix86}
  10. %define archinstall i386
  11. %endif
  12. %ifarch x86_64
  13. %define archinstall amd64
  14. %endif
  15. # 32 bit sparc, optimized for v9
  16. %ifarch sparcv9
  17. %define archinstall sparc
  18. %endif
  19. # 64 bit sparc
  20. %ifarch sparc64
  21. %define archinstall sparcv9
  22. %endif
  23. %ifarch %{multilib_arches}
  24. %define javadir %{_jvmdir}/java-%{javaver}-openjdk.%{_arch}
  25. %define jredir %{_jvmdir}/jre-%{javaver}-openjdk.%{_arch}
  26. %define jre6dir %{_jvmdir}/jre-1.6.0-openjdk.%{_arch}
  27. %define javaplugin libjavaplugin.so.%{_arch}
  28. %else
  29. %define javadir %{_jvmdir}/java-%{javaver}-openjdk
  30. %define jredir %{_jvmdir}/jre-%{javaver}-openjdk
  31. %define jre6dir %{_jvmdir}/jre-1.6.0-openjdk
  32. %define javaplugin libjavaplugin.so
  33. %endif
  34. %define binsuffix .itweb
  35. Name: icedtea-web
  36. Version: 1.3.1
  37. Release: 1%{?_dist_release}
  38. Summary: Java browser plug-in and Web Start implementation
  39. Summary(ja): Java ブラウザプラグイン
  40. Group: Applications/Internet
  41. License: LGPLv2+ and GPLv2 with exceptions
  42. URL: http://icedtea.classpath.org/wiki/IcedTea-Web
  43. Source0: http://icedtea.classpath.org/download/source/%{name}-%{version}.tar.gz
  44. BuildRequires: java-%{javaver}-openjdk-devel
  45. BuildRequires: desktop-file-utils
  46. BuildRequires: gecko-devel
  47. BuildRequires: glib2-devel
  48. BuildRequires: gtk2-devel
  49. BuildRequires: xulrunner-devel
  50. # For functionality and the OpenJDK dirs
  51. Requires: java-%{javaver}-openjdk
  52. # Post requires alternatives to install plugin alternative.
  53. Requires(post): alternatives
  54. # Postun requires alternatives to uninstall plugin alternative.
  55. Requires(postun): alternatives
  56. # Standard JPackage plugin provides.
  57. Provides: java-plugin = %{javaver}
  58. Provides: javaws = %{javaver}
  59. Provides: java-1.7.0-openjdk-plugin
  60. Obsoletes: java-1.6.0-openjdk-plugin <= %{min_openjdk_version}
  61. # IcedTea is only built on these archs for now
  62. ExclusiveArch: x86_64 i686 %{arm}
  63. %description
  64. The IcedTea-Web project provides a Java web browser plugin, an implementation
  65. of Java Web Start (originally based on the Netx project) and a settings tool to
  66. manage deployment settings for the aforementioned plugin and Web Start
  67. implementations.
  68. %package javadoc
  69. Summary: API documentation for IcedTea-Web
  70. Summary(ja): API documentation for IcedTea-Web
  71. Group: Documentation
  72. Requires: jpackage-utils
  73. BuildArch: noarch
  74. %description javadoc
  75. This package contains Javadocs for the IcedTea-Web project.
  76. %prep
  77. %setup -q
  78. %build
  79. autoconf
  80. ./configure \
  81. --with-pkgversion=vine-%{release}-%{_arch} \
  82. --docdir=%{_datadir}/javadoc/%{name} \
  83. --with-jdk-home=%{javadir} \
  84. --with-jre-home=%{jredir} \
  85. --libdir=%{_libdir} \
  86. --program-suffix=%{binsuffix} \
  87. --prefix=%{_prefix}
  88. make CXXFLAGS="$RPM_OPT_FLAGS"
  89. %install
  90. rm -rf $RPM_BUILD_ROOT
  91. make install DESTDIR=$RPM_BUILD_ROOT
  92. # Move javaws man page to a more specific name
  93. mv $RPM_BUILD_ROOT/%{_mandir}/man1/javaws.1 $RPM_BUILD_ROOT/%{_mandir}/man1/javaws-itweb.1
  94. # Install desktop files.
  95. install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/{applications,pixmaps}
  96. cp javaws.png $RPM_BUILD_ROOT%{_datadir}/pixmaps
  97. desktop-file-install --vendor ''\
  98. --dir $RPM_BUILD_ROOT%{_datadir}/applications javaws.desktop
  99. desktop-file-install --vendor ''\
  100. --dir $RPM_BUILD_ROOT%{_datadir}/applications itweb-settings.desktop
  101. mkdir -p $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/
  102. %post
  103. if [ $1 -gt 1 ]
  104. then
  105. alternatives --remove %{javaplugin} \
  106. %{jre6dir}/lib/%{archinstall}/IcedTeaPlugin.so 2>/dev/null || :
  107. fi
  108. %posttrans
  109. update-desktop-database &> /dev/null || :
  110. alternatives \
  111. --install %{_libdir}/mozilla/plugins/libjavaplugin.so %{javaplugin} \
  112. %{_libdir}/IcedTeaPlugin.so %{priority} \
  113. --slave %{_bindir}/javaws javaws %{_prefix}/bin/javaws%{binsuffix} \
  114. --slave %{_mandir}/man1/javaws.1.gz javaws.1.gz \
  115. %{_mandir}/man1/javaws-itweb.1.gz
  116. exit 0
  117. %postun
  118. update-desktop-database &> /dev/null || :
  119. if [ $1 -eq 0 ]
  120. then
  121. alternatives --remove %{javaplugin} \
  122. %{_libdir}/IcedTeaPlugin.so
  123. fi
  124. exit 0
  125. %files
  126. %defattr(-,root,root,-)
  127. %doc NEWS README COPYING
  128. %{_prefix}/bin/*
  129. %{_libdir}/IcedTeaPlugin.so
  130. %{_datadir}/applications/*
  131. %{_datadir}/icedtea-web
  132. %{_datadir}/man/man1/*
  133. %{_datadir}/pixmaps/*
  134. %dir %{_libdir}/mozilla/plugins/
  135. %files javadoc
  136. %defattr(-,root,root,-)
  137. %{_datadir}/javadoc/%{name}
  138. %doc COPYING
  139. %changelog
  140. * Mon Mar 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-1
  141. - update to 1.3.1
  142. * Mon Sep 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  143. - initial build for Vine Linux
  144. * Tue Jul 31 2012 Deepak Bhole <dbhole@redhat.com> 1.2.1-1
  145. - Updated to 1.2.1
  146. - Resolves: RH840592/CVE-2012-3422
  147. - Resolves: RH841345/CVE-2012-3423
  148. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-5
  149. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  150. * Thu May 03 2012 Deepak Bhole <dbhole@redhat.com> 1.2-4
  151. - Resolves rhbz#814585
  152. - Fixed java-plugin provides and added one for javaws
  153. * Tue Apr 17 2012 Deepak Bhole <dbhole@redhat.com> 1.2-3
  154. - Updated summary
  155. - Fixed virtual provide
  156. * Tue Mar 13 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.2-2
  157. - Enable building on ARM platforms
  158. * Mon Mar 05 2012 Deepak Bhole <dbhole@redhat.com> 1.2-1
  159. - Updated to 1.2
  160. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-4
  161. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  162. * Fri Nov 25 2011 Deepak Bhole <dbhole@redhat.com> 1.1.4-3
  163. - Resolves rhbz#757191
  164. - Bumped min_openjdk_version to -60 (latest)
  165. * Thu Nov 24 2011 Deepak Bhole <dbhole@redhat.com> 1.1.4-2
  166. - Resolves: rhbz#742887. Do not own directories not created by the package.
  167. * Tue Nov 08 2011 Deepak Bhole <dbhole@redhat.com> 1.1.4-1
  168. - Updated to 1.1.4
  169. - Added npapi-fix patch so that the plug-in compiles with xulrunner 8
  170. * Thu Sep 01 2011 Deepak Bhole <dbhole@redhat.com> 1.1.2-1
  171. - Updated to 1.1.2
  172. - Removed all patches (now upstream)
  173. - Resolves: rhbz# 734890
  174. * Tue Aug 23 2011 Deepak Bhole <dbhole@redhat.com> 1.1.1-3
  175. - Added patch to allow install to jre dir
  176. - Fixed requirement for java-1.7.0-openjdk
  177. * Tue Aug 09 2011 Deepak Bhole <dbhole@redhat.com> 1.1.1-2
  178. - Fixed file ownership so that debuginfo is not in main package
  179. * Wed Aug 03 2011 Deepak Bhole <dbhole@redhat.com> 1.1.1-1
  180. - Bump to 1.1.1
  181. - Added patch for PR768 and PR769
  182. * Wed Jul 20 2011 Deepak Bhole <dbhole@redhat.com> 1.0.4-1
  183. - Bump to 1.0.4
  184. - Fixed rhbz#718164: Home directory path disclosure to untrusted applications
  185. - Fixed rhbz#718170: Java Web Start security warning dialog manipulation
  186. * Mon Jun 13 2011 Deepak Bhole <dbhole@redhat.com> 1.0.3-1
  187. - Update to 1.0.3
  188. - Resolves: rhbz#691259
  189. * Mon Apr 04 2011 Deepak Bhole <dbhole@redhat.com> 1.0.2-2
  190. - Fixed incorrect macro value for min_openjdk_version
  191. - Use posttrans instead of post, so that upgrade from old plugin works
  192. * Mon Apr 04 2011 Deepak Bhole <dbhole@redhat.com> 1.0.2-1
  193. - Initial build