kdepim3-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588
  1. %define beta 0
  2. %define vine4 %(grep -c 4. /etc/vine-release)
  3. Name: kdepim3
  4. Summary: Compatibility support for kdepim3
  5. Version: 3.5.10
  6. Release: 1%{?_dist_release}
  7. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdepim-%{version}.tar.bz2
  8. # KDE.org patches
  9. # KDE.gr.jp patches
  10. URL: http://www.kde.org/
  11. Group: Applications/Productivity
  12. License: GPLv2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: bison flex
  15. BuildRequires: desktop-file-utils
  16. BuildRequires: kdelibs3-devel >= %{version}
  17. BuildRequires: zlib-devel
  18. BuildRequires: libart_lgpl-devel
  19. BuildRequires: cyrus-sasl-devel
  20. BuildRequires: gpgme-devel
  21. BuildRequires: libXpm-devel libXScrnSaver-devel
  22. BuildRequires: libmal-devel
  23. BuildRequires: pilot-link-devel >= 0.9.5
  24. %description
  25. %{summary}, including libkcal.
  26. %package libs
  27. Summary: Runtime files for %{name}
  28. Group: System Environment/Libraries
  29. Requires: kdelibs3 >= %{version}
  30. %description libs
  31. %{summary}, including libkcal.
  32. %package devel
  33. Summary: Development files for %{name}
  34. Group: Development/Libraries
  35. Requires: %{name}-libs = %{version}-%{release}
  36. Requires: kdelibs3-devel
  37. %description devel
  38. Development files for %{name}.
  39. Install %{name}-devel if you want to write or compile %{name} plugins.
  40. %prep
  41. %setup -q -n kdepim-%{version}
  42. %ifarch ia64 s390 s390x
  43. rm -rf kpilot doc/kpilot
  44. %endif
  45. %build
  46. unset QTDIR || : ; . /etc/profile.d/qt.sh
  47. %configure \
  48. --with-qt-libraries=$QTDIR/lib \
  49. --enable-new-ldflags \
  50. --disable-dependency-tracking \
  51. --disable-rpath \
  52. --disable-debug --disable-warnings \
  53. --enable-final \
  54. --includedir=%{_includedir}/kde \
  55. --with-gpg=%{_bindir}/gpg \
  56. --with-gpgsm=%{_bindir}/gpgsm \
  57. --with-sasl \
  58. --without-gnokii \
  59. --with-mal \
  60. --with-pilot-link
  61. for lib in ktnef libkmime libemailfunctions libkcal libkdepim; do
  62. make %{?_smp_mflags} -C ${lib}
  63. done
  64. %install
  65. rm -rf $RPM_BUILD_ROOT
  66. for lib in ktnef libkmime libemailfunctions libkcal libkdepim; do
  67. make install DESTDIR=$RPM_BUILD_ROOT -C $lib
  68. done
  69. #unpackaged files
  70. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  71. rm -f $RPM_BUILD_ROOT%{_libdir}/libkdepim*
  72. rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/libkdepim/
  73. rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/kdepimwidgets/
  74. rm -f $RPM_BUILD_ROOT%{_libdir}/kde3/plugins/designer/*
  75. rm -f $RPM_BUILD_ROOT%{_libdir}/lib{kmime,ktnef}.so
  76. rm -rf $RPM_BUILD_ROOT%{_includedir}/kde/ktnef/
  77. rm -rf $RPM_BUILD_ROOT%{_datadir}/applications
  78. rm -rf $RPM_BUILD_ROOT%{_datadir}/icons
  79. rm -rf $RPM_BUILD_ROOT%{_datadir}/mimelnk
  80. rm -rf $RPM_BUILD_ROOT%{_datadir}/apps/ktnef
  81. rm -f $RPM_BUILD_ROOT%{_bindir}/ktnef
  82. #cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/config/
  83. %post libs -p /sbin/ldconfig
  84. %postun libs -p /sbin/ldconfig
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %files libs
  88. %defattr(-,root,root)
  89. %doc README korganizer/COPYING
  90. %{_datadir}/config.kcfg/pimemoticons.kcfg
  91. %{_datadir}/apps/libical/
  92. %{_datadir}/services/kresources/kcal*
  93. %{_libdir}/libkcal.so.2*
  94. %{_libdir}/kde3/kcal*
  95. %{_libdir}/libkmime.so.2*
  96. %{_libdir}/libktnef.so.1*
  97. %files devel
  98. %defattr(-,root,root)
  99. %{_includedir}/kde/kdepimmacros.h
  100. %{_includedir}/kde/libemailfunctions
  101. %{_includedir}/kde/libkcal
  102. %{_libdir}/libkcal.so
  103. %changelog
  104. * Sun Mar 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-1
  105. - updated to 3.5.10
  106. - built with new toolchain
  107. * Sat Sep 5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-2
  108. - renamed kdepim3
  109. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  110. - applied new versioning policy, spec in UTF-8
  111. - added Japnaese summary
  112. * Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  113. - rebuild for VineSeed
  114. * Tue Oct 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  115. - new upstream release
  116. * Wed Jun 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  117. - rebuild for VineSeed
  118. * Wed May 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  119. - new upstream release
  120. - remove all patches
  121. * Mon Apr 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  122. - new upstream release
  123. - add Patch0, 1 , 2 and 3
  124. * Mon Oct 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
  125. - added --with-qt-libraries and --enable-libsuffix option
  126. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  127. - rebuild for VineSeed
  128. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  129. - new upstream release
  130. * Mon Sep 4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl3
  131. - rebuild with pilot-link-0.12.0-0vl1
  132. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  133. - rebuild for VineSeed
  134. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  135. - new upstream release
  136. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  137. - rebuild for VineSeed
  138. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  139. - new upstream release
  140. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  141. - rebuild for VineSeed
  142. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  143. - new upstream release
  144. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  145. - rebuild for VineSeed
  146. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  147. - new upstream release
  148. - delete BuildPrereq: libmal-devel and Requires: libmal
  149. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
  150. - rebuild for VineSeed
  151. * Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
  152. - new upstream release
  153. * Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
  154. - new upstream release
  155. * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
  156. - new upstream release
  157. - delete all patches
  158. - add Requires: kdeaccessibility >= %%{version}
  159. - add --enable-indexlib to configure option
  160. * Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
  161. - new upstream release
  162. - remove Patch0
  163. - add Patch0 - Patch1
  164. * Tue Aug 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl2
  165. - rebuild for VineSeed
  166. * Tue Aug 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.2-0vl1
  167. - new upstream release
  168. - remove Patch0
  169. - add BuildPrereq: gpgme-devel >= 0.4.5
  170. - add Patch0 (http://bugs.kde.org/show_bug.cgi?id=109003)
  171. * Mon Jul 4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
  172. - rebuild for VineSeed
  173. - add --disable-rpath to configure option
  174. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
  175. - new upstream release (delete old patch and add new security patch)
  176. - use %%{?_smp_mflags} for make option
  177. * Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
  178. - rebuild for VineSeed
  179. * Wed Mar 16 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
  180. - new upstream release
  181. - add patch0
  182. * Fri Mar 4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl0.rc1
  183. - new upstream release (3.4.0-rc1)
  184. * Tue Feb 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.92-0vl1
  185. - new upstream release
  186. * Wed Feb 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.91-0vl1
  187. - new upstream release
  188. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  189. - rebuild for VineSeed
  190. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  191. - new upstream release
  192. * Sun Oct 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  193. - source upgrade
  194. - update %%files
  195. - all sub-packages are integrated into main package (exclude devel)
  196. * Tue Aug 10 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
  197. - rebuild with qt32
  198. * Tue Jun 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
  199. - source upgrade
  200. - remove lines about vine26
  201. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  202. - source upgrade
  203. - update %%files
  204. * Sat Mar 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  205. - source upgrade
  206. - update %%description
  207. - add Obsoletes: kdenetwork < 3.2.0
  208. * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
  209. - rebuild for VineSeedPlus
  210. * Sun Jan 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
  211. - source upgrade
  212. - build for VinePlus/2.6
  213. - (VinePlus/2.6) BuildPrereq: autoconf258
  214. - remove Patch
  215. * Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl3
  216. - build for VineSeed with new toolchain and qt-3.2.3
  217. - add configure option --with-xinerama --enable-final
  218. * Sun Nov 2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl2
  219. - rebuild with qt-3.2.1-0.26vl3
  220. * Sun Oct 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl2
  221. - rebuild with qt-3.2.1-0vl3
  222. * Sat Sep 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
  223. - build with gcc-3.2.3
  224. * Thu Sep 18 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0.26vl1
  225. - source upgrade
  226. - BuildPrereq: qt-devel >= 3.2.1 arts-devel >= 1:1.1.4
  227. * Sat Aug 2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0.26vl1
  228. - rebuild for Vine2.6
  229. * Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
  230. - source upgrade
  231. - change spec to build with gcc295
  232. - change make option for SMP and add script
  233. - add BuildPrereq: libmal-devel
  234. - add Requires: libmal for pilot
  235. * Sat May 10 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  236. - source upgrade
  237. - remove Patch800 (included in this source)
  238. - built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
  239. * Sat Apr 5 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.1-0vl1
  240. - source upgrade
  241. - change spec to build both VineSeed and Vine2.5/2.6
  242. - revised description and files section
  243. - remove source900
  244. - add patch0 (http://bugs.kde.org/show_bug.cgi?id=55541)
  245. - add patch800 (Kdeveloper:02753)
  246. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  247. - objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
  248. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  249. - source upgrade
  250. * Wed Oct 9 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl2
  251. - rebuild with qt-3.0.5-0vl1
  252. - BuildPrereq: autoconf253 objprelink2
  253. * Wed Sep 18 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  254. - source upgrade
  255. * Sun Jul 14 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-0vl1
  256. - source upgrade
  257. - add BuildPrereq: autoconf252 automake15
  258. * Thu Jul 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.1-1vl1
  259. - merged with rawhide 3.0.1-1
  260. - change %%doc %%{_docdir}/HTML -> %%doc %%{_datadir}/doc/HTML
  261. - add Requires: for each package
  262. - There is Vine's previous changes, hacked for Vine
  263. -- Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  264. - build for VineSeed
  265. - delete Epoch
  266. - objprelink (i386 only)
  267. * Tue Jun 25 2002 Than Ngo <than@redhat.com> 3.0.1-1
  268. - 3.0.1
  269. - fixed bug #67303
  270. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  271. - automated rebuild
  272. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  273. - automated rebuild
  274. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
  275. - Rename libraries
  276. * Wed Apr 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
  277. - Fix #61901
  278. * Fri Mar 29 2002 Than Ngo <than@redhat.com> 3.0.0-1
  279. - final
  280. * Tue Jan 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020122.1
  281. - Update
  282. - Fix build on ia64
  283. * Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010726.1
  284. - Update, fixes korganizer (#50006)
  285. * Sun May 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  286. - Update to get rid of abbrowser (moved to kdebase)
  287. * Thu Feb 22 2001 Than Ngo <than@redhat.com>
  288. - add missing ldconfig in %post anf %postun again
  289. - clean up specfile
  290. * Wed Feb 21 2001 Than Ngo <than@redhat.com>
  291. - 2.1-respin
  292. - fix dangling symlink
  293. - remove excludearch ia64, some hacks to build on ia64
  294. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  295. - 2.1
  296. * Mon Feb 5 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  297. - Update
  298. * Tue Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  299. - Update
  300. * Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  301. - Update to CVS
  302. - Enable building kpilot
  303. - Obsolete kpilot
  304. - Don't exclude ia64, use -O0 on ia64
  305. - Disable building kpilot on ia64 (compiler breakage)
  306. * Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  307. - 2.0 final
  308. * Wed Oct 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  309. - 2.0
  310. * Sun Oct 1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  311. - new CVS
  312. - fix installation of fonts
  313. * Sat Sep 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  314. - new CVS snapshot
  315. - fix up spec file
  316. * Wed Aug 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  317. - get rid of the 3d-screensavers package - now that qt-GL is part of qt,
  318. there's no need to keep them separate to avoid the dependency.
  319. * Mon Aug 21 2000 Than Ngo <than@redhat.com>
  320. - fix gnome-session so that KDE2 can be started from gdm
  321. - pam/kde2 instead pam/kde to avoid problem with KDE1
  322. - don't requires qt-GL, It's now in qt
  323. * Sun Aug 20 2000 Than Ngo <than@redhat.com>
  324. - fix dependency problem with KDE1 so that KDE1 and KDE2 can be installed
  325. at the same time
  326. - add missing ldconfig in %post anf %postun
  327. - fix for reading config files in /etc/X11/xdm, add Xsession to requires
  328. * Tue Aug 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  329. - Fix keytable in konsole (Bug #15682)
  330. * Sun Aug 6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  331. - rebuild, now that kdelibs2 works on alpha
  332. - use the same ugly hack to get kdebase to compile
  333. - remove ksysguard on alpha (even more compiler problems)
  334. * Fri Aug 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  335. - new snapshot (fixed libGL detection in CVS)
  336. * Wed Aug 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  337. - move to /usr/lib/kde2
  338. - new snapshot
  339. * Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  340. - fix the --xdmdir arg to be correct (oops)
  341. * Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  342. - move kdm config files from /usr/config to /etc/X11 by forcing xdmdir
  343. * Fri Jul 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  344. - new snapshot
  345. - some fixes to spec file
  346. * Tue Jul 18 2000 Than Ngo <than@redhat.de>
  347. - rebuilt against glibc-2.1.92-14, gcc-2.96-40
  348. * Sun Jul 16 2000 Than Ngo <than@redhat.de>
  349. - use new snapshot
  350. - disable Motif
  351. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  352. - use gcc 2.96
  353. - new snapshot
  354. * Sun Jul 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  355. - Epoch 3
  356. - Update to current
  357. - Use egcs++
  358. * Fri Jun 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  359. - Update (I put the fixes directly to CVS rather than collecting them
  360. in the spec)
  361. * Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  362. - remove man2html; we get that from man
  363. - new snapshot
  364. * Tue Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  365. - new snapshot
  366. - ExcludeArch ia64 for now
  367. - remove gnome .desktop file, we get it from gnome-core now.
  368. * Wed Apr 5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  369. - remove dependency on xpm (now in XFree86)
  370. * Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  371. - new snapshot
  372. - move it to /usr, where it belongs
  373. * Sat Dec 25 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  374. - Build the OpenGL screensavers, and move them to a separate package
  375. - Improve the spec file (BuildPrereqs etc.)
  376. * Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  377. - remove patch #3 (obsoleted by kwin)
  378. * Sun Oct 24 1999 Bernhard Rosenkraenzer <bero@redhat.de>
  379. - 2.0 CVS snapshot
  380. - fix compilation
  381. * Thu Sep 23 1999 Preston Brown <pbrown@redhat.com>
  382. - clean up files in /tmp from startkde
  383. - mark doc files as such
  384. * Tue Sep 21 1999 Preston Brown <pbrown@redhat.com>
  385. - start autorun if present in startkde
  386. - check for configured soundcard before running sound services
  387. * Mon Sep 20 1999 Preston Brown <pbrown@redhat.com>
  388. - made kdelnks display Name property if they are of type Link
  389. * Thu Sep 16 1999 Preston Brown <pbrown@redhat.com>
  390. - moved png handling here (from kdelibs)
  391. - changed low color icon directory name to locolor
  392. * Tue Sep 14 1999 Preston Brown <pbrown@redhat.com>
  393. - added optional session management to logout dialog
  394. - include GNOME menus
  395. * Mon Sep 13 1999 Preston Brown <pbrown@redhat.com>
  396. - added link to /etc/X11/applnk, .directory file
  397. - included lowcolor icon sub-package
  398. - enable .desktop file access
  399. * Fri Sep 10 1999 Preston Brown <pbrown@redhat.com>
  400. - customized startkde script to set up user environment if not present.
  401. - mention kthememgr in description.
  402. * Wed Sep 08 1999 Preston Brown <pbrown@redhat.com>
  403. - upgraded to 1.1.2 release
  404. - kvt is back
  405. - kde icon included
  406. - linux console fonts included
  407. * Thu Jul 15 1999 Preston Brown <pbrown@redhat.com>
  408. - PAM console logout problem solved.
  409. * Mon Jul 12 1999 Preston Brown <pbrown@redhat.com>
  410. - now includes screensaver password security fix
  411. * Fri Jun 11 1999 Preston Brown <pbrown@redhat.com>
  412. - snapshot, includes kde 1.1.1 + fixes
  413. - kvt removed for security reasons. It is a steaming pile of...
  414. * Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
  415. - last snapshot before release
  416. * Fri Apr 16 1999 Preston Brown <pbrown@redhat.com>
  417. - today's snapshot makes kfm a bit nicer and some other fixes
  418. - moved default rc files to kdesupport
  419. * Thu Apr 15 1999 Preston Brown <pbrown@redhat.com>
  420. - SUID bit removed from konsole_grantpty -- not needed w/glibc 2.1
  421. * Wed Apr 14 1999 Preston Brown <pbrown@redhat.com>
  422. - built with today's snapshot -- had to rebuild to fix pam problems.
  423. * Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
  424. - new snapshot fixes mimetype video/x-flic problem
  425. * Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
  426. - latest stable snapshot
  427. * Fri Apr 09 1999 Preston Brown <pbrown@redhat.com>
  428. - removed bell.xpm (used to be in fvwm2-icons, don't want installer to see
  429. - this previous connection and autoselect kdebase for upgrade).
  430. * Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
  431. - moved gdm patch
  432. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  433. - added gdm session control file
  434. * Fri Mar 19 1999 Preston Brown <pbrown@redhat.com>
  435. - added pam-console stuff to kde pam file
  436. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  437. - Injected new description and group.
  438. * Mon Feb 07 1999 Preston Brown <pbrown@redhat.com>
  439. - upgraded to KDE 1.1 final.
  440. * Tue Jan 19 1999 Preston Brown <pbrown@redhat.com>
  441. - updated macros for RPM 3.0, removed red hat logo.
  442. * Tue Jan 05 1999 Preston Brown <pbrown@redhat.com>
  443. - re-merged from Duncan Haldane's stuff