libvpx-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197
  1. Name: libvpx
  2. Version: 1.1.0
  3. Release: 1%{?_dist_release}
  4. Summary: The VP8 Codec SDK
  5. Summary(ja): VP8 コーデックソフトウェア開発キット
  6. Group: System Environment/Libraries
  7. License: BSD
  8. URL: http://www.webmproject.org/tools/vp8-sdk/
  9. Source0: http://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
  10. Source2: libvpx.ver
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. %ifarch %{ix86} x86_64
  13. BuildRequires: yasm
  14. %endif
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: daisuke
  18. %description
  19. The WebM VP8 Codec SDK allows you to integrate your applications with
  20. the VP8 video codec, a high quality, royalty free, open source codec
  21. deployed on millions of computers and devices worldwide.
  22. %description -l ja
  23. WebM VP8 コーデック SDK は、VP8 ビデオコーデックをアプリケーションに
  24. 統合するための開発きっとです。VP8ビデオコーデックは高品質でロイヤリティ
  25. フリーかつオープンソースのコーデックで、世界中の多くのコンピュータや
  26. デバイスで利用されています。
  27. %package devel
  28. Summary: Development files for %{name}
  29. Summary(ja): %{name} の開発ファイル
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}-%{release}
  32. %description devel
  33. The %{name}-devel package contains development files for
  34. %{name}.
  35. %description devel -l ja
  36. %{name}-devel パッケージは %{name} の開発用ファイルを含んでいます。
  37. %package utils
  38. Summary: example programs for %{name}
  39. Summary(ja): %{name} のサンプルプログラム
  40. Group: Applications/Multimedia
  41. Requires: %{name} = %{version}-%{release}
  42. %description utils
  43. The %{name}-utils package contains example programs that
  44. use %{name}.
  45. %description utils -l ja
  46. %{name}-utils パッケージは、%{name} を使用したサンプル
  47. アプリケーションを含んでいます。
  48. %prep
  49. %setup -q -n %{name}-v%{version}
  50. %build
  51. %ifarch %{ix86}
  52. %global vpxtarget x86-linux-gcc
  53. %else
  54. %ifarch x86_64
  55. %global vpxtarget x86_64-linux-gcc
  56. %else
  57. %global vpxtarget generic-gnu
  58. %endif
  59. %endif
  60. %if "%{vpxtarget}" == "generic-gnu"
  61. %global generic_target 1
  62. %else
  63. %global generic_target 0
  64. %endif
  65. ./configure \
  66. --target=%{vpxtarget} \
  67. --enable-pic \
  68. %if ! %{generic_target}
  69. --enable-shared \
  70. %endif
  71. --prefix=%{_prefix} \
  72. --libdir=%{_libdir} \
  73. --disable-install-docs \
  74. --disable-install-srcs
  75. # fix up optflags
  76. sed -i "s|-O3|%{optflags}|g" libs-%{vpxtarget}.mk
  77. sed -i "s|-O3|%{optflags}|g" examples-%{vpxtarget}.mk
  78. sed -i "s|-O3|%{optflags}|g" docs-%{vpxtarget}.mk
  79. %{__make} %{?_smp_mflags} verbose=true target=libs
  80. %if %{generic_target}
  81. mkdir -p tmp
  82. pushd tmp
  83. ar x ../libvpx_g.a
  84. popd
  85. gcc -shared -fPIC -pthread -lm \
  86. -Wl,--no-undefined \
  87. -Wl,-soname,libvpx.so.0 \
  88. -Wl,--version-script,%{SOURCE2} \
  89. -Wl,-z,noexecstack \
  90. -o libvpx.so.%{version} tmp/*.o
  91. rm -rf tmp
  92. %endif
  93. ln -sf libvpx.so.%{version} libvpx.so
  94. mv libvpx.a libvpx.a.tmp
  95. mv libvpx_g.a libvpx_g.a.tmp
  96. make %{?_smp_mflags} verbose=true target=examples
  97. mv libvpx.a.tmp libvpx.a
  98. mv libvpx_g.a.tmp libvpx_g.a
  99. %install
  100. %{__rm} -rf $RPM_BUILD_ROOT
  101. %{__make} DIST_DIR=$RPM_BUILD_ROOT%{_prefix} dist
  102. %if %{generic_target}
  103. install -p libvpx.so.%{version} %{buildroot}%{_libdir}
  104. pushd %{buildroot}%{_libdir}
  105. ln -sf libvpx.so.%{version} libvpx.so
  106. ln -sf libvpx.so.%{version} libvpx.so.1
  107. ln -sf libvpx.so.%{version} libvpx.so.1.1
  108. popd
  109. %endif
  110. pushd %{buildroot}
  111. # Rename a few examples
  112. mv usr/bin/postproc usr/bin/vp8_postproc
  113. mv usr/bin/simple_decoder usr/bin/vp8_simple_decoder
  114. mv usr/bin/simple_encoder usr/bin/vp8_simple_encoder
  115. mv usr/bin/twopass_encoder usr/bin/vp8_twopass_encoder
  116. # Fix the binary permissions
  117. chmod 755 usr/bin/*
  118. popd
  119. rm -f $RPM_BUILD_ROOT%{_prefix}/md5sums.txt
  120. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
  121. rm -f $RPM_BUILD_ROOT%{_prefix}/{CHANGELOG,README}
  122. rm -rf $RPM_BUILD_ROOT%{_prefix}/build
  123. %clean
  124. rm -rf $RPM_BUILD_ROOT
  125. %post -p /sbin/ldconfig
  126. %postun -p /sbin/ldconfig
  127. %files
  128. %defattr(-,root,root,-)
  129. %doc AUTHORS LICENSE README CHANGELOG
  130. %{_libdir}/*.so.*
  131. %files devel
  132. %defattr(-,root,root,-)
  133. %{_libdir}/*.so
  134. %{_libdir}/pkgconfig/*.pc
  135. %{_includedir}/vpx/*.h
  136. %files utils
  137. %defattr(-,root,root,-)
  138. %{_bindir}/*
  139. %changelog
  140. * Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
  141. - new upstream release
  142. - remove Patch0 (libvpx-0.9.0-no-explicit-dep-on-static-lib.patch)
  143. - remove Source1 (libvpx.pc)
  144. * Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9.6-1
  145. - new upstream release
  146. * Mon Dec 27 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.5-1
  147. - new upstream release
  148. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.1-2
  149. - rebuild with rpm-4.8.1 for pkg-config file
  150. * Sun Jul 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.1-1
  151. - new upstream release
  152. * Mon May 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.0-1
  153. - initial build for Vine Linux