nas-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279
  1. Name: nas
  2. Summary: The Network Audio System (NAS)
  3. Summary(ja): ネットワークオーディオシステム (NAS)
  4. Version: 1.9.3
  5. Release: 2%{?_dist_release}
  6. URL: http://radscan.com/nas.html
  7. License: Public Domain
  8. Group: Development/Libraries
  9. Source0: http://nas.codebrilliance.com/nas/nas-%{version}.src.tar.gz
  10. Source1: http://apt.kde-redhat.org/apt/kde-redhat/SOURCES/nas/nasd.init
  11. Source2: http://apt.kde-redhat.org/apt/kde-redhat/SOURCES/nas/nasd.sysconfig
  12. Patch0: %{name}-1.9.3-Move-AuErrorDB-to-SHAREDIR.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: bison flex
  15. BuildRequires: imake
  16. BuildRequires: libX11-devel libXau-devel libXaw-devel libXext-devel
  17. BuildRequires: libXpm-devel libXp-devel libXt-devel
  18. %define libdir_x11 %{_libdir}/X11
  19. Requires(preun): chkconfig /sbin/service
  20. Requires(post): chkconfig
  21. Requires: %{name}-libs = %{version}-%{release}
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %package devel
  25. Summary: Development and doc files for the NAS
  26. Summary(ja): NAS 用開発ファイルとドキュメント
  27. Group: Development/Libraries
  28. Requires: %{name}-libs = %{version}-%{release}
  29. %description devel
  30. Development files and the documentation
  31. %description devel -l ja
  32. NAS 用開発ファイルとドキュメント
  33. %package libs
  34. Summary: Runtime libraries for NAS
  35. Group: System Environment/Libraries
  36. %description libs
  37. %{summary}.
  38. %description
  39. In a nutshell, NAS is the audio equivalent of an X display server.
  40. The Network Audio System (NAS) was developed by NCD for playing,
  41. recording, and manipulating audio data over a network. Like the
  42. X Window System, it uses the client/server model to separate
  43. applications from the specific drivers that control audio input
  44. and output devices.
  45. Key features of the Network Audio System include:
  46. o Device-independent audio over the network
  47. o Lots of audio file and data formats
  48. o Can store sounds in server for rapid replay
  49. o Extensive mixing, separating, and manipulation of audio data
  50. o Simultaneous use of audio devices by multiple applications
  51. o Use by a growing number of ISVs
  52. o Small size
  53. o Free! No obnoxious licensing terms
  54. %description -l ja
  55. 簡単にいうと、NAS は X ディスプレイサーバのオーディオ版です。
  56. NCD (Network Computing Devices) 社で開発されたネットワークオーディオシステム
  57. (NAS) は、ネットワーク越しにオーディオデータを再生・録音・操作するための
  58. ものです。X Window System と同様にクライアント/サーバモデルを採用し、
  59. アプリケーションをオーディオ入出力デバイスおよび特定のドライバから切り離す
  60. 設計になっています。
  61. NAS の特徴は以下の通りです:
  62. o デバイスに依存しない、ネットワーク越しのオーディオ
  63. o 多数のオーディオファイルやデータフォーマットに対応
  64. o サーバ上にサウンドを保持、すばやくリプレイが可能
  65. o オーディオデータのミキシング、セパレーション、操作が可能
  66. o 複数のアプリケーションからのオーディオデバイス同時利用が可能
  67. o 多数のソフトウェアメーカーによる利用実績
  68. o コンパクトで小さなサイズ
  69. o フリーです!面倒なライセンス条件はありません
  70. %prep
  71. %setup -q
  72. %patch0 -p1 -b .move_AuErrorDB
  73. iconv --from-code=ISO_8859-15 --to-code=UTF-8 HISTORY >HISTORY.tmp
  74. mv HISTORY.tmp HISTORY
  75. %build
  76. xmkmf
  77. find . -name Makefile \
  78. | xargs sed -i -e 's/^\(\s*CDEBUGFLAGS\s*=.*\)/\1 $(RPM_OPT_FLAGS)/'
  79. make %{?_smp_mflags} World MFLAGS="IRULESRC=%{_datadir}/X11/config"
  80. %install
  81. rm -rf %{buildroot}
  82. make MFLAGS="IRULESRC=%{_datadir}/X11/config" \
  83. DESTDIR=%{buildroot} BINDIR=%{_bindir} INCROOT=%{_includedir} \
  84. LIBDIR=%{libdir_x11} SHLIBDIR=%{_libdir} USRLIBDIR=%{_libdir} MANPATH=%{_mandir} \
  85. INSTALLFLAGS='-p' \
  86. install install.man
  87. install -p -m755 -D %{SOURCE1} %{buildroot}%{_initrddir}/nasd
  88. install -p -m644 -D %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/nasd
  89. # remove static lib
  90. rm -f %{buildroot}%{_libdir}/*.a
  91. # rename cofigfile
  92. mv %{buildroot}/etc/nas/nasd.conf.eg %{buildroot}/etc/nas/nasd.conf
  93. %post
  94. /sbin/chkconfig --add nasd
  95. %preun
  96. if [ $1 = 0 ] ; then
  97. /sbin/chkconfig --del nasd
  98. /sbin/service nasd stop >/dev/null 2>&1 ||:
  99. fi
  100. %post libs -p /sbin/ldconfig
  101. %postun libs -p /sbin/ldconfig
  102. %clean
  103. rm -rf %{buildroot}
  104. %files
  105. %defattr(-,root,root,-)
  106. %dir %{_sysconfdir}/nas
  107. %config(noreplace) %{_sysconfdir}/nas/nasd.conf
  108. %config(noreplace) %{_sysconfdir}/sysconfig/nasd
  109. %{_initrddir}/nasd
  110. %{_bindir}/*
  111. %{_mandir}/man1/*
  112. %{_mandir}/man5/*
  113. %files libs
  114. %defattr(-,root,root,-)
  115. %doc README FAQ HISTORY TODO
  116. %{_libdir}/libaudio.so.*
  117. %{_datadir}/X11/AuErrorDB
  118. %files devel
  119. %defattr(-,root,root,-)
  120. %{_includedir}/audio/
  121. %{_libdir}/libaudio.so
  122. %{_mandir}/man3/*
  123. %changelog
  124. * Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.3-2
  125. - add Japanese summary and description
  126. * Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.3-1
  127. - new upstream release
  128. - add Patch0 (move AuErrorDB to sharedir)
  129. * Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.9.1-7
  130. - Initial build for Vine Linux
  131. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-6
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  133. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-5
  134. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  135. * Mon Apr 07 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.9.1-4
  136. - -libs subpkg (f9+, #438547)
  137. - %%install: INSTALLFLAGS='-p' (preserve timestamps)
  138. - fixup %%changelog whitespace
  139. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.9.1-3
  140. - Autorebuild for GCC 4.3
  141. * Sun Nov 11 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9.1-2
  142. - fix spec file
  143. * Sun Nov 11 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9.1-1
  144. - update to 1.9.1
  145. - remove unneeded patches
  146. * Fri Nov 02 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9a-3
  147. - add better patch for #247468
  148. * Fri Nov 02 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9a-2
  149. - add patch to fix #247468
  150. * Sun Oct 28 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9a-1
  151. - update to 1.9a to fix #245712
  152. * Sat Aug 18 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9-4
  153. - fix for bug #245712
  154. * Sat Aug 11 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9-3
  155. - fix for bug #250453
  156. * Fri May 04 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9-2%{?dist}
  157. - rebuild for the new ppc64 arch
  158. * Sun Apr 08 2007 Frank Büttner <frank-buettner@gmx.net> - 1.9-1%{?dist}
  159. - update to 1.9
  160. - remove old patch file
  161. * Mon Mar 26 2007 Frank Büttner <frank-buettner@gmx.net> - 1.8b-1%{?dist}
  162. - update to 1.8b
  163. * Thu Mar 22 2007 Frank Büttner <frank-buettner@gmx.net> - 1.8a-2%{?dist}
  164. - use the SVN version of 1.8a
  165. * Wed Mar 21 2007 Frank Büttner <frank-buettner@gmx.net> - 1.8a-1%{?dist}
  166. - fix bug 233353
  167. * Thu Feb 09 2007 Frank Büttner <frank-buettner@gmx.net> - 1.8-13%{?dist}
  168. - use the corrected patch
  169. * Thu Feb 08 2007 Frank Büttner <frank-buettner@gmx.net> - 1.8-11%{?dist}
  170. - fix bug 227759
  171. * Tue Sep 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 1.8-10
  172. - don't rely-on/use potentially broken %%_libdir/X11 symlink (#207180)
  173. * Mon Sep 11 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-9%{?dist}
  174. - second rebuild for FC6
  175. * Mon Jul 24 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-8%{?dist}
  176. - fix ugly output when starting the daemon
  177. * Fri Jul 21 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-7%{?dist}
  178. - disable build for EMT64 on FC4
  179. * Thu Jul 13 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-6%{?dist}
  180. - fix build on EMT64
  181. * Wed Jul 12 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-5%{?dist}
  182. - fix include dir
  183. * Fri Jul 7 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-4%{?dist}
  184. - add Requires(preun): chkconfig /sbin/service
  185. - add Requires(post): chkconfig
  186. - add remarks for FC4
  187. * Fri Jul 7 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-3%{?dist}
  188. - move man3 to devel
  189. - rename nasd.conf.eg to .conf
  190. - add build depend for libXext-devel libXt-devel
  191. - change license to Public Domain
  192. - add path to make intall
  193. - add rc.d/sysconfig files
  194. * Fri Jul 7 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-2%{?dist}
  195. - move libaudio.so.2 to main package
  196. - switch package name from NAS to nas
  197. - fix depend for devel package
  198. - fix version
  199. - add nas subdir in etc to main package
  200. - set license to Distributable
  201. - add readme file
  202. * Fri Jul 7 2006 Frank Büttner <frank-buettner@gmx.net> - 1.8-1%{?dist}
  203. - start