newt-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Summary: A development library for text mode user interfaces.
  4. Summary(ja): テキストモードインターフェースのための開発ライブラリ
  5. Name: newt
  6. Version: 0.52.14
  7. Release: 1%{?_dist_release}
  8. License: LGPL
  9. Group: System Environment/Libraries
  10. URL: https://fedorahosted.org/newt/
  11. Source: https://fedorahosted.org/releases/n/e/newt/newt-%{version}.tar.gz
  12. # patches from mdv
  13. Patch1: newt-0.51.4-fix-wstrlen-for-non-utf8-strings.patch
  14. # patches from ubuntu
  15. Patch10: 400_python_memory_allocation.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: python-devel, popt-devel, slang-devel
  18. Provides: snack = %{version}-%{release}
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: daisuke
  22. %description
  23. Newt is a programming library for color text mode, widget based user
  24. interfaces. Newt can be used to add stacked windows, entry widgets,
  25. checkboxes, radio buttons, labels, plain text fields, scrollbars,
  26. etc., to text mode user interfaces. This package also contains the
  27. shared library needed by programs built with newt, as well as a
  28. /usr/bin/dialog replacement called whiptail. Newt is based on the
  29. slang library.
  30. %package devel
  31. Summary: Newt windowing toolkit development files.
  32. Summary(ja): Newt ウィンドウツールキット開発ファイル集
  33. Requires: slang-devel %{name} = %{version}
  34. Group: Development/Libraries
  35. %description devel
  36. The newt-devel package contains the header files and libraries
  37. necessary for developing applications which use newt. Newt is a
  38. development library for text mode user interfaces. Newt is based on
  39. the slang library.
  40. Install newt-devel if you want to develop applications which will use
  41. newt.
  42. ## to build compat32 for x86_64 architecture support
  43. %package -n compat32-%{name}
  44. Summary: A development library for text mode user interfaces.
  45. Group: System Environment/Libraries
  46. %description -n compat32-%{name}
  47. Newt is a programming library for color text mode, widget based user
  48. interfaces. Newt can be used to add stacked windows, entry widgets,
  49. checkboxes, radio buttons, labels, plain text fields, scrollbars,
  50. etc., to text mode user interfaces. This package also contains the
  51. shared library needed by programs built with newt, as well as a
  52. /usr/bin/dialog replacement called whiptail. Newt is based on the
  53. slang library.
  54. %package -n compat32-%{name}-devel
  55. Summary: Newt windowing toolkit development files.
  56. Group: Development/Libraries
  57. Requires: compat32-%{name} = %{version}
  58. %description -n compat32-%{name}-devel
  59. The newt-devel package contains the header files and libraries
  60. necessary for developing applications which use newt. Newt is a
  61. development library for text mode user interfaces. Newt is based on
  62. the slang library.
  63. Install newt-devel if you want to develop applications which will use
  64. newt.
  65. %prep
  66. %setup -q -n %{name}-%{version}
  67. %patch1 -p1 -b .fix-wstrlen-for-non-utf8-strings
  68. %patch10 -p1 -b .python_memory_allocation
  69. %build
  70. %if %{build_compat32}
  71. export CC='gcc -m32'
  72. %configure --without-tcl
  73. make CC='gcc -m32'
  74. #make CC='gcc -m32' shared
  75. %else
  76. %configure --without-tcl
  77. make
  78. make shared
  79. %endif
  80. chmod 0644 peanuts.py popcorn.py
  81. %install
  82. rm -rf $RPM_BUILD_ROOT
  83. make instroot=$RPM_BUILD_ROOT install
  84. %find_lang %{name}
  85. %post -p /sbin/ldconfig
  86. %postun -p /sbin/ldconfig
  87. %if %{build_compat32}
  88. %post -n compat32-%{name} -p /sbin/ldconfig
  89. %postun -n compat32-%{name} -p /sbin/ldconfig
  90. %endif
  91. %clean
  92. rm -rf $RPM_BUILD_ROOT
  93. %files -f %{name}.lang
  94. %defattr (-,root,root)
  95. %doc CHANGES COPYING
  96. %{_libdir}/libnewt.so.*
  97. %{_bindir}/whiptail
  98. %{python_sitearch}/*.py*
  99. %{python_sitearch}/*.so
  100. %{_mandir}/man1/whiptail.1*
  101. %files devel
  102. %defattr (-,root,root)
  103. %doc tutorial.sgml peanuts.py popcorn.py
  104. %{_includedir}/newt.h
  105. %{_libdir}/libnewt.a
  106. %{_libdir}/libnewt.so
  107. %{_libdir}/pkgconfig/libnewt.pc
  108. %if %{build_compat32}
  109. %files -n compat32-%{name}
  110. %defattr (-,root,root)
  111. %{_libdir}/libnewt.so.*
  112. %files -n compat32-%{name}-devel
  113. %defattr (-,root,root)
  114. %{_libdir}/libnewt.a
  115. %{_libdir}/libnewt.so
  116. %endif
  117. %changelog
  118. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.52.14-1
  119. - new upstram release
  120. * Thu Oct 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.13-1
  121. - new upstram release
  122. * Sat Jun 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.12-2
  123. - add patch2,3 from mdv
  124. - add patch10 from ubuntu
  125. * Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.12-1
  126. - update to 0.52.12
  127. - add patch0: don't hang in form when stdin disappears
  128. - remove patch100, fixed in upstream
  129. * Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.52.10-7
  130. - rebuilt with recent environment.
  131. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-6
  132. - rebuilt with gcc-4.4.3-3 on ppc
  133. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.52.10-5
  134. - rebuilt with rpm-4.8.0-3 (on ppc)
  135. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.52.10-4
  136. - rebuilt with python-2.6.4
  137. * Thu Oct 8 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-3
  138. - fix build_compat32 if-endif
  139. * Sat Sep 26 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.52.10-2
  140. - add patch100 for fix CVE-2009-2905 (textbox BoF) from fc10
  141. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52.10-1
  142. - new upstream release
  143. - use %%python_sitearch macro
  144. - remove --with-gpm-support
  145. - drop obsolete patches
  146. * Sun Aug 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.35-0vl6
  147. - rebuild to fix dependency problem on x86_64 architecture
  148. * Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl5
  149. - added BuildRequires: slang-devel
  150. - added newt-0.50.35-Makefile.in.patch
  151. - updated newt-0.50.35-make.patch
  152. - changed /usr/lib to %%{_libdir}
  153. - added compat32-* packages for x86_64 architecture support
  154. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl4
  155. - rebuild with python-2.4.1-0vl1
  156. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl3
  157. - rebuild with python-2.3.3-0vl1
  158. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 0.50.35-0vl2.1
  159. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  160. * Wed Jan 29 2003 Tomoya TAKA <taka@vinelinux.org> 0.50.35-0vl2
  161. - build against python-2.2
  162. - drop Patch20
  163. * Thu Oct 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.35-0vl1
  164. - updated to new upstream release 0.50.35
  165. - updated Patch11 and added Patch20
  166. (Patch20 is for python 1.5: REMOVE IT WHEN WE DECIDED TO GO WITH PYTHON2)
  167. * Sat Mar 09 2002 Tomoya TAKA <taka@vinelinux.org> 0.50.33-0vl1
  168. - update to new upstream release
  169. * Mon Jul 2 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp>
  170. - 0.50.22-0vl1
  171. - updated to 0.50.22
  172. - use Release No for Vine Linux
  173. - use better macros
  174. - bytecompile the snack python module
  175. * Wed Sep 29 1999 Norihito Ohmori <ohmori@flatout.rog>
  176. - fix spec file
  177. * Sun Sep 11 1999 Norihito Ohmori <ohmori@flatout.org>
  178. - added Japanese support patch
  179. * Wed Sep 01 1999 Erik Troan <ewt@redhat.com>
  180. - added suspend/resume to snack
  181. * Tue Aug 31 1999 Matt Wilson <msw@redhat.com>
  182. - enable gpm support
  183. * Fri Aug 27 1999 Matt Wilson <msw@redhat.com>
  184. - added hotkey assignment for gridforms, changed listbox.setcurrent to
  185. take the item key
  186. * Wed Aug 25 1999 Matt Wilson <msw@redhat.com>
  187. - fixed snack callback function refcounts, as well as optional data args
  188. - fixed suspend callback ref counts
  189. * Mon Aug 23 1999 Matt Wilson <msw@redhat.com>
  190. - added buttons argument to entrywindow
  191. * Thu Aug 12 1999 Bill Nottingham <notting@redhat.com>
  192. - multi-state checkboxtrees. Woohoo.
  193. * Mon Aug 9 1999 Matt Wilson <msw@redhat.com>
  194. - added snack wrappings for checkbox flag setting
  195. * Thu Aug 5 1999 Matt Wilson <msw@redhat.com>
  196. - added snack bindings for setting current listbox selection
  197. - added argument to set default selection in snack ListboxChoiceWindow
  198. * Mon Aug 2 1999 Matt Wilson <msw@redhat.com>
  199. - added checkboxtree
  200. - improved snack binding
  201. * Fri Apr 9 1999 Matt Wilson <msw@redhat.com>
  202. - fixed a glibc related bug in reflow that was truncating all text to 1000
  203. chars
  204. * Fri Apr 09 1999 Matt Wilson <msw@redhat.com>
  205. - fixed bug that made newt apps crash when you hit <insert> followed by lots
  206. of keys
  207. * Mon Mar 15 1999 Matt Wilson <msw@redhat.com>
  208. - fix from Jakub Jelinek for listbox keypresses
  209. * Fri Feb 27 1999 Matt Wilson <msw@redhat.com>
  210. - fixed support for navigating listboxes with alphabetical keypresses
  211. * Thu Feb 25 1999 Matt Wilson <msw@redhat.com>
  212. - updated descriptions
  213. - added support for navigating listboxes with alphabetical keypresses
  214. * Mon Feb 8 1999 Matt Wilson <msw@redhat.com>
  215. - made grid wrapped windows at least the size of their title bars
  216. * Fri Feb 5 1999 Matt Wilson <msw@redhat.com>
  217. - Function to set checkbox flags. This will go away later when I have
  218. a generic flag setting function and signals to comps to go insensitive.
  219. * Tue Jan 19 1999 Matt Wilson <msw@redhat.com>
  220. - Stopped using libgpm, internalized all gpm calls. Still need some cleanups.
  221. * Thu Jan 7 1999 Matt Wilson <msw@redhat.com>
  222. - Added GPM mouse support
  223. - Moved to autoconf to allow compiling without GPM support
  224. - Changed revision to 0.40
  225. * Wed Oct 21 1998 Bill Nottingham <notting@redhat.com>
  226. - built against slang-1.2.2
  227. * Wed Aug 19 1998 Bill Nottingham <notting@redhat.com>
  228. - bugfixes for text reflow
  229. - added docs
  230. * Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
  231. - devel package moved to Development/Libraries
  232. * Thu Apr 30 1998 Erik Troan <ewt@redhat.com>
  233. - removed whiptcl.so -- it should be in a separate package
  234. * Mon Feb 16 1998 Erik Troan <ewt@redhat.com>
  235. - added newtWinMenu()
  236. - many bug fixes in grid code
  237. * Wed Jan 21 1998 Erik Troan <ewt@redhat.com>
  238. - removed newtWinTernary()
  239. - made newtWinChoice() return codes consistent with newtWinTernary()
  240. * Fri Jan 16 1998 Erik Troan <ewt@redhat.com>
  241. - added changes from Bruce Perens
  242. - small cleanups
  243. - lets whiptail automatically resize windows
  244. - the order of placing a grid and adding components to a form no longer
  245. matters
  246. - added newtGridAddComponentsToForm()
  247. * Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
  248. - added newtWinTernary()
  249. * Tue Oct 07 1997 Erik Troan <ewt@redhat.com>
  250. - made Make/spec files use a buildroot
  251. - added grid support (for newt 0.11 actually)
  252. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  253. - Added patched from Clarence Smith for setting the size of a listbox
  254. - Version 0.9
  255. * Tue May 28 1997 Elliot Lee <sopwith@redhat.com> 0.8-2
  256. - Touchups on Makefile
  257. - Cleaned up NEWT_FLAGS_*
  258. * Tue Mar 18 1997 Erik Troan <ewt@redhat.com>
  259. - Cleaned up listbox
  260. - Added whiptail
  261. - Added newtButtonCompact button type and associated colors
  262. - Added newtTextboxGetNumLines() and newtTextboxSetHeight()
  263. * Tue Feb 25 1997 Erik Troan <ewt@redhat.com>
  264. - Added changes from sopwith for C++ cleanliness and some listbox fixes.