obexftp-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276
  1. %define python_sitelib %(%{__python} -c "from distutils import sysconfig; print sysconfig.get_python_lib()")
  2. %define python_sitearch %(%{__python} -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')
  3. %define ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')
  4. Name: obexftp
  5. Summary: Tool to access devices via the OBEX protocol
  6. Summary(ja): OBEX プロトコルを使用する機器のためのツールです
  7. Group: Applications/System
  8. Version: 0.23
  9. Release: 1%{?_dist_release}
  10. License: GPLv2+
  11. URL: http://openobex.triq.net/
  12. Source: http://triq.net/obexftp/%{name}-%{version}.tar.bz2
  13. Patch0: obexftp-norpath.patch
  14. Patch1: obexftp-perl.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: bluez-libs-devel
  17. BuildRequires: gettext
  18. BuildRequires: libtool
  19. BuildRequires: openobex-devel >= 1.2
  20. ## BuildRequires: perl-ExtUtils-CBuilder
  21. BuildRequires: perl(ExtUtils::MakeMaker)
  22. BuildRequires: python-devel
  23. BuildRequires: ruby
  24. BuildRequires: ruby-devel
  25. BuildRequires: tcl
  26. #----------------------------------------------------------------------------
  27. %description
  28. The overall goal of this project is to make mobile devices featuring
  29. the OBEX protocol and adhering to the OBEX FTP standard accessible
  30. by an open source implementation.
  31. The common usage for ObexFTP is to access your mobile phones memory to
  32. store and retrieve e.g. your phonebook, logos, ringtones, music,
  33. pictures and alike.
  34. %description -l ja
  35. このプロジェクトは OBEXプロトコルおよび、標準的で便利なOBEX-FTPを
  36. フィーチャーしたモバイルデバイスを、オープンソースで実装する事を
  37. 全体的な目標としています。
  38. ObexFTPの共通の使い方
  39. お使いの携帯電話にアクセスし、メモリへ保存したり取り外したりする、
  40. 例えば、お客様の電話帳、ロゴ、着メロ、音楽、写真等も同様に扱えます。
  41. #----------------------------------------------------------------------------
  42. %package -n python-%{name}
  43. Summary: Python library to access devices via the OBEX protocol
  44. Summary(ja): OBEX プロトコルを使って機器を扱うPythonライブラリです
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. %description -n python-%{name}
  48. The overall goal of this project is to make mobile devices featuring
  49. the OBEX protocol and adhering to the OBEX FTP standard accessible
  50. by an open source implementation.
  51. The common usage for ObexFTP is to access your mobile phones memory to
  52. store and retrieve e.g. your phonebook, logos, ringtones, music,
  53. pictures and alike.
  54. %description -n python-%{name} -l ja
  55. このプロジェクトは OBEXプロトコルおよび、標準的で便利なOBEX-FTPを
  56. フィーチャーしたモバイルデバイスを、オープンソースで実装する事を
  57. 全体的な目標としています。
  58. ObexFTPの共通の使い方
  59. お使いの携帯電話にアクセスし、メモリへ保存したり取り外したりする、
  60. 例えば、お客様の電話帳、ロゴ、着メロ、音楽、写真等も同様に扱えます。
  61. (このパッケージはpython向けライブラリです)
  62. #----------------------------------------------------------------------------
  63. %package -n perl-%{name}
  64. Summary: Perl library to access devices via the OBEX protocol
  65. Summary(ja): OBEX プロトコルを使って機器を扱うPerlライブラリです
  66. Group: Development/Libraries
  67. Requires: %{name} = %{version}-%{release}
  68. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  69. %description -n perl-%{name}
  70. The overall goal of this project is to make mobile devices featuring
  71. the OBEX protocol and adhering to the OBEX FTP standard accessible
  72. by an open source implementation.
  73. The common usage for ObexFTP is to access your mobile phones memory to
  74. store and retrieve e.g. your phonebook, logos, ringtones, music,
  75. pictures and alike.
  76. %description -n perl-%{name} -l ja
  77. このプロジェクトは OBEXプロトコルおよび、標準的で便利なOBEX-FTPを
  78. フィーチャーしたモバイルデバイスを、オープンソースで実装する事を
  79. 全体的な目標としています。
  80. ObexFTPの共通の使い方
  81. お使いの携帯電話にアクセスし、メモリへ保存したり取り外したりする、
  82. 例えば、お客様の電話帳、ロゴ、着メロ、音楽、写真等も同様に扱えます。
  83. (このパッケージはperl向けライブラリです)
  84. #----------------------------------------------------------------------------
  85. %package -n ruby-%{name}
  86. Summary: Ruby library to access devices via the OBEX protocol
  87. Summary(ja): OBEX プロトコルを使って機器を扱うRubyライブラリです
  88. Group: Development/Libraries
  89. BuildRequires: ruby
  90. BuildRequires: ruby-devel
  91. Requires: %{name} = %{version}-%{release}
  92. %description -n ruby-%{name}
  93. The overall goal of this project is to make mobile devices featuring
  94. the OBEX protocol and adhering to the OBEX FTP standard accessible
  95. by an open source implementation.
  96. The common usage for ObexFTP is to access your mobile phones memory to
  97. store and retrieve e.g. your phonebook, logos, ringtones, music,
  98. pictures and alike.
  99. %description -n ruby-%{name} -l ja
  100. このプロジェクトは OBEXプロトコルおよび、標準的で便利なOBEX-FTPを
  101. フィーチャーしたモバイルデバイスを、オープンソースで実装する事を
  102. 全体的な目標としています。
  103. ObexFTPの共通の使い方
  104. お使いの携帯電話にアクセスし、メモリへ保存したり取り外したりする、
  105. 例えば、お客様の電話帳、ロゴ、着メロ、音楽、写真等も同様に扱えます。
  106. (このパッケージはruby向けライブラリです)
  107. #----------------------------------------------------------------------------
  108. %package devel
  109. Summary: Header files and libraries for %{name}
  110. Summary(ja): OBEX-FTP の開発用ヘッダーファイル等のパッケージです
  111. Group: Development/Libraries
  112. Requires: %{name} = %{version}-%{release}
  113. Requires: openobex-devel >= 1.2
  114. Requires: pkgconfig
  115. %description devel
  116. This package contains the header files, static libraries and development
  117. documentation for %{name}. If you like to develop programs using %{name},
  118. you will need to install %{name}-devel.
  119. %description devel -l ja
  120. このパッケージには OBEX-FTPのヘッダファイル、静的ライブラリおよび開発者用の
  121. ドキュメントが含まれています。
  122. あなたがOBEX-FTPを使用してプログラムを開発する場合は、この obexftp-develを
  123. インストールする必要があります。
  124. #----------------------------------------------------------------------------
  125. %prep
  126. %setup -q
  127. %patch0 -p1 -b .norpath
  128. %patch1 -p1 -b .p
  129. %build
  130. autoreconf -f -i
  131. %configure --disable-static --disable-dependency-tracking --disable-rpath
  132. %{__make} %{?_smp_mflags}
  133. %install
  134. rm -rf $RPM_BUILD_ROOT
  135. make DESTDIR=$RPM_BUILD_ROOT RUBYARCHDIR=$RPM_BUILD_ROOT%{rarchdir} install
  136. chmod 755 $RPM_BUILD_ROOT%{perl_vendorarch}/*/OBEXFTP/OBEXFTP.so
  137. # chmod 755 %{buildroot}%{perl_sitearch}/*/OBEXFTP/OBEXFTP.so
  138. rm $RPM_BUILD_ROOT%{_libdir}/*.la
  139. rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
  140. rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/*/OBEXFTP/{.packlist,OBEXFTP.bs}
  141. # %{__rm} -f %{buildroot}%{perl_sitearch}/*/OBEXFTP/{.packlist,OBEXFTP.bs}
  142. %clean
  143. rm -rf $RPM_BUILD_ROOT
  144. %post -p /sbin/ldconfig
  145. %postun -p /sbin/ldconfig
  146. %files
  147. %defattr(-, root, root, -)
  148. %doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
  149. %{_mandir}/man1/obexftp.1*
  150. %{_mandir}/man1/obexftpd.1*
  151. %{_bindir}/obexftp
  152. %{_bindir}/obexftpd
  153. %{_libdir}/*.so.*
  154. %files devel
  155. %defattr(-, root, root, -)
  156. %{_includedir}/bfb/
  157. %{_includedir}/multicobex/
  158. %{_includedir}/obexftp/
  159. %{_libdir}/*.so
  160. %{_libdir}/pkgconfig/obexftp.pc
  161. %files -n python-%{name}
  162. %defattr(-, root, root, -)
  163. # %dir %{python_vendorarch}/obexftp
  164. # %{python_vendorarch}/obexftp/_obexftp.so*
  165. # %{python_vendorarch}/obexftp/__init__.py*
  166. %dir %{python_sitearch}/obexftp
  167. %{python_sitearch}/obexftp/_obexftp.so*
  168. %{python_sitearch}/obexftp/__init__.py*
  169. %files -n perl-%{name}
  170. %defattr(-, root, root, -)
  171. %{perl_vendorarch}/OBEXFTP.pm
  172. %dir %{perl_vendorarch}/*/OBEXFTP
  173. %{perl_vendorarch}/*/OBEXFTP/OBEXFTP.so
  174. # %{perl_sitearch}/OBEXFTP.pm
  175. # %dir %{perl_sitearch}/*/OBEXFTP
  176. # %{perl_sitearch}/*/OBEXFTP/OBEXFTP.so
  177. %files -n ruby-%{name}
  178. %defattr(-, root, root, -)
  179. %{rarchdir}/obexftp.so
  180. #{ruby_sitearch}/obexftp.so
  181. #----------------------------------------------------------------------------
  182. # Maintainers: babasaki@mindgear.org
  183. #
  184. #----------------------------------------------------------------------------
  185. %changelog
  186. * Sat Dec 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.23-1
  187. - new upstream release
  188. - removed Requires: ruby(abi) (= 1.8) <BTS:799>
  189. * Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.22-4
  190. - rebuild (ruby-obexftp subpackage not uploaded on i386/x86_64 yet)
  191. * Fri Oct 24 2008 Seiichirou Babasaki 0.22-3
  192. - change %{perl_sitearch} -> %{perl_vendorarch}
  193. - added "# Maintainers: " comments.
  194. - changed UTF-8 encode at obexftp.vs.spec
  195. - Updated specfile
  196. * Wed Oct 2 2008 Seiichirou Babasaki 0.22-2
  197. - change %{perl_vendorarch} -> %{perl_sitearch}
  198. - Updated specfile
  199. * Wed Jan 16 2008 Seiichirou Babasaki 0.20-0.5_2-1
  200. - Import obexftp - Packager: Babasaki
  201. - Updated specfile
  202. #----------------------------------------------------------------------------
  203. * Thu Sep 06 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.5.rc7
  204. - updated to 0.22-rc7
  205. - added pkgconfig file
  206. - make perl BR more specific
  207. * Mon Aug 27 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.4.rc6
  208. - rebuilt for BuildID
  209. - updated license tag
  210. * Mon Aug 06 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.3.rc6
  211. - updated to 0.22-rc6
  212. - added ruby bindings (patch by Andy Shevchenko)
  213. - dropped upstreamed patch
  214. - added missing BRs for F7+
  215. * Mon Mar 26 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.2.pre4
  216. - fix segfault in obexftpd (patch by Jan Kratochvil), closes (#230991)
  217. * Fri Mar 23 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.1.pre4
  218. - updated to 0.22-pre4
  219. - updated patches
  220. * Fri Jan 26 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.20-3
  221. - add missing disttag
  222. * Thu Jan 25 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.20-2
  223. - added missing defattr
  224. - require openobex-devel > 1.2
  225. - added missing MODULE_COMPAT Requires: to perl subpackage
  226. - renamed subpackages to perl/python-obexftp
  227. - fixed rpaths
  228. * Mon Jan 01 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.20-1
  229. - updated to 0.20
  230. * Sun Jan 29 2006 Dag Wieers <dag@wieers.com> - 0.18-1
  231. - Initial package. (using DAR)