ocaml-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330
  1. Name: ocaml
  2. Summary: The Objective Caml compiler and programming environment
  3. Summary(ja): Objective Caml コンパイラとプログラミング環境
  4. Version: 3.12.1
  5. Release: 1%{?_dist_release}
  6. Source0: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-%{version}.tar.bz2
  7. Source1: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.12-refman.html.tar.gz
  8. Source2: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.12-refman.ps.gz
  9. Source3: http://caml.inria.fr/distrib/ocaml-3.10/ocaml-3.12-refman.info.tar.gz
  10. Source4: ocaml-info-entry
  11. # Vine Source(s)
  12. Source10: caml-mode-install.sh
  13. Source11: caml-mode-remove.sh
  14. License: QPL/LGPL
  15. Group: Development/Languages
  16. URL: http://caml.inria.fr/
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: ncurses-devel gdbm-devel emacsen
  19. BuildRequires: libX11-devel
  20. BuildRequires: tk tcl expect thread
  21. Provides: ocaml(runtime) = %{version}
  22. Requires(post): install-info
  23. Requires(preun): install-info
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. Packager: inagaki, kenta
  27. %define debug_package %{nil}
  28. %global __ocaml_requires_opts -c -f %{buildroot}%{_bindir}/ocamlobjinfo
  29. %global __ocaml_provides_opts -f %{buildroot}%{_bindir}/ocamlobjinfo
  30. %description
  31. Objective Caml is a high-level, strongly-typed, functional and
  32. object-oriented programming language from the ML family of languages.
  33. This package comprises two batch compilers (a fast bytecode compiler
  34. and an optimizing native-code compiler), an interactive toplevel system,
  35. parsing tools (Lex,Yacc,Camlp4), a replay debugger, a documentation generator,
  36. and a comprehensive library.
  37. %description -l ja
  38. Object Caml は ML 系言語の方言で、高水準で強い型付けを備えた関数型と
  39. オブジェクト指向を併せ持ったプログラミング言語です。
  40. このパッケージには、2 つのバッチコンパイラ (コンパイル速度が高速な
  41. バイトコードコンパイラと最適化を行なうネイティブコードコンパイラ)、
  42. トップレベル対話環境、構文解析ツール (Lex, Yac, Camlp4)、リプレイ
  43. デバッガ、ドキュメント生成ツール、そして広範囲に渡るライブラリが含まれて
  44. います。
  45. %package labltk
  46. Summary: Tk bindings for Objective Caml
  47. Summary(ja): Objective Caml の Tk バインディング
  48. Group: Development/Languages
  49. Requires: ocaml = %{version}-%{release}
  50. Requires: tk tcl
  51. Obsoletes: labltk <= %{version}
  52. %description labltk
  53. A library for interfacing Objective Caml with the scripting language
  54. Tcl/Tk. It include the OCamlBrowser code editor / library browser.
  55. %package camlp4
  56. Summary: Pre-Processor-Pretty-Printer for OCaml
  57. Group: Development/Languages
  58. Requires: ocaml = %{version}-%{release}
  59. Obsoletes: camlp4 <= %{version}
  60. %description camlp4
  61. Camlp4 is a Pre-Processor-Pretty-Printer for OCaml, parsing a source
  62. file and printing some result on standard output.
  63. %package mode
  64. Summary: Emacs mode for Objective Caml
  65. Summary(ja): Objective Caml の Emacs mode
  66. Group: Applications/Editors/Emacs
  67. Requires: ocaml = %{version}-%{release}
  68. Requires(post): emacs, emacsen-common
  69. Requires(preun): emacs, emacsen-common
  70. Obsoletes: ocaml-emacs <= %{version}
  71. %description mode
  72. Emacs mode for Objective Caml.
  73. %description -l ja mode
  74. Objective Caml 用の Emacs mode です.
  75. %prep
  76. %setup -q -T -b 0
  77. %setup -q -T -D -a 1
  78. %setup -q -T -D -a 3
  79. cp %{SOURCE2} refman.ps.gz
  80. cp %{SOURCE4} infoman/ocaml-info-entry
  81. %build
  82. ./configure -cc "%{__cc} %{optflags}" -with-pthread \
  83. -bindir %{_bindir} \
  84. -libdir %{_libdir}/ocaml \
  85. -mandir %{_mandir} \
  86. -prefix %{_prefix}
  87. make world opt opt.opt
  88. (cd infoman; gzip -cd ocaml.info.gz >> ocaml-info-entry; mv ocaml-info-entry ocaml.info; gzip -f ocaml.info)
  89. # for dumpobj, objinfo
  90. (cd tools; make dumpobj; make objinfo; cd ..)
  91. %install
  92. rm -rf $RPM_BUILD_ROOT
  93. make install BINDIR=$RPM_BUILD_ROOT%{_bindir} LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml MANDIR=$RPM_BUILD_ROOT%{_mandir}
  94. mv $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf.orig
  95. sed -e "s|^%{buildroot}||" $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf.orig > $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf
  96. rm -f $RPM_BUILD_ROOT%{_libdir}/ocaml/ld.conf.orig
  97. (mkdir -p $RPM_BUILD_ROOT%{_infodir}; cd infoman; cp ocaml*.gz $RPM_BUILD_ROOT%{_infodir})
  98. # for dumpobj, objinfo
  99. (cd tools; install dumpobj objinfo $RPM_BUILD_ROOT%{_bindir})
  100. # for Emacs Lisp
  101. make -C emacs install install-ocamltags BINDIR=$RPM_BUILD_ROOT%{_bindir} \
  102. EMACSDIR=$RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/caml-mode
  103. # emacsen-common-ize
  104. mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/emacsen-common/packages/install
  105. mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/emacsen-common/packages/remove
  106. %_installemacsenscript caml-mode %{SOURCE10}
  107. %_removeemacsenscript caml-mode %{SOURCE11}
  108. # Disable build root strip policy:
  109. # executables generated by ocamlc -custom MUST NOT BE STRIPPED
  110. # But now that we have dynamic loading of C code, none of the executables
  111. # in the distribution is generated by ocamlc -custom, so leave default.
  112. # %define __spec_install_post /usr/lib/rpm/brp-compress
  113. %clean
  114. rm -rf $RPM_BUILD_ROOT
  115. %post
  116. /sbin/install-info %{_infodir}/ocaml.info %{_infodir}/dir
  117. %post mode
  118. if [ "$1" = 2 ]; then
  119. %_emacsenPackageRemove caml-mode
  120. fi
  121. %_addemacsenlist caml-mode
  122. %_emacsenPackageInstall caml-mode
  123. %preun
  124. if [ $1 = 0 ]; then
  125. /sbin/install-info --delete %{_infodir}/ocaml.info %{_infodir}/dir
  126. fi
  127. %preun mode
  128. if [ "$1" = 0 ]; then
  129. %_emacsenPackageRemove caml-mode
  130. %_removeemacsenlist caml-mode
  131. fi
  132. %files
  133. %defattr(-, root, root)
  134. %doc README LICENSE refman.ps.gz htmlman
  135. %{_bindir}/*
  136. %{_mandir}/man1/*
  137. %{_mandir}/man3/*
  138. %{_libdir}/ocaml
  139. %{_infodir}/*
  140. ### in ocaml-camlp4
  141. %exclude %{_bindir}/camlp4*
  142. %exclude %{_bindir}/mkcamlp4
  143. %exclude %{_libdir}/ocaml/camlp4/
  144. ### in ocaml-labltk
  145. %exclude %{_bindir}/labltk
  146. %exclude %{_bindir}/ocamlbrowser
  147. %exclude %{_libdir}/ocaml/labltk/
  148. %exclude %{_libdir}/ocaml/stublibs/dlllabltk.so
  149. ### in ocaml-mode
  150. %exclude %{_bindir}/ocamltags
  151. %files camlp4
  152. %defattr(-, root, root, 0755)
  153. %{_bindir}/camlp4*
  154. %{_bindir}/mkcamlp4
  155. %dir %{_libdir}/ocaml/
  156. %{_libdir}/ocaml/camlp4/
  157. %files labltk
  158. %defattr(-, root, root, 0755)
  159. %doc otherlibs/labltk/examples_*tk
  160. %{_bindir}/labltk
  161. %{_bindir}/ocamlbrowser
  162. %dir %{_libdir}/ocaml/
  163. %dir %{_libdir}/ocaml/stublibs/
  164. %{_libdir}/ocaml/labltk/
  165. %{_libdir}/ocaml/stublibs/dlllabltk.so
  166. %files mode
  167. %defattr(-, root, root, 0755)
  168. %doc emacs/README
  169. %{_bindir}/ocamltags
  170. %dir %{_datadir}/emacs/
  171. %dir %{_datadir}/emacs/site-lisp/caml-mode
  172. %{_datadir}/emacs/site-lisp/caml-mode/*.el
  173. #{_datadir}/emacs/site-lisp/caml-mode/*.elc
  174. %{_prefix}/lib/emacsen-common/packages/install/caml-mode
  175. %{_prefix}/lib/emacsen-common/packages/remove/caml-mode
  176. %changelog
  177. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> 3.12.1-1
  178. - new upstream version 3.12.1
  179. - rebuild with rpm-4.9.1.2
  180. * Wed Apr 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.12.0-1
  181. - new upstream release
  182. * Fri Apr 16 2010 Shu KONNO <owa@bg.wakwak.com> 3.11.0-2
  183. - rebuilt with new tool chain
  184. * Sat May 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.11.0-1
  185. - new upstream release
  186. - spec in UTF-8
  187. * Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.2-1vl5
  188. - new upstream release for VineSeed
  189. * Sat Jul 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.2-1vl4
  190. - new upstream release
  191. * Wed Feb 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.1-0vl1
  192. - new upstream release
  193. * Sun Sep 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.0-0vl2
  194. - rebuilt with VineSeed
  195. * Sun Sep 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.10.0-0vl1
  196. - new upstream release
  197. * Tue Nov 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.3-0vl2
  198. - rebuilt for VinePlus/4.0
  199. * Mon Nov 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.3-0vl1
  200. - new upstream release
  201. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.09.2-0vl4
  202. - changed ocaml-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  203. * Wed Aug 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> - 3.09.2-0vl3
  204. - add BuildRequires: XOrg-devel, ncurses-devel, gdbm-devel, emacsen
  205. - use %%{_prefix}/lib instead of %%{_libdir} for elisp directory
  206. * Wed Jun 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.2-0vl2
  207. - rebuilt for VineSeed Plus
  208. * Wed Jun 7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.2-0vl1
  209. - new upstream release
  210. * Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl3
  211. - rebuilt for VineSeed Plus
  212. * Sat Feb 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl2
  213. - rebuilt for VinePlus/3.0
  214. - added BuildRequires: expect, thread
  215. * Sat Jan 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.1-0vl1
  216. - new upstream release
  217. * Sat Nov 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.0-0vl2
  218. - rebuild for VineSeed Plus
  219. * Thu Nov 3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.09.0-0vl1
  220. - new upstream release
  221. * Tue Oct 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl3
  222. - rebuild with VineSeed Plus
  223. * Mon Oct 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl2
  224. - rebuild with VinePlus/3.0
  225. - added dumpobj, objinfo
  226. * Sat Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.4-0vl1
  227. - new upstream release
  228. - split to caml4p, labltk, mode packages
  229. * Thu Mar 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.3-0vl1
  230. - new upstream release
  231. * Sat Dec 4 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.2-0vl1
  232. - new upstream release
  233. * Fri Oct 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.1-0vl1
  234. - new upstream release
  235. * Fri Aug 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.0-0vl4
  236. - fixed typo based on 3.08.0-0vl3
  237. * Thu Aug 12 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 3.08.0-0vl3
  238. - Modified typo: %%descriptin -l ja into %description -l ja
  239. * Tue Aug 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.08.0-0vl3
  240. - rebuild for VinePlus/3.0 and VineSeedPlus
  241. - updated Japanese description
  242. - merged VinePlus/2.6 spec file
  243. * Fri Jul 23 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 3.08.0-0vl2
  244. - Modified the character code of this file into euc-jp.
  245. * Tue Jul 21 2004 by IKEDA Katsumi <ikeda@rg8.so-net.ne.jp> 3.08.0-0vl1
  246. - new upstream release.
  247. - Modified Copyright.
  248. - Added Summary(ja), %%descriptin -l ja, Prereq and %%clean.
  249. - Added %%post and %%preun for running /sbin/install-info.
  250. * Wed Apr 7 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.07-2vl2
  251. - rebuild for VineSeed
  252. - s/Copyright/License/
  253. * Thu Feb 12 2004 by IKEDA Katsumi <ikedak@rg8.so-net.ne.jp>
  254. - 3.07-2vl1
  255. - Modified %Vendor and %BuildRoot.
  256. - Add %Distribution.