opensoap-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274
  1. # -*- mode: rpm-spec; -*-
  2. %define version_major 1.0
  3. %define version_relext 0.20031201
  4. %define version_package 1.0-20031201
  5. ## for apache2
  6. %define _with_cgi_bin /var/www/cgi-bin
  7. ## for apache1
  8. #define _with_cgi_bin /home/httpd/cgi-bin
  9. %define _sysconfdir /etc/opensoap
  10. %define _with_servicesdir /usr/lib/opensoap
  11. %define _localstatedir /var/opensoap
  12. # may need to be modified like /var/{log,spool,run}/opensoap
  13. Summary: SOAP-based middleware for XML Web Services applications.
  14. Summary(ja): XML Webサービスアプリケーション向けSOAPベースミドルウェア。
  15. Name: opensoap
  16. Version: 2.0.1
  17. Release: 0vl1
  18. Epoch: 1
  19. Group: System Environment/Libraries
  20. Source: http://www.opensoap.jp/download/%{name}-%{version}.tar.gz
  21. Patch0: opensoap-2.0.1-protected.patch
  22. License: BSD
  23. URL: http://www.opensoap.jp/
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. #Patch: %{name}-%{version_package}.patch
  26. BuildRequires: libxml2-devel openssl-devel apache2-devel
  27. Requires: libxml2 openssl
  28. %description
  29. OpenSOAP provides an environment for XML Web Services.
  30. API libraries to use SOAP (Simple Object Access Protocol) and the
  31. server for service applications are provided. Also Transaction and
  32. Security functions are implemented.
  33. This main package includes shared libraries for executing OpenSOAP
  34. application software, and such basic tools as Soaping client/service
  35. and Transaction service.
  36. %description -l ja
  37. OpenSOAPはXML Webサービスのための環境を提供します。SOAP (Simple Object
  38. Access Protocol)を利用するためのAPIライブラリと、サービスアプリケーショ
  39. ン運用のためのサーバを提供し、トランザクションやセキュリティの機能を持っ
  40. ています。
  41. この本体パッケージには、OpenSOAPアプリケーションソフト実行時に必要な
  42. 共有ライブラリ、及び、基本ツールであるSoapingクライアント/サービス、
  43. Transactionサービスが含まれます。
  44. %package devel
  45. Summary: Libraries, include files to develop OpenSOAP applications.
  46. Summary(ja): OpenSOAPアプリケーション開発のためのライブラリとヘッダファイル。
  47. Group: Development/Libraries
  48. Requires: %{name} = %{epoch}:%{version}-%{release}
  49. %description devel
  50. Libraries, include-header files and documentation which can be used to
  51. develop software based on SOAP for Web Services, and to compile the
  52. source code for OpenSOAP application programs.
  53. %description devel -l ja
  54. このライブラリとヘッダファイル、及びドキュメント類を利用することで、
  55. WebサービスのためのSOAP通信を利用するソフトウェアを開発したり、入手し
  56. たOpenSOAPアプリケーションのソースコードをコンパイル及びリンクすること
  57. が可能となります。
  58. %package server
  59. Summary: Server for the original OpenSOAP functions.
  60. Summary(ja): OpenSOAP独自の機能を実現するためのサーバ。
  61. Group: System Environment/Daemons
  62. Requires: %{name} = %{epoch}:%{version}-%{release}
  63. Provides: mod_opensoap = %{version}-%{release}
  64. %description server
  65. The OpenSOAP Server supports operations for Web Service systems and
  66. provides practical functions, such as asynchronous client connections
  67. for non-real time processing, message forwarding for searching valid
  68. services and passing through firewalls, and signing messages for
  69. security validation.
  70. %description server -l ja
  71. OpenSOAPサーバは、大規模なWebサービスシステムの運用をサポートします。
  72. サービスの非リアルタイム処理に対応する非同期クライアント接続機能、サービ
  73. スの探索やファイアウォール越えを実現するサーバ間メッセージ転送機能、メッ
  74. セージへの署名などを行うセキュリティ機能が含まれています。
  75. %package samples
  76. Summary: Sample application programs of OpenSOAP.
  77. Summary(ja): OpenSOAPのサンプルアプリケーションプログラム。
  78. Group: Applications/Networking
  79. Requires: %{name} = %{epoch}:%{version}-%{release}
  80. %description samples
  81. This is a collection of simple sample application programs using
  82. OpenSOAP. Please try them if you just want to use OpenSOAP. If you
  83. are interested in developing application programs, please also refer
  84. to the source codes.
  85. %description samples -l ja
  86. OpenSOAPアプリケーションの簡単なサンプルの寄せ集めです。
  87. OpenSOAPをとりあえず使ってみたい場合に、是非お試し下さい。アプリケーショ
  88. ンプログラム開発に興味のある方は、ソースコードもご覧下さい。
  89. %prep
  90. %setup -q
  91. %patch0 -p1 -b .protected
  92. %build
  93. %configure --sysconfdir=%{_sysconfdir} --with-servicesdir=%{_with_servicesdir} --with-cgi-bin=%{_with_cgi_bin} --localstatedir=%{_localstatedir} --with-ssl-include=/usr/include
  94. ## doc files to be copied
  95. cp -pr doc docs
  96. find docs -name 'Makefile*' -exec rm {} \;
  97. rm -rf docs/api/*/Doxyfile
  98. rm -rf docs/api/*/text/
  99. cp -pr samples docs/
  100. make
  101. %install
  102. rm -rf $RPM_BUILD_ROOT
  103. LIBRARY_PATH="$RPM_BUILD_ROOT"%{_libdir} make DESTDIR="$RPM_BUILD_ROOT" install
  104. # samples
  105. make DESTDIR="$RPM_BUILD_ROOT" install-samples
  106. # install SYSV init stuff
  107. mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
  108. install -m755 etc/init.d/opensoap.redhat \
  109. $RPM_BUILD_ROOT/etc/rc.d/init.d/opensoap
  110. %clean
  111. rm -rf $RPM_BUILD_ROOT
  112. %post server
  113. # Register the opensoap service
  114. /sbin/chkconfig --add opensoap
  115. %preun server
  116. if [ $1 = 0 ]; then
  117. # %{_sbindir}/opensoap-server-ctl stop || exit 0
  118. /sbin/service opensoap stop
  119. /sbin/chkconfig --del opensoap
  120. fi
  121. %post -p /sbin/ldconfig
  122. %postun -p /sbin/ldconfig
  123. %files
  124. %defattr(-,root,root)
  125. %{_bindir}/soaping
  126. %{_libdir}/libFileLib.so.*
  127. %{_libdir}/libOpenSOAPClient.so.*
  128. %{_libdir}/libOpenSOAPInterface.so.*
  129. %{_libdir}/libOpenSOAPService.so.*
  130. %{_libdir}/libOpenSOAPSecurity.so.*
  131. %{_libdir}/libSharedLib.so.*
  132. %{_libdir}/libTraceLib.so.*
  133. %{_with_cgi_bin}/TransactionService.cgi
  134. %{_with_cgi_bin}/SoapingService.cgi
  135. %{_with_servicesdir}/Soaping
  136. %{_with_servicesdir}/Transaction
  137. %{_localstatedir}/services/Transaction
  138. %{_mandir}/man1/*
  139. %{_mandir}/ja/man1/*
  140. %doc INSTALL INSTALL.ujis README README.ujis LICENSE
  141. %doc HISTORY HISTORY.ujis TODO TODO.ujis
  142. %doc docs/tools
  143. %files devel
  144. %defattr(-,root,root)
  145. %{_includedir}/OpenSOAP
  146. %{_libdir}/libFileLib.so
  147. %{_libdir}/libOpenSOAPClient.so
  148. %{_libdir}/libOpenSOAPInterface.so
  149. %{_libdir}/libOpenSOAPService.so
  150. %{_libdir}/libOpenSOAPSecurity.so
  151. %{_libdir}/libSharedLib.so
  152. %{_libdir}/libTraceLib.so
  153. %{_libdir}/libFileLib.*a
  154. %{_libdir}/libOpenSOAPClient.*a
  155. %{_libdir}/libOpenSOAPInterface.*a
  156. %{_libdir}/libOpenSOAPService.*a
  157. %{_libdir}/libOpenSOAPSecurity.*a
  158. %{_libdir}/libSharedLib.*a
  159. %{_libdir}/libTraceLib.*a
  160. %doc docs/api/en
  161. %doc docs/api/ja
  162. %files server
  163. %defattr(-,root,root)
  164. %{_sbindir}/*
  165. %{_libdir}/libOpenSOAPServer.*
  166. #{_libdir}/libHTTPMessage.*
  167. %{_libdir}/libSOAPMessage.*
  168. %{_libdir}/libconnection.*
  169. %{_libdir}/apache2/modules/mod_opensoap.so
  170. %config %{_sysconfdir}/server.conf
  171. %config %{_sysconfdir}/privKey.pem
  172. %config %{_sysconfdir}/pubKey.pem
  173. %{_sysconfdir}/*pem.default
  174. %{_sysconfdir}/ssml/Soaping.ssml
  175. %{_sysconfdir}/ssml/Transaction.ssml
  176. %{_with_cgi_bin}/soapInterface.cgi
  177. %{_mandir}/man8/*
  178. %{_mandir}/ja/man8/*
  179. %doc docs/server/*
  180. %config /etc/rc.d/init.d/opensoap
  181. %files samples
  182. %defattr(-,root,root)
  183. %doc docs/samples/*
  184. %{_with_cgi_bin}/*Calc*
  185. %{_with_cgi_bin}/Hello*
  186. %{_with_cgi_bin}/GetCertService.cgi
  187. %{_with_cgi_bin}/*Shopping*
  188. %{_with_cgi_bin}/TransactionApp.cgi
  189. %{_with_cgi_bin}/TransactionHtml
  190. %{_with_cgi_bin}/TransactionABankService.cgi
  191. %{_with_cgi_bin}/Echo*
  192. %{_with_servicesdir}/*Calc*
  193. %{_with_servicesdir}/*Hello*
  194. %{_with_servicesdir}/GetCert
  195. %{_with_servicesdir}/*Shopping*
  196. %{_with_servicesdir}/TransactionABank
  197. %{_with_servicesdir}/Echo
  198. %{_bindir}/*Calc*
  199. %{_bindir}/*Hello*
  200. %{_bindir}/GetCertClient
  201. %{_bindir}/registCA
  202. # %{_bindir}/genrsakey
  203. # %{_bindir}/secEnv
  204. %{_bindir}/*Shopping*
  205. %{_bindir}/TransactionClient
  206. %{_bindir}/EchoClient
  207. %{_sysconfdir}/ssml/*Calc*
  208. %{_sysconfdir}/ssml/GetCert.ssml
  209. %{_sysconfdir}/ssml/*Hello*
  210. %{_sysconfdir}/ssml/*Shopping*
  211. %{_sysconfdir}/ssml/TransactionABank.ssml
  212. %{_sysconfdir}/ssml/Echo.ssml
  213. %{_localstatedir}/services/CalcAsync
  214. %{_localstatedir}/services/GetCert
  215. %{_localstatedir}/services/ShoppingSec
  216. %changelog
  217. * Wed Oct 03 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-0vl1
  218. - updated to 2.0.1
  219. - added Patch0 based on Bugzilla
  220. * Mon Dec 01 2003 Nobuhito OKADA <okada@opensoap.jp> 1.0-0.20031201
  221. - added /usr/kerberos/include to avoid ssl compilation errors on RedHat9
  222. * Wed Sep 03 2003 Nobuhito OKADA <okada@opensoap.jp> 1.0-0.20030903
  223. - specify LIBRARY_PATH for make install
  224. * Fri May 30 2003 Nobuhito OKADA <okada@opensoap.jp> 1.0-0.20030530
  225. - added init script
  226. - added Epoch because versioning was confusing
  227. - added man/ja/
  228. - build opensoap-samples properly
  229. * Sat Mar 1 2003 Nobuhito OKADA <okada@opensoap.jp> 1.0_20030228-2
  230. - added %defattr
  231. - removed Vendor
  232. - corrected _with_cgi_bin (bug of define ?)
  233. * Thu Feb 28 2003 Nobuhito OKADA <okada@opensoap.jp> 1.0_20030228-1
  234. - Released as the first version.