perl-Carp-Clan-vl.spec 2.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. %define perl_sitelib %(eval "`perl -V:installsitelib`"; echo $installsitelib)
  2. Summary: Report errors from perspective of caller of a "clan" of modules for Perl
  3. Name: perl-Carp-Clan
  4. Version: 6.04
  5. Release: 1%{?_dist_release}
  6. License: distributable
  7. Group: Development/Libraries
  8. Source0: http://search.cpan.org/CPAN/authors/id/S/ST/STBEY/Carp-Clan-%{version}.tar.gz
  9. URL: http://search.cpan.org/~stbey/Carp-Clan/
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildArch: noarch
  12. BuildRequires: perl >= 5
  13. BuildRequires: perl-Test-Exception
  14. Requires: perl >= 5
  15. Conflicts: perl-Bit-Vector <= 6.3
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. %description
  19. This module reports errors from the perspective of the caller of a
  20. "clan" of modules, similar to "Carp.pm" itself. But instead of giving
  21. it a number of levels to skip on the calling stack, you give it a
  22. pattern to characterize the package names of the "clan" of modules
  23. which shall never be blamed for any error. :-)
  24. So these modules stick together like a "clan" and any error which
  25. occurs will be blamed on the "outsider" script or modules not belonging
  26. to this "clan".
  27. # Provide perl-specific find-{provides,requires}.
  28. %define __find_provides /usr/lib/rpm/find-provides.perl
  29. %define __find_requires /usr/lib/rpm/find-requires.perl
  30. %prep
  31. %setup -q -n Carp-Clan-%{version}
  32. %build
  33. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
  34. make
  35. %install
  36. rm -rf %{buildroot}
  37. make DESTDIR=%{buildroot} pure_install
  38. [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
  39. find %{buildroot}%{_prefix} -type f -print |
  40. sed "s@^%{buildroot}@@g" |
  41. grep -v perllocal.pod |
  42. grep -v %{_mandir} |
  43. grep -v "\.packlist" > %{name}-filelist
  44. if [ "$(cat %{name}-filelist)X" = "X" ] ; then
  45. echo "ERROR: EMPTY FILE LIST"
  46. exit -1
  47. fi
  48. %check
  49. make test
  50. %clean
  51. rm -rf %{buildroot}
  52. %files -f %{name}-filelist
  53. %defattr(-,root,root)
  54. %doc Changes license/Artistic.txt license/GNU_GPL.txt README
  55. %dir %{perl_vendorlib}/Carp
  56. %{_mandir}/man3/Carp::Clan.3pm*
  57. %changelog
  58. * Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 6.04-1
  59. - new upstrem release
  60. - add Vendor and Distribution tags
  61. - update files in doc
  62. * Sat Nov 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.00-1vl5
  63. - new upstream release
  64. - addede BuildRequires: perl-Test-Exception
  65. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 5.3-1vl5
  66. - applied new versioning policy
  67. - built with perl-5.10.0
  68. * Sun Jan 2 2005 IWAI, Masaharu <iwai@alib.jp> 5.3-0vl1
  69. - initial release