perl-Crypt-DES_EDE3-vl.spec 2.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. %define module Crypt-DES_EDE3
  2. %define name perl-%{module}
  3. %define version 0.01
  4. %define release 2%{_dist_release}
  5. Name: %{name}
  6. Version: %{version}
  7. Release: %{release}
  8. Summary: Triple-DES EDE encryption/decryption
  9. Group: Development/Languages
  10. License: GPL or Artistic
  11. Url: http://search.cpan.org/dist/%{module}/
  12. Source: http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
  13. Requires: perl-Crypt-DES
  14. Buildrequires: perl-Crypt-DES
  15. BuildArch: noarch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. Crypt::DES_EDE3 implements DES-EDE3 encryption.
  21. This is triple-DES encryption where an encrypt operation is
  22. encrypt-decrypt-encrypt, and decrypt is decrypt-encrypt-decrypt.
  23. This implementation uses Crypt::DES to do its dirty DES work,
  24. and simply provides a wrapper around that module: setting up
  25. the individual DES ciphers, initializing the keys, and performing
  26. the encryption/decryption steps.
  27. DES-EDE3 encryption requires a key size of 24 bytes.
  28. You're probably best off not using this module directly,
  29. as the encrypt and decrypt methods expect 8-octet blocks.
  30. You might want to use the module in conjunction with Crypt::CBC,
  31. for example. This would be DES-EDE3-CBC, or triple-DES in outer CBC mode.
  32. #'
  33. %prep
  34. %setup -q -n %{module}-%{version}
  35. %build
  36. CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
  37. %{__make}
  38. # %check
  39. # %{__make} test
  40. %install
  41. rm -rf %{buildroot}
  42. %makeinstall
  43. rm -f %{buildroot}%{perl_archlib}/perllocal.pod
  44. # rm -rf %{buildroot}%{perl_vendorarch}
  45. %clean
  46. rm -rf %{buildroot}
  47. %files
  48. %defattr(-,root,root)
  49. %doc README Changes
  50. %{_mandir}/man3*/*
  51. %{perl_vendorlib}/Crypt/*
  52. %changelog
  53. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.01-2
  54. - rebuild with perl-5.12.3
  55. * Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-1vl5
  56. - rebuild with perl 5.10
  57. - new versioning policy
  58. * Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-0vl1
  59. - built for VineSeed
  60. * Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-0vl0.43
  61. - add Requires: and Buildrequires: perl-Crypt-DES
  62. * Tue Mar 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-0vl0.42
  63. - built for Vine 4.2 (testing)