perl-Error-vl.spec 2.6 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. %define pkgver 0.17016
  2. Summary: Error/exception handling in an OO-ish way with Perl
  3. Name: perl-Error
  4. Version: 0.17
  5. Release: 2%{?_dist_release}
  6. License: Aristic and GPL
  7. Group: Development/Libraries
  8. Source0: http://search.cpan.org/CPAN/authors/id/U/UA/UARUN/Error-%{pkgver}.tar.gz
  9. Url: http://search.cpan.org/dist/Error/
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: perl >= 5.005
  12. Requires: perl >= 5.005
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. BuildArch: noarch
  16. SUmmary(ja): エラーや例外をオブジェクト指向的に扱う Perl モジュール
  17. %description
  18. The Error package provides two interfaces. Firstly Error provides
  19. a procedural interface to exception handling. Secondly Error is a
  20. base class for errors/exceptions that can either be thrown, for
  21. subsequent catch, or can simply be recorded.
  22. Errors in the class Error should not be thrown directly, but the
  23. user should throw errors from a sub-class of Error
  24. %description -l ja
  25. Errorパッケージはふたつのインターフェースを提供します。まず、
  26. Errorは例外を扱うための手続き型インターフェースを提供します。
  27. またErrorは、throw したり、あとでcatchしたり、もしくは単に
  28. recordしたりするための、エラーや例外のベースクラスとなること
  29. ができます。
  30. Errorクラスのエラーを直接throwするべきではありません。Errorの
  31. サブクラスを使ってエラーを投げるようにしてください。
  32. %prep
  33. %setup -q -n Error-%{pkgver}
  34. %build
  35. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
  36. make
  37. %check
  38. make test
  39. %clean
  40. rm -rf %{buildroot}
  41. %install
  42. rm -rf %{buildroot}
  43. make DESTDIR=%{buildroot} install
  44. find %{buildroot}%{_prefix} -type f -print |
  45. sed "s@^%{buildroot}@@g" |
  46. grep -v ^%{_mandir} |
  47. grep -v perllocal.pod |
  48. grep -v "\.packlist" > %{name}.files
  49. if [ "$(cat %{name}.files)X" = "X" ] ; then
  50. echo "ERROR: EMPTY FILE LIST"
  51. exit -1
  52. fi
  53. %files -f %{name}.files
  54. %defattr(-,root,root)
  55. %doc README ChangeLog examples
  56. %dir %{perl_vendorlib}/Error
  57. %{_mandir}/*/*
  58. %changelog
  59. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 0.17-2
  60. - updated to 0.17016
  61. - add %%{perl_vendorlib}/Error directory in %%files
  62. * Thu Aug 28 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-1vl5
  63. - applied new versioning policy, spec in utf-8
  64. - built with perl-5.10.0
  65. * Tue Sep 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-0vl1
  66. - updated to 0.17009
  67. - changed Group to Development/Libraries
  68. - install module files to vendor_perl dir
  69. * Sat May 10 2003 IWAI Masaharu <iwai@alib.jp> 0.15-0vl1
  70. - first build for Vine Linux