perl-Eval-Closure-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101
  1. Name: perl-Eval-Closure
  2. Version: 0.08
  3. Release: 1%{?_dist_release}
  4. Summary: Safely and cleanly create closures via string eval
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/dist/Eval-Closure/
  8. Source0: http://www.cpan.org/authors/id/D/DO/DOY/Eval-Closure-%{version}.tar.gz
  9. BuildArch: noarch
  10. BuildRequires: perl(ExtUtils::MakeMaker)
  11. BuildRequires: perl(PadWalker)
  12. BuildRequires: perl(Perl::Tidy)
  13. BuildRequires: perl(Scalar::Util)
  14. BuildRequires: perl(Sub::Exporter)
  15. BuildRequires: perl(Test::Fatal)
  16. BuildRequires: perl(Test::More) >= 0.88
  17. BuildRequires: perl(Test::Output)
  18. BuildRequires: perl(Test::Requires)
  19. BuildRequires: perl(Try::Tiny)
  20. Requires: perl(Perl::Tidy)
  21. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  22. %{?perl_default_filter}
  23. %description
  24. String eval is often used for dynamic code generation. For instance, Moose uses
  25. it heavily, to generate inlined versions of accessors and constructors, which
  26. speeds code up at runtime by a significant amount. String eval is not without
  27. its issues however - it's difficult to control the scope it's used in (which
  28. determines which variables are in scope inside the eval), and it's easy to miss
  29. compilation errors, since eval catches them and sticks them in $@ instead.
  30. This module attempts to solve these problems. It provides an eval_closure
  31. function, which evals a string in a clean environment, other than a fixed list
  32. of specified variables. Compilation errors are rethrown automatically.
  33. %prep
  34. %setup -q -n Eval-Closure-%{version}
  35. %build
  36. %{__perl} Makefile.PL INSTALLDIRS=vendor
  37. make %{?_smp_mflags}
  38. %install
  39. rm -rf %{buildroot}
  40. make pure_install DESTDIR=%{buildroot}
  41. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  42. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
  43. %{_fixperms} %{buildroot}/*
  44. %check
  45. make test
  46. %clean
  47. rm -rf %{buildroot}
  48. %files
  49. %doc Changes LICENSE README
  50. %{perl_vendorlib}/*
  51. %{_mandir}/man3/*
  52. %changelog
  53. * Mon Mar 05 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.08-1
  54. - initial build for Vine Linux
  55. * Fri Feb 10 2012 Iain Arnell <iarnell@gmail.com> 0.08-1
  56. - update to latest upstream version
  57. * Sat Feb 04 2012 Iain Arnell <iarnell@gmail.com> 0.07-1
  58. - update to latest upstream version
  59. - update description
  60. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-3
  61. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  62. * Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-2
  63. - Perl mass rebuild
  64. * Tue Jun 07 2011 Iain Arnell <iarnell@gmail.com> 0.06-1
  65. - update to latest upstream version
  66. * Wed May 04 2011 Iain Arnell <iarnell@gmail.com> 0.05-1
  67. - update to latest upstream version
  68. * Wed Apr 20 2011 Iain Arnell <iarnell@gmail.com> 0.04-1
  69. - update to latest upstream version
  70. * Thu Mar 03 2011 Iain Arnell <iarnell@gmail.com> 0.03-1
  71. - update to latest upstream version
  72. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.02-2
  73. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  74. * Fri Jan 28 2011 Iain Arnell <iarnell@gmail.com> 0.02-1
  75. - update to latest upstream version
  76. * Sun Jan 23 2011 Iain Arnell <iarnell@gmail.com> 0.01-1
  77. - Specfile autogenerated by cpanspec 1.78.