perl-Module-Find-vl.spec 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475
  1. %define pkgname Module-Find
  2. # Basic Information
  3. Name: perl-%{pkgname}
  4. Version: 0.10
  5. Release: 1%{?_dist_release}
  6. License: Artistic or GPL
  7. Group: Development/Libraries
  8. Source0: http://search.cpan.org/CPAN/authors/id/C/CR/CRENZ/%{pkgname}-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: yasumichi
  13. Summary: Find and use installed modules in a (sub)category
  14. Summary(ja): (サブ)カテゴリー内にインストールされたモジュールを見つけて利用する
  15. # Dependency
  16. Requires: perl
  17. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  18. BuildRequires: perl
  19. %description
  20. Module::Find lets you find and use modules in categories. This can be very
  21. useful for auto-detecting driver or plugin modules. You can differentiate
  22. between looking in the category itself or in all subcategories.
  23. If you want Module::Find to search in a certain directory on your harddisk
  24. (such as the plugins directory of your software installation), make sure you
  25. modify @INC before you call the Module::Find functions.
  26. #%%description -l ja
  27. #ここに日本語で詳細を記述してください。
  28. %prep
  29. %setup -q -n Module-Find-0.10
  30. %build
  31. perl Makefile.PL
  32. %{__make}
  33. %install
  34. %{__rm} -rf ${RPM_BUILD_ROOT}
  35. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  36. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  37. sed "s@^$RPM_BUILD_ROOT@@g" |
  38. grep -v ^%{_mandir} |
  39. grep -v perllocal.pod |
  40. grep -v "\.packlist" > %{name}.files
  41. if [ "$(cat %{name}.files)X" = "X" ] ; then
  42. echo "ERROR: EMPTY FILE LIST"
  43. exit -1
  44. fi
  45. # remove unnecessary files.
  46. %{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
  47. %{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Module/Find/.packlist
  48. %clean
  49. %{__rm} -rf ${RPM_BUILD_ROOT}
  50. %files -f %{name}.files
  51. %defattr(-,root,root)
  52. %doc Changes README
  53. %{_mandir}/*/*
  54. %changelog
  55. * Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.10-1
  56. - initial build for Vine Linux