perl-Moose-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476
  1. Name: perl-Moose
  2. Summary: Complete modern object system for Perl 5
  3. Version: 2.0402
  4. Release: 1%{?_dist_release}
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. Source0: http://search.cpan.org/CPAN/authors/id/D/DO/DOY/Moose-%{version}.tar.gz
  8. URL: http://search.cpan.org/dist/
  9. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  10. # Class::MOP is now included in Moose itself
  11. Obsoletes: perl-Class-MOP <= 1.12-2.fc15
  12. Obsoletes: perl-Class-MOP-tests <= 1.12-2.fc15
  13. # configure
  14. BuildRequires: perl(Dist::CheckConflicts) >= 0.02
  15. BuildRequires: perl(ExtUtils::MakeMaker) >= 6.30
  16. # develop
  17. BuildRequires: perl(Algorithm::C3)
  18. BuildRequires: perl(DBM::Deep) >= 1.0003
  19. BuildRequires: perl(DateTime)
  20. BuildRequires: perl(DateTime::Calendar::Mayan)
  21. BuildRequires: perl(File::Find::Rule)
  22. BuildRequires: perl(HTTP::Headers)
  23. BuildRequires: perl(IO::File)
  24. BuildRequires: perl(IO::String)
  25. BuildRequires: perl(Locale::US)
  26. BuildRequires: perl(Module::Info)
  27. BuildRequires: perl(PadWalker)
  28. BuildRequires: perl(Params::Coerce)
  29. BuildRequires: perl(Regexp::Common)
  30. BuildRequires: perl(Test::Deep)
  31. # author test - we almost certainly don't want this in mock!
  32. #BuildRequires: perl(Test::DependentModules) >= 0.12
  33. BuildRequires: perl(Test::Inline)
  34. BuildRequires: perl(Test::LeakTrace)
  35. BuildRequires: perl(Test::Output)
  36. BuildRequires: perl(Test::Spelling)
  37. BuildRequires: perl(URI)
  38. # not decalared in META.json
  39. BuildRequires: perl(Carp)
  40. BuildRequires: perl(Carp::Heavy)
  41. BuildRequires: perl(SUPER) >= 1.10
  42. # test
  43. BuildRequires: perl(Test::Fatal) >= 0.001
  44. BuildRequires: perl(Test::More) >= 0.88
  45. BuildRequires: perl(Test::Requires) >= 0.05
  46. BuildRequires: perl(Declare::Constraints::Simple)
  47. BuildRequires: perl(Module::Refresh)
  48. # runtime
  49. BuildRequires: perl(Class::Load) >= 0.09
  50. BuildRequires: perl(Class::Load::XS) >= 0.01
  51. BuildRequires: perl(Data::OptList) >= 0.107
  52. BuildRequires: perl(Devel::GlobalDestruction)
  53. BuildRequires: perl(Eval::Closure) >= 0.04
  54. BuildRequires: perl(List::MoreUtils) >= 0.28
  55. BuildRequires: perl(MRO::Compat) >= 0.05
  56. BuildRequires: perl(Package::DeprecationManager) >= 0.11
  57. BuildRequires: perl(Package::Stash) >= 0.32
  58. BuildRequires: perl(Package::Stash::XS) >= 0.24
  59. BuildRequires: perl(Params::Util) >= 1.00
  60. BuildRequires: perl(Scalar::Util) >= 1.19
  61. BuildRequires: perl(Sub::Exporter) >= 0.980
  62. BuildRequires: perl(Sub::Name) >= 0.05
  63. BuildRequires: perl(Task::Weaken)
  64. BuildRequires: perl(Try::Tiny) >= 0.02
  65. Requires: perl(Data::OptList) >= 0.107
  66. Requires: perl(Dist::CheckConflicts) >= 0.02
  67. # hidden from PAUSE
  68. Provides: perl(Moose::Conflicts)
  69. Provides: perl(Moose::Error::Util)
  70. # virtual provides for perl-Any-Moose
  71. Provides: perl(Any-Moose) = %{version}
  72. # obsolete/provide old tests subpackage
  73. # can be removed during F19 development cycle
  74. Obsoletes: %{name}-tests < 2.0401-2
  75. Provides: %{name}-tests = %{version}-%{release}
  76. %{?perl_default_filter}
  77. %description
  78. Moose is an extension of the Perl 5 object system.
  79. The main goal of Moose is to make Perl 5 Object Oriented programming easier,
  80. more consistent and less tedious. With Moose you can to think more about what
  81. you want to do and less about the mechanics of OOP.
  82. Additionally, Moose is built on top of Class::MOP, which is a metaclass system
  83. for Perl 5. This means that Moose not only makes building normal Perl 5
  84. objects better, but it provides the power of metaclass programming as well.
  85. Moose is different from other Perl 5 object systems because it is not a new
  86. system, but instead an extension of the existing one.
  87. %package -n perl-Test-Moose
  88. License: GPL+ or Artistic
  89. Group: Development/Libraries
  90. Summary: Test functions for Moose specific features
  91. Requires: %{name} = %{version}-%{release}
  92. %description -n perl-Test-Moose
  93. This module provides some useful test functions for Moose based classes.
  94. It is an experimental first release, so comments and suggestions are
  95. very welcome.
  96. %prep
  97. %setup -q -n Moose-%{version}
  98. # silence rpmlint warnings
  99. find benchmarks/ -type f -name '*.pl' -print0 \
  100. | xargs -0 sed -i '1s,#!.*perl,#!%{__perl},'
  101. find t/ -type f -name '*.t' -print0 \
  102. | xargs -0 sed -i '1s,#!.*perl,#!%{__perl},'
  103. %build
  104. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  105. make %{?_smp_mflags}
  106. %install
  107. make pure_install DESTDIR=%{buildroot}
  108. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  109. find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  110. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
  111. %{_fixperms} %{buildroot}/*
  112. chmod -x benchmarks/*.pl benchmarks/cmop/*.pl
  113. %check
  114. make test
  115. %files
  116. %doc Changes Changes.Class-MOP LICENSE README TODO doap.rdf
  117. %doc t/ benchmarks/
  118. %{perl_vendorarch}/*
  119. %exclude %dir %{perl_vendorarch}/auto/
  120. %{_mandir}/man3/*
  121. %{_bindir}/moose-outdated
  122. %exclude %{perl_vendorarch}/Test
  123. %exclude %{_mandir}/man3/Test::Moose*
  124. %files -n perl-Test-Moose
  125. %{perl_vendorarch}/Test
  126. %{_mandir}/man3/Test::Moose*
  127. %changelog
  128. * Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0402-1
  129. - initial build for Vine Linux
  130. * Sun Feb 05 2012 Iain Arnell <iarnell@gmail.com> 2.0402-1
  131. - update to latest upstream version
  132. * Sun Jan 22 2012 Iain Arnell <iarnell@gmail.com> 2.0401-2
  133. - drop tests subpackage; move tests to main package documentation
  134. * Thu Jan 12 2012 Iain Arnell <iarnell@gmail.com> 2.0401-1
  135. - update to latest upstream version
  136. * Sun Oct 09 2011 Iain Arnell <iarnell@gmail.com> 2.0205-2
  137. - add virtual provides for perl-Any-Moose
  138. * Sat Oct 01 2011 Iain Arnell <iarnell@gmail.com> 2.0205-1
  139. - update to latest upstream version
  140. * Tue Sep 13 2011 Petr Pisar <ppisar@redhat.com> - 2.0204-2
  141. - Build-require Carp because Carp dual-lives now (bug #736768)
  142. * Sun Aug 28 2011 Iain Arnell <iarnell@gmail.com> 2.0204-1
  143. - update to latest upstream version
  144. - additional build/test dependencies for more testing
  145. * Sat Jul 30 2011 Iain Arnell <iarnell@gmail.com> 2.0202-1
  146. - update to latest upstream version
  147. * Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 2.0010-2
  148. - Perl mass rebuild
  149. * Sat Jun 25 2011 Iain Arnell <iarnell@gmail.com> 2.0010-1
  150. - update to latest upstream version
  151. * Fri May 20 2011 Iain Arnell <iarnell@gmail.com> 2.0007-1
  152. - update to latest upstream version
  153. * Tue May 03 2011 Iain Arnell <iarnell@gmail.com> 2.0002-2
  154. - drop unnecessary BR perl(Devel::PartialDump)
  155. * Tue May 03 2011 Iain Arnell <iarnell@gmail.com> 2.0002-1
  156. - update to latest upstream version
  157. * Tue Apr 26 2011 Iain Arnell <iarnell@gmail.com> 2.0001-3
  158. - add explicit perl(Dist::CheckConflicts) requirement
  159. * Sat Apr 23 2011 Iain Arnell <iarnell@gmail.com> 2.0001-2
  160. - obsolete perl-Class-MOP-tests too
  161. * Sat Apr 23 2011 Iain Arnell <iarnell@gmail.com> 2.0001-1
  162. - update to latest upstream version
  163. * Fri Apr 22 2011 Iain Arnell <iarnell@gmail.com> 2.00-1
  164. - update to latest upstream version
  165. - regenerate BuildRequires from META.json
  166. - obsoletes perl-Class-MOP (now incluced in Moose itself)
  167. - clean up spec for modern rpmbuild
  168. * Sun Apr 03 2011 Iain Arnell <iarnell@gmail.com> 1.25-1
  169. - update to latest upstream version
  170. * Sat Mar 05 2011 Iain Arnell <iarnell@gmail.com> 1.24-1
  171. - update to latest upstream version
  172. * Thu Feb 17 2011 Iain Arnell <iarnell@gmail.com> 1.23-1
  173. - update to latest upstream version
  174. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.21-2
  175. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  176. * Mon Jan 24 2011 Iain Arnell <iarnell@gmail.com> 1.21-1
  177. - update to latest upstream version
  178. - update R/BR perl(Class::MOP) >= 1.11
  179. - update R/BR perl(Params::Util) >= 1.00
  180. - update R/BR perl(Package::DeprecationManager) >= 0.10
  181. - new BR perl(Test::Fatal) >= 0.001
  182. - drop old BR perl(Test::Exception)
  183. * Sat Oct 09 2010 Iain Arnell <iarnell@gmail.com> 1.15-1
  184. - update to latest upstream version
  185. - update BR perl(Class::MOP) >= 1.09
  186. - new BR perl(Params:Util)
  187. * Tue Oct 05 2010 Iain Arnell <iarnell@gmail.com> 1.14-1
  188. - update to latest upstream version
  189. - update BR perl(Class:MOP) >= 1.05
  190. - new BR perl(Test::Requires) >= 0.05
  191. - new R/BR perl(Package::DeprecationManager) >= 0.04
  192. * Sat Jul 03 2010 Iain Arnell <iarnell@gmail.com> 1.08-1
  193. - update to latest upstream
  194. - update BR perl(Class:MOP) >= 1.02
  195. * Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.03-1
  196. - update
  197. * Mon May 03 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.02-1
  198. - Mass rebuild with perl-5.12.0
  199. - switch off tests for meantime, needs Class::ISA
  200. * Fri Apr 30 2010 Marclea Mašláňová <mmaslano@redhat.com> 1.01-1
  201. - update
  202. * Fri Mar 12 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.99-1
  203. - update by Fedora::App::MaintainerTools 0.006
  204. - updating to latest GA CPAN version (0.99)
  205. * Sat Feb 20 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.98-1
  206. - update by Fedora::App::MaintainerTools 0.003
  207. * Sat Feb 13 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.96-1
  208. - auto-update by cpan-spec-update 0.002
  209. - dropped old BR on perl(UNIVERSAL::require)
  210. - dropped old BR on perl(Sub::Install)
  211. - dropped old BR on perl(Test::LongString)
  212. - dropped old BR on perl(Filter::Simple)
  213. * Fri Feb 05 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.94-3
  214. - PERL_INSTALL_ROOT => DESTDIR
  215. - add perl_default_subpackage_tests
  216. - properly exclude vendorarch/auto/ directory
  217. - add br on DateTime::Calendar::Mayan
  218. * Wed Jan 20 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.94-2
  219. - we're not noarch anymore :)
  220. * Wed Jan 20 2010 Chris Weyl <cweyl@alumni.drew.edu> 0.94-1
  221. - auto-update to 0.94 (by cpan-spec-update 0.01)
  222. - altered br on perl(Class::MOP) (0.94 => 0.98)
  223. - altered req on perl(Class::MOP) (0.94 => 0.98)
  224. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.92-2
  225. - rebuild against perl 5.10.1
  226. * Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.92-1
  227. - auto-update to 0.92 (by cpan-spec-update 0.01)
  228. - altered br on perl(Class::MOP) (0.93 => 0.94)
  229. - altered req on perl(Class::MOP) (0.93 => 0.94)
  230. * Fri Sep 18 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.90-1
  231. - switch filtering systems...
  232. - auto-update to 0.90 (by cpan-spec-update 0.01)
  233. - altered br on perl(Class::MOP) (0.92 => 0.93)
  234. - altered br on perl(Test::More) (0.77 => 0.88)
  235. - added a new br on perl(Try::Tiny) (version 0.02)
  236. - altered req on perl(Class::MOP) (0.92 => 0.93)
  237. - added a new req on perl(Try::Tiny) (version 0.02)
  238. * Wed Aug 19 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.89-1
  239. - auto-update to 0.89 (by cpan-spec-update 0.01)
  240. - altered br on perl(Class::MOP) (0.89 => 0.92)
  241. - altered req on perl(Class::MOP) (0.89 => 0.92)
  242. * Mon Jul 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.88-1
  243. - auto-update to 0.88 (by cpan-spec-update 0.01)
  244. - altered br on perl(Class::MOP) (0.85 => 0.89)
  245. - altered br on perl(Sub::Exporter) (0.972 => 0.980)
  246. - added a new req on perl(Carp) (version 0)
  247. - added a new req on perl(Class::MOP) (version 0.89)
  248. - added a new req on perl(Data::OptList) (version 0)
  249. - added a new req on perl(List::MoreUtils) (version 0.12)
  250. - added a new req on perl(Scalar::Util) (version 1.19)
  251. - added a new req on perl(Sub::Exporter) (version 0.980)
  252. - added a new req on perl(Sub::Name) (version 0)
  253. - added a new req on perl(Task::Weaken) (version 0)
  254. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.81-3
  255. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  256. * Mon Jun 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.81-2
  257. - split off Test::Moose
  258. * Tue Jun 09 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.81-1
  259. - auto-update to 0.81 (by cpan-spec-update 0.01)
  260. - altered br on perl(Class::MOP) (0.83 => 0.85)
  261. * Sun Jun 07 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.80-1
  262. - auto-update to 0.80 (by cpan-spec-update 0.01)
  263. * Tue May 19 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.79-1
  264. - auto-update to 0.79 (by cpan-spec-update 0.01)
  265. * Wed May 13 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.78-1
  266. - auto-update to 0.78 (by cpan-spec-update 0.01)
  267. - altered br on perl(Test::Exception) (0.21 => 0.27)
  268. - altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
  269. - added a new br on perl(Sub::Name) (version 0)
  270. - altered br on perl(Class::MOP) (0.81 => 0.83)
  271. - altered br on perl(Sub::Exporter) (0.954 => 0.972)
  272. - added a new br on perl(Carp) (version 0)
  273. * Mon May 04 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.74-2
  274. - switch filtering to a cleaner system
  275. * Sat Apr 18 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.74-1
  276. - update to 0.74
  277. * Wed Apr 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.73-1
  278. - update to 0.73
  279. * Sun Mar 08 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.72-1
  280. - update to 0.72
  281. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.71-2
  282. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  283. * Sun Feb 22 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.71-1
  284. - update to 0.71
  285. * Sun Jan 04 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.64-1
  286. - update to 0.64
  287. * Sun Dec 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.63-1
  288. - update to 0.63
  289. - bump br versions on Moose, List::MoreUtils
  290. * Sat Dec 06 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.62-1
  291. - update to 0.62
  292. - new Task::Weaken and Class::MOP requirements
  293. * Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.61-4
  294. - aaaand drop them again, as it was really perl-Class-MOP's issue.
  295. * Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.61-3
  296. - same with Devel::GlobalDestruction (same RT as below)
  297. * Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.61-2
  298. - add Sub::Name as a build dep (RT#40772)
  299. * Sat Nov 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.61-1
  300. - update to 0.61
  301. - update BR's
  302. * Sat Sep 06 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.57-2
  303. - add additional test BR's
  304. * Sat Sep 06 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.57-1
  305. - update to 0.57
  306. * Fri Jul 18 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.54-1
  307. - update to 0.54
  308. * Sat Jun 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.51-1
  309. - update to 0.51
  310. * Tue Jun 17 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.50-1
  311. - update to 0.50
  312. - drop obviated test patch
  313. * Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.44-2
  314. - bump
  315. * Wed May 21 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.44-1
  316. - update to 0.44
  317. * Wed Mar 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.33-3
  318. - rebuild for new perl
  319. * Mon Jan 07 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.33-2
  320. - remove *.orig files from t/ (BZ#427754)
  321. * Sat Dec 15 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.33-1
  322. - update to 0.33
  323. * Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.32-1
  324. - update to 0.32
  325. * Sun Nov 25 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.30-1
  326. - update to 0.30
  327. * Sat Nov 17 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.29-1
  328. - update to 0.29
  329. - refactor to Module::Install
  330. * Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.26-1
  331. - udpate to 0.26
  332. * Sat Aug 11 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.24-1
  333. - update to 0.24
  334. - license tag: GPL -> GPL+
  335. - patch t/202_...t to write to a tmpdir rather than .
  336. * Thu May 31 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.22-1
  337. - update to 0.22
  338. * Fri May 04 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.21-1
  339. - update to 0.21
  340. * Tue May 01 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.20-2
  341. - add t/ to %%doc
  342. - add br for optional test #7
  343. * Sat Apr 07 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.20-1
  344. - update to 0.20
  345. - add additional BR's for new optional tests
  346. * Fri Mar 23 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
  347. - Sub::Name only needed as a br for Moose < 0.18
  348. - update to 0.18
  349. * Thu Nov 16 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.17-2
  350. - add IO::File and IO::String to br's for testing
  351. * Thu Nov 16 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
  352. - update to 0.17
  353. * Mon Nov 06 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.15-1
  354. - update to 0.15
  355. * Tue Oct 10 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.14-1
  356. - update to 0.14
  357. - drop some cruft from the specfile
  358. - make %%description a touch more verbose :)
  359. * Tue Oct 03 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.13-1
  360. - update to 0.13
  361. * Fri Sep 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.12-2
  362. - bump
  363. * Sat Sep 02 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.12-1
  364. - Specfile autogenerated by cpanspec 1.69.1.