perl-Perl-Critic-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407
  1. # define bootstrap for initial build
  2. %define perl_bootstrap 1
  3. Name: perl-Perl-Critic
  4. Version: 1.117
  5. Release: 2%{?_dist_release}
  6. Summary: Critique Perl source code for best-practices
  7. Group: Development/Libraries
  8. License: GPL+ or Artistic
  9. URL: http://search.cpan.org/dist/Perl-Critic/
  10. Source0: http://search.cpan.org/CPAN/authors/id/T/TH/THALJEF/Perl-Critic-%{version}.tar.gz
  11. BuildArch: noarch
  12. Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
  13. # Build process
  14. BuildRequires: perl(Module::Build)
  15. BuildRequires: perl(Task::Weaken)
  16. # Module requirements
  17. BuildRequires: aspell-en
  18. Requires: aspell
  19. BuildRequires: perl(B::Keywords) >= 1.05
  20. BuildRequires: perl(Carp)
  21. BuildRequires: perl(charnames)
  22. BuildRequires: perl(Config::Tiny) >= 2
  23. BuildRequires: perl(Email::Address) >= 1.889
  24. BuildRequires: perl(English)
  25. BuildRequires: perl(Exception::Class) >= 1.23
  26. BuildRequires: perl(Exporter)
  27. BuildRequires: perl(File::Basename)
  28. BuildRequires: perl(File::Find)
  29. BuildRequires: perl(File::Path)
  30. BuildRequires: perl(File::Spec)
  31. BuildRequires: perl(File::Spec::Unix)
  32. BuildRequires: perl(File::Temp)
  33. BuildRequires: perl(Getopt::Long)
  34. BuildRequires: perl(IO::String)
  35. BuildRequires: perl(List::MoreUtils) >= 0.19
  36. BuildRequires: perl(List::Util)
  37. BuildRequires: perl(Module::Pluggable) >= 3.1
  38. Requires: perl(Module::Pluggable) >= 3.1
  39. BuildRequires: perl(overload)
  40. BuildRequires: perl(Perl::Tidy)
  41. BuildRequires: perl(Pod::Parser)
  42. Requires: perl(Pod::Parser)
  43. BuildRequires: perl(Pod::PlainText)
  44. BuildRequires: perl(Pod::Select)
  45. BuildRequires: perl(Pod::Spell) >= 1
  46. BuildRequires: perl(Pod::Usage)
  47. BuildRequires: perl(PPI) >= 1.215
  48. Requires: perl(PPI) >= 1.215
  49. BuildRequires: perl(PPIx::Regexp) >= 0.010
  50. BuildRequires: perl(PPIx::Utilities::Statement) >= 1.001
  51. BuildRequires: perl(Readonly) >= 1.03
  52. BuildRequires: perl(Scalar::Util)
  53. BuildRequires: perl(strict)
  54. BuildRequires: perl(String::Format) >= 1.13
  55. BuildRequires: perl(Text::ParseWords) >= 3
  56. BuildRequires: perl(version) >= 0.77
  57. BuildRequires: perl(warnings)
  58. # Optional module requirements
  59. BuildRequires: perl(File::HomeDir)
  60. Requires: perl(File::HomeDir)
  61. BuildRequires: perl(File::Which)
  62. Requires: perl(File::Which)
  63. BuildRequires: perl(Readonly::XS)
  64. Requires: perl(Readonly::XS)
  65. BuildRequires: perl(Term::ANSIColor) >= 2.02
  66. Requires: perl(Term::ANSIColor) >= 2.02
  67. # Main test suite
  68. BuildRequires: perl(Test::Deep)
  69. BuildRequires: perl(Test::Memory::Cycle)
  70. BuildRequires: perl(Test::More)
  71. # Author tests: not run if we're bootstrapping
  72. %if 0%{!?perl_bootstrap:1}
  73. BuildRequires: perl(Devel::EnforceEncapsulation)
  74. BuildRequires: perl(Perl::Critic::Policy::Editor::RequireEmacsFileVariables)
  75. BuildRequires: perl(Perl::Critic::Policy::ErrorHandling::RequireUseOfExceptions)
  76. BuildRequires: perl(Test::Kwalitee)
  77. BuildRequires: perl(Test::Perl::Critic)
  78. BuildRequires: perl(Test::Pod) >= 1.00
  79. BuildRequires: perl(Test::Pod::Coverage) >= 1.04
  80. BuildRequires: perl(Test::Without::Module)
  81. %endif
  82. # don't "provide" private Perl libs
  83. %{?perl_default_filter}
  84. Vendor: Project Vine
  85. Distribution: Vine Linux
  86. Packager: shaolin
  87. %description
  88. Perl::Critic is an extensible framework for creating and applying coding
  89. standards to Perl source code. Essentially, it is a static source code
  90. analysis engine. Perl::Critic is distributed with a number of
  91. Perl::Critic::Policy modules that attempt to enforce various coding
  92. guidelines. Most Policy modules are based on Damian Conway's book Perl
  93. Best Practices. However, Perl::Critic is not limited to PBP and will
  94. even support Policies that contradict Conway. You can enable, disable,
  95. and customize those Polices through the Perl::Critic interface. You can
  96. also create new Policy modules that suit your own tastes.
  97. %package -n perl-Test-Perl-Critic-Policy
  98. Summary: A framework for testing your custom Policies
  99. Group: Development/Libraries
  100. License: GPL+ or Artistic
  101. %description -n perl-Test-Perl-Critic-Policy
  102. This module provides a framework for function-testing your custom
  103. Perl::Critic::Policy modules. Policy testing usually involves feeding it a
  104. string of Perl code and checking its behavior. In the old days, those strings
  105. of Perl code were mixed directly in the test script. That sucked.
  106. %prep
  107. %setup -q -n Perl-Critic-%{version}
  108. find . -type f -exec chmod -c -x {} ';'
  109. %build
  110. perl Build.PL installdirs=vendor
  111. ./Build
  112. %install
  113. ./Build install destdir=%{buildroot} create_packlist=0
  114. %{_fixperms} %{buildroot}
  115. %check
  116. LC_ALL=en_US ./Build %{!?perl_bootstrap:author}test
  117. %files
  118. %doc Changes LICENSE README TODO.pod examples/ extras/ tools/
  119. %{_bindir}/perlcritic
  120. %{perl_vendorlib}/Perl/
  121. %{_mandir}/man1/perlcritic.1*
  122. %{_mandir}/man3/Perl::Critic*.3pm*
  123. %files -n perl-Test-Perl-Critic-Policy
  124. %{perl_vendorlib}/Test/
  125. %{_mandir}/man3/Test::Perl::Critic::Policy.3pm*
  126. %changelog
  127. * Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.117-2
  128. - rebuild
  129. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.117-1
  130. - initial build for Vine Linux
  131. * Thu Jan 12 2012 Paul Howarth <paul@city-fan.org> - 1.117-2
  132. - drop %%defattr, no longer needed
  133. * Thu Dec 22 2011 Paul Howarth <paul@city-fan.org> - 1.117-1
  134. - update to 1.117
  135. New Policies:
  136. - Variables::ProhibitAugmentedAssignmentInDeclaration reports constructs like
  137. 'my $x += 1'
  138. Policy Changes:
  139. - BuiltinFunctions::ProhibitLvalueSubstr: add explicit 'use version'
  140. (CPAN RT#68498)
  141. - CodeLayout::ProhibitHardTabs: add 'pbp' to the default_themes list
  142. (CPAN RT#71093)
  143. - ControlStructures::ProhibitMutatingListFunctions now understands that
  144. tr///r (introduced in 5.13.7) does not change its operand
  145. - ControlStructures::ProhibitMutatingListFunctions now understands that
  146. '//=', '<<=', and '>>=' are assignment operators (CPAN RT#70901)
  147. - ErrorHandling::RequireCheckingReturnValueOfEval now allows things
  148. like grep { eval $_ } (CPAN RT#69489)
  149. - Modules::RequireExplicitPackage now has configuraion option
  150. allow_import_of, to allow the import of specified modules before the
  151. package statement (CPAN RT#72660)
  152. - RegularExpressions::ProhibitEnumeratedClasses no longer thinks
  153. that [A-Za-z_] matches \w. RT #69322.
  154. - RegularExpressions::ProhibitUnusedCaptures now skips the first block of
  155. an 'if' or 'elsif' if the regular expression is bound to its operand with
  156. the '!~' operator (CPAN RT#69867)
  157. - RegularExpressions::ProhibitUnusedCaptures now looks into lists and blocks
  158. in the replacement portion of the regular expression if /e is asserted
  159. (CPAN RT#72086)
  160. - RegularExpressions::RequireDotMatchAnything,
  161. RegularExpressions::RequireExtendedFormatting and
  162. RegularExpressions::RequireLineBoundaryMatching now honor defaults set with
  163. 'use re "/modifiers"' (CPAN RT#72151)
  164. - Subroutines::ProhibitManyArgs now recognizes '+' as a prototype character
  165. - Variables::ProhibitPunctuationVars now recognizes bracketed variables
  166. embedded in interpolated strings (e.g. "${$}"); for the purpose of the
  167. 'allow' configuration, these are considered equivalent to the unbracketed
  168. form (CPAN RT#72910)
  169. Other Changes:
  170. - corrected POD in Perl::Critic::PPI::Utils (CPAN RT#68898)
  171. - Perl::Critic::Violation source() method now returns the line containing
  172. the violation (not the first line) when the statement containing the
  173. violation spans multiple lines
  174. - this release by THALJEF -> update source URL
  175. - drop stopwords patch, now included upstream
  176. * Fri Jul 22 2011 Paul Howarth <paul@city-fan.org> - 1.116-6
  177. - reinstate author tests: META.yml creation issue fixed in perl-5.14.1-182
  178. * Fri Jul 22 2011 Petr Sabata <contyk@redhat.com> - 1.116-5
  179. - completely disable author tests to avoid Kwalitee META complaints
  180. * Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 1.116-4
  181. - Perl mass rebuild
  182. * Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 1.116-3
  183. - Perl mass rebuild
  184. * Wed Jun 29 2011 Paul Howarth <paul@city-fan.org> - 1.116-2
  185. - move BR: perl(Test::Perl::Critic) to author test section where it belongs
  186. - run the author tests if we're not bootstrapping
  187. * Mon May 16 2011 Paul Howarth <paul@city-fan.org> - 1.116-1
  188. - update to 1.116
  189. - BuiltInFunctions::ProhibitLvalueSubstr does not report violations if the
  190. document contains an explicit 'use n.nnn;' where the version is before
  191. 5.005 (CPAN RT#59112)
  192. - Documentation::RequirePodSections no longer blows up on code having POD but
  193. no =head1 (CPAN RT#67231)
  194. - RegularExpressions::ProhibitUnusedCapture should more reliably find things
  195. like s/(a)/${1}2/ (CPAN RT#67273)
  196. - ValuesAndExpressions::ProhibitMagicNumbers and Module::RequireVersionVar
  197. now treat versions passed as the second argument of a 'package' statement
  198. the same as versions declared as 'our $VERSION ...' (CPAN RT#67159)
  199. - Variables::RequireLexicalLoopIterators does not report violations if the
  200. document contains an explicit 'use n.nnn;' where the version is before
  201. 5.004 (CPAN RT#67760)
  202. * Fri Apr 1 2011 Paul Howarth <paul@city-fan.org> - 1.115-1
  203. - update to 1.115
  204. - fatal error in RegularExpressions::ProhibitUnusedCapture here document
  205. check (CPAN RT#67116)
  206. - internal POD error in Documentation::RequirePodLinksIncludeText
  207. (CPAN RT#67012)
  208. * Tue Mar 29 2011 Paul Howarth <paul@city-fan.org> 1.114-1
  209. - update to 1.114
  210. - Documentation::RequirePodLinksIncludeText now handles nested POD formatting
  211. (CPAN RT#65569)
  212. - clarified relation of severity numbers to names in Perl::Critic POD
  213. (CPAN RT#66017)
  214. - removed caveats from Variables::RequireLocalizedPunctuationVars, no longer
  215. necessary with PPI 1.208 (CPAN RT#65514)
  216. - have InputOutput::RequireBriefOpen attempt to expand scope as necessary to
  217. deal with the case where the open() and the corresponding close() are not
  218. in the same scope (CPAN RT#64437)
  219. - RegularExpressions::ProhibitUnusedCapture now looks inside double-quotish
  220. things (CPAN RT#38942)
  221. - RegularExpressions::ProhibitUnusedCapture now takes logical alternation
  222. into account, so that (e.g.)
  223. if ( /(a)/ || /(b)/ ) {
  224. say $1;
  225. }
  226. is not a violation (CPAN RT#38942)
  227. - ValuesAndExpressions::ProhibitCommaSeparatedStatements now recognizes
  228. 'return { foo => 1, bar => 2 }' as containing a hash constructor, not a
  229. block; this was fixed by PPI 1.215 (CPAN RT#61301)
  230. - ValuesAndExpressions::ProhibitCommaSeparatedStatements now recognizes
  231. 'bless { foo => 1, bar => 2 }' as containing a hash constructor, not a
  232. block; this was fixed by PPI 1.215 (CPAN RT#64132)
  233. - bump PPI version requirement to 1.215
  234. - BR/R: perl(Pod::Parser)
  235. - BR/R: optional modules perl(Readonly::XS), perl(Term::ANSIColor) >= 2.02
  236. - BR: perl(Pod::Spell) >= 1
  237. - BR: perl(Text::ParseWords) >= 3
  238. - add runtime deps for optional modules perl(File::HomeDir), perl(File::Which)
  239. - drop redundant (for modern rpm) BuildRoot tag and buildroot cleaning
  240. - split Test::Perl::Critic::Policy off into its own package
  241. - add dependency on aspell for Perl::Critic::Policy::Documentation::PodSpelling
  242. - add version 1.889 requirement for perl(Email::Address)
  243. - add version 0.19 requirement for perl(List::MoreUtils)
  244. - add version 0.010 requirement for perl(PPIx::Regexp)
  245. - add version 1.001 requirement for perl(PPIx::Utilities::Statement)
  246. - add version 0.77 requirement for perl(version)
  247. - drop unused buildreq perl(Test::Spelling)
  248. - drop bogus buildreqs perl(lib) and perl(base)
  249. - add option for building with author tests enabled (--with authortests)
  250. - add patch with words not in Fedora dictionaries for spell check tests
  251. - split buildreqs into separate sections for build process, the module, the
  252. main test suite and the author tests
  253. * Mon Mar 7 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.113-1
  254. - update to 1.113
  255. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.111-2
  256. - rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  257. * Mon Jan 3 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.111-1
  258. - update
  259. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.108-2
  260. - rebuild to fix problems with vendorarch/lib (#661697)
  261. * Fri Aug 6 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.108-1
  262. - update
  263. * Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.105-4
  264. - mass rebuild with perl-5.12.0
  265. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.105-3
  266. - rebuild against perl 5.10.1
  267. * Wed Nov 25 2009 Stepan Kasal <skasal@redhat.com> - 1.105-2
  268. - use the new filtering macros (verified that the resulting provides
  269. and requires are the same)
  270. - add version to perl(PPI) require (#541020)
  271. * Wed Oct 7 2009 Stepan Kasal <skasal@redhat.com> - 1.105-1
  272. - new upstream version
  273. - update build requires
  274. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.098-3
  275. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  276. * Sun May 17 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.098-1
  277. - "neaten" filtering
  278. - auto-update to 1.098 (by cpan-spec-update 0.01)
  279. - added a new br on perl(strict) (version 0)
  280. - added a new br on perl(Scalar::Util) (version 0)
  281. - added a new br on perl(File::Temp) (version 0)
  282. - added a new br on perl(Pod::Usage) (version 0)
  283. - added a new br on perl(File::Find) (version 0)
  284. - added a new br on perl(PPI::Token::Whitespace) (version 1.203)
  285. - added a new br on perl(charnames) (version 0)
  286. - added a new br on perl(PPI::Document::File) (version 1.203)
  287. - added a new br on perl(File::Spec::Unix) (version 0)
  288. - added a new br on perl(List::Util) (version 0)
  289. - added a new br on perl(lib) (version 0)
  290. - added a new br on perl(Getopt::Long) (version 0)
  291. - added a new br on perl(Exporter) (version 0)
  292. - added a new br on perl(Test::More) (version 0)
  293. - added a new br on perl(overload) (version 0)
  294. - added a new br on perl(base) (version 0)
  295. - added a new br on perl(version) (version 0)
  296. - added a new br on perl(Carp) (version 0)
  297. - added a new br on perl(warnings) (version 0)
  298. - added a new br on perl(PPI::Document) (version 1.203)
  299. - added a new br on perl(File::Basename) (version 0)
  300. - added a new br on perl(PPI::Token::Quote::Single) (version 1.203)
  301. - added a new br on perl(File::Spec) (version 0)
  302. - added a new br on perl(File::Path) (version 0)
  303. - added a new br on perl(Pod::PlainText) (version 0)
  304. - added a new br on perl(Pod::Select) (version 0)
  305. - added a new br on perl(PPI::Node) (version 1.203)
  306. - added a new br on perl(English) (version 0)
  307. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.092-2
  308. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  309. * Mon Sep 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.092-1
  310. - update to 1.092
  311. * Sun Mar 09 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.082-1
  312. - update to 1.082
  313. - resolve BZ#431577
  314. - add t/ examples/ extras/ tools/, and filter
  315. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-3
  316. - Rebuild for perl 5.10 (again)
  317. * Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-2
  318. - add missing BR: perl-Exception-Class
  319. * Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.080-1
  320. - bump to 1.080
  321. * Mon Jan 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.053-2
  322. - rebuild for new perl
  323. * Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.053-1
  324. - Update to 1.053.
  325. * Tue Mar 20 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
  326. - Update to 1.05.
  327. * Thu Feb 15 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
  328. - Update to 1.03.
  329. * Fri Jan 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-2
  330. - Bumping release (forgot to commit sources and .cvsignore changes).
  331. * Fri Jan 26 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.01-1
  332. - Update to 1.01.
  333. - New build requirement: perl(Test::Memory::Cycle).
  334. * Thu Jan 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.23-2
  335. - perl(Set::Scalar) is no longer required.
  336. * Wed Jan 24 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.23-1
  337. - Update to 0.23.
  338. - New requirement: perl(B::Keywords).
  339. - Author tests coverage improved.
  340. * Sun Dec 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-2
  341. - Enabled author tests.
  342. - BR perl(HomeDir).
  343. * Sun Dec 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.22-1
  344. - Update to 0.22.
  345. * Sat Nov 11 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.21-1
  346. - Update to 0.21.
  347. - New BR: perl(Set::Scalar).
  348. * Sat Sep 16 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.2-1
  349. - First build.