perl-Test-Differences-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130
  1. # RPM version needs 4 digits after the decimal to preserve upgrade path
  2. %global module_version 0.500
  3. %global RPM_version %(echo %{module_version} | %{__perl} -pi -e 's/(.*)/sprintf("%.4f", $1)/e')
  4. Name: perl-Test-Differences
  5. Version: %{RPM_version}
  6. Release: 1%{?_dist_release}
  7. Summary: Test strings and data structures and show differences if not OK
  8. Group: Development/Libraries
  9. License: GPL+ or Artistic
  10. URL: http://search.cpan.org/dist/Test-Differences/
  11. Source0: http://search.cpan.org/CPAN/authors/id/O/OV/OVID/Test-Differences-%{module_version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. BuildArch: noarch
  14. BuildRequires: perl(Text::Diff) >= 0.35
  15. BuildRequires: perl(ExtUtils::MakeMaker)
  16. BuildRequires: perl(Test::More)
  17. BuildRequires: perl(Test::Pod)
  18. BuildRequires: perl(Test::Pod::Coverage)
  19. # not detected
  20. Requires: perl(Text::Diff) >= 0.35
  21. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  22. %description
  23. When the code you're testing returns multiple lines, records or data
  24. structures and they're just plain wrong, an equivalent to the Unix
  25. diff utility may be just what's needed.
  26. %prep
  27. %setup -q -n Test-Differences-%{module_version}
  28. %build
  29. %{__perl} Makefile.PL INSTALLDIRS=vendor
  30. make %{?_smp_mflags}
  31. %install
  32. rm -rf %{buildroot}
  33. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  34. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  35. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  36. chmod -R u+w %{buildroot}/*
  37. %check
  38. make test
  39. %clean
  40. rm -rf %{buildroot}
  41. %files
  42. %defattr(-,root,root,-)
  43. %doc Changes README
  44. %{perl_vendorlib}/Test/
  45. %{_mandir}/man3/Test::Differences.3pm*
  46. %changelog
  47. * Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5000-1
  48. - initial build for Vine Linux
  49. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5000-6
  50. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  51. * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.5000-5
  52. - Perl mass rebuild
  53. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5000-4
  54. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  55. * Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.5000-3
  56. - 661697 rebuild for fixing problems with vendorach/lib
  57. * Thu Jul 08 2010 Iain Arnell <iarnell@gmail.com> 0.500-2
  58. - explicitly require perl(Text::Diff)
  59. * Tue Jun 29 2010 Paul Howarth <paul@city-fan.org> - 0.5000-1
  60. - Update to 0.500
  61. - Add support for all diff styles supplied by Text::Diff (CPAN RT#23579)
  62. - Add Build.PL
  63. - Convert to universally use Test::More instead of Test
  64. - Convert to modern Perl distribution.
  65. - Applied doc suggestion from CPAN RT#24297
  66. - Fix the { a => 1 } versus { a => '1' } bug (CPAN RT#3029)
  67. - Upstream dropped eg/ docs
  68. - Bump perl(Text::Diff) requirement to 0.35
  69. - BR: perl(Test::Pod) and perl(Test::Pod::Coverage) for extra test cover
  70. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.4801-5
  71. - Mass rebuild with perl-5.12.0
  72. * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 0.4801-4
  73. - rebuild against perl 5.10.1
  74. * Wed Aug 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4801-3
  75. - fix source url
  76. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4801-2
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  78. * Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4801-1
  79. - update to 0.4801
  80. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.47-5
  81. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  82. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-4
  83. - Rebuild for perl 5.10 (again)
  84. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-3
  85. - rebuild for new perl
  86. * Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-2.2
  87. - add BR: perl(Test::More)
  88. * Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-2.1
  89. - correct license tag
  90. - add BR: perl(ExtUtils::MakeMaker)
  91. * Sun May 14 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.47-2
  92. - Bumping release (repodata checksum inconsistency for previous release).
  93. * Mon May 01 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.47-1
  94. - First build.