phonon-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203
  1. %define qt4_ver 4.8.0
  2. # Qt4 version auto-detection
  3. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  4. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
  5. %define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix})
  6. %global pulseaudio_version %(pkg-config --modversion libpulse 2>/dev/null || echo 0.9.15)
  7. Name: phonon
  8. Summary: Multimedia framework api
  9. Summary(ja): マルチメディアフレームワーク API
  10. Version: 4.6.0
  11. Release: 1%{?_dist_release}
  12. Group: System Environment/Libraries
  13. License: LGPLv2+
  14. URL: http://phonon.kde.org/
  15. Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.6.0/src/phonon-%{version}.tar.xz
  16. Patch1: phonon-4.4.4-no_rpath.patch
  17. ## upstreamable patches
  18. # phonon_backend ... could not be loaded
  19. # http://bugzilla.redhat.com/760039
  20. Patch50: phonon-4.5.57-plugindir.patch
  21. ## Upstream patches
  22. ## Vine patches
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: automoc4 >= 0.9.86
  25. BuildRequires: cmake >= 2.6.2
  26. BuildRequires: glib2-devel
  27. BuildRequires: libqzeitgeist-devel
  28. BuildRequires: libxcb-devel
  29. BuildRequires: libxml2-devel
  30. BuildRequires: qt4-devel >= 4.6.0
  31. BuildRequires: openssl-devel
  32. BuildRequires: pulseaudio-libs-devel >= 0.9.15
  33. # TODO: enable the following Requires in next release
  34. Requires: phonon-backend >= 4.4
  35. Requires: pulseaudio-libs >= %{pulseaudio_version}
  36. Requires: qt4 >= %{_qt4_version}
  37. %description
  38. Phonon is a cross-platform portable Multimedia Support Abstraction,
  39. which allows you to play multiple audio or video formats with the same
  40. quality on all platforms, no matter which underlying architecture is
  41. used.
  42. %package devel
  43. Summary: Development files for phonon
  44. Summary(ja): phonon の開発用ファイル
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. Requires: qt4-devel >= %{_qt4_version}
  48. %description devel
  49. Header files for developing applications using phonon
  50. %prep
  51. %setup -q
  52. %patch1 -p1 -b .no_rpath
  53. %patch50 -p1 -b .plugindir
  54. %build
  55. %ifarch x86_64
  56. PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
  57. %endif
  58. mkdir -p %{_target_platform}
  59. pushd %{_target_platform}
  60. %cmake \
  61. -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=ON \
  62. ..
  63. popd
  64. make %{?_smp_mflags} -C %{_target_platform}
  65. %install
  66. rm -rf $RPM_BUILD_ROOT
  67. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  68. # symlink for qt/phonon compatibility
  69. ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
  70. # own these dirs
  71. mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend/
  72. mkdir -p $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends/
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %post -p /sbin/ldconfig
  76. %postun -p /sbin/ldconfig
  77. %files
  78. %defattr(-,root,root)
  79. %doc COPYING.LIB
  80. %{_libdir}/*.so.*
  81. %{_qt4_plugindir}/designer/*.so
  82. %{_datadir}/dbus-1/interfaces/*
  83. # kde4-specific dirs
  84. %dir %{_libdir}/kde4/plugins/phonon_backend
  85. %dir %{_datadir}/kde4/services/phononbackends
  86. %files devel
  87. %defattr(-,root,root)
  88. %dir %{_includedir}/KDE
  89. %{_includedir}/KDE/Phonon/
  90. %{_includedir}/phonon/
  91. %{_libdir}/*.so
  92. %dir %{_libdir}/cmake/
  93. %{_libdir}/cmake/phonon/
  94. %{_libdir}/pkgconfig/*.pc
  95. %{_datadir}/phonon/buildsystem/
  96. %{_qt4_datadir}/mkspecs/modules/qt_phonon.pri
  97. %changelog
  98. * Sat Jan 7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
  99. - new upstream release
  100. * Sat Nov 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
  101. - new upstream release
  102. * Sat Oct 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
  103. - added Patch100 and 200 to build with pulseaudio-1.0
  104. * Sun Jun 5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  105. - new upstream release
  106. - added BR: libqzeitgeist-devel
  107. * Tue Mar 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-2
  108. - rebuilt with qt4-4.7.2
  109. * Sat Jan 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-1
  110. - new upstream release
  111. - rebuilt with qt4-4.7.1 on VineSeed
  112. * Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.3-1
  113. - new upstream release
  114. * Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
  115. - added sybolic link in %%{_qt4_headerdir}
  116. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  117. - new upstream release
  118. - dropt Patch51 and 57
  119. - rebuilt with rpm-4.8.1
  120. * Sat Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
  121. - new upstream release
  122. - dropt Patch1, 50, 54 and 100
  123. - added Patch57
  124. * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
  125. - F11: patch/modularize pa device-manager bits
  126. * Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
  127. - added qmake path to PATH (if x86_64)
  128. * Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
  129. - new upstream release
  130. - built with new toolchain
  131. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
  132. - added Patch102 and 103 from FC
  133. * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
  134. - fix for '#' in filenames
  135. * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
  136. - restore patches to the xine backend
  137. * Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
  138. - added Patch100 and 101 from FC
  139. * Tue Mar 3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
  140. - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
  141. - added backend sub-pakcages
  142. * Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
  143. - new upstream release
  144. - add BuildPrereq: cmake
  145. * Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
  146. - new upstream release
  147. * Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
  148. - new upstream release
  149. - update %%files
  150. - add BuildPrereq: xine-lib-devel libxcb-devel
  151. * Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
  152. - new upstream release
  153. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
  154. - added script to append qmake path
  155. - added option -DLIB_INSTALL_DIR at cmake
  156. * Tue Oct 7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
  157. - initial release for VineSeed