pth-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173
  1. Summary: The GNU Portable Threads library
  2. Name: pth
  3. Version: 2.0.7
  4. Release: 7%{?_dist_release}
  5. License: LGPLv2+
  6. Group: System Environment/Libraries
  7. URL: http://www.gnu.org/software/pth/
  8. Source: ftp://ftp.gnu.org/gnu/pth/pth-%{version}.tar.gz
  9. Source1: ftp://ftp.gnu.org/gnu/pth/pth-%{version}.tar.gz.sig
  10. Patch1: pth-2.0.7-dont-remove-gcc-g.patch
  11. Patch2: pth-2.0.7-config-script.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. %description
  14. Pth is a very portable POSIX/ANSI-C based library for Unix platforms
  15. which provides non-preemptive priority-based scheduling for multiple
  16. threads of execution ("multithreading") inside server applications.
  17. All threads run in the same address space of the server application,
  18. but each thread has it's own individual program-counter, run-time
  19. stack, signal mask and errno variable.
  20. %package devel
  21. Summary: Development headers and libraries for GNU Pth
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. %description devel
  25. Development headers and libraries for GNU Pth.
  26. %prep
  27. %setup -q
  28. %patch1 -p1 -b .dont-remove-gcc-g
  29. %patch2 -p1 -b .config-script
  30. %build
  31. %configure --disable-static ac_cv_func_sigstack='no'
  32. # Work around multiarch conflicts in the pth-config script in order
  33. # to complete patch2. Make the script choose between /usr/lib and
  34. # /usr/lib64 at run-time.
  35. if [ "%_libdir" == "/usr/lib64" ] ; then
  36. if grep -e '^pth_libdir="/usr/lib64"' pth-config ; then
  37. sed -i -e 's!^pth_libdir="/usr/lib64"!pth_libdir="/usr/lib"!' pth-config
  38. else
  39. echo "ERROR: Revisit the multiarch pth_libdir fixes for pth-config!"
  40. exit 1
  41. fi
  42. fi
  43. if grep -e "$RPM_OPT_FLAGS" pth-config ; then
  44. # Remove our extra CFLAGS from the pth-config script, since they
  45. # don't belong in there.
  46. sed -i -e "s!$RPM_OPT_FLAGS!!g" pth-config
  47. else
  48. echo "ERROR: Revisit the multiarch CFLAGS fix for pth-config!"
  49. exit 1
  50. fi
  51. # this is necessary; without it make -j fails
  52. make pth_p.h
  53. make %{?_smp_mflags}
  54. %check
  55. make test
  56. l=$($(pwd)/pth-config --libdir)
  57. %ifarch x86_64 ppc64
  58. [ "$l" == "/usr/lib64" ]
  59. %endif
  60. %install
  61. rm -rf $RPM_BUILD_ROOT
  62. make DESTDIR=${RPM_BUILD_ROOT} install
  63. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  64. %clean
  65. rm -rf $RPM_BUILD_ROOT
  66. %post -p /sbin/ldconfig
  67. %postun -p /sbin/ldconfig
  68. %files
  69. %defattr(-,root,root,-)
  70. %doc ANNOUNCE AUTHORS COPYING ChangeLog HISTORY NEWS PORTING README
  71. %doc SUPPORT TESTS THANKS USERS
  72. %{_libdir}/*.so.*
  73. %files devel
  74. %defattr(-,root,root,-)
  75. %doc HACKING
  76. %{_bindir}/*
  77. %{_includedir}/*
  78. %{_libdir}/*.so
  79. %{_mandir}/*/*
  80. %{_datadir}/aclocal/*
  81. %changelog
  82. * Wed Sep 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.7-7
  83. - initial build for VineSeed
  84. * Sat May 31 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-7
  85. - Drop "|| :" from check section. It failed to build for mdomsch
  86. in Rawhide today.
  87. * Fri Feb 08 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-6
  88. - rebuilt for GCC 4.3 as requested by Fedora Release Engineering
  89. * Sun Oct 21 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-5
  90. - Patch pth-config.
  91. This shall fix the multiarch conflict in pth-devel (#342961).
  92. It must not return -I/usr/include and -L/usr/{lib,lib64} either,
  93. since these are default search paths already.
  94. - Replace the config.status CFLAGS sed expr with a patch.
  95. * Tue Aug 21 2007 Michael Schwendt <mschwendt@fedoraproject.org>
  96. - rebuilt
  97. * Thu Aug 2 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-2
  98. - Clarify licence (LGPLv2+).
  99. * Sat Nov 25 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.7-1
  100. - Update to 2.0.7 (very minor maintenance updates only).
  101. * Mon Aug 28 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-3
  102. - rebuilt
  103. * Mon May 22 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-2
  104. - Insert -g into CFLAGS after configure script removes it.
  105. - Disable configure check for obsolete sigstack(), which segfaults.
  106. * Thu Feb 16 2006 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.6-1
  107. - Update to 2.0.6.
  108. * Fri Oct 7 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.5-1
  109. - Update to 2.0.5.
  110. - Don't build static archive.
  111. * Fri May 13 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.4-3
  112. - rebuilt
  113. * Thu Apr 7 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 2.0.4-2
  114. - rebuilt
  115. * Thu Feb 24 2005 Michael Schwendt <mschwendt@fedoraproject.org> - 0:2.0.4-1
  116. - Update to 2.0.4.
  117. - Remove ancient changelog entries which even pre-date Fedora.
  118. * Tue Dec 14 2004 Michael Schwendt <mschwendt@fedoraproject.org> - 0:2.0.3-1
  119. - Update to 2.0.3, minor and common spec adjustments + LGPL, %%check,
  120. use URLs for official GNU companion sites.
  121. * Thu Oct 07 2004 Adrian Reber <adrian@lisas.de> - 0:2.0.2-0.fdr.2
  122. - iconv-ing spec to utf8
  123. * Wed Oct 06 2004 Adrian Reber <adrian@lisas.de> - 0:2.0.2-0.fdr.1
  124. - Update to 2.0.2 and current Fedora guidelines.
  125. - added workaround for make -j problem
  126. * Sat Mar 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.0.0-0.fdr.1
  127. - Update to 2.0.0 and current Fedora guidelines.
  128. - Exclude %%{_libdir}/*.la
  129. * Fri Feb 7 2003 Ville Skyttä <ville.skytta at iki.fi> - 1.4.1-1.fedora.1
  130. - First Fedora release, based on Ryan Weaver's work.
  131. - Move (most of) docs to main package.