python-pyrex-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. %define python_sitelib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(0)')
  2. %define packagename Pyrex
  3. Name: python-pyrex
  4. Version: 0.9.9
  5. Release: 2%{?_dist_release}
  6. BuildArch: noarch
  7. Summary: A compiler/language for writing Python extension modules.
  8. Group: Development/Languages
  9. License: Public Domain
  10. URL: http://www.cosc.canterbury.ac.nz/~greg/python/%{packagename}/
  11. Source0: http://www.cosc.canterbury.ac.nz/~greg/python/%{packagename}/%{packagename}-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. BuildRequires: python-devel
  14. BuildRequires: nkf
  15. BuildRequires: findutils
  16. Requires: python-devel
  17. %description
  18. Pyrex is Python with C types. It is specially designed to allow you to
  19. write extension modules for Python that have the speed of C and the
  20. simplicity and readability of Python. You write your code in a Python-like
  21. language with C-typed variables, then use the pyrexc compiler to transform
  22. it into a C representation. This is useful for speeding up critical sections
  23. of your Python code or wrapping an external library.
  24. Please see the documentation for how to get the best performance from your
  25. code.
  26. %prep
  27. %setup -q -n %{packagename}-%{version}
  28. %build
  29. python setup.py build
  30. # Remove some Macintosh-isms
  31. find . -name '.DS_Store' -exec rm -f \{\} \;
  32. for i in CHANGES.txt ToDo.txt Demos/Makefile.nodistutils Tools/*
  33. do
  34. nkf -Lu --in-place $i
  35. done
  36. find Doc -type f | xargs nkf -Lu --in-place
  37. %install
  38. rm -rf $RPM_BUILD_ROOT
  39. python setup.py install --skip-build --root $RPM_BUILD_ROOT
  40. %clean
  41. rm -rf $RPM_BUILD_ROOT
  42. %files
  43. %defattr(-,root,root,-)
  44. %doc USAGE.txt README.txt CHANGES.txt ToDo.txt Demos Doc Tools
  45. %{python_sitelib}/Pyrex*
  46. %exclude %{python_sitelib}/Pyrex/Mac
  47. %{_bindir}/pyrexc
  48. %changelog
  49. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-2
  50. - rebuild with python-2.7.2
  51. * Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-1
  52. - new upstream release
  53. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8.4-2
  54. - rebuild with python-2.6
  55. * Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8.4
  56. - new upstream release
  57. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.9.3-1vl5
  58. - rebuilt with python-2.5.2
  59. - added pythonlib macro
  60. - applied new versioning policy
  61. * Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3-0vl1
  62. - initial build for Vine Linux
  63. * Tue Mar 22 2005 Jeremy Katz <katzj@redhat.com> - 0.9.3-0
  64. - update to 0.9.3
  65. - add patch to fix generated code to build with gcc4
  66. - require python-abi and python-devel instead of conflicting with
  67. newer python-devel
  68. * Mon Nov 8 2004 Jeremy Katz <katzj@redhat.com> - 0:0.9.2.1-3
  69. - rebuild against python 2.4
  70. * Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9.2.1-2
  71. - Added Steve Grubb's spec file patch (RH Bug #130200)
  72. * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9.2.1-1
  73. - New upstream version
  74. - Pyrex-0.9-split-base-types.patch synced for new version
  75. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  76. - rebuilt
  77. * Fri Jun 03 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-5
  78. - Built to rawhide
  79. * Wed May 19 2004 Florian La Roche <Florian.LaRoche@redhat.de>
  80. - use rpm macros to determine lib64 usage
  81. * Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-3
  82. - Added Pyrex-0.9-split-base-types.patch which fixes
  83. long unsigned int bug showing up in dbus python binding
  84. builds for the x86_64 arch
  85. - Added regex hack to spec to work around a bug in python's
  86. distutils which would install files into /usr/lib instead of
  87. /usr/lib64 on 64 bit archs
  88. * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-2
  89. - Was informed that the epoch change was not needed so the epoch
  90. was reverted back to 0
  91. * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> - 1:0.9-1
  92. - Upped the epoch so as to avoid clashes with the Fedora extra package
  93. * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> - 0:0.9-1
  94. - Transfered to Red Hat Fedora's main tree
  95. - Removed need for LONG_LONG patch
  96. * Mon Feb 02 2004 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.4
  97. - Removed the site-packages directory from the directories owned by the
  98. package
  99. * Mon Feb 02 2004 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.3
  100. - My mistake: rpm automatically removes %%ghost files, no need to script
  101. it manually.
  102. - python distutils --record=FILE option doesn't record directories so include
  103. the site-packages/[directories] manually
  104. * Thu Jan 15 2003 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.2
  105. - Merge changes from Michel Alexandre Salim <salimma[AT]users.sf.net>
  106. + Require build system's python version because directories are named
  107. pythonX.Y
  108. + Create *.pyo files and %ghost them (Privleged user with python optimize
  109. turned on may generate them, but they aren't needed for operation.
  110. + Do not include the Mac Pyrex compiler stuff
  111. + Change license to Public Domain
  112. - Script to remove any %%ghost files on package removal
  113. - Patch around an incompatible change between python 2.2 and python 2.3's
  114. definition of LONG_LONG being renamed to PY_LONG_LONG
  115. * Fri Jan 09 2003 Toshio Kuratomi <toshio@tiki-lounge.com> - 0:0.9-0.fdr.1
  116. - Initial RPM release.