qoauth-vl.spec 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106
  1. %global githash 726325d
  2. %global gitdate 20100625
  3. #global posttag .%{?gitdate}git%{?githash}
  4. %define qt4_ver 4.8.0
  5. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  6. %define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  7. Name: qoauth
  8. Summary: Qt-based C++ library for OAuth authorization scheme
  9. Version: 1.0.1
  10. Release: 4%{?_dist_release}
  11. Group: System Environment/Libraries
  12. License: LGPLv2+
  13. URL: http://github.com/ayoy/qoauth
  14. Source0: http://files.ayoy.net/qoauth/release/%{version}/src/%{name}-%{version}-src.tar.bz2
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: qt4-devel qca2-devel doxygen
  17. BuildRequires: qca-ossl
  18. Requires: qca-ossl
  19. %description
  20. QOAuth is a Qt-based C++ implementation of an interface to services using
  21. OAuth authorization scheme.
  22. %package devel
  23. Summary: Development files for the Qt OAuth support library
  24. Group: Development/Libraries
  25. Requires: %{name} = %{version}-%{release}
  26. Requires: qt4-devel >= %{_qt4_version}
  27. Requires: qca2-devel
  28. %description devel
  29. The %{name}-devel package contains libraries, header files and documentations
  30. for developing applications that use QOAuth library.
  31. %prep
  32. %setup -q -n %{name}-%{version}-src
  33. sed -i -e '/^ *docs \\$/d' \
  34. -e "s!\(\$\${INSTALL_PREFIX}\)/lib.*!%{_libdir}!" src/src.pro
  35. sed -i -e 's\/lib\/%{_lib}\g' src/pcfile.sh
  36. %build
  37. export PATH=%{_qt4_prefix}/bin:$PATH
  38. %{_qt4_prefix}/bin/qmake PREFIX="%{_prefix}"
  39. make %{?_smp_mflags}
  40. %install
  41. make install INSTALL="install -p" INSTALL_ROOT=%{buildroot}
  42. doxygen Doxyfile
  43. # fix the time stamp
  44. for file in doc/html/*; do
  45. touch -r Doxyfile $file
  46. done
  47. %check
  48. make check || :
  49. %clean
  50. rm -rf %{buildroot}
  51. %post -p /sbin/ldconfig
  52. %postun -p /sbin/ldconfig
  53. %files
  54. %defattr(-,root,root,-)
  55. %doc README CHANGELOG LICENSE
  56. %{_libdir}/*.so.*
  57. %files devel
  58. %defattr(-,root,root,-)
  59. %doc doc/html doc/examples
  60. %{_libdir}/*.so
  61. %{_libdir}/*.prl
  62. %{_libdir}/pkgconfig/*.pc
  63. %{_qt4_datadir}/mkspecs/features/*.prf
  64. %{_includedir}/*
  65. %changelog
  66. * Mon Jan 9 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-4
  67. - rebuilt with qt-4.8.0
  68. * Tue Mar 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-3
  69. - rebuilt with qt4-4.7.2
  70. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.1-2
  71. - Initial build for Vine Linux
  72. * Sun Aug 08 2010 Chen Lei <supercyper@163.com> - 1.0.1-1
  73. - Update to 1.0.1
  74. * Fri Jun 25 2010 Chen Lei <supercyper@163.com> - 1.0.1-0.3.20100625git726325d
  75. - New upstream version
  76. * Tue Jun 22 2010 Chen Lei <supercyper@163.com> - 1.0.1-0.2.20100622git7f69e33
  77. - New upstream version
  78. - Add %%check section
  79. * Tue May 25 2010 Chen Lei <supercyper@163.com> - 1.0.1-0.1.20100525gitec7e4d5
  80. - initial rpm build