qtsoap-vl.spec 2.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394
  1. %define _qt4_ver 4.8.0
  2. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  3. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
  4. %define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  5. Name: qtsoap
  6. Summary: The Simple Object Access Protocol Qt-based client side library
  7. Version: 2.7
  8. Release: 4%{?_dist_release}
  9. Group: System Environment/Libraries
  10. License: LGPLv2 with exceptions or GPLv3
  11. URL: http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtsoap/
  12. Source0: http://get.qt.nokia.com/qt/solutions/lgpl/qtsoap-%{version}_1-opensource.tar.gz
  13. Patch0: qtsoap-2.7_1-opensource-install-pub-headers.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: qt4-devel
  16. %description
  17. The SOAP (Simple Object Access Protocol) library uses the XML standard
  18. for describing how to exchange messages. Its primary usage is to invoke web
  19. services and get responses from Qt-based applications.
  20. %package devel
  21. Summary: Development files for %{name}
  22. Summary(ja): %{name} の開発用ファイル
  23. Group: Development/Libraries
  24. Requires: %{name} = %{version}-%{release}
  25. Requires: qt4-devel >= %{_qt4_version}
  26. %description devel
  27. Development files for %{name}.
  28. %prep
  29. %setup -q -n qtsoap-%{version}_1-opensource
  30. # headers are not installed for shared library
  31. %patch0 -p1 -b .install-pub-headers
  32. sed -i 's:$$DESTDIR:%{_libdir}:g' buildlib/buildlib.pro
  33. %build
  34. # we want shared library
  35. echo "SOLUTIONS_LIBRARY = yes" > config.pri
  36. echo "QTSOAP_LIBNAME = \$\$qtLibraryTarget(qtsoap)" >> common.pri
  37. echo "VERSION=%{version}" >> common.pri
  38. qmake PREFIX=%{_prefix}
  39. make %{?_smp_mflags}
  40. %install
  41. rm -rf %{buildroot}
  42. make INSTALL_ROOT=%{buildroot} install
  43. %clean
  44. rm -rf %{buildroot}
  45. %post -p /sbin/ldconfig
  46. %postun -p /sbin/ldconfig
  47. %files
  48. %defattr(-,root,root,-)
  49. %doc README.TXT LGPL_EXCEPTION.txt LICENSE.GPL3 LICENSE.LGPL
  50. %{_libdir}/libqtsoap.so.*
  51. %files devel
  52. %defattr(-,root,root,-)
  53. %doc LGPL_EXCEPTION.txt LICENSE.GPL3 LICENSE.LGPL
  54. %{_libdir}/libqtsoap.so
  55. %{_qt4_headerdir}/QtSoap/
  56. %changelog
  57. * Sun Jan 8 2012 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> - 2.7-4
  58. - rebuilt with qt-4.8.0
  59. * Sat Jul 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.7-3
  60. - Initial build for Vine Linux
  61. * Thu Jul 14 2011 Jaroslav Reznik <jreznik@redhat.com> - 2.7-2
  62. - libqtsoap library name
  63. * Thu May 19 2011 Jaroslav Reznik <jreznik@redhat.com> - 2.7-1
  64. - fix version
  65. * Tue Oct 26 2010 Jaroslav Reznik <jreznik@redhat.com> - 1.7-1
  66. - Initial spec file