rabbitvcs-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305
  1. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  2. %global title RabbitVCS
  3. Summary: Integrated Subversion support for Nautilus
  4. Summary(ja): Subversion サポートを Nautilus に追加する拡張
  5. Name: rabbitvcs
  6. Version: 0.15.2
  7. Release: 3%{?_dist_release}
  8. Source0: http://rabbitvcs.googlecode.com/files/%{name}-%{version}.tar.bz2
  9. Source1: rabbitvcs-0.15.2-ja.po
  10. License: GPL
  11. Group: Development/Tools
  12. URL: http://rabbitvcs.org/
  13. BuildRequires: gettext
  14. BuildRequires: gtk2-devel
  15. BuildRequires: pygtk2-devel
  16. BuildRequires: python-devel
  17. Requires(post): gtk2
  18. Requires(postun): gtk2
  19. #BuildArch: noarch
  20. Obsoletes: rabbitvcs <= 0.14.2.1
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. Packager: kazutaka
  23. %description
  24. RabbitVCS is a set of graphical tools written to provide simple
  25. and straightforward access to the version control systems you use.
  26. This package containg core part of RabbitVCS and not connected
  27. to to any file manager or text editor.
  28. Front-ends or clients is privided separetely as a Nautilus
  29. extention, Thunar extention and Gedit plugin, and a command line
  30. utility.
  31. %description -l ja
  32. RabbitVCS はバージョン管理システムにシンプルかつ直感的にアクセス
  33. できるよう設計された GUI のツールです。
  34. このパッケージには RabbitVCS のコアとなる部分だけが含まれており、
  35. 特定のファイルマネージャやテキストエディタに依存しないようになっ
  36. ています。
  37. フロントエンドやクライアントは Nautilus 及び Thunar 用の拡張と、
  38. Gedit 用のプラグイン、そしてコマンドラインのユーティリティが、
  39. 別パッケージとして提供されています。
  40. %package core
  41. Summary: Core package of RabbitVCS
  42. Summary: RabbitVCS のコアパッケージ
  43. Group: Development/Tools
  44. Requires: dbus-python
  45. Requires: meld
  46. Requires: pygobject
  47. Requires: pygtk2
  48. Requires: pygtk2-libglade
  49. Requires: pysvn
  50. Requires: python-configobj
  51. Requires: python-dulwich
  52. Requires: subversion
  53. Obsoletes: rabbitvcs <= 0.14.2.1
  54. BuildArch: noarch
  55. #Requires: nautilus, pygtk2, python-configobj
  56. #Requires: pygobject, pygtk2-libglade
  57. #Requires: subversion, pysvn, python-simplejson
  58. %description core
  59. Contains packages shared between the RabbitVCS extensions.
  60. %package nautilus
  61. Summary: Nautilus extension for RabbitVCS
  62. Summary(ja): RabbitVCS の Nautilus 拡張
  63. Group: Development/Tools
  64. Requires: nautilus >= 2.22.0
  65. Requires: nautilus-python >= 0.7.0
  66. Requires: rabbitvcs-core = %{version}-%{release}
  67. Obsoletes: nautilussvn
  68. %description nautilus
  69. RabbitVCS is a set of graphical tools written to provide simple
  70. and straightforward access to the version control systems you use.
  71. With this package, You can acces to the version control systems
  72. by Nautilus file manager.
  73. %description nautilus -l ja
  74. RabbitVCS はバージョン管理システムにシンプルかつ直感的にアクセス
  75. できるよう設計された GUI のツールです。
  76. このパッケージを利用することで、Nautilus ファイルマネージャに
  77. 統合された形でバージョン管理システムにアクセスできるようになり
  78. ます。
  79. %package thunar
  80. Summary: Thunar extension for RabbitVCS
  81. Summary(ja): RabbitVCS の Thunar 拡張
  82. Group: Development/Tools
  83. Requires: rabbitvcs-core = %{version}-%{release}
  84. Requires: Thunar >= 0.4.0
  85. Requires: thunarx-python >= 0.2.0
  86. %description thunar
  87. An extension for Thunar to allow better integration with the
  88. Subversion source control system.
  89. %package gedit
  90. Summary: Gedit extension for RabbitVCS
  91. Summary(ja): RabbitVCS の Gedit 拡張
  92. Group: Development/Tools
  93. Requires: rabbitvcs-core = %{version}-%{release}
  94. Requires: gedit
  95. %description gedit
  96. RabbitVCS is a set of graphical tools written to provide simple and
  97. straightforward access to the version control systems you use. This is the
  98. extension for gedit text editor
  99. %package cli
  100. Summary: CLI extension for RabbitVCS
  101. Summary(ja): RabbitVCS の CLI 拡張
  102. Group: Development/Tools
  103. Requires: rabbitvcs-core = %{version}-%{release}
  104. BuildArch: noarch
  105. %description cli
  106. RabbitVCS is a set of graphical tools written to provide simple and
  107. straightforward access to the version control systems you use. This is the
  108. extension for command line interface.
  109. %prep
  110. %setup -q
  111. %build
  112. %{__python} setup.py build
  113. %install
  114. %{__rm} -rf ${RPM_BUILD_ROOT}
  115. %{__python} setup.py install --skip-build --root ${RPM_BUILD_ROOT}
  116. # install nautilus client
  117. %if %{?_dist_release} == "vl6"
  118. %{__install} -d -m755 ${RPM_BUILD_ROOT}/%{_libdir}/nautilus/extensions-2.0/python/
  119. %{__install} -m644 clients/nautilus/RabbitVCS.py ${RPM_BUILD_ROOT}/%{_libdir}/nautilus/extensions-2.0/python/
  120. %else
  121. %{__install} -d -m755 ${RPM_BUILD_ROOT}/%{_datadir}/nautilus-python/extensions/
  122. %{__install} -m644 clients/nautilus-3.0/RabbitVCS.py ${RPM_BUILD_ROOT}/%{_datadir}/nautilus-python/extensions/
  123. %endif
  124. # Installing Thunar Extension
  125. mkdir -p $RPM_BUILD_ROOT%{_libdir}/thunarx-2/python/
  126. cp clients/thunar/%{title}.py $RPM_BUILD_ROOT%{_libdir}/thunarx-2/python/%{title}.py
  127. # Installing Gedit Extension
  128. %if %{?_dist_release} == "vl6"
  129. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gedit-2/plugins/
  130. cp clients/gedit/%{name}-plugin.py $RPM_BUILD_ROOT%{_libdir}/gedit-2/plugins/%{name}-plugin.py
  131. cp clients/gedit/%{name}-gedit2.gedit-plugin $RPM_BUILD_ROOT%{_libdir}/gedit-2/plugins/%{name}-gedit2.gedit-plugin
  132. %else
  133. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gedit/plugins/
  134. cp clients/gedit/%{name}-plugin.py $RPM_BUILD_ROOT%{_libdir}/gedit/plugins/%{name}-plugin.py
  135. cp clients/gedit/%{name}-gedit3.plugin $RPM_BUILD_ROOT%{_libdir}/gedit/plugins/%{name}-gedit3.plugin
  136. %endif
  137. # Installing CLI Extension
  138. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  139. cp clients/cli/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
  140. # install updated japanese translation
  141. msgfmt %{SOURCE1} -o ${RPM_BUILD_ROOT}/%{_localedir}/ja/LC_MESSAGES/RabbitVCS.mo
  142. %clean
  143. %{__rm} -rf ${RPM_BUILD_ROOT}
  144. %post
  145. touch --no-create %{_datadir}/icons/hicolor
  146. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  147. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  148. fi
  149. %postun
  150. touch --no-create %{_datadir}/icons/hicolor
  151. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  152. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  153. fi
  154. %files core
  155. %defattr(-, root, root, -)
  156. %doc %{_datadir}/doc/%{name}/
  157. %{python_sitelib}/%{name}/
  158. %{python_sitelib}/%{name}-%{version}-py?.?.egg-info
  159. %{_datadir}/icons/hicolor/16x16/actions/
  160. %{_datadir}/icons/hicolor/scalable/actions/
  161. %{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
  162. %{_datadir}/icons/hicolor/scalable/apps/%{name}-small.svg
  163. %{_datadir}/icons/hicolor/scalable/emblems/
  164. %{_datadir}/locale/
  165. %{_datadir}/%{name}/configspec.ini
  166. # only usefull for ubuntu (and debian??)
  167. #%exclude %{_datadir}/%{name}/do-rabbitvcs-restart-nautilus
  168. #%exclude %{_datadir}/%{name}/rabbitvcs-restart-required.update-notifier
  169. %files nautilus
  170. %defattr(-, root, root, -)
  171. %doc clients/nautilus/README
  172. %if %{?_dist_release} == "vl6"
  173. %{_libdir}/nautilus/extensions-2.0/python/RabbitVCS.py
  174. %else
  175. %{_datadir}/nautilus-python/extensions/RabbitVCS.py
  176. %endif
  177. %files thunar
  178. %defattr(-, root, root,-)
  179. %{_libdir}/thunarx-2/python/%{title}.py*
  180. %files gedit
  181. %defattr(-, root, root,-)
  182. %if %{?_dist_release} == "vl6"
  183. %{_libdir}/gedit-2/plugins/%{name}-plugin.py*
  184. %{_libdir}/gedit-2/plugins/%{name}-gedit2.gedit-plugin
  185. %else
  186. %{_libdir}/gedit/plugins/%{name}-plugin.py*
  187. %{_libdir}/gedit/plugins/%{name}-gedit3.plugin
  188. %endif
  189. %files cli
  190. %defattr(-, root, root,-)
  191. %{_bindir}/%{name}
  192. %changelog
  193. * Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.15.2-3
  194. - updated japanese translation (Source1)
  195. * Sun Oct 21 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.15.2-2
  196. - updated japanese translation (Source1)
  197. * Sun Oct 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.15.2-1
  198. - new upstream release
  199. - deleted conditional branch and macro for Vine 5
  200. - updated japanese translation (Source1)
  201. - set contitional branch for stable release and VineSeed for -gedit package
  202. * Tue Feb 21 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.15.0.5-2
  203. - rebuilt with python-2.7
  204. * Wed Feb 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.15.0.5-1
  205. - new upstream release
  206. - reorganized rabbitvcs-core, rabbitvcs-nautilus, rabbitvcs-thunar,
  207. rabbitvcs-gedit, rabbitvcs-cli
  208. - set contitional branch for stable release and VineSeed
  209. - added Require packages for rabbitvcs-core
  210. - added meld, pygobject, python-dulwich
  211. * Sun May 29 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.14.2.1-1
  212. - new upstream release
  213. - drop BuildArch: noarch to change installation path for RabbitVCS.py
  214. (need to locate under /usr/lib64 on x86_64)
  215. - add updated japanese translation (Source1)
  216. * Mon Jan 24 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.14.1.1-2
  217. - fix installation path of RabbitVCS.py
  218. - drop unnecessary Requires: glade2
  219. * Sun Jan 23 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.14.1.1-1
  220. - new upstream release
  221. - add Requires: python-simplejson
  222. - add Patch1 to avoid error when gtk+ < 2.18 (only for Vine 5)
  223. * Fri Jul 23 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.13.3-1
  224. - new upstream release
  225. - merge rabbitvcs-nautilus package again (upstream source change)
  226. - requires nautilus-python >= 0.7.0 for rabbitvcs-nautilus
  227. * Sun Feb 14 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 0.13-1
  228. - new upstream release
  229. - now front-end for nautilus is provided separetely
  230. (as rabbitvcs-nautilus package)
  231. * Wed Oct 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-1
  232. - new upstream release with new name
  233. - add Obsoletes: nautilussvn
  234. - drop source1 (japanese translation)
  235. - update description
  236. * Fri Jun 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-3.beta1.2
  237. - update japanese translation
  238. * Sat May 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-2.beta1.2
  239. - add japanese translation as Source1
  240. - add BuildRequires: gettext
  241. * Sat May 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12-1.beta1.2
  242. - initial build for Vine Linux