rhino-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279
  1. # Copyright (c) 2000-2005, JPackage Project
  2. # All rights reserved.
  3. #
  4. # Redistribution and use in source and binary forms, with or without
  5. # modification, are permitted provided that the following conditions
  6. # are met:
  7. #
  8. # 1. Redistributions of source code must retain the above copyright
  9. # notice, this list of conditions and the following disclaimer.
  10. # 2. Redistributions in binary form must reproduce the above copyright
  11. # notice, this list of conditions and the following disclaimer in the
  12. # documentation and/or other materials provided with the
  13. # distribution.
  14. # 3. Neither the name of the JPackage Project nor the names of its
  15. # contributors may be used to endorse or promote products derived
  16. # from this software without specific prior written permission.
  17. #
  18. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  19. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  20. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  21. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
  22. # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  23. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
  24. # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
  25. # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
  26. # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  27. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
  28. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  29. #
  30. %define cvs_version 1_7R2
  31. Name: rhino
  32. Summary: JavaScript for Java
  33. Version: 1.7
  34. Release: 0.r2.1%{?_dist_release}
  35. Group: Development/Libraries
  36. License: MPLv1.1 or GPLv2+
  37. URL: http://www.mozilla.org/rhino/
  38. Source0: ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino%{cvs_version}.zip
  39. Source2: %{name}.script
  40. #Patch0: %{name}-build.patch
  41. ## Patch to try several methods of loading jline library or fail gracefully
  42. #Patch1: %{name}-457336.diff
  43. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  44. BuildArch: noarch
  45. #BuildRequires: ant
  46. #BuildRequires: bea-stax-api
  47. #BuildRequires: java-1.6.0-openjdk-devel >= 1:1.6.0.0
  48. Requires: jpackage-utils
  49. Requires: jline
  50. # Disable xmlbeans until we can get it into Fedora
  51. #Requires: xmlbeans
  52. #BuildRequires: xmlbeans
  53. %description
  54. Rhino is an open-source implementation of JavaScript written entirely
  55. in Java. It is typically embedded into Java applications to provide
  56. scripting to end users.
  57. %description -l ja
  58. Rhino はすべてが Java で記述された JavaScript のオープンソースな実装です.
  59. 一般的には Java アプリケーションに組み込まれることで、エンドユーザーによる
  60. スクリプトの記述が可能になります.
  61. %package demo
  62. Summary: Examples for %{name}
  63. Group: Development/Libraries
  64. %description demo
  65. Examples for %{name}.
  66. #%package manual
  67. #Summary: Manual for %{name}
  68. #Group: Documentation
  69. #
  70. #%description manual
  71. #Documentation for %{name}.
  72. #%package javadoc
  73. #Summary: Javadoc for %{name}
  74. #Group: Development/Documentation
  75. #
  76. #%description javadoc
  77. #Javadoc for %{name}.
  78. %prep
  79. %setup -q -n %{name}%{cvs_version}
  80. #patch0 -p1
  81. #patch1 -p0 -b .jline
  82. # Fix build
  83. #{__perl} -pi -e 's|.*<get.*src=.*>\n||' build.xml testsrc/build.xml toolsrc/org/mozilla/javascript/tools/debugger/build.xml xmlimplsrc/build.xml
  84. # Fix manifest
  85. #{__perl} -pi -e 's|^Class-Path:.*\n||g' src/manifest
  86. # Add jpp release info to version
  87. #{__perl} -pi -e 's|^implementation.version: Rhino .* release .* \${implementation.date}|implementation.version: Rhino %{version} release %{release} \${implementation.date}|' build.properties
  88. %build
  89. #export CLASSPATH=
  90. #export OPT_JAR_LIST=:
  91. #ant -Dxbean.jar=$(build-classpath xmlbeans/xbean) \
  92. # -Djsr173.jar=$(build-classpath bea-stax-api) deepclean jar copy-all javadoc
  93. #pushd examples
  94. #export CLASSPATH=../build/%{name}%{cvs_version}/js.jar:$(build-classpath xmlbeans/xbean 2>/dev/null)
  95. #{javac} *.java
  96. #{jar} cvf ../build/%{name}%{cvs_version}/%{name}-examples-%{version}.jar *.class
  97. #popd
  98. %install
  99. rm -rf $RPM_BUILD_ROOT
  100. # jars
  101. mkdir -p $RPM_BUILD_ROOT%{_javadir}
  102. install -m 644 js.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
  103. #%{__cp} -a build/%{name}%{cvs_version}/%{name}-examples-%{version}.jar %{buildroot}%{_javadir}/%{name}-examples-%{version}.jar
  104. #(cd %{buildroot}%{_javadir} && %{__ln_s} %{name}-%{version}.jar js-%{version}.jar)
  105. (cd %{buildroot}%{_javadir} && for jar in *-%{version}*; do %{__ln_s} ${jar} `echo $jar| %{__sed} "s|-%{version}||g"`; done)
  106. # javadoc
  107. #%{__mkdir_p} %{buildroot}%{_javadocdir}/%{name}-%{version}
  108. #%{__cp} -a build/%{name}%{cvs_version}/javadoc/* %{buildroot}%{_javadocdir}/%{name}-%{version}
  109. #%{__ln_s} %{name}-%{version} %{buildroot}%{_javadocdir}/%{name}
  110. #%{_bindir}/find %{buildroot}%{_javadocdir}/%{name}-%{version} -type f -name '*.html' | %{_bindir}/xargs %{__perl} -pi -e 's/\r$//g'
  111. ## script
  112. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  113. install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
  114. # examples
  115. mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{name}
  116. cp -a examples/* $RPM_BUILD_ROOT%{_datadir}/%{name}
  117. %clean
  118. rm -rf $RPM_BUILD_ROOT
  119. %files
  120. %defattr(0644,root,root,0755)
  121. %doc LICENSE.txt
  122. %attr(0755,root,root) %{_bindir}/*
  123. %{_javadir}/*
  124. %files demo
  125. %defattr(0644,root,root,0755)
  126. %{_datadir}/%{name}
  127. #%files manual
  128. #%defattr(0644,root,root,0755)
  129. #%if 0
  130. #%doc build/%{name}%{cvs_version}/docs/*
  131. #%endif
  132. #files javadoc
  133. #defattr(0644,root,root,0755)
  134. #doc %{_javadocdir}/*
  135. %changelog
  136. * Wed Sep 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.7-0.r2.1
  137. - Initial build for VineLinux
  138. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.7-0.7.r2
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  140. * Sun May 31 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0:1.7-0.6.r2
  141. - Update to rhino1_7R2
  142. - Add patch from Steven Elliott to fix exception in the interpreter shell.
  143. * Mon Apr 20 2009 Lillian Angel <langel@redhat.com> - 0:1.7-0.4.r2pre.1.1
  144. - Added jpackage-utils requirement.
  145. - Resolves: rhbz#496435
  146. * Thu Mar 26 2009 Lillian Angel <langel@redhat.com> - 0:1.7-0.3.r2pre.1.1
  147. - Updated rhino-build.patch
  148. - License for treetable has been fixed. Re-included this code, and removed patch.
  149. - Resolves: rhbz#457336
  150. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.7-0.2.r2pre.1.1
  151. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  152. * Fri Feb 13 2009 Lillian Angel <langel@redhat.com> - 0:1.7-0.1.r2pre.1.1
  153. - Upgraded to 1.7r2pre.
  154. - Resolves: rhbz#485135
  155. * Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:1.6-0.1.r5.1.3
  156. - drop repotag
  157. - fix license tag
  158. * Thu Mar 15 2007 Matt Wringe <mwringe@redhat.com> 0:1.6-0.1.r5.1jpp.2
  159. - Remove script from build as the debugging tool is disabled due to it
  160. containing proprietary code from Sun.
  161. * Wed Mar 07 2007 Deepak Bhole <dbhole@redhat.com> 0:1.6-0.1.r5.1jpp.1
  162. - Upgrade to 1.6r5
  163. - Change release per Fedora guidelines
  164. - Disable dependency on xmlbeans (optional component, not in Fedora yet)
  165. - Disable building of debugger tool, as it needs confidential code from Sun
  166. - Remove post/postuns for javadoc and add the two dirs as %%doc
  167. * Wed Jun 14 2006 Ralph Apel <r.apel@r-apel.de> 0:1.6-0.r2.2jpp
  168. - Add bea-stax-api in order to build xmlimpl classes
  169. * Tue May 31 2006 Fernando Nasser <fnasser@redhat.com> 0:1.6-0.r2.1jpp
  170. - Upgrade to RC2
  171. * Mon Apr 24 2006 Fernando Nasser <fnasser@redhat.com> 0:1.6-0.r1.2jpp
  172. - First JPP 1.7 build
  173. * Thu Dec 02 2004 David Walluck <david@jpackage.org> 0:1.6-0.r1.1jpp
  174. - 1_6R1
  175. - add demo subpackage containing example code
  176. - add jpp release info to implementation version
  177. - add script to launch js shell
  178. - build E4X implementation (Requires: xmlbeans)
  179. - remove `Class-Path' from manifest
  180. * Tue Aug 24 2004 Fernando Nasser <fnasser@redhat.com> - 0:1.5-1.R5.1jpp
  181. - Update to 1.5R5.
  182. - Rebuild with Ant 1.6.2
  183. * Sat Jul 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.5-1.R4.1.1jpp
  184. - Update to 1.5R4.1.
  185. - Non-versioned javadoc dir symlink.
  186. * Fri Apr 11 2003 David Walluck <davdi@anti-microsoft.org> 0:1.5-0.R4.2jpp
  187. - remove build patches in favor of perl
  188. - add epoch
  189. * Sun Mar 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.r4.1jpp
  190. - Update to 1.5R4.
  191. - Rebuild for JPackage 1.5.
  192. * Wed May 08 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5-0.R3.1jpp
  193. - 1.5R3
  194. - versioned dir for javadoc
  195. * Sun Mar 10 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5-0.R2.9jpp
  196. - versioned compatibility symlink
  197. * Mon Jan 21 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5-0.R2.8jpp
  198. - section macro
  199. - new release scheme
  200. * Thu Jan 17 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-7jpp
  201. - spec cleanup
  202. - changelog corrections
  203. * Fri Jan 11 2002 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-6jpp
  204. - backward compatibility js.jar symlink
  205. - used original swing exemples archive
  206. - fixed javadoc empty package-list file
  207. - no dependencies for manual and javadoc packages
  208. * Sat Dec 1 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-5jpp
  209. - javadoc in javadoc package
  210. - fixed offline build
  211. * Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 1.5R2-4jpp
  212. - changed extension --> jpp
  213. * Sat Oct 6 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-3jpp
  214. - first unified release
  215. - s/jPackage/JPackage
  216. - corrected license to MPL
  217. * Sat Sep 15 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-2mdk
  218. - spec cleanup
  219. - standardized cvs references
  220. * Thu Aug 31 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-1mdk
  221. - first Mandrake release