speedbar-vl.spec 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  4. %define origname speedbar
  5. %define origver 0.14beta4
  6. %define release 1%{?_dist_release}
  7. Summary: Speedbar for Emacs
  8. name: %{origname}
  9. Version: %{origver}
  10. Release: %{release}
  11. Source0: http://prdownloads.sourceforge.net/cedet/%{name}-%{version}.tar.gz
  12. Source1: %{origname}-install.sh
  13. Source2: %{origname}-remove.sh
  14. License: GPL
  15. Group: Applications/Editors/Emacs
  16. URL: http://cedet.sourceforge.net/speedbar.shtml
  17. Vendor: Project Vine
  18. Packager: yoneda kenji <yoneda@n.isl.titech.ac.jp>
  19. Buildroot: %{_tmppath}/%{name}-%{version}-root
  20. BuildArchitectures: noarch
  21. PreReq: emacsen
  22. Requires: emacsen
  23. %prereq_ge emacsen-common
  24. %description
  25. Speedbar is an Emacs Lisp program which allows you to create a special
  26. skinny frame with a specialized directory listing in it. This listing
  27. will have both directories and filtered files in it. You can then load
  28. files into your emacs frame, or expand the files to display all the tags
  29. that are in them and jump to those tags. You can also expand multiple
  30. directories into your speedbar frame.
  31. %prep
  32. rm -rf $RPM_BUILD_ROOT
  33. %setup -q -n %{name}-%{version}
  34. %build
  35. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  36. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  37. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
  38. #mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
  39. #mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
  40. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
  41. mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
  42. mkdir -p $RPM_BUILD_ROOT%{_infodir}
  43. #touch $RPM_BUILD_ROOT%{_infodir}/dir
  44. ###
  45. # install el files
  46. cp -a Makefile *.el *.texi *.xpm Project.ede \
  47. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  48. ###
  49. # install info
  50. install -m0644 speedbar.info* ${RPM_BUILD_ROOT}%{_infodir}
  51. ###
  52. # install script( bytecompile el and install elc , remove )
  53. %_installemacsenscript %{origname} %{SOURCE1}
  54. %_removeemacsenscript %{origname} %{SOURCE2}
  55. %post
  56. ###
  57. # bytecompile and install
  58. if [ "$1" = 2 ]; then
  59. %_emacsenPackageRemove %{origname}
  60. fi
  61. %_addemacsenlist %{origname}
  62. %_emacsenPackageInstall %{origname}
  63. /sbin/install-info %{_infodir}/speedbar.info* %{_infodir}/dir \
  64. --section="Emacs"
  65. %preun
  66. if [ "$1" = 0 ]; then
  67. %_emacsenPackageRemove %{origname}
  68. %_removeemacsenlist %{origname}
  69. /sbin/install-info --delete %{_infodir}/speedbar.info* %{_infodir}/dir \
  70. --section="Emacs"
  71. fi
  72. %clean
  73. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  74. rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
  75. %files
  76. %defattr(-,root,root)
  77. %{_datadir}/emacs/site-lisp/%{origname}/
  78. #%{_libdir}/emacsen-common/packages/install/%{origname}
  79. #%{_libdir}/emacsen-common/packages/remove/%{origname}
  80. %{emacsen_pkgdir}/install/%{origname}
  81. %{emacsen_pkgdir}/remove/%{origname}
  82. %{_infodir}/speedbar.info*
  83. %changeLog
  84. * Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 0.14beta4-1vl5
  85. - applied new versioning policy
  86. - added macro %%emacsen_pkgdir
  87. * Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14beta4-0vl2
  88. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  89. * Mon Jul 22 2002 IWAI Masaharu <iwai@alib.jp> 0.14beta4-0vl1
  90. - emacsenize
  91. - update speedbar to version 0.14bera4
  92. * Tue Feb 20 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
  93. - (0.13a-0s)
  94. - 1st Release for Vine Linux 2.1
  95. * Fri Dec 15 2000 Shinya Ohnuma <a61051@cit.nihon-u.ac.jp>
  96. - (0.13a-0s)
  97. - 1st Release for Nishi Lab users.