stunnel-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460
  1. %define ver 4.54
  2. %define rel 1
  3. Summary: An SSL-encrypting socket wrapper
  4. Name: stunnel
  5. Version: %{ver}
  6. Release: %{rel}%{?_dist_release}
  7. License: GPLv2
  8. Group: Applications/Internet
  9. URL: https://www.stunnel.org/
  10. Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
  11. Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
  12. Source2: Certificate-Creation
  13. Source3: sfinger.xinetd
  14. Source4: stunnel-sfinger.conf
  15. Source5: pop3-redirect.xinetd
  16. Source6: stunnel-pop3s-client.conf
  17. Patch0: stunnel-4-authpriv.patch
  18. Patch1: stunnel-4-sample.patch
  19. Buildroot: %{_tmppath}/stunnel-root
  20. # util-linux is needed for rename
  21. BuildRequires: openssl-devel
  22. BuildRequires: pkgconfig
  23. BuildRequires: tcp_wrappers
  24. BuildRequires: util-linux
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: iwaim
  28. %description
  29. Stunnel is a socket wrapper which can provide SSL (Secure Sockets
  30. Layer) support to ordinary applications. For example, it can be used
  31. in conjunction with imapd to create an SSL secure IMAP server.
  32. %prep
  33. %setup -q
  34. %patch0 -p1 -b .authpriv
  35. %patch1 -p1 -b .sample
  36. iconv -f iso-8859-1 -t utf-8 < doc/stunnel.fr.8 > doc/stunnel.fr.8_
  37. mv doc/stunnel.fr.8_ doc/stunnel.fr.8
  38. %build
  39. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  40. if pkg-config openssl ; then
  41. CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
  42. LDFLAGS="`pkg-config --libs-only-L openssl`"; export LDFLAGS
  43. fi
  44. %configure --disable-fips --enable-ipv6 \
  45. CPPFLAGS="-UPIDFILE -DPIDFILE='\"%{_localstatedir}/run/stunnel.pid\"'"
  46. make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
  47. %install
  48. rm -rf $RPM_BUILD_ROOT
  49. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel
  50. touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
  51. make install DESTDIR=$RPM_BUILD_ROOT
  52. # Move the translated man pages to the right subdirectories, and strip off the
  53. # language suffixes.
  54. for lang in fr pl ; do
  55. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
  56. mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
  57. rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
  58. done
  59. mkdir srpm-docs
  60. cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
  61. %clean
  62. rm -rf $RPM_BUILD_ROOT
  63. %files
  64. %defattr(-,root,root)
  65. %doc AUTHORS BUGS ChangeLog COPY* CREDITS PORTS README TODO
  66. %doc tools/stunnel.conf-sample
  67. %doc srpm-docs/*
  68. %lang(en) %doc doc/en/*
  69. %lang(po) %doc doc/pl/*
  70. %{_bindir}/stunnel
  71. %exclude %{_bindir}/stunnel3
  72. %exclude %{_datadir}/doc/stunnel
  73. %{_libdir}/stunnel
  74. %exclude %{_libdir}/stunnel/libstunnel.la
  75. %{_mandir}/man8/stunnel.8*
  76. %lang(fr) %{_mandir}/fr/man8/stunnel.8*
  77. %lang(pl) %{_mandir}/pl/man8/stunnel.8*
  78. %dir %{_sysconfdir}/%{name}
  79. %exclude %{_sysconfdir}/stunnel/*
  80. %changelog
  81. * Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
  82. - initial build for Vine Linux
  83. *Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
  84. - 884183: support for full relro.
  85. *Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
  86. - New upstream realease 4.54
  87. - Updated local patches
  88. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  90. * Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
  91. - New upstream realease 4.53
  92. - Updated local patches
  93. * Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
  94. - New upstream realease 4.52
  95. - Updated local patches
  96. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  98. * Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
  99. - New upstream realease 4.50
  100. - Updated local patches
  101. * Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
  102. - New upstream realease 4.44
  103. - Updated local patches
  104. * Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
  105. - New upstream realease 4.42
  106. - Updated local patches
  107. - Fixes #732069
  108. * Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
  109. - New upstream realease 4.41
  110. - Updated local patches to match the new release
  111. * Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
  112. - New upstream realease 4.37
  113. - Updated local patches to match the new release
  114. * Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
  115. - New upstream realease 4.35
  116. - Updated authpriv and sample patches to match the new release
  117. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  119. * Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
  120. - New upstream realease 4.34
  121. - Updated authpriv and sample patches to match the new release
  122. * Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
  123. - New upstream realease 4.33
  124. - Updated authpriv and sample patches to match the new release
  125. - Addresses bz 580117 (inted mode support issue)
  126. * Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
  127. - New upstream realease 4.32
  128. - Updated authpriv and sample patches to match the new release
  129. * Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
  130. - New upstream realease 4.31
  131. - Updated authpriv and sample patches to match the new release
  132. * Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
  133. - New upstream realease 4.30
  134. - Updated authpriv and sample patches for the new release
  135. * Tue Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
  136. - New upstream realease 4.29
  137. - Updated authpriv and sample patches for the new release
  138. - Modified spec file to include dist tag
  139. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
  140. - rebuilt with new openssl
  141. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
  142. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  143. * Sun May 3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
  144. - Fix the previous patch.
  145. * Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
  146. - Avoid aliasing undefined by ISO C
  147. * Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
  148. - Update to stunnel-4.27.
  149. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
  150. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  151. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
  152. - disable openssl upstream fips mode
  153. * Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
  154. - Update to stunnel-4.26.
  155. * Sun Jun 8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
  156. - Use a clearer error message if the service name is unknown in "accept"
  157. Resolves: #450344
  158. * Mon Jun 2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
  159. - Update to stunnel-4.25
  160. * Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
  161. - Drop stunnel3
  162. Resolves: #442842
  163. * Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
  164. - Update to stunnel-4.24
  165. * Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
  166. - Update to stunnel-4.22
  167. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
  168. - Autorebuild for GCC 4.3
  169. * Tue Dec 4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
  170. - Rebuild with openssl-0.9.8g
  171. * Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
  172. - Revert the port to NSS, wait for NSS-based stunnel 5.x instead
  173. Resolves: #301971
  174. - Mark localized man pages with %%lang (patch by Ville Skyttä)
  175. Resolves: #322281
  176. * Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
  177. - Port to NSS
  178. * Mon Dec 4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
  179. - Update BuildRequires for the separate tcp_wrappers-devel package
  180. * Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
  181. - Update to stunnel-4.20
  182. * Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
  183. - Update to stunnel-4.19
  184. * Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
  185. - Update to stunnel-4.18
  186. - Remove unused stunnel.cnf from the src.rpm
  187. - Fix some rpmlint warnings
  188. * Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
  189. - rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
  190. (#203001)
  191. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
  192. - rebuild
  193. * Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
  194. - Update to stunnel-4.15
  195. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
  196. - bump again for double-long bug on ppc(64)
  197. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
  198. - rebuilt for new gcc4.1 snapshot and glibc changes
  199. * Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
  200. - Use pthread threading to fix crash on x86_64 (#179236)
  201. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  202. - rebuilt
  203. * Wed Nov 9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
  204. - Rebuild with newer openssl
  205. * Thu Nov 3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
  206. - Update to stunnel-4.14
  207. - Override changed default pid file location, keep it in %%{_localstatedir}/run
  208. * Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
  209. - Update to stunnel-4.13
  210. * Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
  211. - Update to stunnel-4.12
  212. * Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
  213. - Enable IPv6 (#169050, patch by Peter Bieringer)
  214. - Don't ship another copy of man pages in HTML
  215. * Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
  216. - Update to stunnel-4.11
  217. - Fix int/size_t mismatches in stack_info ()
  218. - Update Certificate-Creation for /etc/pki
  219. * Wed Jun 1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
  220. - Fix inetd mode
  221. - Remove unnecessary Requires: and BuildRequires:
  222. - Clean up the spec file
  223. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
  224. - update to 4.10
  225. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
  226. - add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
  227. coreutils (#133961)
  228. * Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
  229. - update to 4.08
  230. - build stunnel as a PIE binary
  231. * Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
  232. - Convert man pages to UTF-8
  233. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  234. - rebuilt
  235. * Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
  236. - move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
  237. * Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
  238. - update to 4.05
  239. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  240. - rebuilt
  241. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  242. - rebuilt
  243. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
  244. - Fix libtool
  245. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  246. - rebuilt
  247. * Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
  248. - fix xinetd configuration samples
  249. * Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
  250. - rebuild
  251. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  252. - rebuilt
  253. * Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
  254. - update to 4.04
  255. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
  256. - use pkgconfig for information about openssl, if available
  257. * Fri Jan 3 2003 Nalin Dahyabhai <nalin@redhat.com>
  258. - update to 4.03
  259. * Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
  260. - update to 4.02
  261. * Fri Oct 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
  262. - don't create a dummy cert
  263. * Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
  264. - update to 4.00
  265. - remove textutils and fileutils as buildreqs, add automake/autoconf
  266. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  267. - automated rebuild
  268. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  269. - automated rebuild
  270. * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
  271. - rebuild in new environment
  272. * Wed Jan 2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
  273. - update to 3.22, correcting a format-string vulnerability
  274. * Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
  275. - update to 3.21a
  276. * Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
  277. - log using LOG_AUTHPRIV facility by default (#47289)
  278. - make permissions on stunnel binary 0755
  279. - implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
  280. * Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
  281. - update to 3.19 to avoid problems with stunnel being multithreaded, but
  282. tcp wrappers not being thrad-safe
  283. * Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  284. - update to 3.17
  285. * Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
  286. - update to 3.16
  287. * Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  288. - update to 3.15
  289. - enable tcp-wrappers support
  290. * Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  291. - remove explicit requirement on openssl (specific version isn't enough,
  292. we have to depend on shared library version anyway)
  293. * Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  294. - update to 3.14
  295. * Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
  296. - depend on make (#33148)
  297. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  298. - rebuild in new environment
  299. * Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  300. - update to 3.13 to get pthread, OOB, 64-bit fixes
  301. - don't need sdf any more
  302. * Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  303. - pull in sdf to build the man page (#22892)
  304. * Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  305. - update to 3.11
  306. - chuck the SIGHUP patch (went upstream)
  307. - chuck parts of the 64-bit clean patch (went upstream)
  308. * Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  309. - update to 3.10
  310. - more 64-bit clean changes, hopefully the last bunch
  311. * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  312. - change piddir from the default /var/stunnel to /var/run
  313. - clean out pid file on SIGHUP
  314. * Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
  315. - update to 3.9 to get a security fix
  316. * Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
  317. - change all unsigned longs to u_int32_t when dealing with network
  318. addresses
  319. * Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  320. - make stunnel.pem also be (missingok)
  321. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  322. - move to Applications/Internet group
  323. - clean up %%post script
  324. - make stunnel.pem %%ghost %%config(noreplace)
  325. - provide a sample file for use with xinetd
  326. * Thu Jun 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  327. - FHS compliance fixes
  328. - modify defaults
  329. * Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  330. - update to 3.8
  331. - do not create certificate if one already exists
  332. * Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  333. - update to 3.7
  334. - add patch to find /usr/share/ssl
  335. - change some perms
  336. * Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  337. - Modify spec file to match Red Hat standards
  338. * Fri Aug 12 1999 Damien Miller <damien@ibs.com.au>
  339. - Updated to 3.4a
  340. - Patched for OpenSSL 0.9.4
  341. - Cleaned up files section
  342. * Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
  343. - Updated to 3.3
  344. * Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
  345. - Initial RPMification