texlive-mathabx-type1-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160
  1. %if %{?_dist_release} != "vl5"
  2. exit 1
  3. %endif
  4. %define pkgname mathabx
  5. %define tex_destdir %{_datadir}
  6. %define texmf %{tex_destdir}/texmf
  7. %define texlive_src %{tex_destdir}/texlive-sources
  8. %define build_tex_destdir %{buildroot}%{tex_destdir}
  9. %define build_texmf %{buildroot}%{texmf}
  10. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  11. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  12. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  13. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  14. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  15. %define vartexfonts %{_var}/lib/texmf
  16. %define mapdir %{texmf}-dist/fonts/map/dvips/misc
  17. %define mathabxdate 20050518
  18. Summary: The mathabx font series: extended and extendable series of mathematical symbols for TeX
  19. Summary(ja): mathabx: TeX 用の新しい数式フォント
  20. Name: texlive-mathabx-type1
  21. Version: 2005
  22. Release: 3%{?_dist_release}
  23. Source0: mathabx-%{mathabxdate}.tar.bz2
  24. Source1: abxtype1-%{mathabxdate}.tar.bz2
  25. Source2: mathabx_docs-%{mathabxdate}.tar.bz2
  26. URL: http://auemath.aichi-edu.ac.jp/~khotta/ghost/mathabx.html
  27. License: GPL
  28. Buildroot: %{_tmppath}/%{name}-%{version}-root
  29. Group: Applications/Publishing
  30. BuildArch: noarch
  31. PreReq: sed, sh-utils
  32. Requires: texlive-collection-fontsextra
  33. Obsoletes: mathabx <= 2005-1
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. %description
  37. The mathabx font series is a high quality extended and extendable series of
  38. mathematical symbols.
  39. To use this package, you describe \usepackage{mathabx} at preamble in your
  40. TeX document.
  41. This package provides Type1 fonts of mathabx.
  42. %description -l ja
  43. mathabx は CM + AMS の拡張であると考えられます。 全体的に色々な工夫が見られ,
  44. 例えば、積分記号 \int が CM より垂直に見え、不等号 ≦ は AMS のものより < と
  45. = がくっついているので、日本人が見慣れているものにより近いようです。
  46. TeX 文書の最初の部分へ \usepackage{mathabx} と記述すれば、普通の数式モードに
  47. て mathabx の利用が可能になります。
  48. このパッケージは mathabx の Type1 を提供します。
  49. %prep
  50. %__rm -rf $RPM_BUILD_ROOT
  51. %setup -q -a 1 -a 2 -n %{pkgname}
  52. %build
  53. %install
  54. %__rm -rf $RPM_BUILD_ROOT
  55. # mkdir -p %{build_texmf}/fonts/source/public/mathabx
  56. # cp -p source/* %{build_texmf}/fonts/source/public/mathabx
  57. # mkdir -p %{build_texmf}/tex/latex/mathabx
  58. # cp -p texinputs/* %{build_texmf}/tex/latex/mathabx
  59. %__mkdir_p %{build_texmf}/fonts/type1/mathabx
  60. %__cp -p abxtype1/pfb/*.pfb %{build_texmf}/fonts/type1/mathabx
  61. %__mkdir_p %{buildroot}%{mapdir}
  62. %__cp -p abxtype1/map/mathabx.map %{buildroot}%{mapdir}/mathabx.map
  63. %post
  64. %{exec_texhash}
  65. [ -f %{texmf}/web2c/updmap.cfg ] || exit 0
  66. echo -n " " && \
  67. echo -n "Running updmap: enable mathabx.map ... " && \
  68. %{exec_updmap} --enable Map mathabx.map >/dev/null 2>&1 && \
  69. echo "done."
  70. exit 0
  71. %postun
  72. if [ "$1" = "0" ]; then
  73. %{exec_texhash}
  74. [ -f %{texmf}/web2c/updmap.cfg ] || exit 0
  75. echo -n " " && \
  76. echo -n "Running updmap: disable mathabx.map ... " && \
  77. %{exec_updmap} --disable mathabx.map >/dev/null 2>&1 && \
  78. echo "done."
  79. fi
  80. exit 0
  81. %clean
  82. %__rm -rf $RPM_BUILD_ROOT
  83. %files
  84. %defattr(-,root,root)
  85. # %{texmf}/fonts/source/public/mathabx/*
  86. %{texmf}/fonts/type1/mathabx/*
  87. # %{texmf}/tex/latex/mathabx/*
  88. %{mapdir}/mathabx.map
  89. # %doc mathtest.tex mathtest.dvi mathtest.pdf
  90. %changelog
  91. * Thu Jan 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2005-3
  92. - initial build based on mathabx-type1-2005-2vl6
  93. * Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2005-2
  94. - renamed to mathabx-type1
  95. - TeX Live 2009
  96. - added Requires: texlive-collection-fontsextra
  97. - texlive-collection-fontsextra has mathabx package
  98. * Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 2005-1vl5
  99. - applied new versioning policy, spec in utf-8
  100. * Tue May 16 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl4
  101. - fix exec_updmap: added --nostop option
  102. * Fri Dec 02 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl3
  103. - fix install dir of mathabx.mat
  104. * Thu Nov 17 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl2
  105. - fix exec_updmap
  106. * Wed Nov 16 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 2005-0vl1
  107. - source update
  108. - modified for tetex-3.0
  109. * Tue Feb 03 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl3
  110. - fix exec_updmap
  111. * Thu Dec 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl2
  112. - source update
  113. * Fri Aug 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2003-0vl1
  114. - source update
  115. * Wed Jun 12 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2002-1vl2
  116. - update Type1 fonts
  117. * Sun Jun 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2002-1vl1
  118. - 1st release