texlive-tetex-trans-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112
  1. ## -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. %if %{?_dist_release} != "vl5"
  4. exit 1
  5. %endif
  6. # From $ apt-cache whatdepends jadetex
  7. # docbook-utils-0.6.14-2vl5
  8. # Depends: jadetex
  9. Provides: jadetex
  10. Conflicts: tetex dvipdfmx xdvik xdvik-motif jvf
  11. Conflicts: texlive
  12. %define tex_destdir %{_datadir}
  13. %define texmf %{tex_destdir}/texmf
  14. Summary: TeX Live: teTeX transitional package
  15. Summary(ja): TeX Live: teTeX から TeX Live への移行用パッケージ
  16. Name: texlive-tetex-trans
  17. Version: 2009
  18. Release: 2%{?_dist_release}
  19. License: distributable
  20. Group: Applications/Publishing
  21. URL: http://www.tug.org/texlive/
  22. BuildArch: noarch
  23. Buildroot: %{_tmppath}/%{name}-%{version}-root
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. Packager: munepi
  27. %description
  28. The TeX Live software distribution offers a complete TeX system for a
  29. variety of Unix, Macintosh, Windows and other platforms. It
  30. encompasses programs for editing, typesetting, previewing and printing
  31. of TeX documents in many different languages, and a large collection
  32. of TeX macros and font libraries.
  33. The distribution includes extensive general documentation about TeX,
  34. as well as the documentation for the included software packages.
  35. This package is a transitional package to bring teTeX environment
  36. TeX Live environment.
  37. If your system has installed teTeX environment,
  38. you can install TeX Live environment to execute the following steps:
  39. \# apt-get install %{name}
  40. \# apt-get install task-texlive
  41. %description -l ja
  42. TeX Live ソフトウェアディストリビューションは、
  43. さまざまな Unix, Macintosh, Windows、および
  44. 他のプラットホームに対して完全な TeX システムを提供します。
  45. 多くの異なった言語を含む TeX ドキュメントの
  46. 編集、組版、閲覧、印刷するためのプログラム、
  47. そして、TeX マクロやフォントライブラリの大きなコレクションを
  48. 同梱しています。
  49. このディストリビューションは
  50. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  51. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  52. このパッケージは teTeX 環境から TeX Live 環境へ移行するための
  53. パッケージです。
  54. teTeX 環境がインストールされていたら、
  55. 以下のコマンドを実行することで TeX Live 環境をインストールできます。
  56. \# apt-get install %{name}
  57. \# apt-get install task-texlive
  58. %files
  59. %posttrans
  60. _trans_time=$(date +%Y%m%d)
  61. echo "Running transitional process of your TeX system ... "
  62. for dir in %{texmf}-var %{texmf}-config; do
  63. _trans_dir=${dir}.${_trans_time}.rpmorig
  64. [ -d ${_trans_dir}.old ] && \
  65. echo -n " " && \
  66. echo "Found ${_trans_dir}.old: " && \
  67. echo -n " " && \
  68. %__rm -rvf ${_trans_dir}.old
  69. [ -d ${_trans_dir} ] && \
  70. echo -n " " && \
  71. echo "Found ${_trans_dir}: " && \
  72. echo -n " " && \
  73. %__mv -v ${_trans_dir} ${_trans_dir}.old
  74. [ -d ${dir} ] && \
  75. echo -n " " && \
  76. echo "Found ${dir}: " && \
  77. echo -n " " && \
  78. %__mv -v ${dir} ${_trans_dir}
  79. done
  80. echo "done."
  81. exit 0
  82. %postun
  83. exit 0
  84. %changelog
  85. * Tue Jan 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  86. - fixed %%posttrans
  87. * Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  88. - initial package