thread-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395
  1. %define tclmajor 8.4
  2. %define majorver 2.6
  3. Summary: A Tcl/Tk development environment: thread
  4. Summary(ja): Tcl/Tk 開発環境: thread
  5. Name: thread
  6. Version: %{majorver}.5
  7. Release: 3%{?_dist_release}
  8. License: BSD
  9. Group: Development/Languages
  10. BuildRequires: libtool, util-linux, perl, gdbm
  11. BuildRequires: tcl >= %{tclmajor}
  12. BuildRequires: tk >= %{tclmajor}
  13. Requires: tcl >= %{tclmajor}
  14. Requires: tk >= %{tclmajor}
  15. Buildroot: %{_tmppath}/%{name}-%{version}-root
  16. URL: http://tcl.sourceforge.net/
  17. Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}.tar.gz
  18. Vendor: Project Vine
  19. Distribution: Vine Linux
  20. %description
  21. You can use this extension to gain script-level access to Tcl threading capabilities.
  22. %prep
  23. %setup -q -n %{name}%{version}
  24. %build
  25. chmod 755 ./configure
  26. %configure \
  27. --with-tcl=%{_libdir} --with-tk=%{_libdir} --enable-shared \
  28. --enable-threads --enable-64bit
  29. make %{?_smp_mflags}
  30. %install
  31. rm -rf ${RPM_BUILD_ROOT}
  32. %makeinstall
  33. echo "%%defattr(-,root,root)" > thread.files
  34. (find ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
  35. find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
  36. | sort | uniq -u >> thread.files
  37. set +x +H
  38. for n in `cat thread.files`; do
  39. test -f $n || continue
  40. head -1 $n | grep -q ^#! || continue
  41. chmod u+w $n
  42. perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
  43. done
  44. set -x -H
  45. #
  46. # post process the *.files list, removing build sys references and mark
  47. # which are directories
  48. set +x
  49. for n in *.files; do
  50. mv $n $n.in
  51. sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
  52. if [ -d ${RPM_BUILD_ROOT}/$file ]; then
  53. echo -n '%dir '
  54. fi
  55. echo $file
  56. done > $n
  57. rm -f $n.in
  58. done
  59. set -x
  60. #
  61. # Man pages can be compressed
  62. perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
  63. %post -p /sbin/ldconfig -n thread
  64. %postun -p /sbin/ldconfig -n thread
  65. %clean
  66. rm -rf ${RPM_BUILD_ROOT}
  67. rm -f *.files
  68. %files -f thread.files -n thread
  69. %changelog
  70. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.5-3
  71. - rebuilt with rpm-4.8.1-3
  72. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-2
  73. - rebuilt with new environment
  74. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1vl5
  75. - applied new versioning policy and spec in utf-8
  76. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl3
  77. - rebuild with tcl/tk-8.4.18
  78. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl2
  79. - rebuild with tcl/tk-8.4.16
  80. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl1
  81. - update thread to 2.6.5
  82. - rebuilt with new toolchain
  83. * Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl2
  84. - rebuild for tcl/tk-8.4.12, and x86_64 architecture support
  85. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl1
  86. - update thread to 2.6.2
  87. - rebuilt for tcl/tk-8.4.11
  88. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 2.5.2-0vl2
  89. - rebuild for tcl/tk-8.4.6
  90. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.2-0vl1
  91. - source update
  92. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.1-0vl1
  93. - modified for Vine Linux
  94. - splite source package
  95. * Wed Mar 05 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 83bw
  96. - update Tcl/Tk 8.4.2
  97. * Wed Feb 12 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 82bw
  98. - update thread 2.5
  99. - update expect-20030203 (nightly-cvs)
  100. - remove xotcl
  101. * Wed Nov 20 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 81bw
  102. - add config patch for Trf
  103. - add static libraries of Tcl and Tk
  104. - add tbcload and tclcompiler again
  105. * Fri Nov 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 80bw
  106. - build on RH 8.0
  107. - update expect 5.38.0
  108. - remove tcllib module, which will be separate RPM from this.
  109. - remove tbcload module, which will be separate RPM from this.
  110. - remove tclcompiler module, which will be separate RPM from this.
  111. - add XOTcl 1.0
  112. - add Tcl-Trf 2.1p2
  113. - add Memchan 2.2a4
  114. * Sat Oct 29 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 79bw
  115. - fix to make XIC free, and eliminate XCloseIM when exiting Tk.
  116. * Sat Oct 26 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 78bw
  117. - update Tcl/Tk 8.4.1.
  118. * Fri Oct 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 77bw
  119. - correct install sequence in Tk.
  120. * Sat Sep 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 76bw
  121. - add TclPro tools:
  122. - tbcload CVS
  123. - tclcompiler CVS
  124. * Wed Sep 18 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 75bw
  125. - add iwidgets4.0.1.
  126. - correct symbolic link
  127. * Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 74bw
  128. - fix stub problem in itcl.
  129. * Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 73bw
  130. - adjust libary names to meet compatibility.
  131. * Wed Sep 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 72bw
  132. - update Tcl/Tk 8.4.0.
  133. - update TclX 8.4.
  134. - update tcllib 1.3.
  135. - add thread2.4.
  136. * Sat Feb 02 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 71bw
  137. - update tcllib 1.2.
  138. * Fri Jan 04 2002 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 70bw
  139. - correct to install all of message catalogs for Img.
  140. * Thu Dec 27 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 69bw
  141. - add tcl-8.3.4-encoding.patch for JIS encoding
  142. * Wed Dec 26 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 68bw
  143. - update itcl 3.2.1
  144. * Mon Nov 11 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 67bw
  145. - add link for tclth8.3 and wish8.3
  146. - add img 1.2.4
  147. * Sun Nov 04 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 66bw
  148. - update Tcl/Tk 8.3.4
  149. - update tcllib 1.1
  150. - update patch tcl-8.3.4-cruft.patch
  151. - update patch tcl-8.3.4-makecfg.patch
  152. - update patch tk-8.3.4-makecfg.patch
  153. * Mon Aug 29 2001 Adrian Havill <havill@redhat.com>
  154. - hard-coded the compat symlink for tix libdir. (bug 52812)
  155. * Mon Aug 28 2001 Adrian Havill <havill@redhat.com>
  156. - fixed itkwish/itclsh lib problem (bug 52608)
  157. - make itcl install not need tclsh/wish during config/make (bug 52606)
  158. - expect's fixline1 busted for expectk scripts (tkpasswd/tknewsbiff/tkterm)
  159. * Mon Aug 8 2001 Adrian Havill <havill@redhat.com>
  160. - changed rev for tcllib to 1.0
  161. - added execute bit mode for itclsh and itksh compat shells
  162. - re-enable glibc string and math inlines; recent gcc is a-ok.
  163. - optimize at -O2 instead of -O
  164. - rename "soname" patches related to makefile/autoconf changes
  165. - added elf "needed" for tk, tclx, tix, itk
  166. - removed warnings from tclX
  167. * Wed Jul 25 2001 Adrian Havill <havill@redhat.com>
  168. - added itclsh/itkwish for backwards compatibility, fixed rpath (bug 46086)
  169. - fixed 64 bit RPM provides for dependencies
  170. * Thu Jul 19 2001 Adrian Havill <havill@redhat.com>
  171. - updated tclX to the latest version
  172. - fixed tclX 8.3's busted help install
  173. - eliminated make TK_LIB kludge for multiple math libs for tclX
  174. - used %%makeinstall to brute force fix any remaining unflexible makefile dirs
  175. - fixed bad ref count release in tcl (bug 49406)
  176. - improved randomness of expect's mkpasswd script via /dev/random (bug 9507)
  177. - revert --enable-threads, linux is (still) not ready (yet) (bug 49251)
  178. - fixed DirTree in Tix (bug 45570)
  179. * Sun Jul 8 2001 Adrian Havill <havill@redhat.com>
  180. - refresh all sources to latest stable (TODO: separate expect/expectk)
  181. - massage out some build stuff to patches (TODO: libtoolize hacked constants)
  182. - remove patches already rolled into the upstream
  183. - remove unneeded autopasswd
  184. - removed RPATH (bugs 45569, 46085, 46086), added SONAMEs to ELFs
  185. - changed shared object filenames to something less gross
  186. - fixed tclX shell's argv parsing (bug 47710)
  187. - reenable threads which seem to work now
  188. - added all necessary header files for itcl (bug 41374)
  189. - fixed spawn/eof read problem with expect (bug 43310)
  190. - made compile-friendly for IA64
  191. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  192. - Bump release + rebuild for 7.2.
  193. * Fri Mar 23 2001 Bill Nottingham <notting@redhat.com>
  194. - bzip2 sources
  195. * Mon Mar 19 2001 Bill Nottingham <notting@redhat.com>
  196. - build with -D_GNU_SOURCE - fixes expect on ia64
  197. * Mon Mar 19 2001 Preston Brown <pbrown@redhat.com>
  198. - build fix from ahavill.
  199. * Wed Feb 21 2001 Tim Powers <timp@redhat.com>
  200. - fixed weather expect script using wrong server (#28505)
  201. * Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
  202. - added "ja_JP.eucJP" to locale list for tcl
  203. * Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
  204. - rebuild so make check passes
  205. * Fri Oct 20 2000 Than Ngo <than@redhat.com>
  206. - rebuild with -O0 on alpha (bug #19461)
  207. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  208. - summaries from specspo.
  209. * Tue Aug 8 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  210. - remove symlink to libtixsam.so
  211. * Thu Aug 3 2000 Jeff Johnson <jbj@redhat.com>
  212. - merge "best known" patches from searching, stubs were broken.
  213. - tix needs -fwritable-strings (#14352).
  214. - create tixwish symlink.
  215. * Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
  216. - rebuild against "working" util-linux col.
  217. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  218. - automatic rebuild
  219. * Fri Jun 16 2000 Jeff Johnson <jbj@redhat.com>
  220. - make sure that tix shared libraries are installed.
  221. - don't mess with %%{_libdir}, it's gonna be a FHS pita.
  222. * Sat Jun 10 2000 Jeff Johnson <jbj@redhat.com>
  223. - move, not symlink, unix/tk8.0 to generate Tix pkgIndex.tcl correctly (#11940).
  224. * Tue Jun 6 2000 Jeff Johnson <jbj@redhat.com>
  225. - tclX had wrong version.
  226. * Fri Jun 2 2000 Jeff Johnson <jbj@redhat.com>
  227. - FHS packaging changes.
  228. - revert --enable-threads, linux is not ready (yet) (#11789).
  229. - tcl/tk: update to 8.3.1 (#10779).
  230. - expect: update to 5.31.7+ (#11595).
  231. - add tcllib-0.4.
  232. - abstract major tcltk version for soname expansion etc.
  233. * Sat Mar 18 2000 Jeff Johnson <jbj@redhat.com>
  234. - update to (tcl,tk}-8.2.3, expect-5.31, and itcl-3.1.0, URL's as well.
  235. - use perl to drill out pre-pended RPM_BUILD_ROOT.
  236. - configure with --enable-threads (experimental).
  237. - improved version of autopasswd (#4788).
  238. - autopasswd needs to handle password starting with hyphen (#9917).
  239. - handle 553 ftp status in rftp expect script (#7869).
  240. - remove cryptdir/decryptdir, as Linux has not crypt command (#6668).
  241. - correct hierarchy spelling (#7082).
  242. - fix "expect -d ...", format string had int printed as string (#7775).
  243. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  244. - rebuild for sparc baud rates > 38400.
  245. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  246. - handle compressed manpages
  247. * Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
  248. - Make changes from bug number 7602
  249. - Apply patch from bug number 7537
  250. - Apply fix from bug number 7157
  251. - Add fixes from bug #7601 to the runtcl patch
  252. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  253. - fix descriptions
  254. - man pages are compressed (whatapain)
  255. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  256. - fix tclX symlinks.
  257. - compile on systems where SIGPWR == SIGLOST.
  258. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  259. - update tcl/tk to 8.0.5.
  260. - avoid "containing" in Tix (#2332).
  261. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  262. - use /usr/bin/write in kibitz (#1320).
  263. - use cirrus.sprl.umich.edu in weather (#1926).
  264. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  265. - auto rebuild in the new build environment (release 28)
  266. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  267. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  268. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  269. - expect does unaligned access on alpha (#989)
  270. - upgrade tcl/tk/tclX to 8.0.4
  271. - upgrade expect to 5.28.
  272. - add itcl 3.0.1
  273. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  274. - call libtoolize to allow building on the arm
  275. - build for glibc 2.1
  276. - strip binaries
  277. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  278. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  279. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  280. - expect: mkpasswd needs delay before sending password (problem #576)
  281. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  282. - translations modified for de, fr, tr
  283. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  284. - fixed expect binaries exec permissions
  285. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  286. - updated to Tix 4.1.0.006
  287. - updated version numbers of tcl/tk to relflect includsion of p2
  288. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  289. - updated tcl/tk to patch level 2
  290. - updated tclX to 8.0.2
  291. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  292. - fixed filelist for tix... replacing path to the expect binary in scripts
  293. was leaving junk files around.
  294. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  295. - added patch to remove libieee test in configure.in for tcl and tk.
  296. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  297. solution for all systems
  298. - fixed src urls
  299. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  300. - removed version numbers from descriptions
  301. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  302. - updated to tcl/tk 8.0 and related versions of packages
  303. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  304. - built against glibc
  305. - fixed dangling tclx/tkx symlinks