tla-vl.spec 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138
  1. Summary: A version control system
  2. Summary(ja): GNU Arch バージョンコントロールシステム
  3. Name: tla
  4. Version: 1.3.5
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: Development/Tools
  8. URL: http://www.gnu.org/software/gnu-arch/
  9. Source0: ftp://ftp.gnu.org/gnu/gnu-arch/%{name}-%{version}.tar.gz
  10. Source1: %{name}-generate-manpage.pl
  11. Source2: %{name}-gpg-check.1
  12. Patch0: %{name}-%{version}-alignment-hppa-sparc.patch
  13. Patch1: %{name}-%{version}-neon.patch
  14. Patch2: %{name}-%{version}-neon-327111.patch
  15. Patch3: %{name}-%{version}-posix.patch
  16. Patch4: %{name}-%{version}-remove-invariant.patch
  17. Patch5: %{name}-%{version}-segfault-ia64.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. Requires: diffutils
  20. Requires: patch
  21. Requires: tar
  22. BuildRequires: check-devel
  23. BuildRequires: neon-devel
  24. %description
  25. GNU Arch 1 (also known as tla) is a revision control system, similar in
  26. purpose to tools such as CVS, SCCS, and Subversion. It is used to keep track
  27. of the changes made to a source tree and to help programmers combine and
  28. otherwise manipulate changes made by multiple people or at different times.
  29. TLA is a punning acronym that stands for either "true love, always" and "three
  30. letter acronym".
  31. %prep
  32. %setup -q
  33. %patch0 -p1
  34. %patch1 -p1
  35. %patch2 -p1
  36. %patch3 -p1
  37. %patch4 -p1
  38. %patch5 -p1
  39. # Build against neon-devel.
  40. rm -rf ./src/libneon
  41. # Suppress rpmlint error.
  42. iconv --from-code ISO8859-1 --to-code UTF-8 ./src/tla/AUTHORS \
  43. --output AUTHORS.utf-8 && mv AUTHORS.utf-8 ./src/tla/AUTHORS
  44. iconv --from-code ISO8859-1 --to-code UTF-8 ./src/tla/README \
  45. --output README.utf-8 && mv README.utf-8 ./src/tla/README
  46. %build
  47. # configure script and Makefiles are not generated by Autoconf/Automake.
  48. mkdir -p ./build
  49. pushd ./build
  50. ../src/configure \
  51. --prefix=%{_prefix} --with-install-link-tools=yes --with-cc=%{__cc}
  52. # Parallel make does not work.
  53. make CFLAGS="$RPM_OPT_FLAGS $(neon-config --cflags)"
  54. # Use only HTML and CSS files for documentation.
  55. # To be later listed against %doc.
  56. mkdir -p ./docs-tla
  57. pushd ./docs-tla
  58. find ../../src/docs-tla -name "*.css" -o -name "*.html" \
  59. | xargs tar --atime-preserve -cf- \
  60. | tar --atime-preserve -xf-
  61. popd
  62. popd
  63. # man page
  64. mkdir -p ./debian/tmp
  65. PATH="`pwd`/build/tla/tla:$PATH" perl %{SOURCE1} tla.1
  66. %check
  67. pushd ./build
  68. make test CFLAGS="$RPM_OPT_FLAGS $(neon-config --cflags)"
  69. popd
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
  73. pushd ./build
  74. # Makefiles use destdir instead of DESTDIR.
  75. make install CFLAGS="$RPM_OPT_FLAGS $(neon-config --cflags)" \
  76. destdir=$RPM_BUILD_ROOT
  77. popd
  78. # man page
  79. install -p -m644 ./debian/tmp/%{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
  80. install -p -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man1
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %files
  84. %defattr(-,root,root,-)
  85. %doc build/docs-tla/src/docs-tla
  86. %doc src/tla/AUTHORS
  87. %doc src/tla/README
  88. %{_bindir}/make-links
  89. %{_bindir}/%{name}
  90. %{_bindir}/remove-links
  91. %{_mandir}/man1/%{name}.1.gz
  92. %{_mandir}/man1/%{name}-gpg-check.1.gz
  93. %changelog
  94. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
  95. - initial build for Vine Linux
  96. * Sat Feb 09 2008 Debarshi Ray <rishi@fedoraproject.org> - 1.3.5-5
  97. - Added 'BuildRequires: check-devel' for check stanza.
  98. * Wed Dec 12 2007 Debarshi Ray <rishi@fedoraproject.org> - 1.3.5-4
  99. - Added online manual page, and patches to fix alignment errors on HP-PA and
  100. SPARC and segmentation fault on IA-64 from Debian.
  101. - Fixed sources to work with neon >= 0.27.2 for all distributions, except
  102. Fedora 7. Closes Red Hat Bugzilla bug #327111.
  103. * Sun Nov 18 2007 Debarshi Ray <rishi@fedoraproject.org> - 1.3.5-3
  104. - Resolved CVS merge conflicts for Fedora 7.
  105. * Fri Nov 16 2007 Debarshi Ray <rishi@fedoraproject.org> - 1.3.5-2
  106. - Changed value of License to GPLv2+.
  107. * Sat Nov 10 2007 Debarshi Ray <rishi@fedoraproject.org> - 1.3.5-1
  108. - Initial build. Imported SPEC from Rawhide.
  109. - Added online manual page generator and patch to build against neon-devel
  110. from Debian.
  111. - Added patch to test-dir-regexps.sh from SuSE.
  112. - Removed call to invariant to prevent failure on ppc. Closes Red Hat Bugzilla
  113. bug #182742.
  114. - Disabled parallel make to prevent failure.