wpa_supplicant-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313
  1. Summary: WPA/WPA2/IEEE 802.1X Supplicant
  2. Name: wpa_supplicant
  3. Version: 0.7.3
  4. Release: 3%{?_dist_release}
  5. License: BSD
  6. Group: System Environment/Base
  7. URL: http://w1.fi/wpa_supplicant/
  8. Source0: http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
  9. Source1: %{name}.build-config
  10. Source2: %{name}.conf
  11. Source3: %{name}.init.d
  12. Source4: %{name}.sysconfig
  13. Source6: %{name}.logrotate
  14. # import from Fedora package
  15. # distro specific customization and not suitable for upstream,
  16. # works around busted drivers
  17. Patch0: wpa_supplicant-assoc-timeout.patch
  18. # ensures that debug output gets flushed immediately to help diagnose driver
  19. # bugs, not suitable for upstream
  20. Patch1: wpa_supplicant-flush-debug-output.patch
  21. # disto specific customization for log paths, not suitable for upstream
  22. Patch2: wpa_supplicant-dbus-service-file-args.patch
  23. # quiet an annoying and frequent syslog message
  24. Patch3: wpa_supplicant-quiet-scan-results-message.patch
  25. # recover from streams of driver disconnect messages (iwl3945)
  26. Patch4: wpa_supplicant-squelch-driver-disconnect-spam.patch
  27. # allow more private key encryption algorithms
  28. Patch5: wpa_supplicant-openssl-more-algs.patch
  29. # Send PropertyChanged notificationes when the BSS list changes
  30. Patch7: wpa_supplicant-bss-changed-prop-notify.patch
  31. # Don't crash trying to pass NULL to dbus
  32. Patch8: 0001-dbus-clean-up-new-D-Bus-interface-getters-setters.patch
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  34. BuildRequires: qt4-devel
  35. BuildRequires: qt4-designer
  36. BuildRequires: openssl-devel
  37. BuildRequires: readline-devel
  38. BuildRequires: dbus-devel
  39. BuildRequires: libnl-devel
  40. Requires(post): chkconfig
  41. Requires(preun): chkconfig
  42. %description
  43. wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
  44. for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
  45. component that is used in the client stations. It implements key negotiation
  46. with a WPA Authenticator and it controls the roaming and IEEE 802.11
  47. authentication/association of the wlan driver.
  48. %package gui
  49. Summary: Graphical User Interface for %{name}
  50. Summary(ja): wpa_supplicant のグラフィカルユーザインタフェース
  51. Group: Applications/System
  52. %description gui
  53. Graphical User Interface for wpa_supplicant written using QT4
  54. %description -l ja gui
  55. QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
  56. %prep
  57. %setup -q
  58. %patch0 -p1 -b .assoc-timeout
  59. %patch1 -p1 -b .flush-debug-output
  60. %patch2 -p1 -b .dbus-service-file
  61. %patch3 -p1 -b .quiet-scan-results-msg
  62. %patch4 -p1 -b .disconnect-spam
  63. %patch5 -p1 -b .more-openssl-algs
  64. %patch7 -p1 -b .bss-changed-prop-notify
  65. %patch8 -p1 -b .dbus-rework
  66. %build
  67. pushd wpa_supplicant
  68. cp %{SOURCE1} ./.config
  69. CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ;
  70. CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ;
  71. make %{_smp_mflags}
  72. PATH=$PATH:%{_libdir}/qt4/bin QTDIR=%{_libdir}/qt4 make wpa_gui-qt4 %{_smp_mflags}
  73. popd
  74. %install
  75. rm -rf %{buildroot}
  76. # init scripts
  77. install -D -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
  78. install -D -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
  79. install -D -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
  80. # config
  81. install -D -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
  82. # binary
  83. install -d %{buildroot}/%{_sbindir}
  84. install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
  85. install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
  86. install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
  87. install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
  88. install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
  89. install -D -m 0644 %{name}/dbus/fi.epitest.hostap.WPASupplicant.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
  90. # gui
  91. install -d %{buildroot}/%{_bindir}
  92. install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
  93. # running
  94. mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
  95. # man pages
  96. install -d %{buildroot}%{_mandir}/man{5,8}
  97. install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
  98. install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
  99. # some cleanup in docs
  100. rm -f %{name}/doc/.cvsignore
  101. rm -rf %{name}/doc/docbook
  102. %clean
  103. rm -rf %{buildroot}
  104. %post
  105. if [ $1 = 1 ]; then
  106. chkconfig --add %{name}
  107. fi
  108. %preun
  109. if [ $1 = 0 ]; then
  110. service %{name} stop > /dev/null 2>&1
  111. killall -TERM wpa_supplicant >/dev/null 2>&1
  112. /sbin/chkconfig --del %{name}
  113. fi
  114. %files
  115. %defattr(-, root, root)
  116. %doc COPYING %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
  117. %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  118. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  119. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  120. %{_sysconfdir}/rc.d/init.d/%{name}
  121. %{_sysconfdir}/dbus-1/system.d/%{name}.conf
  122. %{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
  123. %{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
  124. %{_sbindir}/wpa_passphrase
  125. %{_sbindir}/wpa_supplicant
  126. %{_sbindir}/wpa_cli
  127. %dir %{_localstatedir}/run/%{name}
  128. %dir %{_sysconfdir}/%{name}
  129. %{_mandir}/man8/*
  130. %{_mandir}/man5/*
  131. %files gui
  132. %defattr(-, root, root)
  133. %{_bindir}/wpa_gui
  134. %changelog
  135. * Mon Aug 22 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.3-3
  136. - import Patch8 from Fedora 1:0.7.3-9 to fix some crashes
  137. - Wed Jul 27 2011 Dan Williams <dcbw@redhat.com> - 1:0.7.3-9
  138. - Fix various crashes with D-Bus interface (rh #678625) (rh #725517)
  139. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
  140. - rebuild with openssl-1.0.0c
  141. - add BuildRequires: qt4-designer, libnl-devel
  142. * Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
  143. - new upstream release
  144. - update patches
  145. - change License to BSD due to linkage against OpsnSSL since there is no
  146. OpenSSL exception in upstream GPLv2 license text.
  147. - build with qt4
  148. - update build config
  149. * Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
  150. - new upstream release
  151. - remove hostap/madwifi/prism54 drivers, use 'wext' instead.
  152. - drop upstream patches
  153. - import some fedora patches
  154. - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
  155. - Better scanning behavior on resume from suspend/hibernate
  156. - Better interaction with newer kernels and drivers
  157. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
  158. - start wpa_supplicant by default.
  159. * Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
  160. - new upstream release
  161. - import some fedora patches
  162. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
  163. - rebuild with new openssl
  164. * Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
  165. - new upstream release
  166. * Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
  167. - initial build for Vine Linux based on FC package.
  168. * Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
  169. - Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
  170. - Fix up madwifi-ng private ioctl()s for r1331 and later
  171. - Update madwifi headers to r1475
  172. * Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
  173. - Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
  174. * Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
  175. - Fix control interface key obfuscation a bit
  176. * Sun Apr 2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
  177. - Work around older & incorrect drivers that return null-terminated SSIDs
  178. * Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
  179. - Add patch to make orinoco happy with WEP keys
  180. - Enable Prism54-specific driver
  181. - Disable ipw-specific driver; ipw2x00 should be using WEXT instead
  182. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
  183. - Increase association timeout, mainly for drivers that don't
  184. fully support WPA ioctls yet
  185. * Fri Mar 3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
  186. - Add additional BuildRequires #rh181914#
  187. - Add prereq on chkconfig #rh182905# #rh182906#
  188. - Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
  189. * Wed Mar 1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
  190. - Install wpa_passphrase too #rh183480#
  191. * Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
  192. - Don't expose private data on the control interface unless requested
  193. * Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
  194. - Downgrade to 0.4.8 stable release rather than a dev release
  195. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
  196. - Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
  197. * Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
  198. - Move initscript to /etc/rc.d/init.d
  199. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
  200. - bump again for double-long bug on ppc(64)
  201. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
  202. - rebuilt for new gcc4.1 snapshot and glibc changes
  203. * Sun Feb 5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
  204. - Update to 0.5.1
  205. - Add WE auth fallback to actually work with older drivers
  206. * Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
  207. - Bring package into Fedora Core
  208. - Add ap_scan control interface patch
  209. - Enable madwifi-ng driver
  210. * Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
  211. - upgrade to 0.4.7
  212. - added package w/ wpa_gui in it
  213. * Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
  214. - upgrade to 0.4.6
  215. - adding ctrl interface changes recommended
  216. by Hugo Paredes <hugo.paredes@e-know.org>
  217. * Sun Oct 9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
  218. - upgrade to 0.4.5
  219. - updated config file wpa_supplicant is built with
  220. especially, the ipw2100 driver changed to just ipw
  221. and enabled a bunch more EAP
  222. - disabled dist tag
  223. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
  224. - fix typo in init script
  225. * Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
  226. - fixing init script using fedora-extras' template
  227. - removing chkconfig default startup
  228. * Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
  229. - upgrade to 0.4.2
  230. - new sample conf file that will use any unrestricted AP
  231. - make sysconfig config entry
  232. - new BuildRoot for Fedora Extras
  233. - adding dist tag to Release
  234. * Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
  235. - upgrade to 0.3.8
  236. * Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
  237. - compile ipw driver in
  238. * Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
  239. - upgrade to 0.3.6
  240. * Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
  241. - fixing init script
  242. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
  243. - fixing init script
  244. - adding post/preun items to add/remove via chkconfig
  245. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
  246. - adding sysV scripts
  247. * Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
  248. - Initial RPM release.