xlockmore_gl-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216
  1. %define orgname xlockmore
  2. # if you want to make kterm_plus version,
  3. # uncomment below line, or rpm --define withgl:1
  4. # % define withgl 1
  5. %define name %{orgname}%{?withgl:_gl}
  6. %define version 5.03
  7. %define release 0vl1
  8. Summary: An X terminal locking program.
  9. Name: %{name}
  10. Version: %{version}
  11. Release: %{release}
  12. License: MIT
  13. Group: Amusements/Graphics
  14. Url: http://www.tux.org/~bagleyd/xlockmore.html
  15. Source0: ftp://ftp.tux.org/pub/tux/bagleyd/xlockmore/xlockmore-%{version}.tar.bz2
  16. Source1: m-redhat.xpm
  17. Source2: m-redhat.xbm
  18. Source3: s-redhat.xpm
  19. Source4: s-redhat.xbm
  20. Source5: xlock.pamd
  21. Patch0: xlockmore-5.02-sounddir.patch
  22. BuildPrereq: esound-devel, audiofile-devel
  23. Requires: pam >= 0.59, esound, audiofile, fortune-mod
  24. %{?withgl:Requires: Mesa, gle}
  25. %{?withgl:BuildPreReq: Mesa-devel, gle-devel}
  26. %{?withgl:Provides: xlockmore}
  27. Conflicts: %{orgname}%{!?withgl:_gl}
  28. Buildroot: %{_tmppath}/%{name}-%{version}-root
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. %define gldesc %{?withgl:This package has MesaGL feature.}
  32. %define gldescja %{?withgl:このパッケージは MesaGL 対応になっています.}
  33. %description
  34. The xlockmore utility is an enhanced version of the standard xlock
  35. program, which allows you to lock an X session so that other users
  36. can't access it. Xlockmore runs a provided screensaver until you type
  37. in your password.
  38. Install the xlockmore package if you need a locking program to secure
  39. X sessions.
  40. %{gldesc}
  41. %description
  42. xlockmore は 標準的な xlock の機能拡張版です.あなたが席をはずすときに
  43. X セッションをロックし,あなたがパスワードを入力するまで他の人がアク
  44. セスできないようにします.
  45. %{gldescja}
  46. %prep
  47. %setup -q -n %{orgname}-%{version}
  48. %patch0 -p1 -b .sounddir
  49. cp %{_sourcedir}/m-redhat.xpm pixmaps/m-redhat.xpm
  50. cp %{_sourcedir}/m-redhat.xbm bitmaps/m-redhat.xbm
  51. cp %{_sourcedir}/m-redhat.xpm pixmaps/l-redhat.xpm
  52. cp %{_sourcedir}/m-redhat.xbm bitmaps/l-redhat.xbm
  53. cp %{_sourcedir}/s-redhat.xpm pixmaps/s-redhat.xpm
  54. cp %{_sourcedir}/s-redhat.xbm bitmaps/s-redhat.xbm
  55. %build
  56. autoconf
  57. %define nglflag %{!?withgl:--without-opengl --without-mesa --without-gltt}
  58. %define glflag %{?withgl:--with-mesa --with-gltt}
  59. %configure --prefix=/usr --exec-prefix=/usr/X11R6/ --bindir=/usr/X11R6/bin \
  60. --mandir=/usr/X11R6/man/man1 --without-motif --without-gtk --enable-pam \
  61. --with-esound %{glflag} %{nglflag}
  62. make
  63. # recompile xlockgen for each architecture
  64. make -C etc/genlauncher xlockgen
  65. %install
  66. rm -rf %{buildroot}
  67. mkdir -p %{buildroot}/etc/pam.d
  68. %makeinstall exec_prefix=%{buildroot}/usr/X11R6/ bindir=%{buildroot}/usr/X11R6/bin mandir=%{buildroot}/usr/X11R6/man/man1 xapploaddir=%{buildroot}/usr/X11R6/lib/X11/app-defaults/ INSTPGMFLAGS="-m 755"
  69. install -m 644 %{_sourcedir}/xlock.pamd %{buildroot}/etc/pam.d/xlock
  70. mkdir -p %{buildroot}%{_datadir}/sounds/xlockmore/
  71. install -m 644 -p sounds/*.au %{buildroot}%{_datadir}/sounds/xlockmore/
  72. (cd etc
  73. sed -e 's|/usr/X11/bin/wish|/usr/bin/wish|g' xlock.tcl > xlock.tcl.new
  74. mv xlock.tcl.new xlock.tcl
  75. # chmod +x xlock.tcl
  76. )
  77. # eliminate executable bit in %doc
  78. find etc/ -type f -perm +111 | xargs -r chmod -x
  79. %clean
  80. rm -rf %{buildroot}
  81. %files
  82. %defattr(-,root,root)
  83. %doc README docs/ etc/
  84. %config /etc/pam.d/xlock
  85. %attr(4111,root,root)/usr/X11R6/bin/xlock
  86. /usr/X11R6/man/man1/xlock.*
  87. %config /usr/X11R6/lib/X11/app-defaults/XLock
  88. %{_datadir}/sounds/xlockmore/
  89. %changelog
  90. * Tue Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 5.03-0vl1
  91. - updated to current stable release 5.03
  92. - use %%configure, %%makeinstall
  93. - added patch for DEFALUT_SOUND_DIR
  94. * Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.01.2-0vl3
  95. - typo fixed: --without-mesagl -> --without-mesa
  96. * Sun Aug 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  97. - add Conflicts tag
  98. * Fri Aug 17 2001 <sagami@vinelinux.org>
  99. - 5.01.2-0vl1: bump up release
  100. * Wed Jul 18 2001 <sagami@vinelinux.org>
  101. - 5.01.2-0vl0: updated to current stable release 5.01.2
  102. * Mon Apr 2 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl8
  103. - bug fix for withgl option
  104. * Wed Mar 28 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl7
  105. - bug fix in Provides for withgl
  106. - build with gle
  107. * Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl6
  108. - added switch withgl
  109. * Mon Jan 22 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 4.17.2-0vl5
  110. - recompile %%{_docdir}/xlockmore-%{version}/etc/genlauncher/xlockgen
  111. for each architecture (to resolve unmet dependency)
  112. * Sat Jan 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  113. - 4.17.2-0vl4
  114. - eliminate executable bit in %doc (requierment for /bin/ksh etc.)
  115. * Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 4.17.2-0vl3
  116. - build on gcc-2.95.3
  117. - partialy used rpmmacros
  118. * Tue Nov 7 2000 Kazuhisa TAKEI <takei@vinelinux.org> 4.17.2-0vl2
  119. - change filedepend to package name depend
  120. * Sat Sep 2 2000 Jun Nishii <jun@vinelinux.org>
  121. - 4.17.2-0vl1
  122. * Fri Sep 1 2000 Jun Nishii <jun@vinelinux.org>
  123. - 4.17.1-0vl1
  124. - upgrade and build without GL
  125. - added docs etc
  126. * Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
  127. - wmconfig gone.
  128. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  129. - handle compressed man pages
  130. * Fri Jan 14 2000 Bill Nottingham <notting@redhat.com>
  131. - fun with GL
  132. * Tue Nov 9 1999 Bill Nottingham <notting@redhat.com>
  133. - update to 4.15
  134. * Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
  135. - update to 4.13.1
  136. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  137. - auto rebuild in the new build environment (release 2)
  138. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  139. - update to 4.12
  140. * Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
  141. - take out some modules to avoid TMv
  142. * Fri Sep 18 1998 Bill Nottingham <notting@redhat.com>
  143. - turned PAM support on in ./configure
  144. * Fri Sep 11 1998 Preston Brown <pbrown@redhat.com>
  145. - Upgraded to 4.11
  146. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  147. - translations modified for de, fr, tr
  148. * Sat Apr 11 1998 Donnie Barnes <djb@redhat.com>
  149. - upgraded to 4.09
  150. - removed Michael's PAM patch (it's now available in the sources)
  151. * Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
  152. - upgrade to 4.05
  153. - add wmconfig
  154. * Mon Oct 13 1997 Michael K. Johnson <johnsonm@redhat.com>
  155. - Upgraded to 4.04
  156. - Changed pam to new conventions
  157. - Use configure instead of imake
  158. - buildroot
  159. * Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
  160. - built against glibc
  161. * Mon Mar 03 1997 Michael K. Johnson <johnsonm@redhat.com>
  162. - moved from pam.conf to pam.d